Maxim Cournoyer wrote 7 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
Hello!
After some cooperation with upstream to unbundle dependencies and
enable more tests, I think this SuperCollider package is in good shape!
Here's a screenshot to give you an idea of what the included IDE looks
like:
Having a jackd service is not necessary (SuperCollider will start one if
it's not already running), but in case you'd like to have one I've found
the following to work with Shepherd:
Toggle snippet (8 lines)
(define jackd
(make <service>
#:provides '(jackd)
#:requires '()
#:start (make-system-constructor "jackd -d alsa &")
#:stop (make-system-destructor "pkill jackd")))
Thanks,
Maxim
From 59da2743aa90c9fb6f4099303f6481c636fc560e Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sat, 10 Mar 2018 23:09:56 -0500
Subject: [PATCH] doc: Add index entries for realtime and jackd in the manual.
* doc/guix.texi (Base Services): Add realtime and jackd indices to the
`pam-limits-service' service, as the examples shows how they can be
configured.
---
doc/guix.texi | 2 ++
1 file changed, 2 insertions(+)
Toggle diff (15 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 13187f2e8..ff6a24d07 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -10309,6 +10309,8 @@ to add @var{device} to the kernel's entropy pool. The service will fail if
@cindex session limits
@cindex ulimit
@cindex priority
+@cindex realtime
+@cindex jackd
@deffn {Scheme Procedure} pam-limits-service [#:limits @code{'()}]
Return a service that installs a configuration file for the
--
2.16.1
From 8f7d8aeeb455038b223a429d3273a4b42299a85d Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sun, 4 Mar 2018 22:50:04 -0500
Subject: [PATCH 1/3] gnu: Add boost-sync.
* gnu/packages/boost.scm (boost-sync): New variable.
---
gnu/packages/boost.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (64 lines)
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index f4ba82810..d347674ab 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,10 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages icu4c)
@@ -124,6 +128,38 @@ across a broad spectrum of applications.")
(base32
"1aaw48cmimsskzgiclwn0iifp62a5iw9cbqrhfari876af1828ap"))))))
+(define-public boost-sync
+ (let ((commit "c72891d9b90e2ceb466ec859f640cd012b2d8709")
+ (version "1.55")
+ (revision "1"))
+ (package
+ (name "boost-sync")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/boostorg/sync.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "197mp5z048vz5kv1m4v3jm447l2gqsyv0rbfz11dz0ns343ihbyx"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source")))
+ (copy-recursively (string-append source "/include")
+ (string-append %output "/include"))))))
+ (home-page "https://github.com/boostorg/sync")
+ (synopsis "Boost.Sync library")
+ (description "The Boost.Sync library provides mutexes, semaphores, locks
+and events and other thread related facilities. Boost.Sync originated from
+Boost.Thread.")
+ (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt")))))
+
(define-public mdds
(package
(name "mdds")
--
2.16.1
From 44dc28c15144f8b3e7bc184a3271b34ba8132a40 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Mon, 5 Mar 2018 20:15:35 -0500
Subject: [PATCH 2/3] gnu: yaml-cpp: Update to 0.6.1.
* gnu/packages/serialization.scm (yaml-cpp): Update to 0.6.1.
---
gnu/packages/serialization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index f72116575..7d2e88eac 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -248,7 +248,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
(define-public yaml-cpp
(package
(name "yaml-cpp")
- (version "0.5.3")
+ (version "0.6.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -256,7 +256,7 @@ that implements both the msgpack and msgpack-rpc specifications.")
"yaml-cpp-" version ".tar.gz"))
(sha256
(base32
- "1ck7jk0wjfigrf4cgcjqsir4yp1s6vamhhxhpsgfvs46pgm5pk6y"))))
+ "038ddf771d1zrdfiwqzq2lsjdis1fxbaasbdja2w9f1av3k3gv15"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
--
2.16.1