[PATCH 0/3] Add terraform-docs and dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
87zi3bzq6e.fsf@cbaines.net
Christopher Baines (3):
gnu: Add go-github-com-tj-docopt.
gnu: Add go-github-com-hashicorp-hcl.
gnu: Add terraform-docs.

gnu/packages/golang.scm | 52 +++++++++++++++++++++++++++++++++++++++++++++
gnu/packages/terraform.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 105 insertions(+)
create mode 100644 gnu/packages/terraform.scm
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqoMblfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd6Hg/+IyCI4fSij30VvwsrprSd2v5T56Jmc0M+CABctPRyxE0rHlyBf1xQ+c0x
zDfhZZxipzYW/DI6noWejNg+7NghrueEAL6goqJc5sr2YQ6YN01apHit1SQBpQlJ
3e3qShrkOhNwCiKtBayJbsR8agTSwcaHs/kyByI0Fo0swOEl2QtkIHA6hxhpkp1U
/5fHtO6QNSIgAPlwJHjAL/M1QDf9AFWr96zfezvAIo1Op3rX5VGWs9V11DSGC4wf
kQEBzC8jymqTsV5R4ISHcciNF42w2IrYBWRus4jUUNBJxThB3xvOMfgEBTfvg9XY
eIFoN2yh3uI+EJFPHVYM8VxsEoDkwEol02Of1lp3bbHTN+EKG4GT3dtWdZkNhnQ7
rtdCEwEItcGtBAzDaqT0yF1Am2Xsc3YfVE2YwwHJRiINurxeCu30+B+Zrk9EjUEM
lB1kK6GP0wOwdGpNuLdCqFzIjtMqyCTdwW8UX9DHxexQ0BYXTRnQd6EFPszLzHCT
1fpZgzM6zbRSm4f55JD9Mk+OuFGiJ6+ub5qB5DTwuvtP2dk5vdcHHm1kv3x2cOTg
eWGbnIUjTNaZpQKXDGJb8enUHqwENp4Tvn0CWSwWov2LCgLCX4uFzlmytX+JoyoB
7eh2DuAhxiQ2XPHtfgOCyS2dbik9Vbi7YEsB/eIO+yLe29boxbg=
=jof8
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
[PATCH 3/3] gnu: Add terraform-docs.
(address . 30805@debbugs.gnu.org)
20180313202049.815-3-mail@cbaines.net
* gnu/packages/terraform.scm (terraform-docs): New variable.
---
gnu/packages/terraform.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
create mode 100644 gnu/packages/terraform.scm

Toggle diff (61 lines)
diff --git a/gnu/packages/terraform.scm b/gnu/packages/terraform.scm
new file mode 100644
index 000000000..9d0bb4bcb
--- /dev/null
+++ b/gnu/packages/terraform.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages terraform)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system go)
+ #:use-module (gnu packages golang))
+
+(define-public terraform-docs
+ (package
+ (name "terraform-docs")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/segmentio/terraform-docs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xchpik32ab8m89s6jv671vswg8xhprfvh6s5md0zd36482d2nmm"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("go-github-com-hashicorp-hcl" ,go-github-com-hashicorp-hcl)
+ ("go-github-com-tj-docopt" ,go-github-com-tj-docopt)))
+ (arguments
+ '(#:import-path "github.com/segmentio/terraform-docs"))
+ (synopsis
+ "Generate documentation from Terraform modules")
+ (description
+ "The @code{terraform-docs} utility can generate documentation describing
+the inputs and outputs of Terraform modules. These can be shown, or written
+to a file in JSON or Markdown formats.")
+ (home-page "https://github.com/segmentio/terraform-docs")
+ (license license:expat)))
--
2.16.2
Christopher Baines wrote 7 years ago
[PATCH 1/3] gnu: Add go-github-com-tj-docopt.
(address . 30805@debbugs.gnu.org)
20180313202049.815-1-mail@cbaines.net
* gnu/packages/golang.scm (go-github-com-tj-docopt): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 20a8c538b..92e612d34 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -639,3 +640,27 @@ termination.")
per-goroutine.")
(home-page "https://github.com/jtolds/gls")
(license license:expat)))
+
+(define-public go-github-com-tj-docopt
+ (package
+ (name "go-github-com-tj-docopt")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tj/docopt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06h8hdg1mh3s78zqlr01g4si7k0f0g6pr7fj7lnvfg446hgc7080"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/tj/docopt"))
+ (synopsis "Go implementation of docopt")
+ (description
+ "This library allows the user to define a command-line interface from a
+program's help message rather than specifying it programatically with
+command-line parsers.")
+ (home-page "https://github.com/tj/docopt")
+ (license license:expat)))
--
2.16.2
Christopher Baines wrote 7 years ago
[PATCH 2/3] gnu: Add go-github-com-hashicorp-hcl.
(address . 30805@debbugs.gnu.org)
20180313202049.815-2-mail@cbaines.net
* gnu/packages/golang.scm (go-github-com-hashicorp-hcl): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92e612d34..e0ce1032f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -664,3 +664,30 @@ program's help message rather than specifying it programatically with
command-line parsers.")
(home-page "https://github.com/tj/docopt")
(license license:expat)))
+
+(define-public go-github-com-hashicorp-hcl
+ (let ((commit "23c074d0eceb2b8a5bfdbb271ab780cde70f05a8")
+ (revision "0"))
+ (package
+ (name "go-github-com-hashicorp-hcl")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/hcl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0db4lpqb5m130rmfy3s3gjjf4dxllypmyrzxv6ggqhkmwmc7w4mc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f
+ #:import-path "github.com/hashicorp/hcl"))
+ (synopsis "Go implementation of HashiCorp Configuration Language")
+ (description
+ "This package contains the main implementation of the @acronym{HCL,
+HashiCorp Configuration Language}. HCL is designed to be a language for
+expressing configuration which is easy for both humans and machines to read.")
+ (home-page "https://github.com/hashicorp/hcl")
+ (license license:mpl2.0))))
--
2.16.2
Ludovic Courtès wrote 7 years ago
Re: [bug#30805] [PATCH 1/3] gnu: Add go-github-com-tj-docopt.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30805@debbugs.gnu.org)
87zi36mmxm.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-tj-docopt): New variable.

LGTM!
Ludovic Courtès wrote 7 years ago
Re: [bug#30805] [PATCH 2/3] gnu: Add go-github-com-hashicorp-hcl.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30805@debbugs.gnu.org)
87vadummx0.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-hashicorp-hcl): New variable.

OK!
Ludovic Courtès wrote 7 years ago
Re: [bug#30805] [PATCH 3/3] gnu: Add terraform-docs.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30805@debbugs.gnu.org)
87r2oimmus.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/terraform.scm (terraform-docs): New variable.

[...]

Toggle quote (6 lines)
> + (synopsis
> + "Generate documentation from Terraform modules")
> + (description
> + "The @code{terraform-docs} utility can generate documentation describing
> +the inputs and outputs of Terraform modules. These can be shown, or written

Maybe s/Terraform modules/modules of the Terraform foobar/, with
appropriate “foobar”, to give a bit context.

Otherwise LGTM, thanks!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30805-done@debbugs.gnu.org)
87vaduxpth.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (15 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/terraform.scm (terraform-docs): New variable.
>
> [...]
>
>> + (synopsis
>> + "Generate documentation from Terraform modules")
>> + (description
>> + "The @code{terraform-docs} utility can generate documentation describing
>> +the inputs and outputs of Terraform modules. These can be shown, or written
>
> Maybe s/Terraform modules/modules of the Terraform foobar/, with
> appropriate “foobar”, to give a bit context.

Sounds good. I've updated the description.

Toggle quote (2 lines)
> Otherwise LGTM, thanks!

Great, I've tweaked the last patch to update local.mk and pushed these 3
patches now.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqtoApfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdkTA/+KboCf8XPwnj1wgl50EYxCoUkwPcbD7P61bekzo86F1U7ye4XLHQsAN3O
8x6A6XVHoL8Sur69G7W5BJdVTFJZ1M5xfOy9J2Oi5cyHz5Wxda6RBm4FBR+wZYiU
2tgfUOxX+6JKAyZLVFGja0EzuFKfqB48TFIlPJjF6FbZTT21ITrt9O3bOZG3amfc
Hel8vISkkPB9xKoyg0czNtx49wbipPaDeTmACa2Bug2BVBcDfW2fCMze8Q1SQbd9
FcssfRdr20uv+DVdfxg6TsZRIYDADHwu21aISeX4P7rMMniY6AHpisKvEyclsMN5
4dzarevoChX6y3/yyTTAiZUM+8sqqixTkYWE+4WSXbnpTkVdDQHvQPwThkxlRx1d
sX9ikODo1B6yyDFP7UCtq1LIlk0KdFdmyti1Twg5zrPTXIviFvrDlzGE56DJQqOH
EJM6B/8dk9vmaND+gRVTo2roQuDVgYHjmN0FwJyJ4URf3pwGTmi/36fFEtEpxh97
UtH/NCaIXHFYRSgpfWp24SZS1JnymIZZnBd5NXTNKV8YOF9uOKY2nToLuPKp9r2b
wDiyTuHIACILWpLQ9jD6t8PNDiR7G+dZimVdvGivjhi0MzCQ+dAYVsQadfrBh8d3
U+jVOD/T3IjnWHYkFTnjdymod1pQ7biQEu60uDIsEWUzteHGMkk=
=0dLc
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30805@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30805
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help