[PATCH] gnu: Add python-prometheus-client.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20180313185057.14044-1-mail@cbaines.net
* gnu/packages/monitoring.scm (python-prometheus-client,
python2-prometheus-client): New variables.
---
gnu/packages/monitoring.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index c5a86d02c..a74a72c91 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -28,6 +28,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages django)
#:use-module (gnu packages gd)
@@ -262,3 +263,34 @@ and persisting them to disk using the Whisper time-series library.")
two things: store numeric time-series data, and render graphs of this data on
demand.")
(license license:asl2.0)))
+
+(define-public python-prometheus-client
+ (package
+ (name "python-prometheus-client")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prometheus_client" version))
+ (sha256
+ (base32
+ "164qzzg8q8awqk0angcm87p2sjiibaj1wgjz0xk6j0klvqi5q2mz"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests.
+ #:tests? #f))
+ (home-page
+ "https://github.com/prometheus/client_python")
+ (synopsis
+ "Python client for the Prometheus monitoring system.")
+ (description
+ "The @code{prometheus_client} package supports exposing metrics from
+software written in Python, so that they can be scraped by a Prometheus
+service.
+
+Metrics can be exposed through a standalone web server, or through Twisted,
+WSGI and the node exporter textfile collector.")
+ (license license:asl2.0)))
+
+(define-public python2-prometheus-client
+ (package-with-python2 python-prometheus-client))
--
2.16.2
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30802@debbugs.gnu.org)
87lgetrqs3.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/monitoring.scm (python-prometheus-client,
> python2-prometheus-client): New variables.

[...]

Toggle quote (3 lines)
> + (synopsis
> + "Python client for the Prometheus monitoring system.")

No period please. :-)

Otherwise LGTM, thanks!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30802-done@debbugs.gnu.org)
874llejuqg.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/monitoring.scm (python-prometheus-client,
>> python2-prometheus-client): New variables.
>
> [...]
>
>> + (synopsis
>> + "Python client for the Prometheus monitoring system.")
>
> No period please. :-)

I've removed the period and pushed, thanks for taking a look :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqtfqhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcAUQ//R3B5HCAOrgrWJIO4/N6p/crJPAk7sJ/rA8JMVDYt+8WButR10hx14UQ1
dvuD+7X7V20pECfpVnPpjl6HaQK5nA+T7kEzSuD8BBuddpUIz03Bm0QNEUVRmzxv
F1XZx2orfNcNKfUnsOTy2mGKrWEjn6NauqKlvJASfga22fxvTHM4caLF/PwAiYdg
6OdEer/Z2+8TWDxFV5EvGi8NqnLu5cGcH//hi7gwYW3cK2sGYqAPg5C257hcn9sN
itHmyCCrw5Yv7x5GMjvGl+qW9itkhWxWy/oAPL9NFZP0AhHkRp8Cas205jBK/X4q
7UGLfxD7kzt/Lo1Q4F30xzr2v4+DW5fMKZvZ/NRasX+oVSh2dgeTP8cO0dtPWpiI
LLGDT9JPe52fOCJl2R3T5yzOodU8Tv8w+ZYZc+QvETPOpJQ/6VxG8YFEyqYqh5Y9
Dgv76SIo9/pKTh+JwGx7fp6MzjdQ94q/mW8Cv1svHYD4yPhQpYUvVgA2pKng3vHJ
woInwT8ahg9CRAXzzhrNOaCy3t16k+N6e+Qds0GuY+nybDAhrGhQXqI4e3IEnhK/
6PUkpzSNxsD1q+czQtwBGxHCD+je4oYiODH4T6lv/DftU9eIKwzHDfPcCeWpXfuw
+NaBlxqaHAnLucEBH2mpxJp3kSkKOM2msxLhDKWB0wo8y8+sqbM=
=v0ms
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30802@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30802
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help