[PATCH] services: nginx: Support extra content in the http block.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20180304200014.29173-1-mail@cbaines.net
This helpful when adding content to the nginx configuration file, which isn't
supported by the record type used for the configuration. For example, like
adding proxy_cache_path configuration.

* gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
(nginx-configuration-extra-content): New field accessor.
(default-nginx-config): Add support for the extra-content field.
* doc/guix.texi (NGINX): Document the new extra-content field.
---
doc/guix.texi | 4 ++++
gnu/services/web.scm | 9 +++++++--
2 files changed, 11 insertions(+), 2 deletions(-)

Toggle diff (58 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 057272df4..151bc7ddd 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -15431,6 +15431,10 @@ use the size of the processors cache line.
@item @code{server-names-hash-bucket-max-size} (default: @code{#f})
Maximum bucket size for the server names hash tables.
+@item @code{extra-content} (default: @code{'()})
+Extra content for the @code{http} block. Should be a list of strings or
+G-expressions.
+
@end table
@end deffn
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index beda481b0..1f58c9b86 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -73,6 +73,7 @@
nginx-configuration-upstream-blocks
nginx-configuration-server-names-hash-bucket-size
nginx-configuration-server-names-hash-bucket-max-size
+ nginx-configuration-extra-content
nginx-configuration-file
<nginx-server-configuration>
@@ -423,6 +424,8 @@
(default #f))
(server-names-hash-bucket-max-size nginx-configuration-server-names-hash-bucket-max-size
(default #f))
+ (extra-content nginx-configuration-extra-content
+ (default '()))
(file nginx-configuration-file ;#f | string | file-like
(default #f)))
@@ -513,7 +516,8 @@ of index files."
(nginx log-directory run-directory
server-blocks upstream-blocks
server-names-hash-bucket-size
- server-names-hash-bucket-max-size)
+ server-names-hash-bucket-max-size
+ extra-content)
(apply mixed-text-file "nginx.conf"
(flatten
"user nginx nginx;\n"
@@ -542,7 +546,8 @@ of index files."
"\n"
(map emit-nginx-upstream-config upstream-blocks)
(map emit-nginx-server-config server-blocks)
- "}\n"
+ extra-content
+ "\n}\n"
"events {}\n"))))
(define %nginx-accounts
--
2.16.0
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30702@debbugs.gnu.org)
87h8pel6q6.fsf@gnu.org
Hello,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (25 lines)
> This helpful when adding content to the nginx configuration file, which isn't
> supported by the record type used for the configuration. For example, like
> adding proxy_cache_path configuration.
>
> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
> (nginx-configuration-extra-content): New field accessor.
> (default-nginx-config): Add support for the extra-content field.
> * doc/guix.texi (NGINX): Document the new extra-content field.
> ---
> doc/guix.texi | 4 ++++
> gnu/services/web.scm | 9 +++++++--
> 2 files changed, 11 insertions(+), 2 deletions(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index 057272df4..151bc7ddd 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -15431,6 +15431,10 @@ use the size of the processors cache line.
> @item @code{server-names-hash-bucket-max-size} (default: @code{#f})
> Maximum bucket size for the server names hash tables.
>
> +@item @code{extra-content} (default: @code{'()})
> +Extra content for the @code{http} block. Should be a list of strings or
> +G-expressions.

I find it surprising that it’s a list rather than a string or
string-valued gexp. Thoughts?

Otherwise I think it’s very useful!

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30702@debbugs.gnu.org)
87in9ue046.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (32 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This helpful when adding content to the nginx configuration file, which isn't
>> supported by the record type used for the configuration. For example, like
>> adding proxy_cache_path configuration.
>>
>> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
>> (nginx-configuration-extra-content): New field accessor.
>> (default-nginx-config): Add support for the extra-content field.
>> * doc/guix.texi (NGINX): Document the new extra-content field.
>> ---
>> doc/guix.texi | 4 ++++
>> gnu/services/web.scm | 9 +++++++--
>> 2 files changed, 11 insertions(+), 2 deletions(-)
>>
>> diff --git a/doc/guix.texi b/doc/guix.texi
>> index 057272df4..151bc7ddd 100644
>> --- a/doc/guix.texi
>> +++ b/doc/guix.texi
>> @@ -15431,6 +15431,10 @@ use the size of the processors cache line.
>> @item @code{server-names-hash-bucket-max-size} (default: @code{#f})
>> Maximum bucket size for the server names hash tables.
>>
>> +@item @code{extra-content} (default: @code{'()})
>> +Extra content for the @code{http} block. Should be a list of strings or
>> +G-expressions.
>
> I find it surprising that it’s a list rather than a string or
> string-valued gexp. Thoughts?

Lists are used as the type for other fields in related records. I chose
a list as it's easy to add things to, but thinking about it, that's
probably true for strings and gexps as well.

Saying it can be either a string or a gexp might be a little tricky, as
string operations wouldn't work on the gexp. My familiarity with
string-valued gexps is a little limited though, I've only just started
using file-append more, as I think that's how it works. How would you go
about adding say a string to a gexp?
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqtqOlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdwWw/9Fyilf/8Dpc04VZTxco20OEiAKS9q/nhWHkTx4lr40u6H7yV3iXDy3xyL
t+JXeJJGbRZDNbP0NzJiWfMPRJQsiDxD3UST/W9SsfED1yATvn+eFlotunmj9hw/
//15qljejqbBHZllTMVKnW7fNNVfQKaiyddZrQL7DOI56rav5Gn6VZ10t0K8zthv
XKHtFiLBlEiGPwEFIMnXSydJiSaLlsn9ZkJaJjH8+ux7uK3p4Wj4pjhtC34G+26O
HoF9WWSjFXAbZb9+ne/GmgoNxtxUsjsS8kfboHTXWMo3WsVYXQ/wfuVKiyvKEhCO
ym2oTGWuD5W7/K/CeqVRm2J8qRWK4cndHpS9VcReQ6U/aq6yWRLxd+iauu3EnKCI
bOqA0UbBecg17DwpFtrYnwzzWrL4wJYrlKCDr+lIKtl5xFnUeKfLXfFM+D9EuE4I
8hksB9RAje2Lpe2cL0Ba671034h3Qesn5SGjzaGaELo/wqlUmjsWyUCrUqghDNlb
iMThvWeUOnd7UllobU3HYNROBbf4RAlFqiKMrLklV1uA5y9Sw2MX9CUs5rznGiM5
3yJ+WCMYjkwWSyR55+Ixi/Y9rEstR2kTKdwAd7bm6F/Lu2m058rp6Qmche4+Jr+3
IPkUfbGTm6ttNQIO0kJnzJB5JznD2eNQXFsnTGAPoEA26vLiw14=
=R3Mz
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30702@debbugs.gnu.org)
87h8pdnw8l.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> Ludovic Courtès <ludo@gnu.org> writes:

[...]

Toggle quote (17 lines)
>>> +@item @code{extra-content} (default: @code{'()})
>>> +Extra content for the @code{http} block. Should be a list of strings or
>>> +G-expressions.
>>
>> I find it surprising that it’s a list rather than a string or
>> string-valued gexp. Thoughts?
>
> Lists are used as the type for other fields in related records. I chose
> a list as it's easy to add things to, but thinking about it, that's
> probably true for strings and gexps as well.
>
> Saying it can be either a string or a gexp might be a little tricky, as
> string operations wouldn't work on the gexp. My familiarity with
> string-valued gexps is a little limited though, I've only just started
> using file-append more, as I think that's how it works. How would you go
> about adding say a string to a gexp?

You’d have to produce build-side code that will concatenate the strings:

;; Add extra content to CONFIG.
(let ((original (nginx-extra-content config)))
(nginx-configuration
(inherit config)
(extra-content #~(string-append #$original "\nextra extra stuff"))))

HTH!

Ludo’.
Christopher Baines wrote 7 years ago
[PATCH] services: nginx: Support extra content in the http block.
(address . 30702@debbugs.gnu.org)
20180518085422.15849-1-mail@cbaines.net
This helpful when adding content to the nginx configuration file, which isn't
supported by the record type used for the configuration. For example, like
adding proxy_cache_path configuration.

* gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
(nginx-configuration-extra-content): New field accessor.
(default-nginx-config): Add support for the extra-content field.
* doc/guix.texi (NGINX): Document the new extra-content field.
---
doc/guix.texi | 4 ++++
gnu/services/web.scm | 9 +++++++--
2 files changed, 11 insertions(+), 2 deletions(-)

Toggle diff (58 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index a12210db8..eaaf0e684 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -15786,6 +15786,10 @@ use the size of the processors cache line.
@item @code{server-names-hash-bucket-max-size} (default: @code{#f})
Maximum bucket size for the server names hash tables.
+@item @code{extra-content} (default: @code{""})
+Extra content for the @code{http} block. Should be string or a string
+valued G-expression.
+
@end table
@end deffn
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index b336a8dd3..8f55dae5e 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -73,6 +73,7 @@
nginx-configuration-upstream-blocks
nginx-configuration-server-names-hash-bucket-size
nginx-configuration-server-names-hash-bucket-max-size
+ nginx-configuration-extra-content
nginx-configuration-file
<nginx-server-configuration>
@@ -423,6 +424,8 @@
(default #f))
(server-names-hash-bucket-max-size nginx-configuration-server-names-hash-bucket-max-size
(default #f))
+ (extra-content nginx-configuration-extra-content
+ (default ""))
(file nginx-configuration-file ;#f | string | file-like
(default #f)))
@@ -513,7 +516,8 @@ of index files."
(nginx log-directory run-directory
server-blocks upstream-blocks
server-names-hash-bucket-size
- server-names-hash-bucket-max-size)
+ server-names-hash-bucket-max-size
+ extra-content)
(apply mixed-text-file "nginx.conf"
(flatten
"user nginx nginx;\n"
@@ -542,7 +546,8 @@ of index files."
"\n"
(map emit-nginx-upstream-config upstream-blocks)
(map emit-nginx-server-config server-blocks)
- "}\n"
+ extra-content
+ "\n}\n"
"events {}\n"))))
(define %nginx-accounts
--
2.17.0
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30702@debbugs.gnu.org)
87muwx484h.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (32 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This helpful when adding content to the nginx configuration file, which isn't
>> supported by the record type used for the configuration. For example, like
>> adding proxy_cache_path configuration.
>>
>> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
>> (nginx-configuration-extra-content): New field accessor.
>> (default-nginx-config): Add support for the extra-content field.
>> * doc/guix.texi (NGINX): Document the new extra-content field.
>> ---
>> doc/guix.texi | 4 ++++
>> gnu/services/web.scm | 9 +++++++--
>> 2 files changed, 11 insertions(+), 2 deletions(-)
>>
>> diff --git a/doc/guix.texi b/doc/guix.texi
>> index 057272df4..151bc7ddd 100644
>> --- a/doc/guix.texi
>> +++ b/doc/guix.texi
>> @@ -15431,6 +15431,10 @@ use the size of the processors cache line.
>> @item @code{server-names-hash-bucket-max-size} (default: @code{#f})
>> Maximum bucket size for the server names hash tables.
>>
>> +@item @code{extra-content} (default: @code{'()})
>> +Extra content for the @code{http} block. Should be a list of strings or
>> +G-expressions.
>
> I find it surprising that it’s a list rather than a string or
> string-valued gexp. Thoughts?

I've now got around to trying this out, and sent a patch that uses a
string, rather than a list.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEERHy+A2M6g58efdvjEhhPDQ1NBccFAlr+nudfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDQ0
N0NCRTAzNjMzQTgzOUYxRTdEREJFMzEyMTg0RjBEMEQ0RDA1QzcACgkQEhhPDQ1N
BcfCPA/+NrXZLPuAT+RM+DAXGgQ6TFCY49EUqd+XYKx0Mmtvsf+wh64CdkAWOdaR
BqkeAcWf7zNALdo5eM8WZO5l8GH6DrrUFpYBSkJuMZiXtImNhtLwXXQIjLTpn/72
8WBv5zi/RDSHFwdvtVqgWNdFG2zHFLCRre+81v4Ii3gw8xGh8vLucUSRJ/cn4AMQ
iHl6i5KK9zmZG6I8zhpE7HfCviXx0ssNSF/FEiXq9erRzyqtMY+abWfKmn5N2fzn
o+LdPMU6En/9WsDqaHUCP1xzkPu5YmIY1eMNcvJ0UtZctzBBEDwDbHIwKZ0lRv+d
JlMm6wQUSKagl+E6xm5y5OV3BCCkbQcLmz2NX+KUXUTnIkrmngA7H7ylCtSJCYAj
ui7Ss63XKIRsLFLVebP0fWxP3U/hwrwS0MtWYYIlNsRZ60PWxXU9Z4QJiQE80iCQ
/iPfi5u/bVPQ1CPUzg6ZhJ5AjWZ5SiytZ1Myx8gcvkYKxFh1KHaBKmo+8YvEwZGH
UPtrIjN9VuzrPrIdfbrMTzBcC2amyv4leh/sZYvIIGFT2Yl96FVj7+dM8Vms6InS
AsfscAWIlMDoNXFXLVNlFcycwyKYM8VaT/oI8hDH091mZAhew7TrQsmXtGa9IUCr
83AoxT1UUjYbHXvGEJkrpA3X5/+d7vS6eSA4mIZpduvYXNRsLXs=
=S5Pc
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30702@debbugs.gnu.org)
87wovzo01h.fsf@gnu.org
Hello,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (9 lines)
> This helpful when adding content to the nginx configuration file, which isn't
> supported by the record type used for the configuration. For example, like
> adding proxy_cache_path configuration.
>
> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
> (nginx-configuration-extra-content): New field accessor.
> (default-nginx-config): Add support for the extra-content field.
> * doc/guix.texi (NGINX): Document the new extra-content field.

[...]

Toggle quote (4 lines)
> +@item @code{extra-content} (default: @code{""})
> +Extra content for the @code{http} block. Should be string or a string
> +valued G-expression.

[...]

Toggle quote (12 lines)
> (apply mixed-text-file "nginx.conf"
> (flatten
> "user nginx nginx;\n"
> @@ -542,7 +546,8 @@ of index files."
> "\n"
> (map emit-nginx-upstream-config upstream-blocks)
> (map emit-nginx-server-config server-blocks)
> - "}\n"
> + extra-content
> + "\n}\n"
> "events {}\n"))))

That doesn’t work if ‘extra-content’ is something like:

#~(string-append "foo" bar)

does it?

My understanding of the doc above was that it intends to allow this.
But maybe it doesn’t matter after all?

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30702@debbugs.gnu.org)
8736xt42l8.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (42 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This helpful when adding content to the nginx configuration file, which isn't
>> supported by the record type used for the configuration. For example, like
>> adding proxy_cache_path configuration.
>>
>> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
>> (nginx-configuration-extra-content): New field accessor.
>> (default-nginx-config): Add support for the extra-content field.
>> * doc/guix.texi (NGINX): Document the new extra-content field.
>
> [...]
>
>> +@item @code{extra-content} (default: @code{""})
>> +Extra content for the @code{http} block. Should be string or a string
>> +valued G-expression.
>
> [...]
>
>> (apply mixed-text-file "nginx.conf"
>> (flatten
>> "user nginx nginx;\n"
>> @@ -542,7 +546,8 @@ of index files."
>> "\n"
>> (map emit-nginx-upstream-config upstream-blocks)
>> (map emit-nginx-server-config server-blocks)
>> - "}\n"
>> + extra-content
>> + "\n}\n"
>> "events {}\n"))))
>
> That doesn’t work if ‘extra-content’ is something like:
>
> #~(string-append "foo" bar)
>
> does it?
>
> My understanding of the doc above was that it intends to allow this.
> But maybe it doesn’t matter after all?

So... I've finally got back around to looking at this, and as far as I
can see, it does work. extra-content is passed as one of the arguments
to mixed-text-file, which accepts G-exp things.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlseuuNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xe2Yw//TqO2XifrzPW/CH2+gZAY2gK78mZz4jLuUlLoYi3i/8gELolsyqsgmshX
wp0BYBEonz8Npj7OvV4huslI8QwzwM2RZbT/CsAaUlnWUKK6nD1UHVmhJB7VtsOO
niSNAAoKP1k9MTYkaMwj8EL2YBKj69BM4DgFhtcqTxHi+oWvLyl2PtVQMYLpVyFc
3Wlvda9jOENaPainYHApeUil3jjqVgmRQ3ra5dUAaivuMmWDK2lD8Dvf2VnGX+LD
3K0yTmZJmTDKW0YOJXHUlKOjjXWg1rLdGjOML3hZt8cGfDZDJyJszL9Cwy55pOo3
mPPaJascxyht2IR0Z4UsPDT0+x0gDu43ljQI3m3jcd8kk2XAl1lv6T4R/fIcLhuq
6E2zFYDPaYiJHvOUcKyeR/Yvt1ik2iaVjg6yB1sL/PrMzmo3fec6hS+3yDT8pPfO
my1psaUOtqcekajyP/m95RDTyd9Ig0TwfQ2QyamnD2Hnm7lwYcx4ZeuOLpe7SM6n
mX6wcO17HTEIKJduEJo/PDr/Z4X55oDQv/1fYqFLpP2/NbKo8i6mRYZqsh+b70Lr
SVIGUwUizxHGQoWDtMtSJvUZbiMW573q1QjxIQZ0iWZg3sohNbrd7Kk35GMkDMIj
f/tXl5rMnaGJIUUq3kP2JgEOg6ZTngJzRxUnj1OyGEZnCzwFhOg=
=ohdz
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30702@debbugs.gnu.org)
87y3fkqskc.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (48 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello,
>>
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> This helpful when adding content to the nginx configuration file, which isn't
>>> supported by the record type used for the configuration. For example, like
>>> adding proxy_cache_path configuration.
>>>
>>> * gnu/packages/web.scm (<nginx-configuration>): Add new extra-content field.
>>> (nginx-configuration-extra-content): New field accessor.
>>> (default-nginx-config): Add support for the extra-content field.
>>> * doc/guix.texi (NGINX): Document the new extra-content field.
>>
>> [...]
>>
>>> +@item @code{extra-content} (default: @code{""})
>>> +Extra content for the @code{http} block. Should be string or a string
>>> +valued G-expression.
>>
>> [...]
>>
>>> (apply mixed-text-file "nginx.conf"
>>> (flatten
>>> "user nginx nginx;\n"
>>> @@ -542,7 +546,8 @@ of index files."
>>> "\n"
>>> (map emit-nginx-upstream-config upstream-blocks)
>>> (map emit-nginx-server-config server-blocks)
>>> - "}\n"
>>> + extra-content
>>> + "\n}\n"
>>> "events {}\n"))))
>>
>> That doesn’t work if ‘extra-content’ is something like:
>>
>> #~(string-append "foo" bar)
>>
>> does it?
>>
>> My understanding of the doc above was that it intends to allow this.
>> But maybe it doesn’t matter after all?
>
> So... I've finally got back around to looking at this, and as far as I
> can see, it does work. extra-content is passed as one of the arguments
> to mixed-text-file, which accepts G-exp things.

Alright, sounds good then!

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30702-done@debbugs.gnu.org)
87r2lb3gd2.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (2 lines)
> Alright, sounds good then!

Great, I've pushed this patch now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlsgK2lfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcSMA//bMkLqVmNtsMm9dwRz+oOvk8KiVhZj++Yvcz7D17mx1XKGX5roTlbgShX
BlmH0e2IEl5ZCcx36319QNg/P3yJtPkHUwNYeGOHFvrivS+u0U5qJZfRXjPlQMGr
f/OUEx9CSTSd31qmfRCKxZyFhXAymbY+7DhgLUz2fto/h/WpA0h8IUL+8wy6c2tI
Xl9R+GPsH6Rlu8WuM57uRbZFxB9fzVwjeSfXyFVlJEr/a2721kxNvk+o1qmdQ0cB
ETZqwV1U/GYRhMwi55y2aSYa9xMTVjf7ipSqd3FN+nD+7vaDhtTaCfxG3bPvi8k8
j1e8bMaNukeq0nhEU6qFzViT1e9A2uLsVa8BsO9YFFugMwTGuh6XgOMn3ISfYMPq
ikaLgnPim9lu+lVxheYiQlvNtnwwII7G99HT6kgzUNPZ5uqeY6bInI4FQt+1KbLi
jAKuxYjYuqUcuAxHM+46j8h22ZPWRxeq2IkpFyZLyzvMb/Iu/GGe64/UuE+RnlVG
MQxbejQz0Ywr80d6B16jU/qoGSvCzjIV1rS8zSBuhjjRvo2ZpHh7eGZBjfbmslQL
hlMmP//wY0FXAA9CNAheFnkVdF3YfVEft/x7Sb77OTomKOXEqVGB7x7cZA4O/8jV
Coy2+MpKdq7Ltlrfvg0xRDv0y5z29CySrIpPjtUoL07UkncaI0g=
=Pyt7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30702@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30702
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help