[PATCH 0/2] Add Emacs packages for HCL and Terraform.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Kost
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
877eqrrdom.fsf@cbaines.net
Christopher Baines (2):
gnu: Add emacs-hcl-mode.
gnu: Add emacs-terraform-mode.

gnu/packages/emacs.scm | 47 +++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqcIvlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xdkfw/8ClguPZ6gnPgXBXUfu1KcYHKIYBRBYWDMAuA9lfeHrdh8UJI5UAp1xMa7
srevvcIiNTaoJsUQNaW6Q5GtUfmCRFOuj/bBKJd8LdYHTN6g6CSQaYXyrDQSZO0H
yAUZpQ2H9pWMKsZvoS7pmHFqI77RBBamPXETxvspFLL3Ou/uZ/NUvtXQTFZN+t7u
ZYvtEiR+Qi7qTh9Qe6VLwWqyMXNdNaJYDmRMySOLkT03cwbvM4I6yPxb7bYGOIZ7
kcNCIOIzvt7lSeEfo2fGHLGJ8DPBtQ8rtPY7arSt9AMlTfAJNtw+YrMgh86m6vh8
PdBMslLZ8iPTdugG0LqhLVYGiqszxbi/CpsBNo5c+nOiSYfuESIFvDyaRwGHY2Yt
RIfalELnCNlxFL/gWeuAyMGMXIkI+1d7f3hpUvcAoEFseBx73UdOKunOsbtU5vxe
Wj/ySR88S4KZF/GRILOXUVYcSMw+w2enUychEVty1uJtZYhioyn8eir7aL/vt4kp
QOW+bx+4RG5jGnFfirM/fMASgoI6UstvC7e0J4gKY+bQUJldmDzvVGYj8cbzC6cZ
6UYzOo6CtW+O/TFbQTTJLjxo/e5yGiUrDU95XXwcbF6liYht0XGMRqDwIVnVUeDA
OkoRapeZgO9xOgVwEFH0NOpTn08wOzv0Bdgryf/6fZIqKfjULf4=
=N6Em
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
[PATCH 2/2] gnu: Add emacs-terraform-mode.
(address . 30698@debbugs.gnu.org)
20180304165051.14024-2-mail@cbaines.net
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0e46c71f1..da31f7a13 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7336,3 +7336,27 @@ the pipeline, featuring the support for running @code{emacsclient}.")
@acronym{HCL, Hashicorp Configuration Language}. It provides syntax
highlighting and indentation support. ")
(license license:gpl3+)))
+
+(define-public emacs-terraform-mode
+ (package
+ (name "emacs-terraform-mode")
+ (version "0.06")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/syohex/emacs-terraform-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h9267ifdjmcin4sj8slxydbacx4bqicbvg8pa1qq2l72h9m5381"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-hcl-mode" ,emacs-hcl-mode)))
+ (home-page "https://github.com/syohex/emacs-terraform-mode")
+ (synopsis "Major mode for Terraform")
+ (description
+ "@code{emacs-terraform-mode} provides a major mode for working with
+Terraform. Most of the functionality is inherited from @code{hcl-mode}.")
+ (license license:gpl3+)))
--
2.16.1
Christopher Baines wrote 7 years ago
[PATCH 1/2] gnu: Add emacs-hcl-mode.
(address . 30698@debbugs.gnu.org)
20180304165051.14024-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-hcl-mode): New variable.
---
gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 69950cc6d..0e46c71f1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7313,3 +7313,26 @@ Features:
(description "@code{epipe} provides an utility to use your editor in
the pipeline, featuring the support for running @code{emacsclient}.")
(license license:gpl3+)))
+
+(define-public emacs-hcl-mode
+ (package
+ (name "emacs-hcl-mode")
+ (version "0.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/syohex/emacs-hcl-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pvw74qpwh0znqzp6syp4wxjqs7dp1hbn5h7xfk97mff9l5d8k6x"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syohex/emacs-hcl-mode")
+ (synopsis "Major mode for the Hashicorp Configuration Language")
+ (description
+ "@code{emacs-hcl-mode} provides an Emacs major mode for working with
+@acronym{HCL, Hashicorp Configuration Language}. It provides syntax
+highlighting and indentation support. ")
+ (license license:gpl3+)))
--
2.16.1
Alex Kost wrote 7 years ago
Re: [bug#30698] [PATCH 2/2] gnu: Add emacs-terraform-mode.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30698@debbugs.gnu.org)
87bmg3egnb.fsf@gmail.com
Christopher Baines (2018-03-04 16:50 +0000) wrote:

Toggle quote (36 lines)
> ---
> gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 0e46c71f1..da31f7a13 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -7336,3 +7336,27 @@ the pipeline, featuring the support for running @code{emacsclient}.")
> @acronym{HCL, Hashicorp Configuration Language}. It provides syntax
> highlighting and indentation support. ")
> (license license:gpl3+)))
> +
> +(define-public emacs-terraform-mode
> + (package
> + (name "emacs-terraform-mode")
> + (version "0.06")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/syohex/emacs-terraform-mode/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0h9267ifdjmcin4sj8slxydbacx4bqicbvg8pa1qq2l72h9m5381"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-hcl-mode" ,emacs-hcl-mode)))
> + (home-page "https://github.com/syohex/emacs-terraform-mode")
> + (synopsis "Major mode for Terraform")
> + (description
> + "@code{emacs-terraform-mode} provides a major mode for working with
> +Terraform. Most of the functionality is inherited from @code{hcl-mode}.")

Maybe it would be good to clarify what Terraform is in the description,
for example:

"... working with @uref{https://www.terraform.io/,Terraform}
configuration files."

Toggle quote (2 lines)
> + (license license:gpl3+)))

--
Alex
Alex Kost wrote 7 years ago
Re: [bug#30698] [PATCH 1/2] gnu: Add emacs-hcl-mode.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30698@debbugs.gnu.org)
877eqreglf.fsf@gmail.com
Christopher Baines (2018-03-04 16:50 +0000) wrote:

Toggle quote (35 lines)
> * gnu/packages/emacs.scm (emacs-hcl-mode): New variable.
> ---
> gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 69950cc6d..0e46c71f1 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -7313,3 +7313,26 @@ Features:
> (description "@code{epipe} provides an utility to use your editor in
> the pipeline, featuring the support for running @code{emacsclient}.")
> (license license:gpl3+)))
> +
> +(define-public emacs-hcl-mode
> + (package
> + (name "emacs-hcl-mode")
> + (version "0.03")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/syohex/emacs-hcl-mode/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0pvw74qpwh0znqzp6syp4wxjqs7dp1hbn5h7xfk97mff9l5d8k6x"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/syohex/emacs-hcl-mode")
> + (synopsis "Major mode for the Hashicorp Configuration Language")
> + (description
> + "@code{emacs-hcl-mode} provides an Emacs major mode for working with
> +@acronym{HCL, Hashicorp Configuration Language}. It provides syntax
> +highlighting and indentation support. ")
^ extra space
otherwise, looks good to me, thank you!

Toggle quote (2 lines)
> + (license license:gpl3+)))

--
Alex
Christopher Baines wrote 7 years ago
Re: [bug#30698] [PATCH 2/2] gnu: Add emacs-terraform-mode.
(name . Alex Kost)(address . alezost@gmail.com)(address . 30698@debbugs.gnu.org)
87o9k3otk0.fsf@cbaines.net
Alex Kost <alezost@gmail.com> writes:

Toggle quote (44 lines)
> Christopher Baines (2018-03-04 16:50 +0000) wrote:
>
>> ---
>> gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
>> 1 file changed, 24 insertions(+)
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index 0e46c71f1..da31f7a13 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -7336,3 +7336,27 @@ the pipeline, featuring the support for running @code{emacsclient}.")
>> @acronym{HCL, Hashicorp Configuration Language}. It provides syntax
>> highlighting and indentation support. ")
>> (license license:gpl3+)))
>> +
>> +(define-public emacs-terraform-mode
>> + (package
>> + (name "emacs-terraform-mode")
>> + (version "0.06")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://github.com/syohex/emacs-terraform-mode/archive/"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "0h9267ifdjmcin4sj8slxydbacx4bqicbvg8pa1qq2l72h9m5381"))))
>> + (build-system emacs-build-system)
>> + (propagated-inputs
>> + `(("emacs-hcl-mode" ,emacs-hcl-mode)))
>> + (home-page "https://github.com/syohex/emacs-terraform-mode")
>> + (synopsis "Major mode for Terraform")
>> + (description
>> + "@code{emacs-terraform-mode} provides a major mode for working with
>> +Terraform. Most of the functionality is inherited from @code{hcl-mode}.")
>
> Maybe it would be good to clarify what Terraform is in the description,
> for example:
>
> "... working with @uref{https://www.terraform.io/, Terraform}
> configuration files."

Sure, that sounds good, thanks for taking a look :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqc9V9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfDVQ/+LeKUCrEEfpE1VgCjwJEv0NsOBsNIK69t+87NrI3yB5S1rfvm7o5ArKYH
N9DciBjiRrfywBPqTzkj4xCxDwQTZMlfseGuQYChS6E6jPrRf139LCHpGmeFNiLW
UJY1CsznAWxz1RyXmkS//Ce3x+xP79wPLot/WMEt2hr4HimwgIpiIcV6nPkXK/Uv
G5cXkXT0g0d3CItEEU5dAP/Iz/xsb9PFbhTk6seVne/uxb7oXQFgVAA67UR8Lg3J
ePKgg6U4TDFPg6l7cB5V4MDNyrn8oK9BtZeIHQ7gSVWE7sI0DX81JylQ4t3vJlyJ
EXcGzij4gxZgfvwoeCRayjvIZeWCcy5scTjjAulilGUAQvq7qja927sVY7UPGtIt
NUh/miJ1km4jyAxbwecsQoIphvKQxlm6TYp2luWBtDfdr0I5bsyhvF+PK//lOlQe
Q9gn89T2AjeUf7HJrDRDCUIfZo7hbMGVYG6MZHOBss/vPOwoP1sia6PFW3JxDm/a
UeqC9rfPexRWviob5TX3h5bgLLNdKjEvmppk3Z8jNkmDGxDeAZkC7VtRYTC1mXM2
EJbESTAAKTuGbXdQOh0Oskgac/c3Qy1GNWRjwrvwJPoVFhTgQE6dAXPdFtsQohim
oehXCKhakcxZfLMCABOgig/MHDDyw9mbjcEHsGUoU4BbdkkyIRM=
=52s6
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
Re: [bug#30698] [PATCH 1/2] gnu: Add emacs-hcl-mode.
(name . Alex Kost)(address . alezost@gmail.com)(address . 30698-done@debbugs.gnu.org)
87muznota8.fsf@cbaines.net
Alex Kost <alezost@gmail.com> writes:

Toggle quote (40 lines)
> Christopher Baines (2018-03-04 16:50 +0000) wrote:
>
>> * gnu/packages/emacs.scm (emacs-hcl-mode): New variable.
>> ---
>> gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
>> 1 file changed, 23 insertions(+)
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index 69950cc6d..0e46c71f1 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -7313,3 +7313,26 @@ Features:
>> (description "@code{epipe} provides an utility to use your editor in
>> the pipeline, featuring the support for running @code{emacsclient}.")
>> (license license:gpl3+)))
>> +
>> +(define-public emacs-hcl-mode
>> + (package
>> + (name "emacs-hcl-mode")
>> + (version "0.03")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://github.com/syohex/emacs-hcl-mode/archive/"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "0pvw74qpwh0znqzp6syp4wxjqs7dp1hbn5h7xfk97mff9l5d8k6x"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/syohex/emacs-hcl-mode")
>> + (synopsis "Major mode for the Hashicorp Configuration Language")
>> + (description
>> + "@code{emacs-hcl-mode} provides an Emacs major mode for working with
>> +@acronym{HCL, Hashicorp Configuration Language}. It provides syntax
>> +highlighting and indentation support. ")
> ^ extra space
> otherwise, looks good to me, thank you!

Great, I've removed the space, and pushed both of these patches. Thanks
for your review :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqc9r9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfckRAAkyFNo6wmDeqyB/wfNpfEKkQOCMUz6lmyQ2r3utGtNz138BpsknTzvLZD
r9mC37fFtu4JzCx/bHMIh6rXASA71UZhQbojenaKYYecPerDc3zVE6senbzCwTQc
OWdS+9cJ1maW2enIdoGL1IMf5X1iZjdRGscDT6Sg5+Sg+u8S/g6XMqpJ+Q9hU2UY
TP5elbk2PnVbg5QFFJA9hhj2zhmILfegMHh9xOHU/RSJdRrpNwip/M3iELiDPIIg
b7wurQhVfN1mY5hDZ1ZQivo2m7+5Cgr/YB0cS8OeRAp1B0NEYGkGaNW2Dowp4jDt
YI9wUYnABGScImsNEYe4ZkW1KLhoVGQ4h5fnkce2UDaO7bRs0BjqMu+KacFThuD3
XJ37wTDncy18AGHSDZDFRjxJRK9sSj0uSGfKISV/gUeIKlr4azBR5f9tHN3Hk8jG
OUIEU+j6IzFBlgRVqDgHj+q6UIhKQegtp9Mo0rRoT48yxif+6obAiy/rOHybpbW/
pKe6xNNZdLRjcD7c85YnUFulFfqMXSxYLjY+nDsFwdCBKEOvVaa2j4/GTUHdVaZN
GPACkCrIWKdTidCqMBUbNoGIn5DEkq5ouaXG94qD15WY2OVjmuOvP7dy2XPxwrVh
I7Ak+PuVwh0pHlOCZWz1+LZHAXTiXc7HgWkdGafqJBvMiHLS2oM=
=jL33
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30698@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30698
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help