[PATCH 0/4] Django related updates and additions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
878tb7rilb.fsf@cbaines.net
Christopher Baines (4):
gnu: Add python-djangorestframework.
gnu: Add python-django-crispy-forms.
gnu: Update python-django-filter to 1.1.0.
gnu: Update python-django-gravatar2.

gnu/packages/django.scm | 62 +++++++++++++++++++++++++++++++++++++++++++++----
1 file changed, 58 insertions(+), 4 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqcCiBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xck8xAAiDIROuha3+zCw5tBkTPJjd4rnl4d5SWemv3cdoksdQ5HAeK5KYU6g5p1
oiARGi2UvoKNqN5102kTBFjf0tbhiwl1wsRUimMLKmfEJU2N0qVJThgDiH5Hql8d
Q80prTQYVEG3NUAyc3oGYsUbCZEXXRIZLiaOpEZO4CuGNcRmOIWYTpNlSd0dNzNQ
fBrMR6nt1f8JOmJGp3hbs+6v6wvATxItY2w0Cta83/R3qXlfT+uv7W8gF1WFvn5q
cDFSzKsJMrXo+CGgF4HxQqZiKC0q5RJxFy4jQVJjIGqydOTPtDp7OTzm/GH44tNp
MNrpiTawHpdf1oPse98Dt9Zaxp6GlfR4mS3k6SoWy55WVLf/7ivUlXlHPgDz0RB4
4EOrzfrBNM781eINSo+X/YGc80Pfczu+xjkFt0NepfVClszPKIC2d2vGIb4X4zbY
hHcxPBw+nfOJ9Vj4dkllewxsyjVwaKpM79Sdd2QQAHUx3cEZG8rNLD6IOHNZ2kzO
wHlA+w9vlzwV0uvan7ur88jFaZWKDN+xajJXOD9yn32CKyT5wvYQ5SOzgMczerBR
Hl6b2RHHFgIzlIu8+3Slrn14ry3k5U3g+RgIcgqeNoPmy6jINR46xHAUt+2SwSll
YI4Bo0iOsop9g+5xgcD+cQAq7b4n+fZ5ngEfFXmwznphqrFFihw=
=Zdle
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
[PATCH 1/4] gnu: Add python-djangorestframework.
(address . 30696@debbugs.gnu.org)
20180304151907.1611-1-mail@cbaines.net
* gnu/packages/django.scm (python-djangorestframework): New variable.
---
gnu/packages/django.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0b447b517..0c0fc6f75 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -755,3 +755,27 @@ Django projects, which allows association of a number of tags with any
(define-public python2-django-tagging
(package-with-python2 python-django-tagging))
+
+(define-public python-djangorestframework
+ (package
+ (name "python-djangorestframework")
+ (version "3.7.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "djangorestframework" version))
+ (sha256
+ (base32
+ "11qv117gqwswxjljs7wafxg1hyzzlx3qrviwlk9hw41bsbl997lz"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page "https://www.django-rest-framework.org")
+ (synopsis "Toolkit for building Web APIs with Django")
+ (description
+ "The Django REST framework is for building Web APIs with Django. It
+provides features like a web browseable API and authentication policies.")
+ (license license:bsd-2)))
--
2.16.1
Christopher Baines wrote 7 years ago
[PATCH 2/4] gnu: Add python-django-crispy-forms.
(address . 30696@debbugs.gnu.org)
20180304151907.1611-2-mail@cbaines.net
* gnu/packages/django.scm (python-django-crispy-forms): New variable.
---
gnu/packages/django.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0c0fc6f75..ba37f4f87 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -779,3 +779,28 @@ Django projects, which allows association of a number of tags with any
"The Django REST framework is for building Web APIs with Django. It
provides features like a web browseable API and authentication policies.")
(license license:bsd-2)))
+
+(define-public python-django-crispy-forms
+ (package
+ (name "python-django-crispy-forms")
+ (version "1.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-crispy-forms" version))
+ (sha256
+ (base32
+ "16s05jx86jmimlvnwpq73kl0mqw1v9lryc8zi61a9qwl25krm6mj"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page
+ "http://github.com/maraujop/django-crispy-forms")
+ (synopsis "Tool to control Django forms without custom templates")
+ (description
+ "@code{django-crispy-forms} lets you easily build, customize and reuse
+forms using your favorite CSS framework, without writing template code.")
+ (license license:expat)))
--
2.16.1
Christopher Baines wrote 7 years ago
[PATCH 4/4] gnu: Update python-django-gravatar2.
(address . 30696@debbugs.gnu.org)
20180304151907.1611-4-mail@cbaines.net
* gnu/packages/django.scm (python-django-gravatar2)[version]: Update from
1.4.0 to 1.4.2.
[source]: Update sha256 hash.
[arguments]: Disable the tests, as the django project for the tests is
missing.
---
gnu/packages/django.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 9db1e2858..24952aa51 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -267,15 +267,18 @@ account authentication.")
(define-public python-django-gravatar2
(package
(name "python-django-gravatar2")
- (version "1.4.0")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "django-gravatar2" version))
(sha256
(base32
- "1v4qyj6kms321yw0z2g1kch6b2dskmv6fjd6sfxzwr4xshq9mccl"))))
+ "1qsv40xywbqsf4mkrmsswrpzqd7nfljxpfiim9an2z3dykn5rka6"))))
(build-system python-build-system)
+ (arguments
+ '(;; TODO: The django project for the tests is missing from the release.
+ #:tests? #f))
(inputs
`(("python-django" ,python-django)))
(home-page "https://github.com/twaddington/django-gravatar")
--
2.16.1
Christopher Baines wrote 7 years ago
[PATCH 3/4] gnu: Update python-django-filter to 1.1.0.
(address . 30696@debbugs.gnu.org)
20180304151907.1611-3-mail@cbaines.net
* gnu/packages/django.scm (python-django-filter)[version]: Update from 0.14.0
to 1.1.0.
[source]: Update sha256 hash.
[native-inputs]: Add python-djangorestframework and
python-django-crispy-forms as native inputs, as they are used in the test
suite.
---
gnu/packages/django.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index ba37f4f87..9db1e2858 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -182,13 +182,13 @@ useful tools for testing Django applications and projects.")
(define-public python-django-filter
(package
(name "python-django-filter")
- (version "0.14.0")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "django-filter" version))
(sha256
(base32
- "0f78hmk8c903zwfzlsiw7ivgag81ymmb5hi73rzxbhnlg2v0l3fx"))))
+ "0slpfqfhnjrzlrb6vmswyhrzn01p84s16j2x1xib35gg4fxg23pc"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -198,6 +198,8 @@ useful tools for testing Django applications and projects.")
(zero? (system* "python" "runtests.py")))))))
(native-inputs
`(("python-django" ,python-django)
+ ("python-djangorestframework" ,python-djangorestframework)
+ ("python-django-crispy-forms", python-django-crispy-forms)
("python-mock" ,python-mock)))
(home-page "https://django-filter.readthedocs.io/en/latest/")
(synopsis "Reusable Django application to filter querysets dynamically")
--
2.16.1
Marius Bakke wrote 7 years ago
Re: [bug#30696] [PATCH 0/4] Django related updates and additions.
87606911yu.fsf@fastmail.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (9 lines)
> Christopher Baines (4):
> gnu: Add python-djangorestframework.
> gnu: Add python-django-crispy-forms.
> gnu: Update python-django-filter to 1.1.0.
> gnu: Update python-django-gravatar2.
>
> gnu/packages/django.scm | 62 +++++++++++++++++++++++++++++++++++++++++++++----
> 1 file changed, 58 insertions(+), 4 deletions(-)

LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlqe4MkACgkQoqBt8qM6
VPoslgf/QLS4CZx08YZWeeSR/BgWrjBxg0hFej0eFkUbLTg9dKEMyad9HztTeRgq
KV1T7tu5EZiOa89cYS7LTqQMHZFRS8p56Jc5BprTN8TLAtHUXooBBNgfqz+PwGuB
kgyyq+94Yylv592e9lYpPbb8l35Lh1W9j8cByRo7SK9uqotK2eqQWEfrc6j9FFSX
1mjAyeqf26WIg0W8ciAAGO+SnRRvnFHvFIJIm2BBdBK+8qR+VhlNvfyhKBAFhz4c
oDngJOL0nnoJj4SoHvdskiQ74RS4f+rskdIcTEwMz68i/Xoq0DHeSzvzKyG0rUhR
dkQqNs7W5mMHBiujwNqLaS5bZOqN/g==
=B0l4
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30696-done@debbugs.gnu.org)
878tb1p0pz.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (13 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> Christopher Baines (4):
>> gnu: Add python-djangorestframework.
>> gnu: Add python-django-crispy-forms.
>> gnu: Update python-django-filter to 1.1.0.
>> gnu: Update python-django-gravatar2.
>>
>> gnu/packages/django.scm | 62 +++++++++++++++++++++++++++++++++++++++++++++----
>> 1 file changed, 58 insertions(+), 4 deletions(-)
>
> LGTM, thanks!

Great, I've pushed these patches now :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqi0RhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdouBAAljJMZBl5AhHt4SBgRquaVDoPxV14nTT6gd71+VHAAdMpRLPULAbVBLtK
9g5+LMK2uJCITI/NysbWizg/yUj2Jodw7zdjk0Ye5MaAVF4NRZcEWF00OP4+2SOM
1CJ6axctGuniPH8gJwMiZKfXVR8SrMmORLyJm1v4pLuTQR/OBt8vjg6JnTS1A0Ot
Kb8WX0kusLMHPRX/b16dgiiL8lG8RW0Ke1esvT/MNLFs6uKeiWD7D/gULOiqfVLk
o8u69cFLtSrj6/l63dYLHI/BsxvglHh0HWFprJG21rwxRkLJi+AUrFt2ve+BXvr8
iGU50gc8yiX3WxO2gFLpLp4Qwe6R3hQvJwC/eTJc12z1arLgP8JY9l0BkSPfFr8v
P9ODXm2xgxedBylaLaxhnf801BJZanLIXTO9DyycXRWzeLhveNN+bMr5ogryn2li
8WaKWjY3oyODZ036nD8VpD49lcIWUJf+tZpIcUhrDfnelOudVJyR1f4vt737zMJy
XhFYVLBN8eWvnsEKRItL5jOs5hHUYkbkd/Mnl0qup5ssi4vNC0XCrBEIGZl3EHej
l+xUbybgyOOTQi3yBwNJOZmanJWu9KKAbEYPr5fJRIRYAmmVVCGlWMYb/75q3eE1
ckSS6sjRLcnOo9rIPjYq7ppKgKxzVuaiN8e83ANFgKpbnNHwfak=
=sP5W
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30696@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30696
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help