[PATCH] gnu: Add makefile2graph.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20180303220411.22293-1-mail@cbaines.net
* gnu/packages/plotutils.scm (makefile2graph): New variable.
---
gnu/packages/plotutils.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 482ae1b86..17a75ca4f 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages guile)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
@@ -250,3 +251,32 @@ LaTeX does for scientific text.")
;; noted otherwise, are released under version 3 (or later) of the GNU
;; Lesser General Public License"
(license license:lgpl3+)))
+
+(define-public makefile2graph
+ (package
+ (name "makefile2graph")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lindenb/" name
+ "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h1vchkpmm9h6s87p5nf0ksjxcmsxpx8k62a508w428n570wcr4l"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:make-flags (list "CC=gcc" (string-append "prefix=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("graphviz" ,graphviz)))
+ (home-page "https://github.com/lindenb/makefile2graph")
+ (synopsis "Creates a graph of dependencies from GNU Make")
+ (description
+ "@code{make2graph} creates a graph of dependencies from GNU Make. The
+output is a graphviz-dot file, a Gexf-XML file or a list of the deepest
+independent targets.")
+ (license license:expat)))
--
2.16.0
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 30690@debbugs.gnu.org)
87a7vkurhz.fsf@gnu.org
Hello!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/plotutils.scm (makefile2graph): New variable.

I’d put that rather in code.scm, but otherwise LGTM, thanks!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30690-done@debbugs.gnu.org)
874llj26kl.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Hello!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/plotutils.scm (makefile2graph): New variable.
>
> I’d put that rather in code.scm, but otherwise LGTM, thanks!

That seems sensible. I've moved it and pushed. Thanks for taking a look.

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlqoEzpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfxLw//TwZALGRBKc0qiHNpmM9UuREXZp6qK4bsHaNnEjCMSNC2nsR3qMeh6pGq
uKQUeMpDjG2FrmT38SX+HuZVCgXftmiCu4+Cfmma3zlJ7qvu9ChBv4N9vvF2wFJP
2DAEjUtFGhsvfjOeoXOhJFrU1YXF7v2KSg+U5mNaYfc565jA1d5X9Rb2jyKgxVvC
G+Uv7YBoUauA68yF2lfx5u9360otGC1TIXSMB2nCvMTapKk6ur0845+STzuqTvhb
F1vVhOJUxviKZXDit2x0LhXwB3aj6xHHastUZmQMKxT5ChVZ/bvpSUlrrXOYaHuA
xWfrbD6TICII/3FvPxzDdPc/JPam7KovmhqYXYUj7QLHHxdA7445j7ocJJFCjZf4
IJf5/dfDxTO4QzHHOAJzRoY9kewFchaDrqA/4JEnebSFonh4rBzDnSBoMnKL2iYh
xo9RYhbcS0K9E1zOSGMkrwvb2257cY//b0zvDWduBJcHOwBZoRpL3GQ1VMn3psL0
D/TSv2DaVob0BPXcwMpNZBkX7qwpgUpy8kI8abVoe8RYxM+SDkCBk4BfnhUdZerw
09kZx2vMjn0gZs655rT6vf3r7mCt7Gez555e0uTOCHuuJU+nzSuQIWO/39qnYubg
h132ymn7WfpGiAoj1MkCn3lDR1UK9MBHivJj2VdKphRXMpt/M2A=
=cPZx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30690@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30690
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help