Uncaught exception in cuirass

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andreas Enge
Severity
normal

Debbugs page

Andreas Enge wrote 7 years ago
(address . bug-guix@gnu.org)
20180228091245.GA1886@jurong
Hello,

an error I am seeing from time to time in my cuirass.log file when
testing bayfront:

Uncaught exception in fiber ##f:
In ice-9/boot-9.scm:
829:9 4 (catch _ _ #<procedure 7f8567e4c7d0 at cuirass/base.sc?> ?)
In cuirass/base.scm:
599:26 3 (_)
531:2 2 (build-packages _ #<<sqlite-db> pointer: #<pointer 0x7?> ?)
381:27 1 (spawn-builds #<build-daemon 256.97 622e7910> #<<sqlit?> ?)
In srfi/srfi-1.scm:
414:16 0 (split-at _ _)
srfi/srfi-1.scm:414:16: In procedure split-at:
In procedure cdr: Wrong type argument in position 1 (expecting pair): ()

This may be related to bug #30644, since it always (in three cases) follows
a line such as:
2018-02-28T06:26:31 batch of builds (partially) failed:all build users are currently in use; consider creating additional users and adding them to the `guixbuild' group (status: 1)

But conversely, not all lines "batch of builds..." are followed by this
error, and anyway the order of output may be mixed up between different
threads.

Andreas
Ludovic Courtès wrote 7 years ago
(name . Andreas Enge)(address . andreas@enge.fr)(address . 30645-done@debbugs.gnu.org)
877eqv69il.fsf@gnu.org
Hello,

Andreas Enge <andreas@enge.fr> skribis:

Toggle quote (15 lines)
> an error I am seeing from time to time in my cuirass.log file when
> testing bayfront:
>
> Uncaught exception in fiber ##f:
> In ice-9/boot-9.scm:
> 829:9 4 (catch _ _ #<procedure 7f8567e4c7d0 at cuirass/base.sc?> ?)
> In cuirass/base.scm:
> 599:26 3 (_)
> 531:2 2 (build-packages _ #<<sqlite-db> pointer: #<pointer 0x7?> ?)
> 381:27 1 (spawn-builds #<build-daemon 256.97 622e7910> #<<sqlit?> ?)
> In srfi/srfi-1.scm:
> 414:16 0 (split-at _ _)
> srfi/srfi-1.scm:414:16: In procedure split-at:
> In procedure cdr: Wrong type argument in position 1 (expecting pair): ()

This should be fixed by Cuirass commit
ad577114dde4c86455262a35ad4b3838eb4a1453.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30645@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30645
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help