[PATCH] gnu: nautilus: Use meson-build-system, update to 3.26.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Rene
Owner
unassigned
Submitted by
Rene
Severity
normal
R
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
cWrhiFT4RWpmhe6RATSlGEOL_3gUU-rJejmnUrhtLzGqyASCJBJ_AHAqVWbPVkWMdJ4RAF2EPZ1cSSeKzXVwYw3Gejzf52rTezcS8cfUr3s=@protonmail.com
Hello team,
this a proposed patch to update nautilus to 3.26.2.

Thank you
Rene
Attachment: file
From d485df9a712da9c3c3aafa08e05d8fccc78e8b18 Mon Sep 17 00:00:00 2001
From: Rene <pacoon@protonmail.com>
Date: Tue, 27 Feb 2018 13:19:08 -0600
Subject: [PATCH] gnu: nautilus: Use meson-build-system, update to 3.26.2.

* gnu/packages/gnome.scm (nautilus): Update to 3.26.2.
[build-system]: Use meson-build-system.
[native-inputs]: Add desktop-file-utils and gtk+:bin.
[inputs]: Add libselinux.
---
gnu/packages/gnome.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43a348902..5de44fc57 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2016, 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -5727,7 +5727,7 @@ shared object databases, search tools and indexing.")
(define-public nautilus
(package
(name "nautilus")
- (version "3.24.2.1")
+ (version "3.26.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5735,16 +5735,16 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cv138z04qx0fh1a2z2hvxy4p1x15vdv5gmkx5f3hb6c3w2rsz9m"))))
- (build-system glib-or-gtk-build-system)
+ "1d0l4vgcjqj4671hb6s2a56baqlasbxn3wl6vfrpdsk5qq299jbr"))))
+ (build-system meson-build-system)
(arguments
- '(#:configure-flags
- '("--disable-selinux") ; XXX: not packaged
- ;; XXX: FAIL: check-nautilus
+ '(;; XXX: FAIL: check-nautilus
;; Settings schema 'org.gnome.nautilus.preferences' is not installed
#:tests? #f))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
@@ -5754,6 +5754,7 @@ shared object databases, search tools and indexing.")
("exempi" ,exempi)
("gnome-desktop" ,gnome-desktop)
("gnome-autoar" ,gnome-autoar)
+ ("libselinux" ,libselinux)
("nettle" ,nettle) ; XXX required by libarchive.pc via gnome-autoar
("tracker" ,tracker)
;; XXX: gtk+ is required by libnautilus-extension.pc
--
2.14.1
L
L
Ludovic Courtès wrote on 28 Feb 2018 22:31
(name . Rene)(address . pacoon@protonmail.com)(address . 30636@debbugs.gnu.org)
87efl4vm17.fsf@gnu.org
Hello Rene,

Rene <pacoon@protonmail.com> skribis:

Toggle quote (10 lines)
> From d485df9a712da9c3c3aafa08e05d8fccc78e8b18 Mon Sep 17 00:00:00 2001
> From: Rene <pacoon@protonmail.com>
> Date: Tue, 27 Feb 2018 13:19:08 -0600
> Subject: [PATCH] gnu: nautilus: Use meson-build-system, update to 3.26.2.
>
> * gnu/packages/gnome.scm (nautilus): Update to 3.26.2.
> [build-system]: Use meson-build-system.
> [native-inputs]: Add desktop-file-utils and gtk+:bin.
> [inputs]: Add libselinux.

The patch LGTM, but the Nautilus ends with SIGTRAP, both in a VM of
desktop.tmpl and in an environment:

Toggle snippet (55 lines)
$ LANGUAGE= ./pre-inst-env guix environment --ad-hoc nautilus -- gdb --args nautilus
GNU gdb (GDB) 8.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
[<gdb.printing.RegexpCollectionPrettyPrinter object at 0x7fb7617bfc88>, <function lookup_function at 0x7fb7617d97b8>]
Reading symbols from nautilus...(no debugging symbols found)...done.
(gdb) r
Starting program: /gnu/store/q3a721bfwwbyi3cpi6s7j85jqbl4h0xb-nautilus-3.26.2/bin/nautilus
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/gnu/store/n6acaivs0jwiwpidjr551dhdni5kgpcr-glibc-2.26.105-g0890d5379c/lib/libthread_db.so.1".
[New Thread 0x7fffea402700 (LWP 23950)]
[New Thread 0x7fffe9bb1700 (LWP 23951)]
[New Thread 0x7fffe9360700 (LWP 23952)]
[New Thread 0x7fffe8b0f700 (LWP 23954)]

** (nautilus:23946): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

(nautilus:23946): GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed


Thread 1 "nautilus" received signal SIGTRAP, Trace/breakpoint trap.
0x00007ffff7907dd1 in _g_log_abort () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libglib-2.0.so.0
(gdb) bt
#0 0x00007ffff7907dd1 in _g_log_abort () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libglib-2.0.so.0
#1 0x00007ffff7908d71 in g_log_default_handler () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libglib-2.0.so.0
#2 0x00007ffff7908f74 in g_logv () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libglib-2.0.so.0
#3 0x00007ffff7909172 in g_log () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libglib-2.0.so.0
#4 0x00007ffff5c6a9ef in g_settings_set_property () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgio-2.0.so.0
#5 0x00007ffff5926413 in g_object_new_internal () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#6 0x00007ffff5927e28 in g_object_new_valist () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#7 0x00007ffff592810c in g_object_new () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#8 0x0000000000498c65 in nautilus_global_preferences_init ()
#9 0x0000000000448a42 in nautilus_application_startup_common ()
#10 0x0000000000448b07 in nautilus_application_startup ()
#11 0x00007ffff5920be5 in g_closure_invoke () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#12 0x00007ffff59325fc in signal_emit_unlocked_R () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#13 0x00007ffff593b6ff in g_signal_emit_valist () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#14 0x00007ffff593ba22 in g_signal_emit () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgobject-2.0.so.0
#15 0x00007ffff5c01442 in g_application_register () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgio-2.0.so.0
#16 0x00007ffff5c01c2f in g_application_real_local_command_line () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgio-2.0.so.0
#17 0x00007ffff5c01f92 in g_application_run () from /gnu/store/sm37m59gq3smxxz8gs4jikn50qg0g7xh-glib-2.54.2/lib/libgio-2.0.so.0
#18 0x00000000004467da in main ()

Do you experience similar issues? (That’s on x86_64-linux.)

Thanks,
Ludo’.
R
(name . ludo@gnu.org)(address . ludo@gnu.org)(name . 30636@debbugs.gnu.org)(address . 30636@debbugs.gnu.org)
f22790NkmJSAN85pWnKi1Bkgddgs3V_SeQo8ywhSHqgE_HSjNaMZ9FI7NPNvYLpwRUAdl2x5ncERyZ7U4JG7AQM1Ogjg7RGGA3NzSDymrh8=@protonmail.com
Hello Ludovic,

I have corrected the patch and it works within the VM, in the future I will perform this test.

Now I have a couple of doubts:

a) When I run './pre-inst-env guix environment --ad-hoc nautilus -- gdb --args nautilus' I see:

GNU gdb (GDB) 8.0.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
"/home/jin/guix/nautilus": not in executable format: File truncated
(gdb) r
Starting program:
No executable file specified.
Use the "file" or "exec-file" command.

Why can not find the executable?

b) What utility is required to use the code comments?
(--8<---------------cut here---------------start------------->8---)


?Thank you

Rene
From 60e511e88035bb89fca74ab6d5a262834c98e485 Mon Sep 17 00:00:00 2001
From: Rene <pacoon@protonmail.com>
Date: Wed, 28 Feb 2018 20:33:36 -0600
Subject: [PATCH] gnu: nautilus: Use meson-build-system, update to 3.26.2.

* gnu/packages/gnome.scm (nautilus): Update to 3.26.2.
[build-system]: Use meson-build-system.
[native-inputs]: Add desktop-file-utils and gtk+:bin.
[inputs]: Add libselinux.
---
gnu/packages/gnome.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43a348902..057958dff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2016, 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -5727,7 +5727,7 @@ shared object databases, search tools and indexing.")
(define-public nautilus
(package
(name "nautilus")
- (version "3.24.2.1")
+ (version "3.26.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5735,16 +5735,17 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cv138z04qx0fh1a2z2hvxy4p1x15vdv5gmkx5f3hb6c3w2rsz9m"))))
- (build-system glib-or-gtk-build-system)
+ "1d0l4vgcjqj4671hb6s2a56baqlasbxn3wl6vfrpdsk5qq299jbr"))))
+ (build-system meson-build-system)
(arguments
- '(#:configure-flags
- '("--disable-selinux") ; XXX: not packaged
+ '(#:glib-or-gtk? #t
;; XXX: FAIL: check-nautilus
;; Settings schema 'org.gnome.nautilus.preferences' is not installed
#:tests? #f))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
@@ -5754,7 +5755,8 @@ shared object databases, search tools and indexing.")
("exempi" ,exempi)
("gnome-desktop" ,gnome-desktop)
("gnome-autoar" ,gnome-autoar)
- ("nettle" ,nettle) ; XXX required by libarchive.pc via gnome-autoar
+ ("libselinux" ,libselinux)
+ ("nettle" ,nettle) ; XXX required by libarchive.pc via gnome-autoar
("tracker" ,tracker)
;; XXX: gtk+ is required by libnautilus-extension.pc
;;
--
2.14.1
L
L
Ludovic Courtès wrote on 1 Mar 2018 13:59
(name . Rene)(address . pacoon@protonmail.com)(address . 30636-done@debbugs.gnu.org)
87lgfc6jef.fsf@gnu.org
Hi,

Rene <pacoon@protonmail.com> skribis:

Toggle quote (24 lines)
> a) When I run './pre-inst-env guix environment --ad-hoc nautilus -- gdb --args nautilus' I see:
>
> GNU gdb (GDB) 8.0.1
> Copyright (C) 2017 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law. Type "show copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-unknown-linux-gnu".
> Type "show configuration" for configuration details.
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>.
> Find the GDB manual and other documentation resources online at:
> <http://www.gnu.org/software/gdb/documentation/>.
> For help, type "help".
> Type "apropos word" to search for commands related to "word"...
> "/home/jin/guix/nautilus": not in executable format: File truncated
> (gdb) r
> Starting program:
> No executable file specified.
> Use the "file" or "exec-file" command.
>
> Why can not find the executable?

Perhaps PATH does not include the profile’s bin/ directory, which in
turn could be due to an incorrect .bashrc as described in

Toggle quote (3 lines)
> b) What utility is required to use the code comments?
> (--8<---------------cut here---------------start------------->8---)

Heheh, that’s ‘message-mode’ in Emacs (I use Gnus as my MUA).

Toggle quote (10 lines)
> From 60e511e88035bb89fca74ab6d5a262834c98e485 Mon Sep 17 00:00:00 2001
> From: Rene <pacoon@protonmail.com>
> Date: Wed, 28 Feb 2018 20:33:36 -0600
> Subject: [PATCH] gnu: nautilus: Use meson-build-system, update to 3.26.2.
>
> * gnu/packages/gnome.scm (nautilus): Update to 3.26.2.
> [build-system]: Use meson-build-system.
> [native-inputs]: Add desktop-file-utils and gtk+:bin.
> [inputs]: Add libselinux.

Applied, thanks!

Ludo’.
Closed
?