Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/scheme.scm (racket): Update to 6.12.
[arguments]<#:phases>[patch-/bin/sh]: Add substitution.
---
gnu/packages/scheme.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (32 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index d5286b312..a90f88fce 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -404,7 +404,7 @@ implementation techniques and as an expository tool.")
(define-public racket
(package
(name "racket")
- (version "6.11")
+ (version "6.12")
(source (origin
(method url-fetch)
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
@@ -414,7 +414,7 @@ implementation techniques and as an expository tool.")
version "/racket-" version "-src.tgz")))
(sha256
(base32
- "1nk7705x24jjlbqqhj8yvbgqkfscxx3m81bry1g56kjxysjmf3sw"))))
+ "0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -484,6 +484,9 @@ implementation techniques and as an expository tool.")
(lambda _
(substitute* "collects/racket/system.rkt"
(("/bin/sh") (which "sh")))
+ (substitute* "src/racket/src/schpriv.h"
+ ;; Our gcc version is too old so signbit is not a builtin.
+ (("MZ_IS_NEG_ZERO") "MZ_IS_NEG_ZEROdisable"))
#t)))
#:tests? #f ; XXX: how to run them?
))