[PATCH] gnu: racket: Update to 6.12.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
Merged with

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180222165621.2297-1-dannym@scratchpost.org
* gnu/packages/scheme.scm (racket): Update to 6.12.
[arguments]<#:phases>[patch-/bin/sh]: Add substitution.
---
gnu/packages/scheme.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index d5286b312..a90f88fce 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -404,7 +404,7 @@ implementation techniques and as an expository tool.")
(define-public racket
(package
(name "racket")
- (version "6.11")
+ (version "6.12")
(source (origin
(method url-fetch)
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
@@ -414,7 +414,7 @@ implementation techniques and as an expository tool.")
version "/racket-" version "-src.tgz")))
(sha256
(base32
- "1nk7705x24jjlbqqhj8yvbgqkfscxx3m81bry1g56kjxysjmf3sw"))))
+ "0cwcypzjfl9py1s695mhqkiapff7c1w29llsmdj7qgn58wl0apk5"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -484,6 +484,9 @@ implementation techniques and as an expository tool.")
(lambda _
(substitute* "collects/racket/system.rkt"
(("/bin/sh") (which "sh")))
+ (substitute* "src/racket/src/schpriv.h"
+ ;; Our gcc version is too old so signbit is not a builtin.
+ (("MZ_IS_NEG_ZERO") "MZ_IS_NEG_ZEROdisable"))
#t)))
#:tests? #f ; XXX: how to run them?
))
Leo Famulari wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30575@debbugs.gnu.org)
20180222192552.GB23632@jasmine.lan
On Thu, Feb 22, 2018 at 05:56:21PM +0100, Danny Milosavljevic wrote:
Toggle quote (12 lines)
> * gnu/packages/scheme.scm (racket): Update to 6.12.
> [arguments]<#:phases>[patch-/bin/sh]: Add substitution.

> @@ -484,6 +484,9 @@ implementation techniques and as an expository tool.")
> (lambda _
> (substitute* "collects/racket/system.rkt"
> (("/bin/sh") (which "sh")))
> + (substitute* "src/racket/src/schpriv.h"
> + ;; Our gcc version is too old so signbit is not a builtin.
> + (("MZ_IS_NEG_ZERO") "MZ_IS_NEG_ZEROdisable"))
> #t)))

Would it make sense to just user a newer version of GCC for Racket?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqPGUAACgkQJkb6MLrK
fwhZtQ//Vs1QqvopkiYqm01TKSHF+E8oLBavK1wkVesav6YopJMlfbkIkhnMB5aW
KtNEJ1Kz8bwK/9WB1QK/4voleSN/ZrP4DD400dqLZzyLlJq4Plw8hqg/B1O8NTMx
Ea74CgUcdVs1njDb9m0O24Y8zQ1vzxBfd3pTyXDP/YuxBfPzpKUA+BWIVlm7xD1V
CD3nxEl+/w9U9Xh9ywsBcEl5O6JUDLoqIkyK7XXbltWXyvNMyowXmHkRDACmySyS
62jOM5o48p1C8WVzV9//mShx8MxHXIcdIKH4Tg9i8JAwMnt2FZ3tPNeyS4Ll1qZ/
Vc2UfggQtQwy2C2u5KLmFik1GDhWARz8qKzDSlpB0Z/Me0StltSte9ruKfFrQwAG
mDkUF4FC6C8E4m7wxm6veOzD1+TeACphF/sQ1O3xwTIqAZPH9SI3zc0om5ikMxwC
B5DSnmjTXaKsyBjurzuTNLeeewCbtp5HYESI6Y9YcD1eors13WxsyhbqRC2ENyc8
nYwjXFxeeHCva3MIW0qUs2MvOcgBCr4/mXf5mETy/ZbZwHKPgp2Kjd5+vApd7t2J
ZljV4JH0ikHtj6nqIOwAfEBd588DvD2Z2zUDjGZQojCo7ADpzDUGiWJwI+BCnnml
b0IGjRNW9cQsBT1Wagwsj9Dx/xS9IpbB7HcoK73m/xusHhvTH9I=
=hglM
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 7 years ago
control message for bug #30603
(address . control@debbugs.gnu.org)
87po4q4vtq.fsf@gnu.org
merge 30603 30575
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30575@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30575
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help