[PATCH] gnu: milkytracker: Actually link with the JACK library.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180218195049.20339-1-kkebreau@posteo.net
* gnu/packages/music.scm (milkytracker)[arguments]: Add appropriate configure
flag.
---
gnu/packages/music.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3709f10d1..e88c9f21f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2609,7 +2609,8 @@ of tools for manipulating and accessing your music.")
(("add_subdirectory\\(resources/music\\)") ""))))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f)) ; no check target
+ '(#:tests? #f ; no check target
+ #:configure-flags '("-DCMAKE_CXX_FLAGS=-ljack")))
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
--
2.16.1
Kei Kebreau wrote 7 years ago
(address . 30517@debbugs.gnu.org)
874lmeyrng.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (21 lines)
> * gnu/packages/music.scm (milkytracker)[arguments]: Add appropriate configure
> flag.
> ---
> gnu/packages/music.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 3709f10d1..e88c9f21f 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -2609,7 +2609,8 @@ of tools for manipulating and accessing your music.")
> (("add_subdirectory\\(resources/music\\)") ""))))))
> (build-system cmake-build-system)
> (arguments
> - '(#:tests? #f)) ; no check target
> + '(#:tests? #f ; no check target
> + #:configure-flags '("-DCMAKE_CXX_FLAGS=-ljack")))
> (inputs
> `(("alsa-lib" ,alsa-lib)
> ("jack" ,jack-1)

It should be noted that when I configure MilkyTracker to use JACK as an
audio driver, close the program, start the JACK server and open
MilkyTracker again, the MilkyTracker window appears black. When I drag
the window around on my desktop the program graphics flicker until I
stop dragging it, at which point it goes black again. Does anyone else
get this bug?
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlqJ4IQACgkQ5qXuPBlG
eg0CxA//XgCBIWSuZWQYSvFnJtDPQNS/ijWPPxe+9R3JTGc8/EsL1eGSI+DCkHr1
7sI6RrgUhm1HNobOgjonpj8klGkQKVxBlk9rknRs2tmGrQe/jayhIJI6BU3TL+QP
76MhqCqwvY8kGXUnOnXe4IrgA8zOjd2iFriDR7cjjC7/P/2xELNMw0tIo9qeGq6t
z/CPgt5a4b62JPTex/4UB7q2aF9gwQ5qekeMIzkULGH7RBeEZMtXYeoiVsu9+gTx
ex5fqUpMsCfxruLVmqqkk7uvNUTgHzE+iDWVmS5Jh3UKkl8Abzu3LmyZ2RXX11Pc
ioCUVGju35XoNXWhZnILtfL5ZPb68UKju+R9f+K6KoIHo4P/AmnMv9A6NrN+vFoS
6T62cHcp4P8blwwe6taqTlMV2gkunU2fLvddZ5+4TMzd+bfOaN+XHenmEngBnXmn
6BdGvAv4BBCtAyjt0OJAsfG/fJTVzjH3hUxP/mWUSKQ4+PHrg7zFssnbkP1MSZ+Q
bFbaxmwIHweKLZHS1Ut29SimNa5BPI5I2ovaXrWGIREmWZZoD5r+aSsnwE/h0Hjf
QTjLVfU5nVrzBzAt0rjwA3SeOCwSXs8nX2MYDUg2TW7E3qPIRLbq+EI3btRCxLnF
4HEa2myFoXF223nAqTNGcG8SEUv7AAK1yVlpglb3xjZFieVPx7M=
=sB00
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 30517@debbugs.gnu.org)
87y3j4rq8u.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (18 lines)
> * gnu/packages/music.scm (milkytracker)[arguments]: Add appropriate configure
> flag.
> ---
> gnu/packages/music.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 3709f10d1..e88c9f21f 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -2609,7 +2609,8 @@ of tools for manipulating and accessing your music.")
> (("add_subdirectory\\(resources/music\\)") ""))))))
> (build-system cmake-build-system)
> (arguments
> - '(#:tests? #f)) ; no check target
> + '(#:tests? #f ; no check target
> + #:configure-flags '("-DCMAKE_CXX_FLAGS=-ljack")))

I’d suggest adding a comment as to why this is needed.

Then I think you can go ahead and push it. If it fixes a use case for
you, that’s already an improvement.

Thanks,
Ludo’.
Kei Kebreau wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30517-done@debbugs.gnu.org)
874llqlhz8.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (28 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/music.scm (milkytracker)[arguments]: Add appropriate configure
>> flag.
>> ---
>> gnu/packages/music.scm | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index 3709f10d1..e88c9f21f 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -2609,7 +2609,8 @@ of tools for manipulating and accessing your music.")
>> (("add_subdirectory\\(resources/music\\)") ""))))))
>> (build-system cmake-build-system)
>> (arguments
>> - '(#:tests? #f)) ; no check target
>> + '(#:tests? #f ; no check target
>> + #:configure-flags '("-DCMAKE_CXX_FLAGS=-ljack")))
>
> I’d suggest adding a comment as to why this is needed.
>
> Then I think you can go ahead and push it. If it fixes a use case for
> you, that’s already an improvement.
>
> Thanks,
> Ludo’.

Pushed with added comment. Thanks for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlqhUrsACgkQ5qXuPBlG
eg01qg/+Oi0Z81aF2akjYTkUDYJ3nGTWxfk5nraV09w3nZ0vLkbQehO7ElHrt8aT
+q5V96nJDdnEkxVk+prCHP2B6vZHpkfDb5Kol4kBND4uoYoZmfxLRjs4mgUw2Et1
zPpwdSGZMIAC5k2z26XEifnPdgVNeorbx5VNlq26n1At4j0DPpjqsA5hjCJavH1L
rjacg34an81dTMJv184+t82g0AmashOibjZ5SGSS/b/Vv7DbMkD5hObmtHaCvHNk
iFiUxwvD71lqVqBUVWeAIYJz5PSH0AB/vzVvAoz8tXwKVfBWhJr5b7xp9qPKFrmX
roHTjdK6ECWnVC3sZCQuBqGvY6e3w0dVA78zyiEx7pTUy9ieOtEa4sDSbnhssfHq
XSb8a7u4W8+IDpL/81hJjeyroJ3EBOk1gSjV+AfvFPudU8sxPAQUa7XbS6F2HHLu
tEwbydn4Tms4KXEzouxn7CVCnoBcbeH2TrQoSeSAVWO2NlBUdwMZlymGHjczWW1G
o35hCm4cYrO01uX4A+3f27PQ4rsdsbS56Dokii8/uToSRxxrvOZidOnjX7cOChL0
qecWGAZLCNYJfVlhlKWr1U5RrAFax4ZGE257fAj1y9gpa1Sbt5LGstzf/+bfzKhZ
aqcVGtrjChcUgi4V5X9yLp7Hk+uZnqeKbpOytv82JivGAjPa8HA=
=KF07
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30517@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30517
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help