[PATCH] gnu: Add python-boto3 and python2-boto3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Thompson, David
  • Leo Famulari
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 7 years ago
(address . guix-patches@gnu.org)
CAJ=RwfY4LXbP2bsDd+xLTiNyD=fpcCfjWAz_2ODtBYUoA9vPNQ@mail.gmail.com
Small patch that adds the AWS SDK for Python which came in handy for
me while testing a Lambda function (in the AWS sense) on my local
machine yesterday.

- Dave
From a328be2daccc7778f05c86a06b3b7db237473a44 Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Fri, 16 Feb 2018 10:35:04 -0500
Subject: [PATCH] gnu: Add python-boto3 and python2-boto3.

* gnu/packages/python-web.scm (python-boto3, python2-boto3): New variables.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3cad440b9..d295cbf1d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2442,3 +2442,32 @@ layouts.")
(define-public python2-pastescript
(package-with-python2 python-pastescript))
+
+(define-public python-boto3
+ (package
+ (name "python-boto3")
+ (version "1.5.29")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boto3" version))
+ (sha256
+ (base32
+ "1f2sy0qjgs0sh0sxqfpf2ykr0y43cgrilp8y6zmzy9wbnkfp6cx8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-botocore" ,python-botocore)
+ ("python-jmespath" ,python-jmespath)
+ ("python-s3transfer" ,python-s3transfer)))
+ (home-page "https://github.com/boto/boto3")
+ (synopsis "The AWS SDK for Python")
+ (description "Boto3 is the official Amazon Web Services SDK for Python.")
+ (license license:asl2.0)))
+
+(define-public python2-boto3
+ (let ((base (package-with-python2 python-boto3)))
+ (package
+ (inherit base)
+ (propagated-inputs
+ `(("python2-futures" ,python2-futures)
+ ,@(package-propagated-inputs base))))))
--
2.16.1
Leo Famulari wrote 7 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 30486@debbugs.gnu.org)
20180216193458.GA29221@jasmine.lan
On Fri, Feb 16, 2018 at 10:37:20AM -0500, Thompson, David wrote:
Toggle quote (13 lines)
> Small patch that adds the AWS SDK for Python which came in handy for
> me while testing a Lambda function (in the AWS sense) on my local
> machine yesterday.
>
> - Dave

> From a328be2daccc7778f05c86a06b3b7db237473a44 Mon Sep 17 00:00:00 2001
> From: David Thompson <dthompson2@worcester.edu>
> Date: Fri, 16 Feb 2018 10:35:04 -0500
> Subject: [PATCH] gnu: Add python-boto3 and python2-boto3.
>
> * gnu/packages/python-web.scm (python-boto3, python2-boto3): New variables.

Thanks!

Toggle quote (8 lines)
> +(define-public python2-boto3
> + (let ((base (package-with-python2 python-boto3)))
> + (package
> + (inherit base)
> + (propagated-inputs
> + `(("python2-futures" ,python2-futures)
> + ,@(package-propagated-inputs base))))))

I think this needs to use the python2-variant system. The package
definition of python2-parse-type has a simple example.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqHMl8ACgkQJkb6MLrK
fwhOiw/9GkCTKNGdljIP6qctdlaiAxKy97k9YJejLoEGVUmA3nj3+dkArz+pmyuR
WHtdwcOQ/5vy4nFVorOrrhaFha9k+xGYcFySkLrK+r5UoqSChIpjxx05BB7kDHz7
YJi4N3EohuOz7HDA3RRDXzg1GrCsK/BHT4lCuY5nkhZJjsQYXLAbfIs6MeYupXP5
NfSfh2tY1shxQ3AyDCvpGgfd9e/rAceMYa8fJOeXYviAIl9MY2Q95n9XGAJ2mYom
kAufPiMzD/OKrAfLtJywE4n2XTvKtsSOnYCds9S6gujs9ND5bFXUNzHn4Nts5D3w
y0ZLNf1e0JROWDjrYWEbYWAYXgd6aqAuyjjFVrG7XjBuqiZgXnLQSCIN4mt0Ied3
X6RjVBca0VRMg8oBSaQXYqWyxq7ShFzjjGBVTvA39Uz5QeOx7T4K7P9mtSdUQ+Dt
Y1AwVEYl5M+FzYVFv03jCnywgoL7BbqfhHyzRFwnS32aLRBjCIGYfL32uqOXypuJ
YIGHZuj0TQ5dOe4Ua3+/eelEgIervpeMD0RtL/MNix4FppYJBUwT2WAzl7toGkWJ
ffwbvSN55Cz34xHOHMB4WMyJjHWri7Sg0LW3EVP+iHBPWjod6RwSos/nDthaFj+p
43vxZoaqGn/VqdKmkr74IL0SyXktO7w7zOEygwNPVS5ER4jaFUI=
=Cqos
-----END PGP SIGNATURE-----


Arun Isaac wrote 4 years ago
(address . 30486@debbugs.gnu.org)
87pn3gkfju.fsf@systemreboot.net
Hi,

python-boto3 has been added in 65579957d524804ea27dec2bed4382aa00a607e2.

Toggle snippet (11 lines)
commit 65579957d524804ea27dec2bed4382aa00a607e2
Author: Kristian Trandem <kristian@devup.no>
Date: Fri Aug 16 02:35:39 2019 +0200

gnu: Add python-boto3.
gnu/packages/python-xyz.scm (python-boto3): New variable.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>

I guess we don't need python2-boto3 since python2 has reached end of
life. So, can we close this bug report?

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl/TFUUbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzn7cIAJg4Ui1FHk5l1UFYh2Xv
eJYCR44W6nAQNR6kLeTrHzIWDly8bgzhi5CGSkW91rFBjhQa6/7XBhfda/5HT4tQ
h0ZBWxleug6bsT0qp1oVdktkcRZM4HXlCCv3XBxRJAS8p+byOmybUmFeU1G0bGQf
rwH/Le6pEwoxBK3G7kc/9KZE89hJouFBrHbL/hhQ2WFu1zkqDGuK34llb28SgLTo
ptOB33NYNz9f6FiKbYWV/1Twzqnf0AjKjSTYn8+Vxu4nKeAhWpQVXS+20F7G7aZI
AmTEEPFyMi0R8jZFqqL3np3Cubk3U0O1IRL1OYdQ6gcP+Mj+b2/Jqm3mbLKA+A1N
/VI=
=eOJe
-----END PGP SIGNATURE-----

Leo Famulari wrote 4 years ago
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
X9Qb8Ikz0A6UNQCb@jasmine.lan
On Fri, Dec 11, 2020 at 12:14:21PM +0530, Arun Isaac wrote:
Toggle quote (20 lines)
>
> Hi,
>
> python-boto3 has been added in 65579957d524804ea27dec2bed4382aa00a607e2.
>
> --8<---------------cut here---------------start------------->8---
> commit 65579957d524804ea27dec2bed4382aa00a607e2
> Author: Kristian Trandem <kristian@devup.no>
> Date: Fri Aug 16 02:35:39 2019 +0200
>
> gnu: Add python-boto3.
>
> gnu/packages/python-xyz.scm (python-boto3): New variable.
>
> Signed-off-by: Marius Bakke <mbakke@fastmail.com>
> --8<---------------cut here---------------end--------------->8---
>
> I guess we don't need python2-boto3 since python2 has reached end of
> life. So, can we close this bug report?

Done!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30486@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30486
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help