[PATCH 0/1] Require Guile >= 2.0.14

  • Done
  • quality assurance status badge
Details
3 participants
  • Eric Bavier
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 15 Feb 2018 16:26
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20180215152627.4695-1-ludo@gnu.org
Hello Guix,

This patch is to require Guile >= 2.0.14, released one year ago, instead
of 2.0.9, released in 2013.

For the record, here’s the distro status:

• Debian unstable has 2.2:

• Older Debian versions have 2.0.13 (not .14):

• Parabola, Gentoo, Homebrew, openSUSE, Fedora 26+ have 2.0.14 and/or

I’d like to have this change in place for the next Guix release, 0.14.1
I presume.

I’d also like it to be the last release that support Guile 2.0.

Thoughts?

Ludo’.

Ludovic Courtès (1):
build: Require Guile >= 2.0.14.

README | 2 +-
config-daemon.ac | 5 --
configure.ac | 2 +-
doc/guix.texi | 2 +-
guix/build/download.scm | 10 +--
guix/build/syscalls.scm | 48 +-------------
guix/hash.scm | 3 +-
guix/http-client.scm | 154 +-------------------------------------------
guix/scripts/substitute.scm | 18 ++----
m4/guix.m4 | 17 -----
tests/hash.scm | 11 +---
11 files changed, 14 insertions(+), 258 deletions(-)

--
2.16.1
L
L
Ludovic Courtès wrote on 15 Feb 2018 16:29
[PATCH 1/1] build: Require Guile >= 2.0.14.
(address . 30469@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20180215152957.7614-1-ludo@gnu.org
* README, configure.ac, doc/guix.texi (Requirements): Increase minimum
Guile version from 2.0.9 to 2.0.14.
* config-daemon.ac: Remove use of 'GUIX_CHECK_UNBUFFERED_CBIP'.
* m4/guix.m4 (GUIX_CHECK_UNBUFFERED_CBIP): Remove.
* guix/build/download.scm (current-http-proxy): Remove.
* guix/build/syscalls.scm (%libc-errno-pointer, errno): Remove.
(syscall->procedure): Use #:return-errno unconditionally.
* guix/hash.scm (open-sha256-input-port)[unbuffered]: Remove outdated
comment.
* guix/http-client.scm (when-guile<=2.0.5-or-otherwise-broken): Remove.
<top level>: Remove 'when-guile<=2.0.5-or-otherwise-broken' block.
* guix/scripts/substitute.scm (fetch): Remove 'guile-version>?'
conditional.
* tests/hash.scm (supports-unbuffered-cbip?): Remove.
<top level>: Remove 'test-skip' call.
---
README | 2 +-
config-daemon.ac | 5 --
configure.ac | 2 +-
doc/guix.texi | 2 +-
guix/build/download.scm | 10 +--
guix/build/syscalls.scm | 48 +-------------
guix/hash.scm | 3 +-
guix/http-client.scm | 154 +-------------------------------------------
guix/scripts/substitute.scm | 18 ++----
m4/guix.m4 | 17 -----
tests/hash.scm | 11 +---
11 files changed, 14 insertions(+), 258 deletions(-)

Toggle diff (440 lines)
diff --git a/README b/README
index d96a43bbe..6d1a10ad5 100644
--- a/README
+++ b/README
@@ -20,7 +20,7 @@ Guix is based on the [[https://nixos.org/nix/][Nix]] package manager.
GNU Guix currently depends on the following packages:
- - [[https://gnu.org/software/guile/][GNU Guile 2.2.x or 2.0.x]], version 2.0.9 or later
+ - [[https://gnu.org/software/guile/][GNU Guile 2.2.x or 2.0.x]], version 2.0.14 or later
- [[https://gnupg.org/][GNU libgcrypt]]
- [[https://www.gnu.org/software/make/][GNU Make]]
- [[https://www.gnutls.org][GnuTLS]] compiled with guile support enabled.
diff --git a/config-daemon.ac b/config-daemon.ac
index 80d84cbdb..524b10b30 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -132,11 +132,6 @@ if test "x$guix_build_daemon" = "xyes"; then
AC_DEFINE_UNQUOTED([GUIX_SUBSTITUTE_URLS], ["$guix_substitute_urls"],
[Default list of substitute URLs used by 'guix-daemon'.])
- dnl Check whether the 'offload' build hook can be built (uses
- dnl 'restore-file-set', which requires unbuffered custom binary input
- dnl ports from Guile >= 2.0.10.)
- GUIX_CHECK_UNBUFFERED_CBIP
-
dnl Check for Guile-SSH, which is required by 'guix offload'.
GUIX_CHECK_GUILE_SSH
diff --git a/configure.ac b/configure.ac
index 398846f64..d533c160e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,7 @@ if test "x$GUILD" = "x"; then
fi
if test "x$GUILE_EFFECTIVE_VERSION" = "x2.0"; then
- PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.9])
+ PKG_CHECK_MODULES([GUILE], [guile-2.0 >= 2.0.14])
fi
dnl Installation directories for .scm and .go files.
diff --git a/doc/guix.texi b/doc/guix.texi
index 7ed39ff13..9227e0e83 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -601,7 +601,7 @@ in the Guix source tree for additional details.
GNU Guix depends on the following packages:
@itemize
-@item @url{http://gnu.org/software/guile/, GNU Guile}, version 2.0.9 or
+@item @url{http://gnu.org/software/guile/, GNU Guile}, version 2.0.14 or
later, including 2.2.x;
@item @url{http://gnupg.org/, GNU libgcrypt};
@item
diff --git a/guix/build/download.scm b/guix/build/download.scm
index 1b630a9d6..315a3554e 100644
--- a/guix/build/download.scm
+++ b/guix/build/download.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -321,14 +321,6 @@ host name without trailing dot."
((uri? uri-or-string) uri-or-string)
(else (error "Invalid URI" uri-or-string))))
-(define current-http-proxy
- ;; XXX: Add a dummy definition for Guile < 2.0.10; this is used in
- ;; 'open-socket-for-uri'.
- (or (and=> (module-variable (resolve-interface '(web client))
- 'current-http-proxy)
- variable-ref)
- (const #f)))
-
(define* (open-socket-for-uri uri-or-string #:key timeout)
"Return an open input/output port for a connection to URI. When TIMEOUT is
not #f, it must be a (possibly inexact) number denoting the maximum duration
diff --git a/guix/build/syscalls.scm b/guix/build/syscalls.scm
index 0cb630cfb..25726b885 100644
--- a/guix/build/syscalls.scm
+++ b/guix/build/syscalls.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -350,39 +350,6 @@ expansion-time error is raised if FIELD does not exist in TYPE."
;;; FFI.
;;;
-(define %libc-errno-pointer
- ;; Glibc's 'errno' pointer, for use with Guile < 2.0.12.
- (let ((errno-loc (false-if-exception
- (dynamic-func "__errno_location" (dynamic-link)))))
- (and errno-loc
- (let ((proc (pointer->procedure '* errno-loc '())))
- (proc)))))
-
-(define errno ;for Guile < 2.0.12
- (if %libc-errno-pointer
- (let ((bv (pointer->bytevector %libc-errno-pointer (sizeof int))))
- (lambda ()
- "Return the current errno."
- ;; XXX: We assume that nothing changes 'errno' while we're doing all this.
- ;; In particular, that means that no async must be running here.
-
- ;; Use one of the fixed-size native-ref procedures because they are
- ;; optimized down to a single VM instruction, which reduces the risk
- ;; that we fiddle with 'errno' (needed on Guile 2.0.5, libc 2.11.)
- (let-syntax ((ref (lambda (s)
- (syntax-case s ()
- ((_ bv)
- (case (sizeof int)
- ((4)
- #'(bytevector-s32-native-ref bv 0))
- ((8)
- #'(bytevector-s64-native-ref bv 0))
- (else
- (error "unsupported 'int' size"
- (sizeof int)))))))))
- (ref bv))))
- (lambda () 0)))
-
(define (call-with-restart-on-EINTR thunk)
(let loop ()
(catch 'system-error
@@ -406,17 +373,8 @@ the returned procedure is called."
(lambda ()
(let ((ptr (dynamic-func name (dynamic-link))))
;; The #:return-errno? facility was introduced in Guile 2.0.12.
- ;; Support older versions of Guile by catching 'wrong-number-of-args'.
- (catch 'wrong-number-of-args
- (lambda ()
- (pointer->procedure return-type ptr argument-types
- #:return-errno? #t))
- (lambda (key . rest)
- (let ((proc (pointer->procedure return-type ptr argument-types)))
- (lambda args
- (let ((result (apply proc args))
- (err (errno)))
- (values result err))))))))
+ (pointer->procedure return-type ptr argument-types
+ #:return-errno? #t)))
(lambda args
(lambda _
(error (format #f "~a: syscall->procedure failed: ~s"
diff --git a/guix/hash.scm b/guix/hash.scm
index 44e447258..773b9d477 100644
--- a/guix/hash.scm
+++ b/guix/hash.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -159,7 +159,6 @@ data read from PORT. The thunk always returns the same value."
(define (unbuffered port)
;; Guile <= 2.0.9 does not support 'setvbuf' on custom binary input ports.
- ;; If you get a wrong-type-arg error here, the fix is to upgrade Guile. :-)
(setvbuf port _IONBF)
port)
diff --git a/guix/http-client.scm b/guix/http-client.scm
index bab31875d..e8a2a23fc 100644
--- a/guix/http-client.scm
+++ b/guix/http-client.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2012, 2015 Free Software Foundation, Inc.
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -69,158 +69,6 @@
(reason http-get-error-reason)) ; string
-(define-syntax when-guile<=2.0.5-or-otherwise-broken
- (lambda (s)
- (syntax-case s ()
- ((_ body ...)
- ;; Always emit BODY, regardless of VERSION, because sometimes this code
- ;; might be compiled with a recent Guile and run with 2.0.5---e.g.,
- ;; when using "guix pull".
- #'(begin body ...)))))
-
-(when-guile<=2.0.5-or-otherwise-broken
- ;; Backport of Guile commits 312e79f8 ("Add HTTP Chunked Encoding support to
- ;; web modules."), 00d3ecf2 ("http: Do not buffer HTTP chunks."), and 53b8d5f
- ;; ("web: Gracefully handle premature EOF when reading chunk header.")
-
- (use-modules (ice-9 rdelim))
-
- (define %web-http
- (resolve-module '(web http)))
-
- ;; Chunked Responses
- (define (read-chunk-header port)
- "Read a chunk header from PORT and return the size in bytes of the
- upcoming chunk."
- (match (read-line port)
- ((? eof-object?)
- ;; Connection closed prematurely: there's nothing left to read.
- 0)
- (str
- (let ((extension-start (string-index str
- (lambda (c)
- (or (char=? c #\;)
- (char=? c #\return))))))
- (string->number (if extension-start ; unnecessary?
- (substring str 0 extension-start)
- str)
- 16)))))
-
- (define* (make-chunked-input-port port #:key (keep-alive? #f))
- "Returns a new port which translates HTTP chunked transfer encoded
-data from PORT into a non-encoded format. Returns eof when it has
-read the final chunk from PORT. This does not necessarily mean
-that there is no more data on PORT. When the returned port is
-closed it will also close PORT, unless the KEEP-ALIVE? is true."
- (define (close)
- (unless keep-alive?
- (close-port port)))
-
- (define chunk-size 0) ;size of the current chunk
- (define remaining 0) ;number of bytes left from the current chunk
- (define finished? #f) ;did we get all the chunks?
-
- (define (read! bv idx to-read)
- (define (loop to-read num-read)
- (cond ((or finished? (zero? to-read))
- num-read)
- ((zero? remaining) ;get a new chunk
- (let ((size (read-chunk-header port)))
- (set! chunk-size size)
- (set! remaining size)
- (if (zero? size)
- (begin
- (set! finished? #t)
- num-read)
- (loop to-read num-read))))
- (else ;read from the current chunk
- (let* ((ask-for (min to-read remaining))
- (read (get-bytevector-n! port bv (+ idx num-read)
- ask-for)))
- (if (eof-object? read)
- (begin ;premature termination
- (set! finished? #t)
- num-read)
- (let ((left (- remaining read)))
- (set! remaining left)
- (when (zero? left)
- ;; We're done with this chunk; read CR and LF.
- (get-u8 port) (get-u8 port))
- (loop (- to-read read)
- (+ num-read read))))))))
- (loop to-read 0))
-
- (make-custom-binary-input-port "chunked input port" read! #f #f close))
-
- ;; Chunked encoding support in Guile <= 2.0.11 would load whole chunks in
- ;; memory---see <http://bugs.gnu.org/19939>.
- (when (module-variable %web-http 'read-chunk-body)
- (module-set! %web-http 'make-chunked-input-port make-chunked-input-port))
-
- (define (make-delimited-input-port port len keep-alive?)
- "Return an input port that reads from PORT, and makes sure that
-exactly LEN bytes are available from PORT. Closing the returned port
-closes PORT, unless KEEP-ALIVE? is true."
- (define bytes-read 0)
-
- (define (fail)
- ((@@ (web response) bad-response)
- "EOF while reading response body: ~a bytes of ~a"
- bytes-read len))
-
- (define (read! bv start count)
- ;; Read at most LEN bytes in total. HTTP/1.1 doesn't say what to do
- ;; when a server provides more than the Content-Length, but it seems
- ;; wise to just stop reading at LEN.
- (let ((count (min count (- len bytes-read))))
- (let loop ((ret (get-bytevector-n! port bv start count)))
- (cond ((eof-object? ret)
- (if (= bytes-read len)
- 0 ; EOF
- (fail)))
- ((and (zero? ret) (> count 0))
- ;; Do not return zero since zero means EOF, so try again.
- (loop (get-bytevector-n! port bv start count)))
- (else
- (set! bytes-read (+ bytes-read ret))
- ret)))))
-
- (define close
- (and (not keep-alive?)
- (lambda ()
- (close-port port))))
-
- (make-custom-binary-input-port "delimited input port" read! #f #f close))
-
- (define (read-header-line port)
- "Read an HTTP header line and return it without its final CRLF or LF.
-Raise a 'bad-header' exception if the line does not end in CRLF or LF,
-or if EOF is reached."
- (match (%read-line port)
- (((? string? line) . #\newline)
- ;; '%read-line' does not consider #\return a delimiter; so if it's
- ;; there, remove it. We are more tolerant than the RFC in that we
- ;; tolerate LF-only endings.
- (if (string-suffix? "\r" line)
- (string-drop-right line 1)
- line))
- ((line . _) ;EOF or missing delimiter
- ((@@ (web http) bad-header) 'read-header-line line))))
-
- (unless (guile-version>? "2.0.11")
- ;; Guile <= 2.0.9 had a bug whereby 'response-body-port' would read more
- ;; than what 'content-length' says. See Guile commit 802a25b.
- ;; Guile <= 2.0.11 had a bug whereby the 'close' method of the response
- ;; body port would fail with wrong-arg-num. See Guile commit 5a10e41.
- (module-set! (resolve-module '(web response))
- 'make-delimited-input-port make-delimited-input-port)
-
- ;; Guile <= 2.0.11 was affected by <http://bugs.gnu.org/22273>. See Guile
- ;; commit 4c7732c.
- (when (module-variable %web-http 'read-line*)
- (module-set! %web-http 'read-line* read-header-line))))
-
-
(define* (http-fetch uri #:key port (text? #f) (buffered? #t)
keep-alive? (verify-certificate? #t)
(headers '((user-agent . "GNU Guile"))))
diff --git a/guix/scripts/substitute.scm b/guix/scripts/substitute.scm
index 2fd2bf810..8e1119fb4 100755
--- a/guix/scripts/substitute.scm
+++ b/guix/scripts/substitute.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Nikita Karetnikov <nikita@karetnikov.org>
;;;
;;; This file is part of GNU Guix.
@@ -212,15 +212,7 @@ provide."
(begin
(warning (G_ "while fetching ~a: server is somewhat slow~%")
(uri->string uri))
- (warning (G_ "try `--no-substitutes' if the problem persists~%"))
-
- ;; Before Guile v2.0.9-39-gfe51c7b, EINTR was reported to the user,
- ;; and thus PORT had to be closed and re-opened. This is not the
- ;; case afterward.
- (unless (or (guile-version>? "2.0.9")
- (version>? (version) "2.0.9.39"))
- (when port
- (close-connection port))))
+ (warning (G_ "try `--no-substitutes' if the problem persists~%")))
(begin
(when (or (not port) (port-closed? port))
(set! port (guix:open-connection-for-uri
@@ -571,10 +563,8 @@ initial connection on which HTTP requests are sent."
;; XXX: Do our own caching to work around inefficiencies when
;; communicating over TLS: <http://bugs.gnu.org/22966>.
(let-values (((buffer get) (open-bytevector-output-port)))
- ;; On Guile > 2.0.9, inherit the HTTP proxying property from P.
- (when (module-variable (resolve-interface '(web http))
- 'http-proxy-port?)
- (set-http-proxy-port?! buffer (http-proxy-port? p)))
+ ;; Inherit the HTTP proxying property from P.
+ (set-http-proxy-port?! buffer (http-proxy-port? p))
(for-each (cut write-request <> buffer)
(at-most 1000 requests))
diff --git a/m4/guix.m4 b/m4/guix.m4
index 721285b01..8e174e92e 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -136,23 +136,6 @@ AC_DEFUN([GUIX_ASSERT_GUILE_FEATURES], [
done
])
-dnl GUIX_CHECK_UNBUFFERED_CBIP
-dnl
-dnl Check whether 'setbvuf' works on custom binary input ports (CBIPs), as is
-dnl the case starting with Guile 2.0.10.
-AC_DEFUN([GUIX_CHECK_UNBUFFERED_CBIP], [
- AC_CACHE_CHECK([whether Guile's custom binary input ports support 'setvbuf'],
- [ac_cv_guix_cbips_support_setvbuf],
- [if "$GUILE" -c "(use-modules (rnrs io ports)) \
- (let ((p (make-custom-binary-input-port \"cbip\" pk #f #f #f))) \
- (setvbuf p _IONBF))" >&5 2>&1
- then
- ac_cv_guix_cbips_support_setvbuf=yes
- else
- ac_cv_guix_cbips_support_setvbuf=no
- fi])
-])
-
dnl GUIX_ASSERT_SYNTAX_OBJECT_EQUAL
dnl
dnl Guile 2.2.1 was a brown-paper-bag release where 'equal?' wouldn't work
diff --git a/tests/hash.scm b/tests/hash.scm
index b189e435c..b4cf2b61d 100644
--- a/tests/hash.scm
+++ b/tests/hash.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,13 +37,6 @@
(base16-string->bytevector
"b94d27b9934d3e08a52e52d7da7dabfac484efe37a5380ee9088f7ace2efcde9"))
-(define (supports-unbuffered-cbip?)
- "Return #t if unbuffered custom binary input ports (CBIPs) are supported.
-In Guile <= 2.0.9, CBIPs were always fully buffered, so the
-'open-sha256-input-port' does not work there."
- (false-if-exception
- (setvbuf (make-custom-binary-input-port "foo" pk #f #f #f) _IONBF)))
-
(test-begin "hash")
@@ -77,8 +70,6 @@ In Guile <= 2.0.9, CBIPs were always fully buffered, so the
(equal? (sha256 contents)
(call-with-input-file file port-sha256))))
-(test-skip (if (supports-unbuffered
This message was truncated. Download the full message here.
E
E
Eric Bavier wrote on 24 Feb 2018 15:30
Re: [bug#30469] [PATCH 0/1] Require Guile >= 2.0.14
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30469@debbugs.gnu.org)
20180224083032.4f5f1e36@centurylink.net
On Thu, 15 Feb 2018 16:26:27 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (13 lines)
> Hello Guix,
>
> This patch is to require Guile >= 2.0.14, released one year ago, instead
> of 2.0.9, released in 2013.
>
> For the record, here’s the distro status:
>
> • Debian unstable has 2.2:
> <https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=guile-2.2>.
>
> • Older Debian versions have 2.0.13 (not .14):
> <https://packages.debian.org/search?keywords=guile-2.0>.

How much of this patch would change if it were to instead support
2.0.13? Is cutting off users of Debian stable a good idea?

Toggle quote (9 lines)
>
> • Parabola, Gentoo, Homebrew, openSUSE, Fedora 26+ have 2.0.14 and/or
> 2.2: <https://repology.org/metapackage/guile/versions>.
>
> I’d like to have this change in place for the next Guix release, 0.14.1
> I presume.
>
> I’d also like it to be the last release that support Guile 2.0.

Same question.

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlqRdwgACgkQ/XPKxxnT
JWZnWxAAmR5p2QTXRiNZWY/4sws0217C8l2549fp1JO3oWUvJDvuZlU2u1X4P07H
EQG7TznJmjtvKiOCnt75zj0nVUTyL6uPcQgtYxaUVuPRP7eB5GIYaokHO+A1yYRK
sIQm7bYpGvxysPUa1O/zVQmOBQW5NluaoznuKGB/Ql+bIcIdywG/mv9L2VFY7J88
P//cQXSijqh/u4xWkJHr4/djK9QUmK/wMks7CuRYCKR0kANlgRp7s8e4IVQxC2yy
q0Xa3i4ZAYFEthTB1fSlXy3oXjJnPsxSSMwO8gJS/O7i0sq/jPwDYqyyx868+eDN
mNR6BWlK13ctx4xkJ4QsLfPtxuniuToPzTXs88ZYECdcBITsycbMEV0PRc08xwvE
Zfie528BzOAuJxtFVwFYXUoyLU4/ryk1MAo6Q+z699qucrUQ+4EgtyiAEUU4hnjA
5puoQyEWamCF7/yXTIxXwMx0oskE8zlWz0OXHMEk+I0Uw/xwOvXxPPV+HsJJ4wv+
MVYkfQZSUIW6bzt7EHF19HS3ELi7u9PdHuU3nL0KWtrSyUpn5lWKi0h5LOWVi75r
ts17xw05eVDQDaRbe6vz3Z6gZHoPbv91f1x9zTRYSUt0nHLbke3F/kP5/TkUe9h4
ml5S1rug8bofRbFlPEbbNnQG2lrhvKyXwEq5GbGTBUil4w+yDzk=
=tRa+
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 24 Feb 2018 23:41
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 30469@debbugs.gnu.org)
87k1v280yz.fsf@gnu.org
Hello,

Eric Bavier <ericbavier@centurylink.net> skribis:

Toggle quote (19 lines)
> On Thu, 15 Feb 2018 16:26:27 +0100
> Ludovic Courtès <ludo@gnu.org> wrote:
>
>> Hello Guix,
>>
>> This patch is to require Guile >= 2.0.14, released one year ago, instead
>> of 2.0.9, released in 2013.
>>
>> For the record, here’s the distro status:
>>
>> • Debian unstable has 2.2:
>> <https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=guile-2.2>.
>>
>> • Older Debian versions have 2.0.13 (not .14):
>> <https://packages.debian.org/search?keywords=guile-2.0>.
>
> How much of this patch would change if it were to instead support
> 2.0.13? Is cutting off users of Debian stable a good idea?

I’ll double-check but I think the patch remains valid if we require
2.0.13.

If it works I’ll commit that next week.

Toggle quote (4 lines)
>> I’d also like it to be the last release that support Guile 2.0.
>
> Same question.

2.2 is becoming quite widespread in distros.

Overall it’s a cost/benefit tradeoff, and we have to take into account
that most users get Guix using the binary tarball or GuixSD.

Thanks for your feedback,
Ludo’.
J
J
Jonathan Brielmaier wrote on 25 Feb 2018 12:53
(address . guix-patches@gnu.org)
f40c758b-e385-5ff8-bc6d-bb91ddd9c1a1@web.de
On 02/24/2018 11:41 PM, Ludovic Courtès wrote:>> How much of this patch
would change if it were to instead support
Toggle quote (5 lines)
>> 2.0.13? Is cutting off users of Debian stable a good idea?
>
> I’ll double-check but I think the patch remains valid if we require
> 2.0.13.

Opensuse Leap 15 will have 2.0.14, so I would be okay with it.

Toggle quote (11 lines)
> If it works I’ll commit that next week.
>
>>> I’d also like it to be the last release that support Guile 2.0.
>>
>> Same question.
>
> 2.2 is becoming quite widespread in distros.
>
> Overall it’s a cost/benefit tradeoff, and we have to take into account
> that most users get Guix using the binary tarball or GuixSD.

2.2 is not as easy as I thought it would be, to bring it to openSUSE
Leap. There are packages who still require guile 2.0 (see comments in
a handful of packages need guile, makes it not really worthwhile for
distros to have two versions of guile present like we see it for python.

It would be nice to have guix in Debian, Ubuntu, SUSE land and Red Hat
land. I think that would enable far more people to use guix.

At the moment it's not easy to install guix from source without having
guix in place, at least on openSUSE. You need those guile modules
(guile-git, guile-bytestructures) who comes with almost no build
documentation. And then you have to fiddle together guile with the right
versions...

We struggle a lot with bootstrapping rust, go, java etc, so we should
make sure that "bootstrapping" guix (install from source) is easy or at
least doable.

Best Regards
Jonathan
E
E
Eric Bavier wrote on 26 Feb 2018 01:59
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30469@debbugs.gnu.org)
20180225151831.1b413f51@centurylink.net
On Sat, 24 Feb 2018 23:41:24 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (28 lines)
> Hello,
>
> Eric Bavier <ericbavier@centurylink.net> skribis:
>
> > On Thu, 15 Feb 2018 16:26:27 +0100
> > Ludovic Courtès <ludo@gnu.org> wrote:
> >
> >> Hello Guix,
> >>
> >> This patch is to require Guile >= 2.0.14, released one year ago, instead
> >> of 2.0.9, released in 2013.
> >>
> >> For the record, here’s the distro status:
> >>
> >> • Debian unstable has 2.2:
> >> <https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=guile-2.2>.
> >>
> >> • Older Debian versions have 2.0.13 (not .14):
> >> <https://packages.debian.org/search?keywords=guile-2.0>.
> >
> > How much of this patch would change if it were to instead support
> > 2.0.13? Is cutting off users of Debian stable a good idea?
>
> I’ll double-check but I think the patch remains valid if we require
> 2.0.13.
>
> If it works I’ll commit that next week.

Cool.

Toggle quote (10 lines)
>
> >> I’d also like it to be the last release that support Guile 2.0.
> >
> > Same question.
>
> 2.2 is becoming quite widespread in distros.
>
> Overall it’s a cost/benefit tradeoff, and we have to take into account
> that most users get Guix using the binary tarball or GuixSD.

Right. But this can also become self-fulfilling. If we make it too
hard for people to build from source, the binary tarball becomes more
and more the only option.

Toggle quote (3 lines)
>
> Thanks for your feedback,

Thanks for humoring me.

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlqTW+wACgkQ/XPKxxnT
JWY7gw/+LMohftkeO99tifvhnjCsu7vRAi6LPM4PFfR+GLUNf1Hl56UNWavO6omC
EYB5EdL92WRUEPXZtnk+OzxqQzBUkm0R2xwtBBSHsBPplcByhSxFr7c/yvCfsOQG
ky3KDw9Lsh1PI+sad8VTNErzKvJ111M250M2MOFZw7T/1cfhuHXX11fFEAdcJk8N
AE4KUSipbYdIpHSUrcasBpMcWR8H22IexXNfIg9Jj86/+hsBbsi+dOhouEb5S7fo
/kuzxvm2AgcooTRF5uIx3TDXqdrgRTvO8chxWdAwxoPSTSgwNOus4rvvmsFE0rIC
Hl8QDnDMbTgM1POIq+OfwbiQvyYj9bj1TwoLgCsoJOFupAygPrMS/hXUEa8/BiM7
h/3y+nbsDGMuoOd5ZqW//uCbaDx9uRPVkWdut2IAKkPC5rnEjS0LsI2+ediYgQW4
GufGahYlbFyOWirsCr76Pg9II/IZzA5tuyaO1wSi9AhsOjfYbff3s4fo16RHGcgk
2NPPZvzrakalCrogy506mVnrRUB8vlStyRkscGXDWcTPi8UYE3RcCrIpxiBsyvEI
FkF4i+GIydCq4CDImyMCA080IdXDCwbOGY3PL04uImyGGO0r4oJvHlN+ksmanqqc
ch/SZKOJAi62B26rvQrshry3fN7Z6t4DhZGK0vLrzLbhMbhpOHM=
=B7yN
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 26 Feb 2018 19:49
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 30469-done@debbugs.gnu.org)
87fu5ntwl9.fsf@gnu.org
Eric Bavier <ericbavier@centurylink.net> skribis:

Toggle quote (33 lines)
> On Sat, 24 Feb 2018 23:41:24 +0100
> ludo@gnu.org (Ludovic Courtès) wrote:
>
>> Hello,
>>
>> Eric Bavier <ericbavier@centurylink.net> skribis:
>>
>> > On Thu, 15 Feb 2018 16:26:27 +0100
>> > Ludovic Courtès <ludo@gnu.org> wrote:
>> >
>> >> Hello Guix,
>> >>
>> >> This patch is to require Guile >= 2.0.14, released one year ago, instead
>> >> of 2.0.9, released in 2013.
>> >>
>> >> For the record, here’s the distro status:
>> >>
>> >> • Debian unstable has 2.2:
>> >> <https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=guile-2.2>.
>> >>
>> >> • Older Debian versions have 2.0.13 (not .14):
>> >> <https://packages.debian.org/search?keywords=guile-2.0>.
>> >
>> > How much of this patch would change if it were to instead support
>> > 2.0.13? Is cutting off users of Debian stable a good idea?
>>
>> I’ll double-check but I think the patch remains valid if we require
>> 2.0.13.
>>
>> If it works I’ll commit that next week.
>
> Cool.

Pushed as 1d84d7bf6052c0c80bd212d4524876576e9817d4.

Thanks for your feedback!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 27 Feb 2018 18:23
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 30469@debbugs.gnu.org)
87606iz6qw.fsf@gnu.org
Hi Jonathan,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (19 lines)
> 2.2 is not as easy as I thought it would be, to bring it to openSUSE
> Leap. There are packages who still require guile 2.0 (see comments in
> https://build.opensuse.org/request/show/568553). And the fact that only
> a handful of packages need guile, makes it not really worthwhile for
> distros to have two versions of guile present like we see it for python.
>
> It would be nice to have guix in Debian, Ubuntu, SUSE land and Red Hat
> land. I think that would enable far more people to use guix.
>
> At the moment it's not easy to install guix from source without having
> guix in place, at least on openSUSE. You need those guile modules
> (guile-git, guile-bytestructures) who comes with almost no build
> documentation. And then you have to fiddle together guile with the right
> versions...
>
> We struggle a lot with bootstrapping rust, go, java etc, so we should
> make sure that "bootstrapping" guix (install from source) is easy or at
> least doable.

Agreed.

It becomes clearer to me that we would want to take advantage of Guix’
modularity here so that one can build just the core of Guix with no
dependencies other than Guile and libgcrypt maybe, and from there build
higher-level layers, etc.

Ludo’.
?