[PATCH] gnu: make-linux-libre: Use invoke.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Mark H Weaver
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180214083722.12245-1-dannym@scratchpost.org
* gnu/packages/linux.scm (make-linux-libre): Use invoke.
---
gnu/packages/linux.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 858f0885c..e01edce9c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -336,7 +336,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(begin
(copy-file config ".config")
(chmod ".config" #o666))
- (system* "make" ,defconfig))
+ (invoke "make" ,defconfig))
;; Appending works even when the option wasn't in the
;; file. The last one prevails if duplicated.
@@ -345,7 +345,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(display extra-configuration port)
(close-port port))
- (zero? (system* "make" "oldconfig")))))
+ (invoke "make" "oldconfig"))))
(replace 'install
(lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -360,13 +360,13 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(find-files "." "\\.dtb$"))
;; Install kernel modules
(mkdir-p moddir)
- (zero? (system* "make"
- (string-append "DEPMOD=" kmod "/bin/depmod")
- (string-append "MODULE_DIR=" moddir)
- (string-append "INSTALL_PATH=" out)
- (string-append "INSTALL_MOD_PATH=" out)
- "INSTALL_MOD_STRIP=1"
- "modules_install"))))))
+ (invoke "make"
+ (string-append "DEPMOD=" kmod "/bin/depmod")
+ (string-append "MODULE_DIR=" moddir)
+ (string-append "INSTALL_PATH=" out)
+ (string-append "INSTALL_MOD_PATH=" out)
+ "INSTALL_MOD_STRIP=1"
+ "modules_install")))))
#:tests? #f))
(home-page "https://www.gnu.org/software/linux-libre/")
(synopsis "100% free redistribution of a cleaned Linux kernel")
Leo Famulari wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180214214102.GB22425@jasmine.lan
On Wed, Feb 14, 2018 at 09:37:22AM +0100, Danny Milosavljevic wrote:
Toggle quote (2 lines)
> * gnu/packages/linux.scm (make-linux-libre): Use invoke.

Thanks!

This will require rebuilding linux-libre, right? If so, we should push
it along with updates to those packages.

CC-ing Mark, who usually handles linux-libre.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqErO4ACgkQJkb6MLrK
fwijEA//XouXnwY1ag/Ge0GiwdHAZn/dDSDP+IDWpOIsDYrhtsp8o6SmyF38ypE0
B3CmC3wQRJx6V5pIbiZSSza8kjNM3jrLX9iT02Uty1TxcPPWvB2S8mNLSAWJJths
5m1TbdhRxw+d/B9V9jkLlAMZerlBECZcRxxXdqQiOjRve6m7yQEgvTObOtI5hWYA
qbzoe5Vd0g8p107j8rmvQdxRE9Pl3st9H08FqdfLKjedXu717H8MJQm/lU9XCXgH
ewlDwnjGdaWs+aKNnkOD+NFZ4yHHl2lsti5/cZHQBr4/pLrDEa8yNQeWLo9RZrAy
clQ/GEMSCPatmVfw0MLc2bPxNX2duqjw2FSz9UjrqcPkfZY1kjxUEBRJZNJ4cwpN
7Id++KWgc2YjxS9w5ibGb76wPZTJOwfUTscNXVhPcLLXQn3xwwmntDyBpRUtzDV9
jBTzUZ9nUM1+LidxtPWGnFJm0B410sXp7laMtZgyThiWUUaXg+5V3HeDAMn/K+eA
AEvsYWCdhqIbiUHu/hv1aAjHJ+F6fZU3POSVjWb6Cgu/DhY6jvUn4pRMInTZ+kC9
H0k0cmLk6X7L1mHMRYNrj4tjEmowHaL+rqB7QBs4V8e2aqOdhPqEiMMpO7whaupY
TPzKjm+S0b0OCHXclVc0QKQUDS6Sd7Z4LWFAT7XqKfjYsjuP2M8=
=JbwI
-----END PGP SIGNATURE-----


Mark H Weaver wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)
87eflmog44.fsf@netris.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (8 lines)
> On Wed, Feb 14, 2018 at 09:37:22AM +0100, Danny Milosavljevic wrote:
>> * gnu/packages/linux.scm (make-linux-libre): Use invoke.
>
> Thanks!
>
> This will require rebuilding linux-libre, right? If so, we should push
> it along with updates to those packages.

Agreed. I'll try to remember to push Danny's commit the next time I
push kernel updates, which typically happen every few days anyway.
Let's hold off on this until then.

Thanks!
Mark
Mark H Weaver wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)
87inauj33t.fsf@netris.org
I just pushed Danny's commit to master along with kernel updates, commit
fdd400d82ed83e230331f837aee70e1d504fe58c. I'm marking this as done.

Thanks!
Mark
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30454@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30454
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help