[PATCH 0/3] Add Intel ME tools.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180213180001.4339-1-dannym@scratchpost.org
Danny Milosavljevic (3):
gnu: Add ifdtool.
gnu: Add intelmetool.
gnu: Add me-cleaner.

gnu/packages/flashing-tools.scm | 107 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 107 insertions(+)
Danny Milosavljevic wrote 7 years ago
[PATCH 1/3] gnu: Add ifdtool.
(address . 30446@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180213180145.4412-1-dannym@scratchpost.org
* gnu/packages/flashing-tools.scm (ifdtool): New variable.
---
gnu/packages/flashing-tools.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 9683c6b4a..c29982551 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -330,3 +330,38 @@ USB and interacts with low-level software running on the device, known as Loke.
Loke and Heimdall communicate via the custom Samsung-developed protocol typically
referred to as the \"Odin 3 protocol\".")
(license license:expat)))
+
+(define-public ifdtool
+ (let ((commit "1b64ae1119fc7891b043d5d29bf93859ef9dbfa1")
+ (revision "0"))
+ (package
+ (name "ifdtool")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/p/coreboot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0i3h9ns5f0z9ffapmlcj1mcgi5b1kzdlakixs2i8s4mkjn0aidsc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ "INSTALL=install"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/ifdtool")
+ #t))
+ (delete 'configure)
+ (delete 'check))))
+ (home-page "https://github.com/corna/me_cleaner/")
+ (synopsis "Intel Firmware Descriptor dumper")
+ (description "This package provides @ifdtool}, a program to
+dump Intel Firmware Descriptor data of an image file.")
+ (license license:gpl2))))
Danny Milosavljevic wrote 7 years ago
[PATCH 2/3] gnu: Add intelmetool.
(address . 30446@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180213180145.4412-2-dannym@scratchpost.org
* gnu/packages/flashing-tools.scm (intelmetool): New variable.
---
gnu/packages/flashing-tools.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index c29982551..78981f4b6 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libusb)
#:use-module (gnu packages libftdi)
@@ -365,3 +366,43 @@ referred to as the \"Odin 3 protocol\".")
(description "This package provides @ifdtool}, a program to
dump Intel Firmware Descriptor data of an image file.")
(license license:gpl2))))
+
+(define-public intelmetool
+ (let ((commit "1b64ae1119fc7891b043d5d29bf93859ef9dbfa1")
+ (revision "0"))
+ (package
+ (name "intelmetool")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://review.coreboot.org/p/coreboot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0i3h9ns5f0z9ffapmlcj1mcgi5b1kzdlakixs2i8s4mkjn0aidsc"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("pciutils" ,pciutils)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ "INSTALL=install"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "util/intelmetool")
+ #t))
+ (delete 'configure)
+ (delete 'check))))
+ (home-page "https://github.com/zamaudio/intelmetool")
+ (synopsis "Intel ME tools")
+ (description "This package provides tools for working with Intel
+Management Engine (ME). You need to @code{sudo rmmod mei_me} and
+@code{sudo rmmod mei} before using this tool. Also pass
+@code{iomem=relaxed} to the Linux kernel command line.")
+ (license license:gpl2))))
Danny Milosavljevic wrote 7 years ago
[PATCH 3/3] gnu: Add me-cleaner.
(address . 30446@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180213180145.4412-3-dannym@scratchpost.org
* gnu/packages/flashing-tools.scm (me-cleaner): New variable.
---
gnu/packages/flashing-tools.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 78981f4b6..1c32d0745 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
@@ -406,3 +407,33 @@ Management Engine (ME). You need to @code{sudo rmmod mei_me} and
@code{sudo rmmod mei} before using this tool. Also pass
@code{iomem=relaxed} to the Linux kernel command line.")
(license license:gpl2))))
+
+(define-public me-cleaner
+ (package
+ (name "me-cleaner")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/corna/me_cleaner/"
+ "archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pgwdqy0jly80nhxmlmyibs343497yjzs6dwfbkcw0l1gjm8i5hw"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-setup.py
+ (lambda _
+ (call-with-output-file "setup.py"
+ (lambda (port)
+ (format port "\
+from setuptools import setup
+setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
+" ,version))))))))
+ (home-page "https://github.com/corna/me_cleaner")
+ (synopsis "Intel ME cleaner")
+ (description "This package provides tools for disabling Intel
+ME as far as possible (in image files).")
+ (license license:gpl3+)))
Leo Famulari wrote 7 years ago
Re: [bug#30446] [PATCH 1/3] gnu: Add ifdtool.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30446@debbugs.gnu.org)
20180213191843.GA31517@jasmine.lan
On Tue, Feb 13, 2018 at 07:01:43PM +0100, Danny Milosavljevic wrote:
Toggle quote (9 lines)
> * gnu/packages/flashing-tools.scm (ifdtool): New variable.

> +(define-public ifdtool
> + (let ((commit "1b64ae1119fc7891b043d5d29bf93859ef9dbfa1")
> + (revision "0"))
> + (package
> + (name "ifdtool")
> + (version (git-version "0.0" revision commit))

I notice the Git repo has tagged versions. If the latest one is
inappropriate to build from, please use it in the git-version like this:

(git-version "4.7" revision commit)

Otherwise, LGTM!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqDOhMACgkQJkb6MLrK
fwgP+w/+P4zKATrkwKlx9Wk7FdtBs3xaNI9NbIyXEZg4InoAYYLpzXpn8wvLlp1b
1LyurR9t70AFUfX9zeCWGSYEScueC3xjMXxfb92TOXC3vUJwkQcds1NGn+cVlnpD
1tucffNjBrR5VOGzT5FfhcpjsSap3pv/H7H4pZIltvhuR6Bu5OKHoBlCmJNOP8JI
mfET6+qOgINit2HhxS2ky9Q0EiOISHow1LYM7YJKgM04LOdxxpSft2X9f9w6NomC
vhwACTpzLxrXxFdvQq1vOWwZpgWfxPWmlgWBLXpE7xD/JwVVYjMMC3tqRzg65oId
ldhyaJibpSHLSPpgsBCl1+TSGDhT2SPkqU/EEsnMG/uFm4AJMwTCEF9CcsozYWam
b0jycs4Kn/I5Fyp7ZCpe3BsuCHtxqOh8LvUThk2Q+WFj5AvXvo1Js8YZ+RoZqypr
q4r/JqOznCaFcjsnWdFyCwU2ScZhcSGYiR2Dr5DrORUJYVxOtReVnPPsYxgojnv+
jIkrNDw2xUVyO4Bu7BDIfVsGKRF3esV3Jw51QDiHfAPm9968mZmGWxzpqn1GbXxN
p1BXoBp/w8z0oU8T+GLjrzGiyMeCAk26bLURFU7K47KDwva7kp7xhkquRL24xyj+
mxFMJtzm54t9y9AM634mGPFk2GzBw/rGwG+Q5tb+ONAyOx/oWpw=
=e2U3
-----END PGP SIGNATURE-----


Leo Famulari wrote 7 years ago
Re: [bug#30446] [PATCH 2/3] gnu: Add intelmetool.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30446@debbugs.gnu.org)
20180213192031.GB31517@jasmine.lan
On Tue, Feb 13, 2018 at 07:01:44PM +0100, Danny Milosavljevic wrote:
Toggle quote (9 lines)
> * gnu/packages/flashing-tools.scm (intelmetool): New variable.

> +(define-public intelmetool
> + (let ((commit "1b64ae1119fc7891b043d5d29bf93859ef9dbfa1")
> + (revision "0"))
> + (package
> + (name "intelmetool")
> + (version (git-version "0.0" revision commit))

Same feedback about the version string as with the other coreboot-based
package.

Toggle quote (6 lines)
> + (synopsis "Intel ME tools")
> + (description "This package provides tools for working with Intel
> +Management Engine (ME). You need to @code{sudo rmmod mei_me} and
> +@code{sudo rmmod mei} before using this tool. Also pass
> +@code{iomem=relaxed} to the Linux kernel command line.")

Overall LGTM, but I don't think we should use the description as a
source of copy-and-paste instructions. Does the package include any
docs?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqDOn8ACgkQJkb6MLrK
fwi9hA//an88FPOSLIlECj3zRcIu/fdf9bXvLrtKCr/KGKBesQkBwP3tRDa5Z5d8
BzjYA8kkaI7vPSY9c/ulfUrv2Z2tf0irKT6rV6jAVIhHBFC4q1QTDQxzTdc5hVXj
2Jjjvydq0FRNKs6Qcj7Vl1U3Bx9q3obkS3DxOngbKptL0Io+NbQDxQIi2lwtWod6
DKKJa5pNnaYoWf16vvOcYQOCJfqN/7IttMNUe6RyvDOueqattCRanYP+ZcwfONvG
k/Zj7/OfVP7CPf+a6t4f5P4lDsTu5KXFiHNScidvFovPb1HLpXNMT4GAZW1vUILB
iwYCS6VlwOe6KoNqVJkpeYNhMSbTddDFMYcScu1gMqlpexJK5s849pZ+MY/ryd05
tTi92bNam3jZuNqJrAxcup1UgOzGaPgpfxAmWQXFR4CQHFCcZXapHxh5qKRd5+0F
/wkEV9rCz8TM80DpgqCDYmLWVKnXmFDZMbWN7Bor9mQQzPKM8mMpFndL3lhakfNo
6LjKLWEs0UI1vO4pyEoZG0ln49qdZPRdWFEZzN0t5vujujAmTw2uPt1DxE+pWm6R
iLkdm4xopVTJ4hgyaP0Or8Gc2rjjrOQ2rVm+CaTlj0lumMuyD5MDKXadqTnyAST4
TUy3VoGdeT1HRZfRnEhoXngkTpfTQdaLfusUuGO0fnUJ6H7tFYo=
=UcT7
-----END PGP SIGNATURE-----


Leo Famulari wrote 7 years ago
Re: [bug#30446] [PATCH 3/3] gnu: Add me-cleaner.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30446@debbugs.gnu.org)
20180213192150.GC31517@jasmine.lan
On Tue, Feb 13, 2018 at 07:01:45PM +0100, Danny Milosavljevic wrote:
Toggle quote (15 lines)
> * gnu/packages/flashing-tools.scm (me-cleaner): New variable.

> + (build-system python-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'create-setup.py
> + (lambda _
> + (call-with-output-file "setup.py"
> + (lambda (port)
> + (format port "\
> +from setuptools import setup
> +setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
> +" ,version))))))))

Okay if it works!

Toggle quote (3 lines)
> + (description "This package provides tools for disabling Intel
> +ME as far as possible (in image files).")

Can you clarify "image files"? I'm not sure what it means here.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqDOs4ACgkQJkb6MLrK
fwi1ww//d6AZNB1Q1N39IX4qatFsxhDowr9R8oVfFlrFnUEvcr9VoK2zniSqM5f5
77TIXyQ4rtrdifrogSGNw+B1W4A0FK7CZrSkZAQ6Po/7X8Fh2omlavfKhW/5pWGq
YfCoCZQLrXEQWenIqjvwWbVHBOnaoODJHUqTuaJu7M+IlcBojRs/CQptp8Kmpqjp
JBBult5zvYahEjOcAhc3Rj5xaWmDRyg2aNasDRePRPpcsUk/L1UrnrlHcMR+VBtc
RGiwr5qT5oWZgnBhe/1T5iG9mTJeWjjr+JNXQVoBG3ZGXTnQsEfiVPjq2PseQcMF
u/rwJxqrIqkTS90jxj+wZTHMsedoFyN2wGjqDsDaRv6h12f2tDQOcqdz8I0X1NNV
49fhr6TDfDVUcIdAB4exHG8kF/iX1hyOWgR9Dkpf5oACNMrQek89Uf8sAe/LIInn
VMmNs1Ow8Bf/ONHZQ8SjVTZHAZZ07vQVeubhiqdhHKlKR1dd4QegvJ58Zmosu7Ou
O0CrcKxOvkVsFTKRv9K66pvfd7Zp9LcJo6U7kj0vDdzp0Viki+F5Hoe90xlBVzMP
e9XZKjG0b8svLCp/RdG5dWqVtN1H/nvFEsvPv/AoRvo9DHo4iULW5311poCQ6E4L
Ku55yx+spj06xbeWT5lKAaAZnuBUz/GR4j5q1fEmy8qlsbZSyEw=
=il8f
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 7 years ago
Re: [bug#30446] [PATCH 2/3] gnu: Add intelmetool.
(name . Leo Famulari)(address . leo@famulari.name)(address . 30446@debbugs.gnu.org)
20180213213626.7d3a7910@scratchpost.org
Hi Leo,

Toggle quote (4 lines)
> Overall LGTM, but I don't think we should use the description as a
> source of copy-and-paste instructions. Does the package include any
> docs?

Apparently not. While coreboot has docs, it doesn't mention intelmetool anywhere.

I just thought to include those things in the description because if you don't
do the stuff (note: Guix doesn't do it by default) it will fail in strange ways
(and did for me).
Danny Milosavljevic wrote 7 years ago
Re: [bug#30446] [PATCH 1/3] gnu: Add ifdtool.
(name . Leo Famulari)(address . leo@famulari.name)(address . 30446@debbugs.gnu.org)
20180213213722.6bffd81d@scratchpost.org
Hi Leo,

On Tue, 13 Feb 2018 14:18:43 -0500
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (3 lines)
> I notice the Git repo has tagged versions. If the latest one is
> inappropriate to build from, please use it in the git-version like this:

How do I find out which commit corresponds to a tag (or which commits are
not in the 4.7 tag) ?
Danny Milosavljevic wrote 7 years ago
Re: [bug#30446] [PATCH 3/3] gnu: Add me-cleaner.
(address . 30446@debbugs.gnu.org)
20180213222935.4332e0f9@scratchpost.org
On Tue, 13 Feb 2018 14:21:50 -0500
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (16 lines)
> On Tue, Feb 13, 2018 at 07:01:45PM +0100, Danny Milosavljevic wrote:
> > * gnu/packages/flashing-tools.scm (me-cleaner): New variable.
>
> > + (build-system python-build-system)
> > + (arguments
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (add-after 'unpack 'create-setup.py
> > + (lambda _
> > + (call-with-output-file "setup.py"
> > + (lambda (port)
> > + (format port "\
> > +from setuptools import setup
> > +setup(name='me_cleaner', version='~a', scripts=['me_cleaner.py'])
> > +" ,version))))))))

Note to self: forgot the #t.
Marius Bakke wrote 7 years ago
Re: [bug#30446] [PATCH 1/3] gnu: Add ifdtool.
(address . 30446@debbugs.gnu.org)
87po58mudi.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (11 lines)
> Hi Leo,
>
> On Tue, 13 Feb 2018 14:18:43 -0500
> Leo Famulari <leo@famulari.name> wrote:
>
>> I notice the Git repo has tagged versions. If the latest one is
>> inappropriate to build from, please use it in the git-version like this:
>
> How do I find out which commit corresponds to a tag (or which commits are
> not in the 4.7 tag) ?

You can use the tag name in the (revision ...) field (see e.g. libvpx).

To find which commits are not in a given tag, use something along the
lines of...

$ git log --format=oneline v4.7..master
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlqDXbkACgkQoqBt8qM6
VPpeFggAw9Pl2w+tgKgD1wgRUQ9pL28Yq7pf3FA2Xosa8rayk+sp3QAv8oT6V+AB
Qn6P786XrvOAlvQyFL+MHbqHZQAMdVU7eVZwhxx14Ws7hV8DBYev8YHefVEXKbmM
9i+p9jHkkcdlhKuHIFB5FW7vwvV71NPnFhiuhcD9IlS7eKVTpLyf0/ZBpNXkWPcO
OP4EEIzQgr9oOXxr25xM5e0Xo28u7m6rIcQVSlWkoZusXJb/QVbPQvYzfXrxHeAk
QrPdW4ASmcJ/bBM01xcS9kJhlSWXiRYFeK8ji+fwNRYzoSVpJZEYWMYPAPe1kUpu
0mHHVeI6pUm90VXdljHwp5jk91XNtg==
=O4Bg
-----END PGP SIGNATURE-----

Leo Famulari wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
20180214030033.GB2349@jasmine.lan
On Tue, Feb 13, 2018 at 10:50:49PM +0100, Marius Bakke wrote:
Toggle quote (20 lines)
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
> > Hi Leo,
> >
> > On Tue, 13 Feb 2018 14:18:43 -0500
> > Leo Famulari <leo@famulari.name> wrote:
> >
> >> I notice the Git repo has tagged versions. If the latest one is
> >> inappropriate to build from, please use it in the git-version like this:
> >
> > How do I find out which commit corresponds to a tag (or which commits are
> > not in the 4.7 tag) ?
>
> You can use the tag name in the (revision ...) field (see e.g. libvpx).
>
> To find which commits are not in a given tag, use something along the
> lines of...
>
> $ git log --format=oneline v4.7..master

Also, `git describe --contains $commit` will tell you the latest tag
that contains the commit.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqDplEACgkQJkb6MLrK
fwhGzw/9GLb4PpoYOVVXXRztoROo1qWba3Cz2GDc/+ulOGBNf8YqxotdCIRT4gAK
jeQs4nJQ+laJ4qgYyC5AbkWDyVehV6Lk4FHFggnv70/kVAwBj/sf76gbp/0L4qgt
J7gxju2kRao5fVFYYG4CVNlkTSYv7mWv56uQYq5t6/ZYWowObvwizWjLSo5V8rAe
QoLKI52SQUkjbnqFIeX7LHMjYxyr7BkCKwVGLlKcZEXjtv8Gl1bLi7JnXvCR3P6o
AuN7Mn9ImlxER3iTAz2ZRGX0joBnETBhNBp2gY17ZDNYrgijaJXzrbhZcVXJ8ZcH
gIsgfNCz/lQZ5iZm7PTXrWMWyskNTlT6EHrdj1rOUeaOXiOYLCxd1f+te2BFH87d
+EHdvtUtSlKLykkdO6g4rZGVe81gHk7iWUlZJlN1104qmrKhwI6UjRddASgIx3O8
CXC0/T1g+p2pJ32s2G22eDCKbGHV9oYjLv5tesEGFHD0iGD+7wo73NTaVOdc02OA
oTMkxie3WXpDIEndMBgUXpiM6GdKJup08mcirvSJRW8/YvjbPOdQ6HJwVTDQm3Wb
5wEnjDJhwn08wMjDA7oOX8P356YAe0+HsnJuP3RdKXJAfdvK1JgQgJ+uMbkiiQ8A
wQAhfAi8jsNvtM2WGIFHKIQDKQXAtXiF4uDJzzKDn4NCUizi7bg=
=n2fA
-----END PGP SIGNATURE-----


Leo Famulari wrote 7 years ago
Re: [bug#30446] [PATCH 2/3] gnu: Add intelmetool.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30446@debbugs.gnu.org)
20180214030640.GC2349@jasmine.lan
On Tue, Feb 13, 2018 at 09:36:26PM +0100, Danny Milosavljevic wrote:
Toggle quote (12 lines)
> Hi Leo,
>
> > Overall LGTM, but I don't think we should use the description as a
> > source of copy-and-paste instructions. Does the package include any
> > docs?
>
> Apparently not. While coreboot has docs, it doesn't mention intelmetool anywhere.
>
> I just thought to include those things in the description because if you don't
> do the stuff (note: Guix doesn't do it by default) it will fail in strange ways
> (and did for me).

Are the instructions mostly distro-agnostic? Maybe upstream would accept
a simple README file.

Or we could even add our own in the meantime. But hopefully we don't end
up having to support it :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqDp8AACgkQJkb6MLrK
fwjkKBAAp16oaOTKuDSIRqolAiHGp1Xw1XmNWsEEtl4ZiN48wiG2ZeWhxQQlmTX8
kFtCqFDI/HTjCFt0Hp0qQassgMDTBaupFW/jrS+qcWWcKVKiTwdxTQLmvX2A+tLU
kdjzMC/wptwmFiAOF7i1AOSt/s2Go/7ud6QM6mTBH2WK3+MNZO5Kp51jjaByYKfD
DtqiARklhMIVlngtzhKHtMH5RuvcVQ/WBmklueQm3nRRKkaCZCz9OQt8NYUyGF+O
XcO8mbHPwIQsnkRQXJ0V0l9m7/lRADwj/rGcwON/s3v0KGR6eFeE6n8dAs2gs+5u
/AhZf3XGcIYTnQnOpVB9+vw8T/aQxbG4adEOEYvvD1pSnfawg4czM9MiQOZJk0IM
2B4J+HPsH70kivy2aL/TcmuxU4GUpYMjkJ0EmVCiatVlnLQTgJUUTFKPPPpRfJbl
Jhhh8iD8Z7eIkj2ViXe9w62Y8Tfwueesw54Rh7vSlMxiH9XKAAPcYtABVXFxottz
Mq5G1DckNJ7z5P8NQnR12uCplWC3PCy8qdWIL08IdCTWqPlfe37jRtr2k8p82luh
819xlquSZtuwPy2Z+beRkhf2B6wO9dTxe7LbMxj3LPzQBqJj3n/DmLEPrm5IEa8Z
M0AMU6/CaXBYBewv2OCNpMQ0akKWht2aoGLSpZJ1BjQb0DwX05U=
=j3lL
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20180215120607.73992763@scratchpost.org
close 30446
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30446@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30446
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help