gnu: Add dolphin-emulator.

  • Done
  • quality assurance status badge
Details
7 participants
  • Björn Höfling
  • Thompson, David
  • Leo Famulari
  • Ludovic Courtès
  • Manolis Ragkousis
  • Marius Bakke
  • Rutger Helling
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 7 years ago
(address . guix-patches@gnu.org)
CAJ=RwfaFVeQ+3i_h8SQDXa1wurWgbzpCoxUj5Lx1gqwPyNfuLg@mail.gmail.com
Here a couple of patches that add the Dolphin emulator. I used a Git
snapshot because the project goes *years* between releasing official
source tarballs while at the same time directing users to use binaries
built from the latest commit in their Git repo, so I think packaging
the Git source aligns best with what a Dolphin user would expect.

- Dave
From b09950c2847be7f17ea57906714f74a5ca2f671b Mon Sep 17 00:00:00 2001
From: David Thompson <davet@gnu.org>
Date: Wed, 7 Feb 2018 06:28:46 -0500
Subject: [PATCH 1/2] gnu: Add wxwidgets-gtk2-3.1.

* gnu/packages/wxwidgets.scm (wxwidgets-gtk2-3.1): New variable.
---
gnu/packages/wxwidgets.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 84446d8ef..9f7a87ca4 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -126,6 +126,14 @@ and many other languages.")
((#:configure-flags flags)
`(cons "--enable-mediactrl" ,flags))))))
+(define-public wxwidgets-gtk2-3.1
+ (package (inherit wxwidgets-3.1)
+ (inputs `(("gtk+" ,gtk+-2)
+ ,@(alist-delete
+ "gtk+"
+ (package-inputs wxwidgets-3.1))))
+ (name "wxwidgets-gtk2")))
+
(define-public python2-wxpython
(package
(name "python2-wxpython")
--
2.16.1
From f3793694d8313a242195315214dd829685f6d52d Mon Sep 17 00:00:00 2001
From: David Thompson <davet@gnu.org>
Date: Wed, 7 Feb 2018 06:29:28 -0500
Subject: [PATCH 2/2] gnu: Add dolphin-emulator.

* gnu/packages/games.scm (dolphin-emulator): New variable.
---
gnu/packages/games.scm | 77 +++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 76 insertions(+), 1 deletion(-)

Toggle diff (101 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e2f855aa5..3f50945d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014, 2015, 2016 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2014, 2015, 2016, 2018 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
@@ -88,6 +88,7 @@
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libunwind)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages haskell)
#:use-module (gnu packages mp3)
#:use-module (gnu packages music)
@@ -5526,3 +5527,77 @@ hacking the gamification of contribution graphs on platforms such as
Github or Gitlab.")
(home-page "https://github.com/umayr/badass")
(license license:expat))))
+
+;; Building from recent Git because the official 5.0 release no longer builds.
+(define-public dolphin-emulator
+ (let ((commit "d04b179111f8d863f360839474cb82c766f762b8")
+ (revision "0"))
+ (package
+ (name "dolphin-emulator")
+ (version (git-version "5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dolphin-emu/dolphin.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g725wmhlim73zrhi47wmr1bmplpy4b7sbimd5pm8xpfhj5nm10l"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f
+ ;; The FindGTK2 cmake script only checks hardcoded directories for
+ ;; glib/gtk headers.
+ #:configure-flags
+ (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "gtk+")
+ "/lib/gtk-2.0/include")
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include")
+ (string-append "-DX11_INCLUDE_DIR="
+ (assoc-ref %build-inputs "libx11")
+ "/include")
+ (string-append "-DX11_LIBRARIES="
+ (assoc-ref %build-inputs "libx11")
+ "/lib/libX11.so")
+ "-DX11_FOUND=1"
+ "-DENABLE_QT2=False"))) ; disable qt frontend
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gettext" ,gnu-gettext)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ao" ,ao)
+ ("bluez" ,bluez)
+ ("eudev" ,eudev)
+ ("ffmpeg" ,ffmpeg)
+ ("glew" ,glew)
+ ("glib" ,glib)
+ ("glu" ,glu)
+ ("gtk+" ,gtk+-2)
+ ("libevdev" ,libevdev)
+ ("libpng" ,libpng)
+ ("libusb" ,libusb)
+ ("libx11" ,libx11)
+ ("libxi" ,libxi)
+ ("libxrandr" ,libxrandr)
+ ("lzo" ,lzo)
+ ("mesa" ,mesa)
+ ("miniupnpc" ,miniupnpc)
+ ("openal" ,openal)
+ ("pulseaudio" ,pulseaudio)
+ ("sdl2" ,sdl2)
+ ("soil" ,soil)
+ ("soundtouch" ,soundtouch)
+ ("wxwidgets" ,wxwidgets-gtk2-3.1)
+ ("zlib" ,zlib)))
+ (home-page "https://dolphin-emu.org/")
+ (synopsis "Nintendo Wii and GameCube emulator")
+ (description
+ "Dolphin is an emulator for two Nintendo video game consoles: the
+GameCube and the Wii. It provides compatibility with all PC controllers,
+turbo speed, networked multiplayer, and graphical enhancements.")
+ (license license:gpl2))))
--
2.16.1
Björn Höfling wrote 7 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 30380@debbugs.gnu.org)
20180207214353.36366a2c@alma-ubu
On Wed, 7 Feb 2018 11:58:02 -0500
"Thompson, David" <dthompson2@worcester.edu> wrote:

Toggle quote (8 lines)
> Here a couple of patches that add the Dolphin emulator. I used a Git
> snapshot because the project goes *years* between releasing official
> source tarballs while at the same time directing users to use binaries
> built from the latest commit in their Git repo, so I think packaging
> the Git source aligns best with what a Dolphin user would expect.
>
> - Dave

Hi Dave,

I haven't done a full review, here are some things I noticed:

* License is GPLv2+, not only v2.
* dolphin/Data/Sys/GC/font_*.bin: Licensed under ASL2.0.
* The homepage states this package is only available for x86_64.
If that is true, add a line like this to your package:
(supported-systems '("x86_64-linux"))
* dolphin/Installer/dxredist/ contains (Windows) binaries. Remove with
a snippet.
* Remove dolphin/Externals in a snippet. Or at least those that you
have added as dependencies.
* There are binaries in the distribution:
dolphin/Data/Sys/GC/dsp_coef.bin and dsp_rom.bin
The commit message says something like "based off of observed
effects on the virtual machine", but still this is binaray. Or is there
some way of building this from commented assembly? Here is the full
commit message:

* Finally, doesn't this encourage people to use non-free software, i.e.
the original manufacturers game discs? Or is there any free software
implementation running on this emulator?

Björn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlp7ZQoACgkQvyhstlk+X/0f6QCgiEtvZ2snCD0O/B8PMsna0qQe
ZT4An28fto2D/4Fsh1vEsrjajWn5VJWz
=++0N
-----END PGP SIGNATURE-----


Thompson, David wrote 7 years ago
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)(address . 30380@debbugs.gnu.org)
CAJ=RwfbOySqzLGMqiSVa7PKw1+5E2967Q-e_g8TV4fdwyQB=bQ@mail.gmail.com
Hello,

On Wed, Feb 7, 2018 at 3:43 PM, Björn Höfling
<bjoern.hoefling@bjoernhoefling.de> wrote:
Toggle quote (38 lines)
> On Wed, 7 Feb 2018 11:58:02 -0500
> "Thompson, David" <dthompson2@worcester.edu> wrote:
>
>> Here a couple of patches that add the Dolphin emulator. I used a Git
>> snapshot because the project goes *years* between releasing official
>> source tarballs while at the same time directing users to use binaries
>> built from the latest commit in their Git repo, so I think packaging
>> the Git source aligns best with what a Dolphin user would expect.
>>
>> - Dave
>
> Hi Dave,
>
> I haven't done a full review, here are some things I noticed:
>
> * License is GPLv2+, not only v2.
> * dolphin/Data/Sys/GC/font_*.bin: Licensed under ASL2.0.
> * The homepage states this package is only available for x86_64.
> If that is true, add a line like this to your package:
> (supported-systems '("x86_64-linux"))
> * dolphin/Installer/dxredist/ contains (Windows) binaries. Remove with
> a snippet.
> * Remove dolphin/Externals in a snippet. Or at least those that you
> have added as dependencies.
> * There are binaries in the distribution:
> dolphin/Data/Sys/GC/dsp_coef.bin and dsp_rom.bin
> The commit message says something like "based off of observed
> effects on the virtual machine", but still this is binaray. Or is there
> some way of building this from commented assembly? Here is the full
> commit message:
> https://github.com/dolphin-emu/dolphin/commit/e3531d17d700339828d7bab192c66fba5fcbac86
>
> * Finally, doesn't this encourage people to use non-free software, i.e.
> the original manufacturers game discs? Or is there any free software
> implementation running on this emulator?
>
> Björn

Nevermind. I am dropping this patch set.

Sorry,

- Dave
Ludovic Courtès wrote 7 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)
87zi4i31l7.fsf@gnu.org
Hi David,

"Thompson, David" <dthompson2@worcester.edu> skribis:

Toggle quote (2 lines)
> Nevermind. I am dropping this patch set.

To clarify, is it because of freedom issues like Björn suggested, or due
to lack of time?

Thank you, and thanks Björn for taking the time to look into it!

Ludo’.
Thompson, David wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30380@debbugs.gnu.org)
CAJ=Rwfa=iFfQGgeimqNugzw6QjZf4-84c8hgpjgxVkVFgXGnjw@mail.gmail.com
On Fri, Feb 9, 2018 at 5:21 AM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (9 lines)
> Hi David,
>
> "Thompson, David" <dthompson2@worcester.edu> skribis:
>
>> Nevermind. I am dropping this patch set.
>
> To clarify, is it because of freedom issues like Björn suggested, or due
> to lack of time?

I can just tell there's going to be a lot of friction here so it's
easier if I just keep this in my personal package collection instead.

- Dave
Manolis Ragkousis wrote 7 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)
210f8200-d7bc-b88a-32d2-7db56d3afc39@gmail.com
Hello everyone,

On 02/09/18 16:11, Thompson, David wrote:
Toggle quote (14 lines)
> On Fri, Feb 9, 2018 at 5:21 AM, Ludovic Courtès <ludo@gnu.org> wrote:
>> Hi David,
>>
>> "Thompson, David" <dthompson2@worcester.edu> skribis:
>>
>>> Nevermind. I am dropping this patch set.
>>
>> To clarify, is it because of freedom issues like Björn suggested, or due
>> to lack of time?
>
> I can just tell there's going to be a lot of friction here so it's
> easier if I just keep this in my personal package collection instead.
>

And why should this be a reason to stop packaging dolphin? If dolphin
can be packaged without the binaries we should definitely have it in
Guix. How will we be able to reverse engineer proprietary software, if
we don't have a way to test it? And besides there are free software
gamecube homebrew applications which can run on dolphin.

David if you don't intend to continue on this patch, I will take it over
to try and find if it possible for it to be built without any
proprietary binaries.

Manolis
Thompson, David wrote 7 years ago
(name . Manolis Ragkousis)(address . manolis837@gmail.com)
CAJ=RwfYUKudjDvgXi0CRp-xP-ozhVwHn8KsB-NoRG=FN6=-pUg@mail.gmail.com
On Fri, Feb 9, 2018 at 10:52 AM, Manolis Ragkousis <manolis837@gmail.com> wrote:
Toggle quote (27 lines)
> Hello everyone,
>
> On 02/09/18 16:11, Thompson, David wrote:
>> On Fri, Feb 9, 2018 at 5:21 AM, Ludovic Courtès <ludo@gnu.org> wrote:
>>> Hi David,
>>>
>>> "Thompson, David" <dthompson2@worcester.edu> skribis:
>>>
>>>> Nevermind. I am dropping this patch set.
>>>
>>> To clarify, is it because of freedom issues like Björn suggested, or due
>>> to lack of time?
>>
>> I can just tell there's going to be a lot of friction here so it's
>> easier if I just keep this in my personal package collection instead.
>>
>
> And why should this be a reason to stop packaging dolphin? If dolphin
> can be packaged without the binaries we should definitely have it in
> Guix. How will we be able to reverse engineer proprietary software, if
> we don't have a way to test it? And besides there are free software
> gamecube homebrew applications which can run on dolphin.
>
> David if you don't intend to continue on this patch, I will take it over
> to try and find if it possible for it to be built without any
> proprietary binaries.

Sure, you and/or Rutger should feel free to modify it.

- Dave
Rutger Helling wrote 7 years ago
Re: [bug#30380] gnu: Add dolphin-emu.
20180216102046.562bda38@mykolab.com
Hello everyone,

As promised I've updated these patches. Just to reiterate, these are
David's patches. I've only changed a few things.

Here's the changes of the top of my head:
* First patch is unchanged.
* Renamed to dolphin-emu instead of dolphin-emulator since that seems
like a more canonical name.
* Incorporated Björn's suggestions.
* Added a few more inputs to get rid of more externals.
* Enabled Qt interface.
From b09950c2847be7f17ea57906714f74a5ca2f671b Mon Sep 17 00:00:00 2001
From: David Thompson <davet@gnu.org>
Date: Wed, 7 Feb 2018 06:28:46 -0500
Subject: [PATCH 1/2] gnu: Add wxwidgets-gtk2-3.1.

* gnu/packages/wxwidgets.scm (wxwidgets-gtk2-3.1): New variable.
---
gnu/packages/wxwidgets.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 84446d8ef..9f7a87ca4 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -126,6 +126,14 @@ and many other languages.")
((#:configure-flags flags)
`(cons "--enable-mediactrl" ,flags))))))
+(define-public wxwidgets-gtk2-3.1
+ (package (inherit wxwidgets-3.1)
+ (inputs `(("gtk+" ,gtk+-2)
+ ,@(alist-delete
+ "gtk+"
+ (package-inputs wxwidgets-3.1))))
+ (name "wxwidgets-gtk2")))
+
(define-public python2-wxpython
(package
(name "python2-wxpython")
--
2.16.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEAVThuRzJ2e93ZI3n86cn20T8yjYFAlqGom8ACgkQ86cn20T8
yjax9gf/chFfHvrR5tQZhIOqYUyLZ8N2XDg6QTI5L1gcPP5qX9nyhd4gjyVW0gHa
EYHN/MukG4h9ustXC++aRFzCixYawJ1AIxHZnjrt+DUBcvcXoh+XQIXAHO4lI85M
OhgrjhnC23msxA/PUP/NBeFYmGTYvyUhHgKTYpWWFK8BCJcjjsdWlwtx4p9S0nwC
O+kr8w7tzzmuhETBz4bm+Gty3u7DK0FdbVyoNyDy76q0Xr2aZQ/seXIe4zUAN5uf
86oj6+NyrUTlAtpiIMu0RdrpWvLxnPde3kMr/qzdd8OrB3s8Z/rJj12Rtod6qBmz
xtcoqWlftHH/BNEqdMiQCmHww0JYxw==
=Ify1
-----END PGP SIGNATURE-----


Björn Höfling wrote 7 years ago
(name . Rutger Helling)(address . rhelling@mykolab.com)
20180220235208.54ae3b81@alma-ubu
Hi Rutger,

On Fri, 16 Feb 2018 10:20:46 +0100
Rutger Helling <rhelling@mykolab.com> wrote:

Toggle quote (13 lines)
> Hello everyone,
>
> As promised I've updated these patches. Just to reiterate, these are
> David's patches. I've only changed a few things.
>
> Here's the changes of the top of my head:
> * First patch is unchanged.
> * Renamed to dolphin-emu instead of dolphin-emulator since that seems
> like a more canonical name.
> * Incorporated Björn's suggestions.
> * Added a few more inputs to get rid of more externals.
> * Enabled Qt interface.

Thanks for taking another iteration of this.

In my review of the first patch by David I stated that I haven't done a
full review. I just mentioned some points I noticed, not all possible
critics. I still haven't done a full review and found some more points.

As Dave said, this package bears some "friction": I'm still not
convinced of it. For me this doesn't feel like a sound, perfect
package. It is a collection of the emulators code plus binaries plus
reverse-engineered codes and notes plus external documentation.

I thought of quickly fixing it myself but I find it hard to
figure out what of the Data and the docs directory is really part of the
program (documentation) and what can safely be stripped away.

On the other hand there seams to be interest by at least 2-3 people to
make a package out of that and I wouldn't say it's not possible.

Here is what I found that should be stripped away:

/review/dolphin-emu-5.0-0.d04b179-checkout$ find . -name "*.rar" -or
-name "*.pdf" -or -name "*.bin" -or -name "*.pdf" -or -name "*.dsy" -or -name "*.jar" -or -name "*.exe"

./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10001.bin
./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10000.bin
./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10000_strip.bin
./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10001_strip.bin
./docs/WiiMote/Dumps/WiiMote_ServiceScan.bin
./docs/WiiMote/HID_SPEC_V10.rar
./docs/DSP/GC_DSP.pdf
./Installer/vcredist/vc_redist.x64.exe
./Source/Android/code-style-java.jar
./Source/Android/gradle/wrapper/gradle-wrapper.jar
./Data/Sys/Wii/shared2/wc24/nwc24dl.bin
./Data/Sys/Wii/shared2/wc24/misc.bin
./Data/Sys/Wii/shared2/wc24/nwc24fls.bin
./Data/Sys/Wii/shared2/wc24/nwc24fl.bin
./Data/Sys/GC/font_western.bin
./Data/Sys/GC/font_japanese.bin
./Data/Sys/totaldb.dsy
./Data/Sys/codehandler.bin


Yours,

Björn
Rutger Helling wrote 7 years ago
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)
20180221104852.77a2daa9@mykolab.com
Hi Björn,

Thanks for the review. I've added a phase to the patch that removes all
the file types that you mentioned entirely.

I think that the only files that are truly needed to work are
"Data/Sys/GC/font_{western,japanese}.bin". Thankfully these two
files can be built from the source code. I've done that in the
'remove-more-binaries&generate-fonts phase as well.

On Tue, 20 Feb 2018 23:52:08 +0100
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> wrote:

Toggle quote (67 lines)
> Hi Rutger,
>
> On Fri, 16 Feb 2018 10:20:46 +0100
> Rutger Helling <rhelling@mykolab.com> wrote:
>
> > Hello everyone,
> >
> > As promised I've updated these patches. Just to reiterate, these are
> > David's patches. I've only changed a few things.
> >
> > Here's the changes of the top of my head:
> > * First patch is unchanged.
> > * Renamed to dolphin-emu instead of dolphin-emulator since that
> > seems like a more canonical name.
> > * Incorporated Björn's suggestions.
> > * Added a few more inputs to get rid of more externals.
> > * Enabled Qt interface.
>
> Thanks for taking another iteration of this.
>
> In my review of the first patch by David I stated that I haven't done
> a full review. I just mentioned some points I noticed, not all
> possible critics. I still haven't done a full review and found some
> more points.
>
> As Dave said, this package bears some "friction": I'm still not
> convinced of it. For me this doesn't feel like a sound, perfect
> package. It is a collection of the emulators code plus binaries plus
> reverse-engineered codes and notes plus external documentation.
>
> I thought of quickly fixing it myself but I find it hard to
> figure out what of the Data and the docs directory is really part of
> the program (documentation) and what can safely be stripped away.
>
> On the other hand there seams to be interest by at least 2-3 people to
> make a package out of that and I wouldn't say it's not possible.
>
> Here is what I found that should be stripped away:
>
> /review/dolphin-emu-5.0-0.d04b179-checkout$ find . -name "*.rar" -or
> -name "*.pdf" -or -name "*.bin" -or -name "*.pdf" -or -name "*.dsy"
> -or -name "*.jar" -or -name "*.exe"
>
> ./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10001.bin
> ./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10000.bin
> ./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10000_strip.bin
> ./docs/WiiMote/Dumps/WiiMote_AttribTree_0x10001_strip.bin
> ./docs/WiiMote/Dumps/WiiMote_ServiceScan.bin
> ./docs/WiiMote/HID_SPEC_V10.rar
> ./docs/DSP/GC_DSP.pdf
> ./Installer/vcredist/vc_redist.x64.exe
> ./Source/Android/code-style-java.jar
> ./Source/Android/gradle/wrapper/gradle-wrapper.jar
> ./Data/Sys/Wii/shared2/wc24/nwc24dl.bin
> ./Data/Sys/Wii/shared2/wc24/misc.bin
> ./Data/Sys/Wii/shared2/wc24/nwc24fls.bin
> ./Data/Sys/Wii/shared2/wc24/nwc24fl.bin
> ./Data/Sys/GC/font_western.bin
> ./Data/Sys/GC/font_japanese.bin
> ./Data/Sys/totaldb.dsy
> ./Data/Sys/codehandler.bin
>
>
> Yours,
>
> Björn
>
From b09950c2847be7f17ea57906714f74a5ca2f671b Mon Sep 17 00:00:00 2001
From: David Thompson <davet@gnu.org>
Date: Wed, 7 Feb 2018 06:28:46 -0500
Subject: [PATCH 1/2] gnu: Add wxwidgets-gtk2-3.1.

* gnu/packages/wxwidgets.scm (wxwidgets-gtk2-3.1): New variable.
---
gnu/packages/wxwidgets.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 84446d8ef..9f7a87ca4 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -126,6 +126,14 @@ and many other languages.")
((#:configure-flags flags)
`(cons "--enable-mediactrl" ,flags))))))
+(define-public wxwidgets-gtk2-3.1
+ (package (inherit wxwidgets-3.1)
+ (inputs `(("gtk+" ,gtk+-2)
+ ,@(alist-delete
+ "gtk+"
+ (package-inputs wxwidgets-3.1))))
+ (name "wxwidgets-gtk2")))
+
(define-public python2-wxpython
(package
(name "python2-wxpython")
--
2.16.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEAVThuRzJ2e93ZI3n86cn20T8yjYFAlqNQIUACgkQ86cn20T8
yjaEIgf/WAzIZ4eLvs35Ui5tkQXtqHLtCcAqSrlvj0aW1uvV1rZIaEipw/UeYrcu
x8O061W8CFehuEzc4AKBjEQV7KZziDgLIvQu1KSZTg+fcfS7VIJUL59WRB8deXSa
wel2xZer8k1BgKbzfLRgkbVQ+gnKxCP15/0L+HzxbDk8dWFM9rhxItKqa7Pkj0OH
sD8BmaxdRCkGWFZjjcgJrppAzFB6bpGkOAkMwVX8bPQMBv6wV3NGt6n0C4njiiG3
JtegnV2ZegXfX0xgFUMxaeFdWHnJ73OHg/h7KZqbpUSM6RCJrL2lrW7ntzndmVaT
DE1TXOmz1pGuj/GJFTiOPZ4yBrxkbA==
=CVll
-----END PGP SIGNATURE-----


Marius Bakke wrote 7 years ago
(address . 30380@debbugs.gnu.org)
87d10ybcac.fsf@fastmail.com
Rutger Helling <rhelling@mykolab.com> writes:

Toggle quote (10 lines)
> Hi Björn,
>
> Thanks for the review. I've added a phase to the patch that removes all
> the file types that you mentioned entirely.
>
> I think that the only files that are truly needed to work are
> "Data/Sys/GC/font_{western,japanese}.bin". Thankfully these two
> files can be built from the source code. I've done that in the
> 'remove-more-binaries&generate-fonts phase as well.

Thanks! Can you delete the files in the source snippet instead?
Otherwise they will show up in `guix build --source`, which we cannot
allow for non-free files.

Somewhat unrelated, WDYT about creating a new (gnu packages emulators)
module?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlqNjgsACgkQoqBt8qM6
VPoUBwf8CBb1GMz8OvE7l4bLp8wkXHzWupEqJ0/RZW5+iQapdzN2SKwkGyNfGxXz
qcw+kSw1G/Tgv2UhXwSYVbmGQhcm1h0sfcDOQLnnp51mK+RZmRodF3nHFxRxKM3m
TizMJM00zIc/V8I9zIMyeLAEqg3YJazU1GPtSwyTe7nnuRkVJNFPza5RFQcV2yeR
LJIuZf85FQopG7TbPaODxd1fe/G2WFMykkB5SrIG+Gyd+wHXChfK6uSpZcHnyNr8
HJYF4ibRUWmVns+o8LUKtSxx1gGMTaqKRsC6G97IFOpwfA8mArZN3dXCl/nctEK+
qocTapUm564FifUagK6yLhoxcPbfXw==
=wiBW
-----END PGP SIGNATURE-----

Rutger Helling wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
20180221165548.35311188@mykolab.com
On Wed, 21 Feb 2018 16:19:39 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (17 lines)
> Rutger Helling <rhelling@mykolab.com> writes:
>
> > Hi Björn,
> >
> > Thanks for the review. I've added a phase to the patch that removes
> > all the file types that you mentioned entirely.
> >
> > I think that the only files that are truly needed to work are
> > "Data/Sys/GC/font_{western,japanese}.bin". Thankfully these two
> > files can be built from the source code. I've done that in the
> > 'remove-more-binaries&generate-fonts phase as well.
>
> Thanks! Can you delete the files in the source snippet instead?
> Otherwise they will show up in `guix build --source`, which we cannot
> allow for non-free files.
>

Will do!

Toggle quote (3 lines)
> Somewhat unrelated, WDYT about creating a new (gnu packages emulators)
> module?

Sounds good. Should I create the module and push dolphin-emu on it
to start?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEAVThuRzJ2e93ZI3n86cn20T8yjYFAlqNloQACgkQ86cn20T8
yja/FQf+LVlE5uY3Ee7yzmmMxkC2wFFO+VX7e6+h9W5Z3+Ji565IpuwNbWbNrRlQ
+w1MvXoQLACO3/T38V/60Dz4/pDo+bHBf+Fdhk3mfhrUF8drJD7AT2CW0ji9ndvM
8zu0qQMvtB6m5IDA7Apq+zXK2TPEI2+LjFHE11KqdzMt3FQDBFu0InrbXnOwbzau
snk9cUJuKnF6o9b6AxF01BGVHlGGK71nBKuHMXkBhYoIPhsu71s+vo1rdtof7EM0
6cRUPjyulLNqKtvsa5DvEUSRchvVCMoRmnWcYAp+OMcXLQc9vTuJrcFdZ1AwjA2t
tvrGoFsi0SenYAcj6kysQYHlLvFNVw==
=xdJQ
-----END PGP SIGNATURE-----


Leo Famulari wrote 7 years ago
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)
20180221163730.GA31667@jasmine.lan
On Tue, Feb 20, 2018 at 11:52:08PM +0100, Björn Höfling wrote:
Toggle quote (5 lines)
> Here is what I found that should be stripped away:
>
> /review/dolphin-emu-5.0-0.d04b179-checkout$ find . -name "*.rar" -or
> -name "*.pdf" -or -name "*.bin" -or -name "*.pdf" -or -name "*.dsy" -or -name "*.jar" -or -name "*.exe"

I didn't look at the file in question, but in general it's not necessary
to remove PDFs from Guix packages.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlqNoEYACgkQJkb6MLrK
fwij8w/9FJpBAEkVPLgeKVmG14idIzhQJCgQvOI+/BT7ljZQ3NyMc1wLzthiTGPU
47r/LoTYGa+pcQqY7mTB7JyzYKLaAWGYdDW9Xw3sL2ScFvVwjOEBRc5tYoEEXEHj
RNhpfAvXWZBtCbVMYetaLfU6HCHDn+fNqG17KKXTQpiJ9FehnEdndhTTy9JodaZY
a10+kW/nyEvgOekeKmEspuuPA+Nc/TZBRe1XZFfPFzsNfXhTg57kn5/Pbt3lG5LL
gi4ILzSyX/VcLhqqQNw2yAoGuB17T1FVH1exBWYS7S1fyndWaFXCnNzBHVJGSxos
oleekR6/g1TdEfzH8LfWjyBgl3FlScZ+lD2VmglIXQVqmfu/uEfSZXVCUGKxRL16
sRpZqPI7jmBx4wlFhEYoCX0qKQE7X7ZpA+D/Fkhyxe0KgXvxhF/5NxgyYaNa6Rpy
GvESIUG6xTI4a3FXHz3h6yK58RyDiD38l8CNj7tdEBtvh4hrByT1DSIu9Dd5ISt6
+GmVSMtC8e1AD8YCmk+F2YpAoWuVMOiHb3slImfyzrE+3WVLMD0QRD3XF+mXo/If
MeR3XIcTw3DEN0mVk1hUSm8EPgcQPcFKHWPbEbAZ/WfCfhY5/zOzk79EesPa0aOm
LRTHXoMjRXqrnQIwzBTn9XtxRIDYHXO89Fll9AOGMkQFmLzz7eM=
=thZ6
-----END PGP SIGNATURE-----


Björn Höfling wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)
20180221225541.4115b323@alma-ubu
On Wed, 21 Feb 2018 11:37:30 -0500
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (10 lines)
> On Tue, Feb 20, 2018 at 11:52:08PM +0100, Björn Höfling wrote:
> > Here is what I found that should be stripped away:
> >
> > /review/dolphin-emu-5.0-0.d04b179-checkout$ find . -name "*.rar" -or
> > -name "*.pdf" -or -name "*.bin" -or -name "*.pdf" -or -name "*.dsy"
> > -or -name "*.jar" -or -name "*.exe"
>
> I didn't look at the file in question, but in general it's not
> necessary to remove PDFs from Guix packages.

Ah, sorry, you are right. I was confused about all the findings:

./docs/WiiMote/HID_SPEC_V10.rar

This .rar contained just one PDF that is under proprietary copyright. It should
be snipped away.

./docs/DSP/GC_DSP.pdf

This is a reverse-engineered documentation of the GameCube DSP and is licensed
under "GNU Free Documentation License, Version 1.2 or any later version", so
a "licenses:fdl1.2+" should be added for this to the license list.

Björn
Rutger Helling wrote 7 years ago
(name . Björn Höfling)(address . bjoern.hoefling@bjoernhoefling.de)
20180222094633.5a599ed6@mykolab.com
I've added the license, moved deleting the files to the snippet (minus
the PDF) and pushed it under a new (gnu packages emulators) module.
I'll open a bug report later about moving the existing emulators over
from (gnu packages games) to (gnu packages emulators).

Thanks everyone!

On Wed, 21 Feb 2018 22:55:41 +0100
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> wrote:

Toggle quote (28 lines)
> On Wed, 21 Feb 2018 11:37:30 -0500
> Leo Famulari <leo@famulari.name> wrote:
>
> > On Tue, Feb 20, 2018 at 11:52:08PM +0100, Björn Höfling wrote:
> > > Here is what I found that should be stripped away:
> > >
> > > /review/dolphin-emu-5.0-0.d04b179-checkout$ find . -name "*.rar"
> > > -or -name "*.pdf" -or -name "*.bin" -or -name "*.pdf" -or -name
> > > "*.dsy" -or -name "*.jar" -or -name "*.exe"
> >
> > I didn't look at the file in question, but in general it's not
> > necessary to remove PDFs from Guix packages.
>
> Ah, sorry, you are right. I was confused about all the findings:
>
> ./docs/WiiMote/HID_SPEC_V10.rar
>
> This .rar contained just one PDF that is under proprietary copyright.
> It should be snipped away.
>
> ./docs/DSP/GC_DSP.pdf
>
> This is a reverse-engineered documentation of the GameCube DSP and is
> licensed under "GNU Free Documentation License, Version 1.2 or any
> later version", so a "licenses:fdl1.2+" should be added for this to
> the license list.
>
> Björn
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEAVThuRzJ2e93ZI3n86cn20T8yjYFAlqOg2oACgkQ86cn20T8
yjbrmgf/XJzaqBcYCZzMQLv3nqaAlx6xdjh4Q7K6ZH8ezsEI991kbPjZtqqxS1Ir
rQ9Z0wubKPsayx+sKilT+hlV3BazIFU/D98sUn78Hd51sEuFtzbq2UObKKA3jGUX
XTN+oVmnEJFvXrXM0+G/BD/1z4RWBax4ROVuUIZ/Zu8/eAvciICAYETBD2OU9qNN
kkUWWOZNKZ00DBCrTpOFUtsxJYSnHmdxxsOXGiKclHOcwe/O5d1Wl209BPGCY7JR
XlgsvmpQH7KzcKNT5ciozX+EqffXpOCqvrhnwOCu9nA4uiXtxcon5F504QwBmPhs
jSs0UqovEIrHYcHXFn+jouVPR+SLCw==
=pDeI
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30380@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30380
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help