Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/system/install.scm (agetty-default-service): Delete variable.
(beaglebone-black-installation-os): Do not specify tty.
(a20-olinuxino-lime-installation-os): Do not specify tty.
(a20-olinuxino-lime2-emmc-installation-os): Do not specify tty.
(a20-olinuxino-micro-installation-os): Do not specify tty.
(banana-pi-m2-ultra-installation-os): Do not specify tty.
(nintendo-nes-classic-edition-installation-os): Do not specify tty.
(embedded-installation-os): Move agetty-service instantiation to...
* gnu/services/base.scm (%base-services): ...here.
(default-serial-port): New variable.
(agetty-shepherd-service): Make tty optional, default to the above.
* doc/guix.texi (agetty-configuration): Update "tty" documentation.
---
doc/guix.texi | 15 +++++++++-
gnu/services/base.scm | 77 ++++++++++++++++++++++++++++++++++++++++----------
gnu/system/install.scm | 37 ++++++++----------------
3 files changed, 88 insertions(+), 41 deletions(-)
Toggle diff (236 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 2b27a675c..4e5d9e33f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -9621,7 +9621,20 @@ man page for more information.
@item @code{tty}
The name of the console this agetty runs on, as a string---e.g.,
-@code{"ttyS0"}. This argument is mandatory.
+@code{"ttyS0"}. This argument is optional, it will default to
+a reasonable default serial port used by Linux.
+
+For this, if there is a value for an option "agetty.tty" in the Linux
+command line, agetty will extract the device name of the serial port
+from it and use that.
+
+If not and if there is a value for an option "console" with a tty in
+the Linux command line, agetty will extract the device name of the
+serial port from it and use that.
+
+In both cases, agetty will leave the other serial device settings
+(baud rate etc) alone - in the hope that Linux pinned them to the
+correct values.
@item @code{baud-rate} (default: @code{#f})
A string containing a comma-separated list of one or more baud rates, in
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 8e30bcd34..8e740bf6c 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -817,7 +817,7 @@ the message of the day, among other things."
agetty-configuration?
(agetty agetty-configuration-agetty ;<package>
(default util-linux))
- (tty agetty-configuration-tty) ;string
+ (tty agetty-configuration-tty) ;string | #f
(term agetty-term ;string | #f
(default #f))
(baud-rate agetty-baud-rate ;string | #f
@@ -890,6 +890,42 @@ the message of the day, among other things."
;;; (default #f))
)
+(define (default-serial-port)
+ "Return a gexp that determines a reasonable default serial port
+to use as the tty. This is primarily useful for headless systems."
+ #~(begin
+ ;; console=device,options
+ ;; device: can be tty0, ttyS0, lp0, ttyUSB0 (serial).
+ ;; options: BBBBPNF. P n|o|e, N number of bits,
+ ;; F flow control (r RTS)
+ (use-modules (gnu build linux-boot))
+ (let* ((not-comma (char-set-complement (char-set #\,)))
+ (command (linux-command-line))
+ (agetty-specs (find-long-options "agetty.tty" command))
+ (console-specs (filter (lambda (spec)
+ (not (or
+ (string-prefix? "tty0" spec)
+ (string-prefix? "tty1" spec)
+ (string-prefix? "tty2" spec)
+ (string-prefix? "tty3" spec)
+ (string-prefix? "tty4" spec)
+ (string-prefix? "tty5" spec)
+ (string-prefix? "tty6" spec)
+ (string-prefix? "tty7" spec)
+ (string-prefix? "tty8" spec)
+ (string-prefix? "tty9" spec))))
+ (filter
+ (lambda (spec)
+ (string-prefix? "tty" spec))
+ (find-long-options "console" command))))
+ (specs (append agetty-specs console-specs))
+ (spec (if (null? specs)
+ #f
+ (car specs))))
+ (and spec
+ ;; Extract device name.
+ (car (string-tokenize spec not-comma))))))
+
(define agetty-shepherd-service
(match-lambda
(($ <agetty-configuration> agetty tty term baud-rate auto-login
@@ -901,7 +937,7 @@ the message of the day, among other things."
(list
(shepherd-service
(documentation "Run agetty on a tty.")
- (provision (list (symbol-append 'term- (string->symbol tty))))
+ (provision (list (symbol-append 'term- (string->symbol (or tty "auto")))))
;; Since the login prompt shows the host name, wait for the 'host-name'
;; service to be done. Also wait for udev essentially so that the tty
@@ -946,6 +982,9 @@ the message of the day, among other things."
('always "--local-line=always")
('never "-local-line=never")))
#~())
+ #$@(if tty
+ #~()
+ #~("--keep-baud"))
#$@(if extract-baud?
#~("--extract-baud")
#~())
@@ -1009,7 +1048,7 @@ the message of the day, among other things."
#$@(if login-pause?
#~("--login-pause")
#~())
- #$tty
+ #$(or tty (default-serial-port))
#$@(if baud-rate
#~(#$baud-rate)
#~())
@@ -1058,18 +1097,21 @@ the tty to run, among other things."
;; text is not lost in the middle of kernel messages (XXX).
(requirement '(user-processes host-name udev))
- (start #~(make-forkexec-constructor
- (list #$(file-append mingetty "/sbin/mingetty")
- "--noclear" #$tty
- #$@(if auto-login
- #~("--autologin" #$auto-login)
- #~())
- #$@(if login-program
- #~("--loginprog" #$login-program)
- #~())
- #$@(if login-pause?
- #~("--loginpause")
- #~()))))
+ (start #~(let ((tty #$(default-serial-port)))
+ (if tty
+ (make-forkexec-constructor
+ (list #$(file-append mingetty "/sbin/mingetty")
+ "--noclear" #$tty
+ #$@(if auto-login
+ #~("--autologin" #$auto-login)
+ #~())
+ #$@(if login-program
+ #~("--loginprog" #$login-program)
+ #~())
+ #$@(if login-pause?
+ #~("--loginpause")
+ #~())))
+ (const #f)))) ; never start.
(stop #~(make-kill-destructor)))))))
(define mingetty-service-type
@@ -2012,6 +2054,11 @@ This service is not part of @var{%base-services}."
(cons tty %default-console-font))
'("tty1" "tty2" "tty3" "tty4" "tty5" "tty6")))
+ (agetty-service (agetty-configuration
+ (extra-options '("-L")) ; no carrier detect
+ (term "vt100")
+ (tty #f))) ; automatic
+
(mingetty-service (mingetty-configuration
(tty "tty1")))
(mingetty-service (mingetty-configuration
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index e4b2e8237..db06b7a52 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -381,19 +381,10 @@ You have been warned. Thanks for being so brave.\x1b[0m
nvi ;:wq!
%base-packages))))
-(define* (agetty-default-service #:optional (tty "ttyS0"))
- "Return an agetty-service on the given TTY"
- (agetty-service (agetty-configuration
- (extra-options '("-L"))
- (baud-rate "115200")
- (term "vt100")
- (tty tty))))
-
-(define* (embedded-installation-os bootloader bootloader-target tty
+(define* (embedded-installation-os bootloader bootloader-target
#:key (extra-modules '()))
"Return an installation os for embedded systems.
The initrd gets the extra modules EXTRA-MODULES.
-A getty is provided on TTY.
The bootloader BOOTLOADER is installed to BOOTLOADER-TARGET."
(operating-system
(inherit installation-os)
@@ -404,43 +395,39 @@ The bootloader BOOTLOADER is installed to BOOTLOADER-TARGET."
(initrd (lambda (fs . rest)
(apply base-initrd fs
#:extra-modules extra-modules
- rest)))
- (services (cons* (agetty-default-service tty)
- (operating-system-user-services installation-os)))))
+ rest)))))
(define beaglebone-black-installation-os
(embedded-installation-os u-boot-beaglebone-black-bootloader
"/dev/sda"
- "ttyO0"
#:extra-modules
;; This module is required to mount the sd card.
'("omap_hsmmc")))
-
(define a20-olinuxino-lime-installation-os
(embedded-installation-os u-boot-a20-olinuxino-lime-bootloader
- "/dev/mmcblk0" ; SD card storage
- "ttyS0"))
+ ;; SD card storage
+ "/dev/mmcblk0"))
(define a20-olinuxino-lime2-emmc-installation-os
(embedded-installation-os u-boot-a20-olinuxino-lime2-bootloader
- "/dev/mmcblk1" ; eMMC storage
- "ttyS0"))
+ ;; eMMC storage
+ "/dev/mmcblk1"))
(define a20-olinuxino-micro-installation-os
(embedded-installation-os u-boot-a20-olinuxino-micro-bootloader
- "/dev/mmcblk0" ; SD card storage
- "ttyS0"))
+ ;; SD card storage
+ "/dev/mmcblk0"))
(define banana-pi-m2-ultra-installation-os
(embedded-installation-os u-boot-banana-pi-m2-ultra-bootloader
- "/dev/mmcblk1" ; eMMC storage
- "ttyS0"))
+ ;; eMMC storage
+ "/dev/mmcblk1"))
(define nintendo-nes-classic-edition-installation-os
(embedded-installation-os u-boot-nintendo-nes-classic-edition-bootloader
- "/dev/mmcblk0" ; SD card (solder it yourself)
- "ttyS0"))
+ ;; SD card storage (solder it yourself)
+ "/dev/mmcblk0"))
;; Return the default os here so 'guix system' can consume it directly.
installation-os