Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* build-aux/hydra/gnu-system.scm (qemu-jobs): Only build the "flash image"
on arm.
---
build-aux/hydra/gnu-system.scm | 28 ++++++++++++++++------------
1 file changed, 16 insertions(+), 12 deletions(-)
Toggle diff (50 lines)
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index c9aa59775..29e3268a2 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -162,29 +162,33 @@ system.")
(define MiB
(expt 2 20))
- (define (adjust-bootloader os)
- (if (member system %u-boot-systems)
- (operating-system (inherit os)
- (bootloader (bootloader-configuration
- (bootloader u-boot-bootloader)
- (target "/dev/null"))))
- os))
-
(if (member system %guixsd-supported-systems)
- (list (->job 'usb-image
+ (if (member system %u-boot-systems)
+ (list (->job 'flash-image
(run-with-store store
(mbegin %store-monad
(set-guile-for-build (default-guile))
- (system-disk-image (adjust-bootloader installation-os)
+ (system-disk-image
+ (operating-system (inherit os)
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-bootloader)
+ (target #f))))
+ #:disk-image-size
+ (* 1024 MiB))))))
+ (list (->job 'usb-image
+ (run-with-store store
+ (mbegin %store-monad
+ (set-guile-for-build (default-guile))
+ (system-disk-image installation-os
#:disk-image-size
(* 1024 MiB)))))
- (->job 'iso9660-image
+ (->job 'iso9660-image
(run-with-store store
(mbegin %store-monad
(set-guile-for-build (default-guile))
(system-disk-image installation-os
#:file-system-type
- "iso9660")))))
+ "iso9660"))))))
'()))
(define (system-test-jobs store system)