[PATCH] hydra: Only build the "flash image" on arm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180128231845.11006-1-dannym@scratchpost.org
* build-aux/hydra/gnu-system.scm (qemu-jobs): Only build the "flash image"
on arm.
---
build-aux/hydra/gnu-system.scm | 28 ++++++++++++++++------------
1 file changed, 16 insertions(+), 12 deletions(-)

Toggle diff (50 lines)
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index c9aa59775..29e3268a2 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -162,29 +162,33 @@ system.")
(define MiB
(expt 2 20))
- (define (adjust-bootloader os)
- (if (member system %u-boot-systems)
- (operating-system (inherit os)
- (bootloader (bootloader-configuration
- (bootloader u-boot-bootloader)
- (target "/dev/null"))))
- os))
-
(if (member system %guixsd-supported-systems)
- (list (->job 'usb-image
+ (if (member system %u-boot-systems)
+ (list (->job 'flash-image
(run-with-store store
(mbegin %store-monad
(set-guile-for-build (default-guile))
- (system-disk-image (adjust-bootloader installation-os)
+ (system-disk-image
+ (operating-system (inherit os)
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-bootloader)
+ (target #f))))
+ #:disk-image-size
+ (* 1024 MiB))))))
+ (list (->job 'usb-image
+ (run-with-store store
+ (mbegin %store-monad
+ (set-guile-for-build (default-guile))
+ (system-disk-image installation-os
#:disk-image-size
(* 1024 MiB)))))
- (->job 'iso9660-image
+ (->job 'iso9660-image
(run-with-store store
(mbegin %store-monad
(set-guile-for-build (default-guile))
(system-disk-image installation-os
#:file-system-type
- "iso9660")))))
+ "iso9660"))))))
'()))
(define (system-test-jobs store system)
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30278@debbugs.gnu.org)
87efm8n3r5.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> * build-aux/hydra/gnu-system.scm (qemu-jobs): Only build the "flash image"
> on arm.

Looks good. Please run “make hydra-jobs.scm” before pushing to make
sure that evaluation still works.

Thanks!

Ludo’.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20180129155749.64e7f859@scratchpost.org
close 30278
Danny Milosavljevic wrote 7 years ago
Re: [bug#30278] [PATCH] hydra: Only build the "flash image" on arm.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30278-done@debbugs.gnu.org)
20180129163113.5e9d2768@scratchpost.org
Hi Ludo,

On Mon, 29 Jan 2018 15:22:54 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (8 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > * build-aux/hydra/gnu-system.scm (qemu-jobs): Only build the "flash image"
> > on arm.
>
> Looks good. Please run “make hydra-jobs.scm” before pushing to make
> sure that evaluation still works.

Aha! Good idea.

Committed as 2a49a18e8b60a03d85b7ad8b02a3730fa003eb69.

Let's see what Hydra says...
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30278@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30278
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help