[PATCH] hydra: Add arm image builder.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180122235012.22981-1-dannym@scratchpost.org
* build-aux/hydra/gnu-system.scm (%u-boot-systems): New
variable.
(%guixsd-supported-systems): Add armhf-linux.
(qemu-jobs): Use u-boot if system in %u-boot-systems.
---
build-aux/hydra/gnu-system.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (46 lines)
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index 04845a3e1..c9aa59775 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -51,6 +51,7 @@
((guix scripts system) #:select (read-operating-system))
((guix scripts pack)
#:select (lookup-compressor self-contained-tarball))
+ (gnu bootloader u-boot)
(gnu packages)
(gnu packages gcc)
(gnu packages base)
@@ -135,7 +136,10 @@ SYSTEM."
"i686-w64-mingw32"))
(define %guixsd-supported-systems
- '("x86_64-linux" "i686-linux"))
+ '("x86_64-linux" "i686-linux" "armhf-linux"))
+
+(define %u-boot-systems
+ '("armhf-linux"))
(define (qemu-jobs store system)
"Return a list of jobs that build QEMU images for SYSTEM."
@@ -158,12 +162,20 @@ system.")
(define MiB
(expt 2 20))
+ (define (adjust-bootloader os)
+ (if (member system %u-boot-systems)
+ (operating-system (inherit os)
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-bootloader)
+ (target "/dev/null"))))
+ os))
+
(if (member system %guixsd-supported-systems)
(list (->job 'usb-image
(run-with-store store
(mbegin %store-monad
(set-guile-for-build (default-guile))
- (system-disk-image installation-os
+ (system-disk-image (adjust-bootloader installation-os)
#:disk-image-size
(* 1024 MiB)))))
(->job 'iso9660-image
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30220@debbugs.gnu.org)
87607ly51f.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (5 lines)
> * build-aux/hydra/gnu-system.scm (%u-boot-systems): New
> variable.
> (%guixsd-supported-systems): Add armhf-linux.
> (qemu-jobs): Use u-boot if system in %u-boot-systems.

LGTM, thanks!

Ludo'.
Danny Milosavljevic wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30220-done@debbugs.gnu.org)
20180129001229.26b5fe76@scratchpost.org
On Sun, 28 Jan 2018 23:47:24 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (9 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > * build-aux/hydra/gnu-system.scm (%u-boot-systems): New
> > variable.
> > (%guixsd-supported-systems): Add armhf-linux.
> > (qemu-jobs): Use u-boot if system in %u-boot-systems.
>
> LGTM, thanks!

Pushed as de2bc8d6da0ba4e74ed083af66a22cf96f74e67f.

I think the ISO image will be useless because mkrescue
doesn't support u-boot - and the u-boot config file will be
ignored by it, too.

It might make sense to make the ISO image conditional later...
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30220@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30220
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help