(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/linux.scm (curlftpfs): New variable.
---
gnu/packages/linux.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c33a8c2e5..efe5d90c9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
@@ -1833,6 +1834,41 @@ up: on the server side there's nothing to do; on the client side mounting the
file system is as easy as logging into the server with an SSH client.")
(license license:gpl2+)))
+(define-public curlftpfs
+ (package
+ (name "curlftpfs")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/curlftpfs/curlftpfs/" version
+ "/curlftpfs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n397hmv21jsr1j7zx3m21i7ryscdhkdsyqpvvns12q7qwwlgd2f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda _
+ ;; One of the 512-Byte block counts is definitely wrong.
+ ;; See <https://sourceforge.net/p/curlftpfs/bugs/73/>.
+ (substitute* "tests/ftpfs-ls_unittest.c"
+ (("4426192") "12814800"))
+ #t)))))
+ (inputs
+ `(("curl" ,curl)
+ ("glib" ,glib)
+ ("fuse", fuse)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://curlftpfs.sourceforge.net/")
+ (synopsis "Mount remote filesystems over FTP")
+ (description
+ "This is a file system client based on the FTP File Transfer Protocol.")
+ (license license:gpl2+)))
+
(define-public archivemount
(package
(name "archivemount")