[PATCH] gnu: Add curlftpfs.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 16 Jan 2018 11:08
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20180116100855.24353-1-dannym@scratchpost.org
* gnu/packages/linux.scm (curlftpfs): New variable.
---
gnu/packages/linux.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c33a8c2e5..efe5d90c9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
@@ -1833,6 +1834,41 @@ up: on the server side there's nothing to do; on the client side mounting the
file system is as easy as logging into the server with an SSH client.")
(license license:gpl2+)))
+(define-public curlftpfs
+ (package
+ (name "curlftpfs")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/curlftpfs/curlftpfs/" version
+ "/curlftpfs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n397hmv21jsr1j7zx3m21i7ryscdhkdsyqpvvns12q7qwwlgd2f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda _
+ ;; One of the 512-Byte block counts is definitely wrong.
+ ;; See <https://sourceforge.net/p/curlftpfs/bugs/73/>.
+ (substitute* "tests/ftpfs-ls_unittest.c"
+ (("4426192") "12814800"))
+ #t)))))
+ (inputs
+ `(("curl" ,curl)
+ ("glib" ,glib)
+ ("fuse", fuse)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://curlftpfs.sourceforge.net/")
+ (synopsis "Mount remote filesystems over FTP")
+ (description
+ "This is a file system client based on the FTP File Transfer Protocol.")
+ (license license:gpl2+)))
+
(define-public archivemount
(package
(name "archivemount")
L
L
Ludovic Courtès wrote on 16 Jan 2018 15:45
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 30136@debbugs.gnu.org)
87r2qp50ct.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (curlftpfs): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "Mount remote filesystems over FTP")

Rather “file system” (two words). :-)

Otherwise LGTM, thanks!

Ludo’.
M
M
Marius Bakke wrote on 16 Jan 2018 17:03
87lggxaizo.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (curlftpfs): New variable.

Maybe better suited in (gnu packages file-systems)? Linux.scm is
growing fast.

And for something completely off-topic: can you please configure your
mail client to wrap lines at <80 characters (typically 72)? Reading
your mails on a wide screen is tiring since I have to scan the whole
screen for every line, whereas with shorter lines I can read at least 2x
faster.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlpeIlsACgkQoqBt8qM6
VPq0ygf+NoEQRBb+B2kw228BB8cH9wtjUJp8f9JgarfZtoHKVYlDS7nw1llOB0jV
FyCwermhw4M1Ed8pcMIl3aUxw15mkBnAZuvFeEPmCn7pAfS5Fsqm2wKnPBlnHVT6
4hTyGg846beXsQzIiWkkxLNZ5ZxM54p080FOT5eOz2VEM5Vy2r/+IVXEWNBakSSK
sdmLvk5khW2PTxzW8iSzHYoDp+m/P73CscXR5YGUBB/oQufP4wulpYJYLvDoLhcf
hej+vkjyJk+91uwYcZko6oT7RuEFdPVrcjbl6b0ugMQ71alhLdjjEqsUV6gVQ5Nk
5gtZXqcAy9FMJoRBMivQqvTkO817jw==
=V1f6
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 16 Jan 2018 17:45
(no subject)
(address . control@debbugs.gnu.org)
20180116174557.0c58a914@scratchpost.org
close 30136
?
Your comment

This issue is archived.

To comment on this conversation send an email to 30136@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 30136
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch