(address . guix-patches@gnu.org)
Previously, python-libxml2 would inherit the ungrafted libxml2, missing
several patches on the libxml2 source code.
* gnu/packages/xml.scm (python-libxml2, python2-libxml2): Use
package/inherit.
---
gnu/packages/xml.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ce0d13a99..01a435344 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -159,7 +159,7 @@ project (but it is usable outside of the Gnome platform).")
"libxml2-CVE-2017-15412.patch")))))))
(define-public python-libxml2
- (package (inherit libxml2)
+ (package/inherit libxml2
(name "python-libxml2")
(build-system python-build-system)
(arguments
--
2.15.1