[PATCH] gnu: stellarium: Update to 0.17.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20180105210147.9825-1-kkebreau@posteo.net
* gnu/packages/astronomy.scm (stellarium): Update to 0.17.0.
[source]: Use new upstream URL.
[arguments]: Adjust #:test-target; add #:configure-flags to locate the
qtserialport header files and enable the building of tests.; remove
'patch-tests' phase.
---
gnu/packages/astronomy.scm | 37 +++++++++++++++++++------------------
1 file changed, 19 insertions(+), 18 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d21c09387..61197ccea 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -117,15 +117,16 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.16.0")
+ (version "0.17.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/"
- "Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Stellarium/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1krxj51lix096xbz64lys166a8zdwhill5vvs7dlxdn14amc8d98"))))
+ "0d6b3fs5aify7i1lwgkcickppnj73cbh24g8qschnfs3ypdf48fc"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -140,19 +141,19 @@ programs for the manipulation and analysis of astronomical data.")
("qtbase" ,qtbase) ; Qt MOC is needed at compile time
("qttools" ,qttools)))
(arguments
- `(#:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "src/tests/testStelSphereGeometry.cpp"
- (("Vec3d v[(]0[)]") "Vec3d v(0.0)"))
- #t))
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ `(#:test-target "test"
+ #:configure-flags (list "-DENABLE_TESTING=1"
+ (string-append
+ "-DCMAKE_CXX_FLAGS=-isystem "
+ (assoc-ref %build-inputs "qtserialport")
+ "/include/qt5"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ ;; make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp")
+ #t)))))
(home-page "http://www.stellarium.org/")
(synopsis "3D sky viewer")
(description "Stellarium is a planetarium. It shows a realistic sky in
--
2.15.1
Leo Famulari wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29997@debbugs.gnu.org)
20180105211252.GA23897@jasmine.lan
On Fri, Jan 05, 2018 at 04:01:47PM -0500, Kei Kebreau wrote:
Toggle quote (5 lines)
> * gnu/packages/astronomy.scm (stellarium): Update to 0.17.0.
> [source]: Use new upstream URL.
> [arguments]: Adjust #:test-target; add #:configure-flags to locate the
> qtserialport header files and enable the building of tests.; remove
> 'patch-tests' phase.
^
Typo here? --------------------------------------------------|

Otherwise LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlpP6lQACgkQJkb6MLrK
fwg6AhAAkg19bxgueSmB3DHJHniGM7OgFxZJcoEt+y6Ixg3z+N0+ZBBnM5IqrHTe
W9aL5ocGtSRhk0m6Hury07Gvrw5XEmjwS3WjFofwXwOyng8Hju7szQmYJfG6azzB
SPthYjYGt3HwyHb61HNnvDSaO2Slx59xFTnbkHycCciJ9LGQyZuJWKUc7FORTLEc
+vhg0uSkF9tHsXsh+c7Asv6Y3ir8q30l0P0uX2Dd6bMImCwKuQGfNJlpCNFpd6EY
1ElFF7hvq4M3oaZH2HP0eGVLsWcNYUbh6XNBN+apiasG3/v0GaVWu3PSEODsgI9z
rZqkBsXG+8LekI7VENkrpSppEkEc+JAgVcxPAYZXB9wz06pIXiA3c4C+V11w/f9x
L5M5rA/cuqAmlWjJ7Gm6848Ss3AlpBS0zLx26gj/ZwXJDQxhh8PAaAxR1N0WTlJp
QA/Y18Bdl1gdX1CcBV6nCg9mdqp8qlEma8rAc9gQCgDt0CTeNjVxKioDOO3MP95E
kEPeuX42UTg6N70o1dDplkj2V1nbGr2yPUsZ3/QWxpDXg0NMLjY+w4B12RgjmrC1
jMiHw+qnxWlI3hu4OAaqfK7hWEV/Lt88tRjxIbriQ6CJkKNW8vvFAj8raAjlP5hq
ODaNcMoshBFylmYiakbeqsPTs1QTRwCpTyAE+l+CmovMDHtu/MQ=
=hlPc
-----END PGP SIGNATURE-----


Kei Kebreau wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29997-done@debbugs.gnu.org)
87incfk92u.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (9 lines)
> On Fri, Jan 05, 2018 at 04:01:47PM -0500, Kei Kebreau wrote:
>> * gnu/packages/astronomy.scm (stellarium): Update to 0.17.0.
>> [source]: Use new upstream URL.
>> [arguments]: Adjust #:test-target; add #:configure-flags to locate the
>> qtserialport header files and enable the building of tests.; remove
>> 'patch-tests' phase.
> ^
> Typo here? --------------------------------------------------|

Indeed! I've pushed this without the typo.

Toggle quote (3 lines)
>
> Otherwise LGTM, thanks!

Thanks for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlpQNgkACgkQ5qXuPBlG
eg1xTQ//R5E7J4YbYRVm8+7CXl85LTKBpozhohx1IHtS8iM+igJsXvorphDLBb/0
CugkAl9TLk8K5xvVwd5707f36ANyODt3/yLybuDJZp5Q6IH5S7km3FEUXJf1xqDL
/r8Os6U4gnbDMCQTL+xVHX3ohIfV22/bf5YgcuwYMa11cav1tjYfS9FSQ0j4TB0n
ehvP9wdANE0b6dK9Dy3UjfWNQjPzJ8y8PWUcia1h7HEDrlEHMrJH54VjkQqw1xCH
Ioan0YgThaMH5Xts7pF4uD4Q48YCCvkXJupsujENv4DjBpB14yEyDQo8h6WJi7l+
0pnhqr9h1kilmGrFeMdMbHtd8gk0FX91dnLGIfwcUZzNXgTQXmsGLBpz3xRZ8Roe
HL2Cpi0lGLcVb52lFkpE0rbarpdTO1HyNy1wzre34G2E3tsYeT7A3BPtBM6WByqi
QpIL1TzW8IzvoH7lcqmwqkFyUDtCdz/Z6Hzat41F2MDKKreTbANaSCI06aRumiaB
W/1e4S3LtpA4I3hmifdxB7+tFZBR23CDSNMF8fP0i8kl1M2hBUK8TaDDipiN3n6U
Bh6FSTCY3cqhWqLDV8T2A0aIqtE8oDD3jGfxF3cC+hmR9EvGQo45pkfG9jaNLPIb
tgvBwn6/L8hD23e0JjLt0yabTR52+OZHP+UlDq+9WARPsuF1HQA=
=Lhla
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29997@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29997
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help