[PATCH 4/4] gnu: Add kurly.

  • Done
  • quality assurance status badge
Details
3 participants
  • Catonano
  • Leo Famulari
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 29 Dec 2017 21:52
(address . guix-patches@gnu.org)
e62093fba0a69df576bb06f6def4f94579371d04.1514580733.git.leo@famulari.name
* gnu/packages/curl.scm (kurly): New variable.
---
gnu/packages/curl.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 49703c092..4b40dda58 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -25,10 +25,13 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages groff)
#:use-module (gnu packages gsasl)
#:use-module (gnu packages libidn)
@@ -135,3 +138,31 @@ tunneling, and so on.")
(sha256
(base32
"0y3qbjjcxhcvm1yawp3spfssjbskv0g6gyzld6ckif5pf8ygvxpm"))))))
+
+(define-public kurly
+ (package
+ (name "kurly")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davidjpeacock/kurly.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1q192f457sjypgvwq7grrf8gq8w272p3zf1d5ppc20mriqm0mbc3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/davidjpeacock/kurly"))
+ (inputs
+ `(("go-github-com-alsm-ioprogress" ,go-github-com-alsm-ioprogress)
+ ("go-github-com-aki237-nscjar" ,go-github-com-aki237-nscjar)
+ ("go-github-com-davidjpeacock-cli" ,go-github-com-davidjpeacock-cli)))
+ (synopsis "Command-line HTTP client")
+ (description "kurly is an alternative to the widely popular curl
+program, written in Go. kurly is designed to operate in a similar
+manner to curl, with select features. Notably, kurly is not aiming for
+feature parity, but common flags and mechanisms particularly within the
+HTTP(S) realm are to be expected.")
+ (home-page "https://github.com/davidjpeacock/kurly")
+ (license license:asl2.0)))
--
2.15.1
C
C
Catonano wrote on 31 Dec 2017 09:07
(name . Leo Famulari)(address . leo@famulari.name)(address . 29898@debbugs.gnu.org)
CAJ98PDw5-HdyGify2BYCQU_PfcyYdO_gdWJ9KQK28wswxtmLnA@mail.gmail.com
Hi Leo !

I linted and built all your 4 patches. No errors.

If there's anything else you'd like me to try, let me know

LGTM ! ?


2017-12-29 21:52 GMT+01:00 Leo Famulari <leo@famulari.name>:

Toggle quote (64 lines)
> * gnu/packages/curl.scm (kurly): New variable.
> ---
> gnu/packages/curl.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
> index 49703c092..4b40dda58 100644
> --- a/gnu/packages/curl.scm
> +++ b/gnu/packages/curl.scm
> @@ -25,10 +25,13 @@
> #:use-module ((guix licenses) #:prefix license:)
> #:use-module (guix packages)
> #:use-module (guix download)
> + #:use-module (guix git-download)
> #:use-module (guix utils)
> #:use-module (guix build-system gnu)
> + #:use-module (guix build-system go)
> #:use-module (gnu packages)
> #:use-module (gnu packages compression)
> + #:use-module (gnu packages golang)
> #:use-module (gnu packages groff)
> #:use-module (gnu packages gsasl)
> #:use-module (gnu packages libidn)
> @@ -135,3 +138,31 @@ tunneling, and so on.")
> (sha256
> (base32
> "0y3qbjjcxhcvm1yawp3spfssjbskv0g6gyzld6ckif5pf8ygvxpm"))))))
> +
> +(define-public kurly
> + (package
> + (name "kurly")
> + (version "1.1.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/davidjpeacock/kurly.git")
> + (commit (string-append "v" version))))
> + (sha256
> + (base32
> + "1q192f457sjypgvwq7grrf8gq8w272
> p3zf1d5ppc20mriqm0mbc3"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/davidjpeacock/kurly"))
> + (inputs
> + `(("go-github-com-alsm-ioprogress" ,go-github-com-alsm-ioprogress)
> + ("go-github-com-aki237-nscjar" ,go-github-com-aki237-nscjar)
> + ("go-github-com-davidjpeacock-cli" ,go-github-com-davidjpeacock-
> cli)))
> + (synopsis "Command-line HTTP client")
> + (description "kurly is an alternative to the widely popular curl
> +program, written in Go. kurly is designed to operate in a similar
> +manner to curl, with select features. Notably, kurly is not aiming for
> +feature parity, but common flags and mechanisms particularly within the
> +HTTP(S) realm are to be expected.")
> + (home-page "https://github.com/davidjpeacock/kurly")
> + (license license:asl2.0)))
> --
> 2.15.1
>
>
>
>
>
Attachment: file
M
M
Marius Bakke wrote on 31 Dec 2017 15:38
87incnaron.fsf@fastmail.com
Leo Famulari <leo@famulari.name> writes:

Toggle quote (2 lines)
> * gnu/packages/curl.scm (kurly): New variable.

[...]

Toggle quote (2 lines)
> + (description "kurly is an alternative to the widely popular curl

The word "widely" is not adding anything here IMO :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlpI9lgACgkQoqBt8qM6
VPr7uwf/Vx+PAQSmMS9LR9UtVD5KH/B5XEleEX7zMZYrrbkAsp2SNNGzOPrOH1Tz
OUCpVnMNuGw5X9sI8Tzu6Cy7u5WWN72JfRLro4LCix69wRfzYylyBDqEe0MK8JY9
G8T170j2uYO6rB1v5rwR9hb8D+mwSmXRFo+HRaQs9wroHyicSdwZzlB9/QXC5fj6
uwPKBckPiuXAPQLQ6foy6eC38FWWy4iweY/QeLRfThAaZayXCJQgP7Cj2ykaIjHp
AiQatzytfhiDbX1J5Y9hQy2ngm9bSnGL40c4syk8vnPlTdIdJd94GwbWUtoNEXLy
I43FfTINuGA/FHr62LijVj1/2rMmHQ==
=IS+e
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 31 Dec 2017 18:37
(no subject)
(address . control@debbugs.gnu.org)
20171231173740.GA7222@jasmine.lan
close 29898
close 29899
close 29900
close 29901
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29898@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29898
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch