[PATCH core-updates] gnu: java-classpathx-servletapi: Update to 3.0-r1244.

  • Done
  • quality assurance status badge
Details
3 participants
  • Gábor Boskovits
  • Chris Marusich
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Gábor Boskovits
Severity
normal
G
G
Gábor Boskovits wrote on 29 Dec 2017 14:41
(address . guix-patches@gnu.org)(name . Gábor Boskovits)(address . boskovits@gmail.com)
20171229134104.6951-1-boskovits@gmail.com
* gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.
[source]: Change to svn-fetch from upstream. (This version is only available from there)
[arguments]: Switch to a java8 compiler, remove comment about not working with java8,
add phase chdir to compensate for the different layout of the upstream repository.

This version fixes java8 compilation by fixing a method signature which conflicts with
java8. Communication with upstream:

2017-12-18 9:38 GMT+01:00 Chris Burdess <dog@gnu.org>:
On 17/12/2017 20:53, Gábor Boskovits wrote:
Dear classpathx developers,

I discovered, that classpathx servletapi 3.0 does not compile with java8.
The problem is that java8 added a method to the Map interface:
boolean remove(Object,Object), which conflicts with
Object remove(Object,Object) method in:
source/javax/servlet/jsp/el/ImplicitObjectELResolver.java;
ImplicitObjectELResolver::ScopeMap::remove

how should we fix this problem?

It was a typo in the method signature. I've fixed it now.

Thank you very much!
---
gnu/packages/java.scm | 20 +++++++++-----------
1 file changed, 9 insertions(+), 11 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0be488dec..480d93c55 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,28 +2018,26 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0-r1244")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/classpathx/servletapi/"
- "servletapi-" version ".tar.gz"))
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "svn://svn.savannah.gnu.org/classpathx/trunk")
+ (revision 1244)))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07ihcwhm5awdr1wj28lqvcxhd6z72w427zbyxrqh42lgga74wsh3"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "servletapi") #t))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)
(zero? (apply system* `("ant" "dist" ,@make-flags))))))))
--
2.15.1
G
G
Gábor Boskovits wrote on 7 Jan 2018 23:11
[PATCH] gnu: java-classpathx-servletapi: Update to 3.0-r1244.
(address . 29891@debbugs.gnu.org)(name . Gábor Boskovits)(address . boskovits@gmail.com)
20180107221142.17118-1-boskovits@gmail.com
* gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.
[source]: Change to svn-fetch from upstream. (This version is only available from there)
[arguments]: Switch to a java8 compiler, remove comment about not working with java8,
add phase chdir to compensate for the different layout of the upstream repository.

This version fixes java8 compilation by fixing a method signature which conflicts with
java8. Communication with upstream:

2017-12-18 9:38 GMT+01:00 Chris Burdess <dog@gnu.org>:
On 17/12/2017 20:53, Gábor Boskovits wrote:
Dear classpathx developers,

I discovered, that classpathx servletapi 3.0 does not compile with java8.
The problem is that java8 added a method to the Map interface:
boolean remove(Object,Object), which conflicts with
Object remove(Object,Object) method in:
source/javax/servlet/jsp/el/ImplicitObjectELResolver.java;
ImplicitObjectELResolver::ScopeMap::remove

how should we fix this problem?

It was a typo in the method signature. I've fixed it now.

Thank you very much!
---
gnu/packages/java.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0be488dec..b2b4c254f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,28 +2018,27 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0-r1244")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/classpathx/servletapi/"
- "servletapi-" version ".tar.gz"))
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "svn://svn.savannah.gnu.org/classpathx/trunk")
+ (revision 1244)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07ihcwhm5awdr1wj28lqvcxhd6z72w427zbyxrqh42lgga74wsh3"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "servletapi") #t))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)
(zero? (apply system* `("ant" "dist" ,@make-flags))))))))
--
2.15.1
G
G
Gábor Boskovits wrote on 7 Jan 2018 23:13
(address . 29891@debbugs.gnu.org)
CAE4v=piF-D9LycaodpXTUJE=T+uyUenpVuT2qtL5rm+k1RTQeQ@mail.gmail.com
The second version of this patch provides a good file-name.

2018-01-07 23:11 GMT+01:00 Gábor Boskovits <boskovits@gmail.com>:

Toggle quote (83 lines)
> * gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.
> [source]: Change to svn-fetch from upstream. (This version is only
> available from there)
> [arguments]: Switch to a java8 compiler, remove comment about not working
> with java8,
> add phase chdir to compensate for the different layout of the upstream
> repository.
>
> This version fixes java8 compilation by fixing a method signature which
> conflicts with
> java8. Communication with upstream:
>
> 2017-12-18 9:38 GMT+01:00 Chris Burdess <dog@gnu.org>:
> On 17/12/2017 20:53, Gábor Boskovits wrote:
> Dear classpathx developers,
>
> I discovered, that classpathx servletapi 3.0 does not compile with java8.
> The problem is that java8 added a method to the Map interface:
> boolean remove(Object,Object), which conflicts with
> Object remove(Object,Object) method in:
> source/javax/servlet/jsp/el/ImplicitObjectELResolver.java;
> ImplicitObjectELResolver::ScopeMap::remove
>
> how should we fix this problem?
>
> It was a typo in the method signature. I've fixed it now.
>
> Thank you very much!
> ---
> gnu/packages/java.scm | 21 ++++++++++-----------
> 1 file changed, 10 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
> index 0be488dec..b2b4c254f 100644
> --- a/gnu/packages/java.scm
> +++ b/gnu/packages/java.scm
> @@ -2018,28 +2018,27 @@ debugging, etc.")
> (define-public java-classpathx-servletapi
> (package
> (name "java-classpathx-servletapi")
> - (version "3.0")
> + (version "3.0-r1244")
> (source (origin
> - (method url-fetch)
> - (uri (string-append "mirror://gnu/classpathx/servletapi/"
> - "servletapi-" version ".tar.gz"))
> + (method svn-fetch)
> + (uri (svn-reference
> + (url "svn://svn.savannah.gnu.org/classpathx/trunk")
> + (revision 1244)))
> + (file-name (string-append name "-" version "-checkout"))
> (sha256
> (base32
> - "0y9489pk4as9q6x300sk3ycc0psqfx
> cd4b0xvbmf3rhgli8q1kx3"))))
> + "07ihcwhm5awdr1wj28lqvcxhd6z72w
> 427zbyxrqh42lgga74wsh3"))))
> (build-system ant-build-system)
> (arguments
> `(#:tests? #f ; there is no test target
> #:build-target "compile"
> - ;; NOTE: This package does not build with Java 8 because of a type
> - ;; mismatch in
> - ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java".
> It
> - ;; defines the return value of ScopeMap's "remove" method to be of
> type
> - ;; "Object", whereas Map's "remove" method returns boolean.
> #:make-flags
> - (list "-Dbuild.compiler=javac1.7"
> + (list "-Dbuild.compiler=javac1.8"
> (string-append "-Ddist=" (assoc-ref %outputs "out")))
> #:phases
> (modify-phases %standard-phases
> + (add-after 'unpack 'chdir
> + (lambda _ (chdir "servletapi") #t))
> (replace 'install
> (lambda* (#:key make-flags #:allow-other-keys)
> (zero? (apply system* `("ant" "dist" ,@make-flags))))))))
> --
> 2.15.1
>
>
Attachment: file
C
C
Chris Marusich wrote on 9 Jan 2018 08:25
Re: [bug#29891] [PATCH] gnu: java-classpathx-servletapi: Update to 3.0-r1244.
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . 29891@debbugs.gnu.org)
87d12jh4td.fsf@gmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.

This seems correct to me. I also verified that this builds
reproducibly.

The commit message is a bit long; we could summarize it with a sentence
instead.

How difficult would it be to have upstream make a new release? It looks
like we're now using an arbitrary revision of their source code, instead
of a release. In general, I think it's better to use a release if we
can, since that implies the code has been more thoroughly tested etc.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlpUbl4ACgkQ3UCaFdgi
Rp100w/9EDZR0h4TwlIkfzwjT2kpH0tdy3qe36C+p1K1J6uzstdBgRxUR7lB3uKs
YRf4TyGYL2zPHe+hTGRqppVg+MbVih59pmyAZSslRocVGiZBxuzZh8pp1fnHn269
sEeXWv9KXtQD1+x65wWFLzBanV3CnxpqnW+ndoEbotT4oQ/wNRUeBHYhyvsS/pCc
VukACF96Br3qF0iK+p7j1HHDjKANZFz0mymAM19MR7Shrs5s7CjEqolLRrj988lP
O4TZc75NRdEtZeLEn2EsxqvUBmd1em2QDLS/gOyBtAoLwy4kUp3a1FRIY60konwC
rlKEssTv9vy0GKuCjKnsyVZIRWtpwdjsGQO/qsLVFyH5EoQHQzn0oQ2V/4+/pxNI
Np7aUBn3sWeeUkLuUlgDm/xorM9B9ei3u3Qs7CJUQrbQBPBISGw6H2DsOz6CJqsU
yAVUib4Shy1DGYE0V6neo2zrxi4NIhjM5YHStUYk3viFy9yZyGV7XHxp4E0mleJ4
7rbk7kAYFFbR/3EnhX3f8K94qkgke6D4Bn64Vxt6k1GcnT8JiCbTNfn9tdfl3NtL
NHfNl7Rq3n8XLkZNLByUsg6WG3crIXhI05OHTiFhKpN+sQa0b0dh8cvqPaNjqiSg
p4LPIW7lMm7WQix2k6EKjaeikrHZ9WN76dg+IPFXytET0YOXjAo=
=1sGM
-----END PGP SIGNATURE-----

G
G
Gábor Boskovits wrote on 9 Jan 2018 10:59
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 29891@debbugs.gnu.org)
CAE4v=ph00A4pB_M-vUy8xAUy01FDLsypgGqyBN4Hz-D2f-FDRQ@mail.gmail.com
Actually, I don't know. I've not asked for that. This is the only commit
since years. Maybe they are willing to make a new release.
I will ask them, and cc you.

2018-01-09 8:25 GMT+01:00 Chris Marusich <cmmarusich@gmail.com>:

Toggle quote (19 lines)
> Gábor Boskovits <boskovits@gmail.com> writes:
>
> > * gnu/packages/java.scm (java-classpathx-servletapi): Update to
> 3.0-r1244.
>
> This seems correct to me. I also verified that this builds
> reproducibly.
>
> The commit message is a bit long; we could summarize it with a sentence
> instead.
>
> How difficult would it be to have upstream make a new release? It looks
> like we're now using an arbitrary revision of their source code, instead
> of a release. In general, I think it's better to use a release if we
> can, since that implies the code has been more thoroughly tested etc.
>
> --
> Chris
>
Attachment: file
G
G
Gábor Boskovits wrote on 9 Jan 2018 11:55
[PATCH] gnu: java-classpathx-servletapi: Update to 3.0-r1244.
(address . 29891@debbugs.gnu.org)(name . Gábor Boskovits)(address . boskovits@gmail.com)
20180109105517.29578-1-boskovits@gmail.com
* gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.
[source]: Change to svn-fetch from upstream. (This version is only available from there)
[arguments]: Switch to a java8 compiler, remove comment about not working with java8,
add phase chdir to compensate for the different layout of the upstream repository.

Fixes:
Object ImplicitObjectELResolver::ScopeMap::remove(Object,Object) in
source/javax/servlet/jsp/el/ImplicitObjectELResolver.java
conflicts with boolean remove(Object,Object) of Map in java8.
---
gnu/packages/java.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8dd635605..8bd25d361 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,28 +2018,27 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0-r1244")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/classpathx/servletapi/"
- "servletapi-" version ".tar.gz"))
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "svn://svn.savannah.gnu.org/classpathx/trunk")
+ (revision 1244)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07ihcwhm5awdr1wj28lqvcxhd6z72w427zbyxrqh42lgga74wsh3"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "servletapi") #t))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)
(zero? (apply system* `("ant" "dist" ,@make-flags))))))))
--
2.15.1
G
G
Gábor Boskovits wrote on 9 Jan 2018 11:56
(address . 29891@debbugs.gnu.org)
CAE4v=phyc2osUtk5-+oHVeJ0+p3fo0FQ6oA+=-jyyBLg2OryOg@mail.gmail.com
Reworded commit message.

2018-01-09 11:55 GMT+01:00 Gábor Boskovits <boskovits@gmail.com>:

Toggle quote (67 lines)
> * gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.
> [source]: Change to svn-fetch from upstream. (This version is only
> available from there)
> [arguments]: Switch to a java8 compiler, remove comment about not working
> with java8,
> add phase chdir to compensate for the different layout of the upstream
> repository.
>
> Fixes:
> Object ImplicitObjectELResolver::ScopeMap::remove(Object,Object) in
> source/javax/servlet/jsp/el/ImplicitObjectELResolver.java
> conflicts with boolean remove(Object,Object) of Map in java8.
> ---
> gnu/packages/java.scm | 21 ++++++++++-----------
> 1 file changed, 10 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
> index 8dd635605..8bd25d361 100644
> --- a/gnu/packages/java.scm
> +++ b/gnu/packages/java.scm
> @@ -2018,28 +2018,27 @@ debugging, etc.")
> (define-public java-classpathx-servletapi
> (package
> (name "java-classpathx-servletapi")
> - (version "3.0")
> + (version "3.0-r1244")
> (source (origin
> - (method url-fetch)
> - (uri (string-append "mirror://gnu/classpathx/servletapi/"
> - "servletapi-" version ".tar.gz"))
> + (method svn-fetch)
> + (uri (svn-reference
> + (url "svn://svn.savannah.gnu.org/classpathx/trunk")
> + (revision 1244)))
> + (file-name (string-append name "-" version "-checkout"))
> (sha256
> (base32
> - "0y9489pk4as9q6x300sk3ycc0psqfx
> cd4b0xvbmf3rhgli8q1kx3"))))
> + "07ihcwhm5awdr1wj28lqvcxhd6z72w
> 427zbyxrqh42lgga74wsh3"))))
> (build-system ant-build-system)
> (arguments
> `(#:tests? #f ; there is no test target
> #:build-target "compile"
> - ;; NOTE: This package does not build with Java 8 because of a type
> - ;; mismatch in
> - ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java".
> It
> - ;; defines the return value of ScopeMap's "remove" method to be of
> type
> - ;; "Object", whereas Map's "remove" method returns boolean.
> #:make-flags
> - (list "-Dbuild.compiler=javac1.7"
> + (list "-Dbuild.compiler=javac1.8"
> (string-append "-Ddist=" (assoc-ref %outputs "out")))
> #:phases
> (modify-phases %standard-phases
> + (add-after 'unpack 'chdir
> + (lambda _ (chdir "servletapi") #t))
> (replace 'install
> (lambda* (#:key make-flags #:allow-other-keys)
> (zero? (apply system* `("ant" "dist" ,@make-flags))))))))
> --
> 2.15.1
>
>
Attachment: file
C
C
Chris Marusich wrote on 14 Jan 2018 03:25
Re: [bug#29891] [PATCH] gnu: java-classpathx-servletapi: Update to 3.0-r1244.
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . 29891@debbugs.gnu.org)
87wp0lb2hz.fsf@gmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (6 lines)
> Reworded commit message.
>
> 2018-01-09 11:55 GMT+01:00 Gábor Boskovits <boskovits@gmail.com>:
>
>> * gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0-r1244.

I wasn't able to apply this patch cleanly. I tried "git am" and also
the "patch" tool, but they didn't work. ("git am" did work using your
earlier patches, though.)

By the way, I see that Chris Burdess released a new minor version of
classpathx, which we can get from:


Could you attach one more patch that uses this release?

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlpav5gACgkQ3UCaFdgi
Rp2mQBAAjWk/XQ2eupVDB3j0Ho/3l9AtUHEjVuA7QUx9X1iZtrBifFxO2RIHwA7U
3RomNbsxgq08y9fx87OAoGPP5z4pRXY1rVvuMvqiS54j5L4uG34knEWbAjHKjxuv
A5zTph15uVyVWJzFt7MhPwskUwb6hnbAY2guelTHWDH6nKnyBDqLuQ+tdTxtBhjv
ipVF9sORq6k//fb0yAonzS5CHg2GbZV34D0yk1W2dp6UpcmAVVtz7ZYoQgRgPm4b
88eInG4peoNCQbmZONHxxNS2iMvNYhpUHL4VT74UX8BhYnQkXmMH8WSXcuUoPp8T
0SyO4JK7Ko/nWLQU24LJUbvyHN7Drdx+/30IvOa30DdmMeTfJ/xeR3iaQLcWqlKT
21Us1G2yIydrMxRuI+Di4j8rmoy8j1em8AGux2AIsF72/9kv8P0MkmfFAe/p7Ija
Ex7KaIeerS7dfn1JqtIpDXAsUDtIjWPUmN4f2TNy7sA+xMu2x4gTePWbFziBPza9
Mwhkw9nm330EwCFYWG7YP3eTNl2XEAgm49xQd/li2Peye3O8olqekbTPjgYYzIw9
9g5OF0hJ3T/pwF7iACjvoaE/kP5iGo43fi/33XWkeMeNK3dePs5Squ8p75Wu68+F
7+6x4lROgvLkSJ3niF97tNUdJZmHkzvl2uA52IP8RE20p4eoVNM=
=Qbx0
-----END PGP SIGNATURE-----

G
G
Gábor Boskovits wrote on 14 Jan 2018 10:07
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 29891@debbugs.gnu.org)
CAE4v=piG7uDZfDmfhvWGfOzqDHRrnkxAF7UCabxZYNkBfJZz-A@mail.gmail.com
Yes, I'm working on it.

2018-01-14 3:25 GMT+01:00 Chris Marusich <cmmarusich@gmail.com>:

Toggle quote (23 lines)
> Gábor Boskovits <boskovits@gmail.com> writes:
>
> > Reworded commit message.
> >
> > 2018-01-09 11:55 GMT+01:00 Gábor Boskovits <boskovits@gmail.com>:
> >
> >> * gnu/packages/java.scm (java-classpathx-servletapi): Update to
> 3.0-r1244.
>
> I wasn't able to apply this patch cleanly. I tried "git am" and also
> the "patch" tool, but they didn't work. ("git am" did work using your
> earlier patches, though.)
>
> By the way, I see that Chris Burdess released a new minor version of
> classpathx, which we can get from:
>
> https://ftp.gnu.org/gnu/classpathx/servletapi/servletapi-3.0.1.tar.gz
>
> Could you attach one more patch that uses this release?
>
> --
> Chris
>
Attachment: file
T
T
Tobias Geerinckx-Rice wrote on 14 Jan 2018 16:04
052c85c4-0370-35d3-17dd-66d5f2667592@tobias.gr
Gábor,

Gábor Boskovits wrote on 09/01/18 at 11:56:
Toggle quote (2 lines)
> Reworded commit message.

Sorry to be a drive-by nit-picker, but this commit message is still much
longer than needed:

Toggle quote (8 lines)
> 2018-01-09 11:55 GMT+01:00 Gábor Boskovits <boskovits@gmail.com
> <mailto:boskovits@gmail.com>>:
>
> * gnu/packages/java.scm (java-classpathx-servletapi): Update to
> 3.0-r1244.
> [source]: Change to svn-fetch from upstream. (This version is only
> available from there)

That parenthesis should be far more useful to future generations as a
comment in the code.

Toggle quote (3 lines)
> [arguments]: Switch to a java8 compiler, remove comment about not
> working with java8,

The first half implies the second: I'd not mention the comment.

Toggle quote (3 lines)
> add phase chdir to compensate for the different layout of the
> upstream repository.

Also very verbose (just “Add ‘chdir’ phase.”?) but OK :-)

Kind regards,

T G-R
G
G
Gábor Boskovits wrote on 14 Jan 2018 16:28
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 29891@debbugs.gnu.org)
CAE4v=piq-2Oyv1zJBmBczL6fvbTS6hLEnibC8BTgPkid=t4KmQ@mail.gmail.com
I will send an updated patch soon. Upstream released this fix as 3.0.1, so
it will be just update to 3.0.1.
I would add something like remove obsolate comment, and that will be all.
I'm a bit slow here, I had to run guix gc, so I have a lot to rebuild.
I will send an updated patch asap.

2018-01-14 16:04 GMT+01:00 Tobias Geerinckx-Rice <me@tobias.gr>:

Toggle quote (33 lines)
> Gábor,
>
> Gábor Boskovits wrote on 09/01/18 at 11:56:
> > Reworded commit message.
>
> Sorry to be a drive-by nit-picker, but this commit message is still much
> longer than needed:
>
> > 2018-01-09 11:55 GMT+01:00 Gábor Boskovits <boskovits@gmail.com
> > <mailto:boskovits@gmail.com>>:
> >
> > * gnu/packages/java.scm (java-classpathx-servletapi): Update to
> > 3.0-r1244.
> > [source]: Change to svn-fetch from upstream. (This version is only
> > available from there)
>
> That parenthesis should be far more useful to future generations as a
> comment in the code.
>
> > [arguments]: Switch to a java8 compiler, remove comment about not
> > working with java8,
>
> The first half implies the second: I'd not mention the comment.
>
> > add phase chdir to compensate for the different layout of the
> > upstream repository.
>
> Also very verbose (just “Add ‘chdir’ phase.”?) but OK :-)
>
> Kind regards,
>
> T G-R
>
Attachment: file
G
G
Gábor Boskovits wrote on 15 Jan 2018 09:27
[PATCH] gnu: java-classpathx-servletapi: Update to 3.0.1.
(address . 29891@debbugs.gnu.org)(name . Gábor Boskovits)(address . boskovits@gmail.com)
20180115082757.5801-1-boskovits@gmail.com
* gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0.1.
[arguments]: Switch to a java8 compiler, remove comment about not working with java8.
---
gnu/packages/java.scm | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c2888b552..8431ed44b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2019,25 +2019,20 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/classpathx/servletapi/"
"servletapi-" version ".tar.gz"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07d8h051siga2f33fra72hk12sbq1bxa4jifjg0qj0vfazjjff0x"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
--
2.15.1
C
C
Chris Marusich wrote on 16 Jan 2018 09:03
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . 29891-done@debbugs.gnu.org)
87h8rmjkm2.fsf@gmail.com
Gábor Boskovits <boskovits@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0.1.

Thank you for taking the time to update the patch. It looks good to me,
and I've committed it as ae307724de2957bbed6b763a1d039dba0876b5a7.

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlpdseUACgkQ3UCaFdgi
Rp2MlA//dxtAEvPYxbJwg3JfuOiaLaLcIEvqnjDOiRxBXhvkNh4VDz6X4IUutEf0
PmTf7tznc1AcZqOfT0kSktaPVBFD/GC6Ys842GdWCFc2coejws6STR4eAfW/hler
5V2q3nKcE7RWoQwAgpjkZnk6CnWsdKsxHriLN+wvdPS4RIiC6ZmC9yZW8mvBOi7k
U3YEjhw5TmY+Z81eOvQxiA0HhBgU7inY5UUbYhRKUB8+zoFb4nmU1/9BQsqIeyFl
h13yP/w/F1gaKfZOBBPRvs1QmTrxwkmcu0uzzkRHd58QTHah0sycCmasmmPlX1pk
XDLdslN1PU5S5gjeufihCcetmZW43VS5ANS8oYta09hU/7nhtsbtFhw6zChAhIR9
KuTfYOLZEo6zIcjBieervWBd0MPfO1YZ0Nz/wtZvCSfnXIu0RsPLtgPgluEpWwNn
w8iPeWhQ0PtiC/jBMqeoiADKJ2yUPClvWrzERk9CvUkO0QR5YhKNVBtk/AYpPo9b
g/bveg6dWPM91xnaHmD5uuJ6XcsKBGVlT8ORJhD3Ys9e7IoEzxokLpT621RppUrz
kZ/Gawm1xgjpuvczauYlYwHGZYaKaEt0zppk3Ug3CB74nhw3P80pBRKljFyFPBMY
u8s9pr3NSUsXJSbvyQAZbWxLvNV5ImlEJkEkBkWju+6UwZ1QRRs=
=zreS
-----END PGP SIGNATURE-----

Closed
?