[PATCH] gnu: gtk+: Enable broadway backend.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20171228230804.5854-1-dannym@scratchpost.org
* gnu/packages/gtk.scm (gtk+)[arguments]: Add "--enable-broadway-backend"
to #:configure-flags.
---
gnu/packages/gtk.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0424a0423..bfc298f6a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -712,7 +712,9 @@ application suites.")
;; by gnome-control-center
"--enable-wayland-backend"
;; This is necessary to build both backends.
- "--enable-x11-backend")
+ "--enable-x11-backend"
+ ;; This enables the HTML5 websocket backend.
+ "--enable-broadway-backend")
#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda _
Danny Milosavljevic wrote 7 years ago
Re: bug#29882: Acknowledgement ([PATCH] gnu: gtk+: Enable broadway backend.)
(address . 29882@debbugs.gnu.org)
20171229002555.71cdec9f@scratchpost.org
(for core-updates)
Marius Bakke wrote 7 years ago
Re: [bug#29882] [PATCH] gnu: gtk+: Enable broadway backend.
87shbsb0o9.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (19 lines)
> * gnu/packages/gtk.scm (gtk+)[arguments]: Add "--enable-broadway-backend"
> to #:configure-flags.
> ---
> gnu/packages/gtk.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 0424a0423..bfc298f6a 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -712,7 +712,9 @@ application suites.")
> ;; by gnome-control-center
> "--enable-wayland-backend"
> ;; This is necessary to build both backends.
> - "--enable-x11-backend")
> + "--enable-x11-backend"
> + ;; This enables the HTML5 websocket backend.
> + "--enable-broadway-backend")

How much does this add to the size of GTK+?

LGTM, assuming it's not a huge difference.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlpHyNYACgkQoqBt8qM6
VPo8jAf/dSu8yQWK1/SJiu3NmXD8xz9iKYO+NjEbcZnd9gTd/fqYX/OCNTX9piMt
RaLiUZ4CPyIRD0UwrXF0fD0DogGXziZHf99avOpPbKKcofjqj0fbd0sPEQrH/1HS
8kZxHtvDKhdujRYRf2KM8PrWFZdwbaj8N+6o6CKv1rdymq6x4P8zgrSQn9BzYIMf
OvCy9k5qM4KTxz/8PA9w2+PUEYaumyEXIBUOC6rSJkvSTdvT8QdCdk8zFkuMuT6U
e3Zx9LglBxKsl6Dp5pF14z2xtvKO5d4GfWty8Y560u1PzqQ4RFYpvyY8XWwUhOS2
CGg79jPS/KHfLwAgbne2ckBnvnsNMQ==
=Kpse
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 7 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 29882-done@debbugs.gnu.org)
20171230184627.0f34055f@scratchpost.org
Before:

$ du -ks ...
3796 /gnu/store/3yxrhf2r889x377m6xndgprh53hw8zhy-gtk+-3.22.21-bin
25004 /gnu/store/vfmx21jirz50vr0rnp6fpd5cnbfy0mdv-gtk+-3.22.21-doc
47784 /gnu/store/yawiwhnk61f934i7fn623ghhxavcihmx-gtk+-3.22.21

Afterwards:

$ du -ks ...
3928 /gnu/store/5lnnrsfk9cpf63s5ikq45dk9rlwdhj9f-gtk+-3.22.26-bin
25016 /gnu/store/8iwr4dh8ims0sm8vw22lahgzl4ixsn9l-gtk+-3.22.26-doc
48024 /gnu/store/5vz7n1psaab58259yxmra3aa4zc1d4am-gtk+-3.22.26

Applied as 150e230165901fb7e35f0e1d69bae0344f0ffe53 to core-updates.

Thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29882@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29882
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help