Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)
* gnu/packages/libusb.scm (python-hidapi, python2-hidapi): New variables.
---
gnu/packages/libusb.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 31c7dfa44..404ae8659 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -352,3 +352,40 @@ HID-Class devices.")
(license (list gpl3
bsd-3
(non-copyleft "file://LICENSE-orig.txt")))))
+
+(define-public python-hidapi
+ (package
+ (name "python-hidapi")
+ (version "0.7.99.post21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hidapi" version))
+ (sha256
+ (base32
+ "15ws59zdrxahf3k7z5rcrwc4jgv1307anif8ixm2cyb9ask1mgp0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-configuration
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("'/usr/include/libusb-1.0'")
+ (string-append "'" (assoc-ref inputs "libusb")
+ "/include/libusb-1.0'")))
+ #t)))))
+ (inputs
+ `(("libusb" ,libusb)
+ ("eudev" ,eudev)))
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (home-page "https://github.com/trezor/cython-hidapi")
+ (synopsis "Cython interface to hidapi")
+ (description "A Cython interface to the hidapi.")
+ ;; The library can be used under either of these licenses.
+ ;; TODO cython-hidapi DIY license.
+ (license (list gpl3 bsd-3))))
+
+(define-public python2-hidapi
+ (package-with-python2 python-hidapi))