[PATCH] gnu: Add Pioneer.

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Leo Famulari
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 7 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20171221234250.1635-1-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/games.scm (pioneer): New variable.
---
gnu/packages/games.scm | 57 +++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 56 insertions(+), 1 deletion(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c494d0beb..9a0ad161f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016 David Thompson <dthompson2@worcester.edu>
-;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
@@ -80,6 +80,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages imagemagick)
@@ -5185,3 +5186,57 @@ It includes support for 64 bit CPUs, custom music playback, a new sound driver,
some graphical niceities, and numerous bug-fixes and other improvements.")
(home-page "http://quakespasm.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public pioneer
+ (package
+ (name "pioneer")
+ (version "20171001")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pioneerspacesim/pioneer/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nxhx22swfqq6lfvcnpfm31wig3sjv5pp0rslj79nbxc7nyihh8m"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("assimp" ,assimp)
+ ("curl" ,curl)
+ ("freetype" ,freetype)
+ ("glu" ,glu)
+ ("libpng" ,libpng)
+ ("libsigc++" ,libsigc++)
+ ("libvorbis" ,libvorbis)
+ ("lua" ,lua-5.2) ;not compatible with 5.3
+ ("mesa" ,mesa)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image)))))
+ (arguments
+ `(#:tests? #f ;tests are broken
+ #:configure-flags (list "--with-external-liblua"
+ (string-append "PIONEER_DATA_DIR="
+ %output "/share/games/pioneer"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _ (zero? (system "./bootstrap"))))
+ (add-before 'bootstrap 'fix-lua-check
+ (lambda _
+ (substitute* "configure.ac"
+ (("lua5.2")
+ (string-append "lua-" ,(version-major+minor
+ (package-version lua-5.2))))))))))
+ (home-page "http://pioneerspacesim.net")
+ (synopsis "Game of lonely space adventure")
+ (description
+ "Pioneer is a space adventure game set in our galaxy at the turn of the
+31st century. The game is open-ended, and you are free to eke out whatever
+kind of space-faring existence you can think of. Look for fame or fortune by
+exploring the millions of star systems. Turn to a life of crime as a pirate,
+smuggler or bounty hunter. Forge and break alliances with the various
+factions fighting for power, freedom or self-determination. The universe is
+whatever you make of it.")
+ (license license:gpl3)))
--
2.15.0
Leo Famulari wrote 7 years ago
(address . ericbavier@centurylink.net)
20171226192002.GG1413@jasmine.lan
On Thu, Dec 21, 2017 at 05:42:50PM -0600, ericbavier@centurylink.net wrote:
Toggle quote (4 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/games.scm (pioneer): New variable.

Cool, I love this type of game :)

Toggle quote (6 lines)
> + (arguments
> + `(#:tests? #f ;tests are broken
> + #:configure-flags (list "--with-external-liblua"
> + (string-append "PIONEER_DATA_DIR="
> + %output "/share/games/pioneer"))

This is just for the game's "assets", right? That is, it doesn't need to
be written to for things like saving the game?

Toggle quote (4 lines)
> + #:phases (modify-phases %standard-phases
> + (add-before 'configure 'bootstrap
> + (lambda _ (zero? (system "./bootstrap"))))

Lately we have been doing these bootstrap phases directly after
unpacking:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlpCoOIACgkQJkb6MLrK
fwjprhAAqSmiMkH2q6htHqh1wOjapnTKaDrDjdl7G12NJdabhGpkal2HlGcsfdT4
7+rDtaot65jG0HUxKA2ou4bXD241507RFc8/f67H9FdzDlmnsxIX3j85u8ENB/Su
Fc3G/Z0P7ZWpu6SJvB8S/efkpLL1F8EkCGTD0Ri6do57/DsF/53LwhdgAY9P+zhW
mQWtheEQYEIBdNuv2Ro1KzIhyHUatEqw7bp2JZPnK1TmJzTTxqtKgn+MCYkwDklW
j4GVKlqFTnsrKGiYbNFf5BNJt0y1J3AFsoWhJphS7c3fmYYd4sWohxtJ9/xJVABS
PGC54Tqm9L4sdDEXbtb/t0XkWeE+JjM8JXRJhUJitpf+K0tdsnKCgUCirzLUx5Kq
toLoIxI2/20FaCi0PAAyOfqXACGP2IpgNp55ktQTL26lZJTO/irmP67WZXfrOQbf
4LFLfuKfuvPyeppdYWxrGYGvdhfqqcXfYdWN44bGa8N7CAc9mw+/EvDhMJpiYd7O
nTALg/BxyR4MGgGZkeXVeGbINR8pGjqi7tO0KytEXmx7K6noGgSNJoVE3dGcyody
+bfiot320dsjC88o9qccIV+50UzjnZr2Vk6wF56FP4DMSW6TS9FdzoByoT6vyaqo
xNcvPMqorIfrvqyYQXKG61dRjzTL/szkSWhEdPMzaSMbJgxACWs=
=fTr+
-----END PGP SIGNATURE-----


Eric Bavier wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29808-done@debbugs.gnu.org)
20171227082052.24e3ef1b@centurylink.net
On Tue, 26 Dec 2017 14:20:02 -0500
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (7 lines)
> On Thu, Dec 21, 2017 at 05:42:50PM -0600, ericbavier@centurylink.net wrote:
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > * gnu/packages/games.scm (pioneer): New variable.
>
> Cool, I love this type of game :)

Me too :)

Toggle quote (10 lines)
>
> > + (arguments
> > + `(#:tests? #f ;tests are broken
> > + #:configure-flags (list "--with-external-liblua"
> > + (string-append "PIONEER_DATA_DIR="
> > + %output "/share/games/pioneer"))
>
> This is just for the game's "assets", right? That is, it doesn't need to
> be written to for things like saving the game?

Right, afaict nothing is written there during gameplay.

Toggle quote (10 lines)
>
> > + #:phases (modify-phases %standard-phases
> > + (add-before 'configure 'bootstrap
> > + (lambda _ (zero? (system "./bootstrap"))))
>
> Lately we have been doing these bootstrap phases directly after
> unpacking:
>
> https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00101.html

Good catch. Thanks.

Fixed and pushed in aac1aa75f4fede7db9fb5be1af344c985fd526f4

`~Eric
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoMXjUi7471xkzbfw/XPKxxnTJWYFAlpDrEQACgkQ/XPKxxnT
JWYY7A//SwPV9dAIqMQLHe9PjWoFtEaKLNbuBdXZxKyhOs4qsrPtonygrsLr5xlf
jIpImmtBa1re8IbG4IeLj3F41RFb9E1P6FMuXwnX7Py0uJDMUIELmcRdhZrdOzeo
ZBIIr0Wb52ODcxAFdJdAclhzS759D5qher5ITK/ZzNyp5db89lGCa54PwJxrj8Jd
VKsjE6bovE3tPJG/LPlWgY7sSKbyRPvbuAFHMCDV6dOgCYotHAa6CO+Q6SwhRdN+
1D3FxbZ9uuAeNFMVanLy5O0Qcfw0G4jSzHFl4wpyf7Z4JjR/P6HwDU6jdjMqT5KC
AZ/gIHLRAjnEhBJtfnziYSo9imJ00AratQk03UrXCnTAKfMWAqk57JC+h41PqiW4
QPZCJ8RtI3YhV+w5ByP8aeXS9/XPKlu9mFoij8O8RGbW/LvL9AEFAnEPLfsTYaJD
wlWYl3nLTAZwpuBKip1BpwOj8poiaFOVWj3vh7aOsJtXVJh5HQP+mkvCqZBm3K2f
uMbqZJQC3td7mIwIecCCVtpCb+3QrJsXvOM/5TP2AQygLqgS65BseTteuFaeb/At
rrWwjeAwmOKgzSiX/d7Exxev+A1LjDIHuqOohnAEqBWRhXvINrtF7CydrFKYP0XD
UD24Qaa3BV42StafwSTip5iA+SYF+mmIBUoZnkp3LeQxHpazntI=
=JAba
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29808@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29808
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help