[PATCH] gnu: Add meandmyshadow.

  • Done
  • quality assurance status badge
Details
2 participants
  • Eric Bavier
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal

Debbugs page

Ricardo Wurmus wrote 7 years ago
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
20171221152254.3293-1-rekado@elephly.net
* gnu/packages/games.scm (meandmyshadow): New variable.
---
gnu/packages/games.scm | 50 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c494d0beb..2b1bddb2f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -354,6 +354,56 @@ played. Freedoom complements the Doom engine with free levels, artwork, sound
effects and music to make a completely free game.")
(license license:bsd-3)))
+(define-public meandmyshadow
+ (package
+ (name "meandmyshadow")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/meandmyshadow/"
+ version "/meandmyshadow-" version
+ "-src.tar.gz"))
+ (sha256
+ (base32
+ "1dpb7s32b2psj5w3nr5kqibib8nndi86mw8gxp4hmxwrfiisf86d"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-sdl'paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cmake/Modules/FindSDL_gfx.cmake"
+ (("/usr/local/include/SDL")
+ (string-append (assoc-ref inputs "sdl")
+ "/include/SDL")))
+ ;; Because SDL provides lib/libX11.so.6 we need to explicitly
+ ;; link with libX11, even though we're using the GL backend.
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{X11_LIBRARIES\\}") "-lX11"))
+ )))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl
+ sdl-image
+ sdl-gfx
+ sdl-mixer
+ sdl-ttf)))
+ ("libx11" ,libx11) ; needed by sdl's libX11
+ ("libarchive" ,libarchive)
+ ("openssl" ,openssl)
+ ("mesa" ,mesa)
+ ("glu" ,glu)
+ ("curl" ,curl)))
+ (home-page "http://meandmyshadow.sourceforge.net/")
+ (synopsis "Puzzle/platform game")
+ (description "Me and My Shadow is a puzzle/platform game in which you try
+to reach the exit by solving puzzles. Spikes, moving blocks, fragile blocks
+and much more stand between you and the exit. Record your moves and let your
+shadow mimic them to reach blocks you couldn't reach alone.")
+ (license license:gpl3+)))
+
(define-public knights
(package
(name "knights")
--
2.15.0
Eric Bavier wrote 7 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 29800@debbugs.gnu.org)
20171221060322.576d0105@centurylink.net
On Thu, 21 Dec 2017 16:22:54 +0100
Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (2 lines)
> * gnu/packages/games.scm (meandmyshadow): New variable.

Fun game. Looks good, builds and runs fine by me.

`~Eric
Ricardo Wurmus wrote 7 years ago
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 29800-done@debbugs.gnu.org)
87tvwjw8pd.fsf@elephly.net
Eric Bavier <ericbavier@centurylink.net> writes:

Toggle quote (7 lines)
> On Thu, 21 Dec 2017 16:22:54 +0100
> Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> * gnu/packages/games.scm (meandmyshadow): New variable.
>
> Fun game. Looks good, builds and runs fine by me.

Thanks for checking!

Pushed to master with commit 5145001a1.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29800@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29800
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help