[PATCH] gnu: Add qjackrcd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal

Debbugs page

Ricardo Wurmus wrote 7 years ago
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
20171216224312.11239-1-rekado@elephly.net
* gnu/packages/audio.scm (qjackrcd): New variable.
---
gnu/packages/audio.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 81ea1b136..b13c2f4d3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1993,6 +1993,38 @@ and ALSA.")
into various outputs and to start, stop and configure jackd")
(license license:gpl2+)))
+(define-public qjackrcd
+ (package
+ (name "qjackrcd")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/qjackrcd/stable/"
+ "qjackrcd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xpnhzbwg5c60n5dhwln5p7qm191nvmf23la88zxfqx1jv0mmxxb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out")))))))))
+ (native-inputs
+ `(("qtbase" ,qtbase))) ; for qmake
+ (inputs
+ `(("jack" ,jack-1)
+ ("libsndfile" ,libsndfile)
+ ("qtbase" ,qtbase)))
+ (home-page "https://sourceforge.net/projects/qjackrcd/")
+ (synopsis "Stereo audio recorder for JACK")
+ (description "QJackRcd is a simple graphical stereo recorder for JACK
+supporting silence processing for automatic pause, file splitting, and
+background file post-processing.")
+ (license license:gpl2+)))
(define-public raul
(package
--
2.15.0
Ludovic Courtès wrote 7 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 29744@debbugs.gnu.org)
87tvwouzjb.fsf@gnu.org
Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (qjackrcd): New variable.

LGTM!
Ricardo Wurmus wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29744-done@debbugs.gnu.org)
87ind4l1fv.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> * gnu/packages/audio.scm (qjackrcd): New variable.
>
> LGTM!

Thanks. Pushed to master.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29744@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29744
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help