[PATCH] gnu: Add mod-wsgi.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171216202911.25810-1-mail@cbaines.net
* gnu/packages/web.scm (mod-wsgi): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eb0436cb3..9cda0f3e0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -145,6 +145,37 @@ and its related documentation.")
(license l:asl2.0)
(home-page "https://httpd.apache.org/")))
+(define-public mod-wsgi
+ (package
+ (name "mod-wsgi")
+ (version "4.5.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/GrahamDumpleton/mod_wsgi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0n1yhmrfp8mjbsngmyjl937c6rc0069p6wdi1lknrbn1q42hzw6q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; TODO: Can't figure out if there are tests
+ #:make-flags (list
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "LIBEXECDIR=/modules")))
+ (inputs
+ `(("httpd" ,httpd)
+ ("python" ,python-wrapper)))
+ (synopsis "Apache module for applications using the Python WSGI
+specification")
+ (description
+ "The mod_wsgi module for the Apache @acronym{HTTP, HyperText Transfer
+Protocol} Server adds support for running applications that support the Python
+@acronym{WSGI, Web Server Gateway Interface} specification.")
+ (license l:asl2.0)
+ (home-page "https://modwsgi.readthedocs.io/")))
+
(define-public nginx
(package
(name "nginx")
--
2.14.1
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 29742@debbugs.gnu.org)
87h8spbab0.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (mod-wsgi): New variable.

[...]

Toggle quote (3 lines)
> + (arguments
> + '(#:tests? #f ;; TODO: Can't figure out if there are tests

That’s OK at a first stab at least. :-)

Toggle quote (3 lines)
> + (synopsis "Apache module for applications using the Python WSGI
> +specification")

s/Apache/Apache httpd/

and maybe “for …” → “for Python WSGI applications”

Toggle quote (4 lines)
> + (description
> + "The mod_wsgi module for the Apache @acronym{HTTP, HyperText Transfer
> +Protocol} Server adds support for running applications that support the Python

I’d just write “for Apache httpd”.

Otherwise LGTM, thanks!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29742-done@debbugs.gnu.org)
87mv2ht6oj.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (26 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/web.scm (mod-wsgi): New variable.
>
> [...]
>
>> + (arguments
>> + '(#:tests? #f ;; TODO: Can't figure out if there are tests
>
> That’s OK at a first stab at least. :-)
>
>> + (synopsis "Apache module for applications using the Python WSGI
>> +specification")
>
> s/Apache/Apache httpd/
>
> and maybe “for …” → “for Python WSGI applications”
>
>> + (description
>> + "The mod_wsgi module for the Apache @acronym{HTTP, HyperText Transfer
>> +Protocol} Server adds support for running applications that support the Python
>
> I’d just write “for Apache httpd”.
>
> Otherwise LGTM, thanks!

Great, I've made these changes and pushed. Thanks for reviewing :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlo22exfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcSqxAAjBHdFqdcpE4D50ZYmB68PrWwu+p2WyHdEKD+onMlPMllJ6AoWRKGs/4T
9vPsnKr+jgmyRhVQV1hz0Tn2q7sGiqAVXxko+IfB3D+SvLbjN2iDC2dFw7sfP7fR
t5eAdXbyfh3F71fqRJdp5+ikHjrBUO2Bvsp7WonU7UwcXPhUo7Mj4vstwtTh+GKG
1WVFipdTBh66RxoigDfAd5UCQSJKii8vjbaLnPyDUK0pTsA5DsYnS4zsn63IqUFS
I0P0wnc8yldZMrY1ZC1efJL08TUrHuFyJJ4XQW+NhxaWyd8bnkuhGM720+nXaHUI
qcUd+KuPyTM2RJm2NXs6oHKc5sw69F7KHb+PwbaWOrVNar/P79m7Ph/eStIr6XVZ
CqV2VClV8QWEPOtOf8qR06JjTk+usmG6knySQ/kwz6fEVTu34VFgjiWoeLOtyrmO
2K16eENIZwERxcR9dv/N8OwTam1Z/qJlR3glAo14enNQ6VXNGzdelpEhO9J2wTgE
d7byAac3rNw8+kqDet98xgrYoB6CC/vpvtMMvnMGu/axqeNxCDq12w7oKD5ncIez
TBCI/zJFpjvPdPWepbStK7Gmn1O10uCZ8QlS84R+JYyFm1s5Vms4ho5wR1YCOPhc
o+v+g1baf7EdAEoG3yVl1W54NlSXvai0Tgxvs7hwHHNTStY/2Mc=
=8RrV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29742@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29742
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help