[PATCH] gnu: system: vm: Use loose cache for 9p file system.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171216192018.19417-1-mail@cbaines.net
This improves the performance of the shared store for operations involving
lots of files, e.g. searching through the store.

* gnu/system/vm.scm (mapping->file-system): Add cache=loose to options.
---
gnu/system/vm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 6102d465b..c1305d3f9 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -554,7 +554,7 @@ of the GNU system as described by OS."
(device (file-system->mount-tag source))
(type "9p")
(flags (if writable? '() '(read-only)))
- (options (string-append "trans=virtio"))
+ (options "trans=virtio,cache=loose")
(check? #f)
(create-mount-point? #t)))))
--
2.15.1
Leo Famulari wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 29740@debbugs.gnu.org)
20171216202514.GA21263@jasmine.lan
On Sat, Dec 16, 2017 at 07:20:18PM +0000, Christopher Baines wrote:
Toggle quote (5 lines)
> This improves the performance of the shared store for operations involving
> lots of files, e.g. searching through the store.
>
> * gnu/system/vm.scm (mapping->file-system): Add cache=loose to options.

Okay!

Toggle quote (11 lines)
> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
> index 6102d465b..c1305d3f9 100644
> --- a/gnu/system/vm.scm
> +++ b/gnu/system/vm.scm
> @@ -554,7 +554,7 @@ of the GNU system as described by OS."
> (device (file-system->mount-tag source))
> (type "9p")
> (flags (if writable? '() '(read-only)))
> - (options (string-append "trans=virtio"))
> + (options "trans=virtio,cache=loose")

Was that string-append unnecessary in this context?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlo1gSMACgkQJkb6MLrK
fwhHyQ/+LaFaCOBtlzLjj6cynzsx0YH1xQtwvfjSBB3EvQSS8fOreJ3EbIy5Xt2q
0X8vrco7Ae9UzSJxlnn6UjlGA0wT6tXcye5eZ2ZPQcKQ6/mD55fYAomWzsX5gM/0
XHEP//gDWcr0n5NolQyqGtgz1pEqlxNyiLo/xCJqZ6oylPxUxpPB0E4b7r9pB4sZ
s5Rztb910/wc1Nk5n6NIx0uLqhOE5SwcGaHFsXa5d2mzs1VLzwvcxBDJio+V0oKK
Mh4YqhUVCCvqdDkQRoRk/9DdzIuwr/sGUu2LLCgi/pW4+EoetIl3A7opNy4GbU0E
2XrGnj8FdbmuR6M26DyvQufiOQWpqo8wjUXuYNXEOKXRgGG0fG0ndzxxpDRFaMAd
gMXytzJZaGK0KcA6JpUNep6/KtAM84/YQJRFS1HZk3+S+i1ylIHCUZrkQ2NoSBj9
KBUuMKJhJWos43Hg1BFAZ5JM2gAyCED5i4viL8AdwrCuenjaMkrKbDI4ax1ZPhUU
YLzd4UUoiqKlJ+9Zg/0ppWefylLg9UsAd1y58V19N9XvGv/fV+dMT/jReDAAuiR/
QxQaMKn+PI0/0pEgDz5rxWb/9GyhvwNMsNk4xtMDbm6GT8hi6XseVjioYR8KIoR0
kcSoP/mCRdMMESCC/hKq7RxyQDAenU77w5neREX0LJXSEyC9kNc=
=zfhv
-----END PGP SIGNATURE-----


Christopher Baines wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29740@debbugs.gnu.org)
87shca5qh7.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (21 lines)
> On Sat, Dec 16, 2017 at 07:20:18PM +0000, Christopher Baines wrote:
>> This improves the performance of the shared store for operations involving
>> lots of files, e.g. searching through the store.
>>
>> * gnu/system/vm.scm (mapping->file-system): Add cache=loose to options.
>
> Okay!
>
>> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
>> index 6102d465b..c1305d3f9 100644
>> --- a/gnu/system/vm.scm
>> +++ b/gnu/system/vm.scm
>> @@ -554,7 +554,7 @@ of the GNU system as described by OS."
>> (device (file-system->mount-tag source))
>> (type "9p")
>> (flags (if writable? '() '(read-only)))
>> - (options (string-append "trans=virtio"))
>> + (options "trans=virtio,cache=loose")
>
> Was that string-append unnecessary in this context?

I think so. It has always been like this I think, and I haven't had any
problems with this change.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlo1i7RfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xemaw/+Pt6ijyD/UpfF3cB5qQYQiZEdnYv51xWE4Xw8mhb3dTs1IdDXdW0SY73J
YzWNf7vtbOzvp7EIyQqGjPAW1mBsps+NRoS0pNEtcHagYMHb/szZo4c9OXFpD/TT
1M3gXq0z+n8IIVxwEHmxRF5+ALupnWsGDgDh7CVfvekdctBKNYrP6XwZShc3Taye
izvG5xjvPOiRrAtsuZ7mtAZ1INy/MIJGft8zCFK1jvCIgee+xfhwhYQxogRNIsTw
0VQk0WsZ149MdPrKnhIXwwdkaqAjXWZkau/gyQnGk/sbH9CiFOsZymtgrTtPbKao
mkEq9lknQUXn2p3nN+/rLfQSk85wLwacN1DC4Rlw8QpEvK6uTM2XaP2XOoaEq8YP
6HxqrvJFxKQdIC0PKtURnKIINGlKIvlvdM84XeuFaKdC9cnIRDe6m6vmjIuLCDRf
IYDb6T+wIpKWRMLktcy6ET4M8KC4n1gWUjGAADbrJ3Ot3aYtcLlmXYnhyR+kso7W
LxOaT50JqKFaImoHRW+rjSuZYlqx/UtlykAepizYe8RXpA66izfULI932aSNU3Kz
AJ9aF11JnwAy+81gSvY7Lcg8onZTvRrMyHHo7drMAGgwxET4MHXesqNqXvvIUiEZ
Ahu7DWgetUlU4CWStjXysNy2isd6oLQHinWpyKWhk+JYCaw/tgU=
=EcfB
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 29740@debbugs.gnu.org)
87lgi1baha.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> This improves the performance of the shared store for operations involving
> lots of files, e.g. searching through the store.
>
> * gnu/system/vm.scm (mapping->file-system): Add cache=loose to options.

That’s a good idea, thank you!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29740@debbugs.gnu.org)
87po7dt6t0.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This improves the performance of the shared store for operations involving
>> lots of files, e.g. searching through the store.
>>
>> * gnu/system/vm.scm (mapping->file-system): Add cache=loose to options.
>
> That’s a good idea, thank you!

I've now pushed this patch. Thanks for reviewing :)

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlo22UtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfUkA//V37XZHW72U9uMLpxD4cv6nJKeMKD/z1cNcsKD4ZVzyd0jYNMCB/OD+w2
aL7P+Q1MXSuSNd+2netS+ZRzZudUFhzIGYQlfaIhUCAMEqB71xggma7LgHIl+CNw
gKSSkLcD/h8ph+7S0ravDhrlTD8pFAPrNA4+z/MUCwh7LVtdGy1+IdRtSQhESTqf
KBlERoksoZ6Fjhgr6kU7bbqBeS6wuAP3nZnpMoobLCqI7UC8xmHxc1YWWAy2cNbY
3eqPWbOJjlqRp3C3qcrHTZ7hnygAiFi0jCBBfIf2gtgNMi+V8mFeDpaaAOKf/CXY
K58qcLdieSpZkCTnbUlEX0DgdQ0Aa8qQK0JkB/ko4qSE4dwMKCHHXFRZ9/7jy9nz
v/SrSLo3XSZW57aIqQeKTXXygtcIFFRKgNzmfJMT6VIU71hDcA+IS8DooytpAYCk
pKYAqOtd+dRwd7cDkj31OYM8t4jKEyw9hP3DTFDdPQcdO2atLicCN/V+VoG8BWB5
voHPf2pGiTXNNGhc+NzDs9XjPNidLsgFC9/OfNM25bcToKNIWkTY1J8a211YnGh8
ygm903/q4KqnxM8Y+617hDRLArwT3HtwrVeUYNeVVJGQVRDsBldseB0Q5WvoxUqC
e/qorDyFyKoVQzWqAehYFZR1QciDVSsxSGCHDs1R4WawidnOt0E=
=kSAw
-----END PGP SIGNATURE-----

Christopher Baines wrote 7 years ago
done
(address . 29740-done@debbugs.gnu.org)
87o9mxt6rr.fsf@cbaines.net

-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlo22X5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdAkQ//Tyvg2gfOCm+A/VR4P+3bfG3zq+EyiOmoapZzlvkwCzyd9GbgV+omNkKh
R+qkCpBZICayMWlYMybKXvA1W1ldrBpteh97xqhpqEC4RE4NsB+X1oae2wwvyM77
NuqnJtbmkejtqmnUoEnKlozRCoRNdo5Nf04oWCkaRo/NWsOfnaaQfX34frZF+rQo
BI7I4bk3oKuulf4aQw9eL00PU1csaiAXJCB2qTJCnm2C1d7WmRBYGsHGO5qPJe1y
XjscAE++mL2vhb0hDHzU9UdvnH9g6xf6oGgLTY7BT88e6nDG/jOCD2dfP0q/d+Eo
CebqyHGeXPpHT1DOa8WEGe45euXgU5/p1d1G/qHGc7Q3r+3+wrALFTtefP1nlqeM
LP5lKW/DqJEcB3lNYm+LaOJ27qYEPHrMqv/N0tYvctWNyIboeD+yS6Zw5HRe0fHU
zLrgjbJOz3F1YcrhoR/XWdmawDARn9qwpHYG39J+/hjT8RWYlJOnAYmIcIeXnsE/
uHFY8k5xIJ51lUCRHRjwqcuuaXRbBVoNIq5v6Scj95hugy0SlY8/iGKmMLxVpbQk
5K6E23i4Okw3l7x00bPIOfxEN5auuAiv66Le5EMrKSDksydWa+pxzcORf1jPxNWY
CYbuXBehj2B5cyCyevk89laH0gk7wb0dCx7rGEuoYWnGjXJhs/Y=
=PS3/
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29740@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29740
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help