[PATCH] services: certbot: Fix certbot renewal job.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171216191843.18428-1-mail@cbaines.net
Quote the list of hosts, to avoid generating a broken job definition.

* gnu/services/certbot.scm (certbot-renewal-jobs): Quote the hosts when
passing them in to the job gexp.
---
gnu/services/certbot.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
index dc072ea8d..0d72a4b70 100644
--- a/gnu/services/certbot.scm
+++ b/gnu/services/certbot.scm
@@ -72,7 +72,7 @@
(string-concatenate
(map (lambda (host)
(string-append " -d " host))
- #$hosts))))))))))
+ '#$hosts))))))))))
(define certbot-activation
(match-lambda
--
2.15.1
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 29739@debbugs.gnu.org)
87po7dbait.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> Quote the list of hosts, to avoid generating a broken job definition.
>
> * gnu/services/certbot.scm (certbot-renewal-jobs): Quote the hosts when
> passing them in to the job gexp.

Good catch, LGTM!

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29739-done@debbugs.gnu.org)
87r2rtt6tx.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Quote the list of hosts, to avoid generating a broken job definition.
>>
>> * gnu/services/certbot.scm (certbot-renewal-jobs): Quote the hosts when
>> passing them in to the job gexp.
>
> Good catch, LGTM!

Great, I've now pushed this :)

Thanks for reviewing.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlo22SpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfRcw//cBxA+UoY5Uqyfa40VyEoPRj+zt+WfkRqo8L3xPS+cH4yVITAZkfJNUpr
WySCZ14sB4PqS7cjfjb0pA8Snrq6Z1R8NuiiBvUSVzQvq+7/6TPqwfd2L8d7f1bj
Lhvj3fL3qGnSgX7lECmrtu8Zw0iG63CcXaBGreaN/+jWPpr906gUXfMqohqFsBR9
cM0bReLfUdPZPllb2npqCJSZ3Vxd+MiXhsEshPX9gg9+sFDHxgPf+rvVixAFi4tU
ICXqeXTUKUGqkKGg8rsY0FX7wzJdXouARWykqa8hOpsN6kvJSy01ttZuhBxTgNDZ
wxtcjqTWDOGbLgs4JbNhveB7UStO217c0LYil5O4Bjj0P99+H+xwpbtER4zFvQ7f
xfrZRH7daP3uJcVz3F3zHZohTPqByH16pELkQmVUnp1Fu7rHE+J+TRYJH90shLrS
8HDBPGiof3X79mo96b0JVd7E+oi2DGy/BMw03n/wTDgd+Cs7Z4CfTQ/nd30KIXfu
5i83tgzo0B6RZ40VjII9KgHNvF5GsSy9Y70ob3Vx7+Bk04Xvtt1KDfGIomz5WAmp
MudwKIyuvabqvMCTz4em/nLeyX1P2mXHDGqGyqjpk5qlTQwz3/hXjYoJNKjI24YX
fk0a8IaEoJMoPc28Hlf/rGUbmQecy2fkgnFSf1n2h0OyGX5YReY=
=mJty
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29739@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29739
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help