Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
Quote the list of hosts, to avoid generating a broken job definition.
* gnu/services/certbot.scm (certbot-renewal-jobs): Quote the hosts when
passing them in to the job gexp.
---
gnu/services/certbot.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/services/certbot.scm b/gnu/services/certbot.scm
index dc072ea8d..0d72a4b70 100644
--- a/gnu/services/certbot.scm
+++ b/gnu/services/certbot.scm
@@ -72,7 +72,7 @@
(string-concatenate
(map (lambda (host)
(string-append " -d " host))
- #$hosts))))))))))
+ '#$hosts))))))))))
(define certbot-activation
(match-lambda
--
2.15.1