Improve Krita

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Mark Meyer
  • ng0
Owner
unassigned
Submitted by
Mark Meyer
Severity
normal
M
M
Mark Meyer wrote on 14 Dec 2017 01:18
(address . guix-patches@gnu.org)
1513210726.1193324.1204381152.68C7761A@webmail.messagingengine.com
Hi,
I'm currently testing several changes to Krita, I've broken stuff up
into three commits/patches which are attached.

These
- add a dependency to vc (vectorize Krita)
- enable OpenEXR
- enable JPEG (via libjpeg-turbo)

Cheers, Mark

--
Mark Meyer
mark@ofosos.org
From 8f631d21210af3c8ec35594f5a99e4259665a7c4 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Thu, 14 Dec 2017 00:49:05 +0100
Subject: [PATCH] * gnu: krita: Add OpenEXR support.

---
gnu/packages/kde.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index d74325c5d..89ad30ecd 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -256,7 +256,10 @@ plugins, as well as code to create plugins, or complete applications.")
(string-append "-DWITH_LibRaw="
(assoc-ref %build-inputs "libraw"))
(string-append "-DWITH_TIFF="
- (assoc-ref %build-inputs "libtiff")))))
+ (assoc-ref %build-inputs "libtiff"))
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "ilmbase")
+ "/include/OpenEXR"))))
(native-inputs
`(("curl" ,curl)
("eigen" ,eigen)
@@ -298,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
("poppler-qt5" ,poppler-qt5)
("libraw" ,libraw)
("libtiff" ,libtiff)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("ilmbase" ,ilmbase)
+ ("openexr" ,openexr)))
(home-page "https://krita.org")
(synopsis "Digital painting application")
(description
--
2.15.0
From adea158919123c732ea2a314133188a0c13929e5 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Thu, 14 Dec 2017 00:36:26 +0100
Subject: [PATCH] * gnu: krita: Add vc to native-inputs.

---
gnu/packages/kde.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index e8f38b920..d74325c5d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -263,7 +263,8 @@ plugins, as well as code to create plugins, or complete applications.")
("extra-cmake-modules" ,extra-cmake-modules)
("gettext-minimal" ,gettext-minimal)
("kitemmodels" ,kitemmodels)
- ("qwt" ,qwt)))
+ ("qwt" ,qwt)
+ ("vc" ,vc)))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
--
2.15.0
From 85e672fc58cad18177651f7e8c2af99e12475d88 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Wed, 13 Dec 2017 23:49:09 +0100
Subject: [PATCH] * gnu: krita: Add libjpeg-turbo to inputs.

---
gnu/packages/kde.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b5a3df2ca..e8f38b920 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -287,6 +287,7 @@ plugins, as well as code to create plugins, or complete applications.")
("exiv2" ,exiv2)
("lcms" ,lcms)
("libpng" ,libpng)
+ ("libjpeg-turbo" ,libjpeg-turbo)
("zlib" ,zlib)
("libx11" ,libx11)
("libxcb" ,libxcb)
--
2.15.0
M
M
Mark Meyer wrote on 14 Dec 2017 01:41
Looks good
(address . 29703@debbugs.gnu.org)
1513212105.1199164.1204399648.4AF43F0D@webmail.messagingengine.com
Ok, I built this changed version and it supports both OpenEXR and JPEG
images. I can't easily test the vectorization.

--
Mark Meyer
mark@ofosos.org
N
Re: [bug#29703] Improve Krita
(name . Mark Meyer)(address . mark@ofosos.org)(address . 29703@debbugs.gnu.org)
20171214115531.llwpyqjzjbwepvep@abyayala
Hi Mark,

Mark Meyer transcribed 5.4K bytes:
Toggle quote (9 lines)
> Hi,
> I'm currently testing several changes to Krita, I've broken stuff up
> into three commits/patches which are attached.
>
> These
> - add a dependency to vc (vectorize Krita)
> - enable OpenEXR
> - enable JPEG (via libjpeg-turbo)

Thanks for the work on Krita.
I haven't tested them, but it looks good.
It would be okay to squash these commits into one, we've done this
in the past in similar cases (see `git log gnu/packages/gnunet.scm`
for libextractor for example).

Toggle quote (99 lines)
> Cheers, Mark
>
> --
> Mark Meyer
> mark@ofosos.org

> From 8f631d21210af3c8ec35594f5a99e4259665a7c4 Mon Sep 17 00:00:00 2001
> From: Mark Meyer <mark@ofosos.org>
> Date: Thu, 14 Dec 2017 00:49:05 +0100
> Subject: [PATCH] * gnu: krita: Add OpenEXR support.
>
> ---
> gnu/packages/kde.scm | 9 +++++++--
> 1 file changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> index d74325c5d..89ad30ecd 100644
> --- a/gnu/packages/kde.scm
> +++ b/gnu/packages/kde.scm
> @@ -256,7 +256,10 @@ plugins, as well as code to create plugins, or complete applications.")
> (string-append "-DWITH_LibRaw="
> (assoc-ref %build-inputs "libraw"))
> (string-append "-DWITH_TIFF="
> - (assoc-ref %build-inputs "libtiff")))))
> + (assoc-ref %build-inputs "libtiff"))
> + (string-append "-DCMAKE_CXX_FLAGS=-I"
> + (assoc-ref %build-inputs "ilmbase")
> + "/include/OpenEXR"))))
> (native-inputs
> `(("curl" ,curl)
> ("eigen" ,eigen)
> @@ -298,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
> ("poppler-qt5" ,poppler-qt5)
> ("libraw" ,libraw)
> ("libtiff" ,libtiff)
> - ("perl" ,perl)))
> + ("perl" ,perl)
> + ("ilmbase" ,ilmbase)
> + ("openexr" ,openexr)))
> (home-page "https://krita.org")
> (synopsis "Digital painting application")
> (description
> --
> 2.15.0
>

> From adea158919123c732ea2a314133188a0c13929e5 Mon Sep 17 00:00:00 2001
> From: Mark Meyer <mark@ofosos.org>
> Date: Thu, 14 Dec 2017 00:36:26 +0100
> Subject: [PATCH] * gnu: krita: Add vc to native-inputs.
>
> ---
> gnu/packages/kde.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> index e8f38b920..d74325c5d 100644
> --- a/gnu/packages/kde.scm
> +++ b/gnu/packages/kde.scm
> @@ -263,7 +263,8 @@ plugins, as well as code to create plugins, or complete applications.")
> ("extra-cmake-modules" ,extra-cmake-modules)
> ("gettext-minimal" ,gettext-minimal)
> ("kitemmodels" ,kitemmodels)
> - ("qwt" ,qwt)))
> + ("qwt" ,qwt)
> + ("vc" ,vc)))
> (inputs
> `(("qtbase" ,qtbase)
> ("qtdeclarative" ,qtdeclarative)
> --
> 2.15.0
>

> From 85e672fc58cad18177651f7e8c2af99e12475d88 Mon Sep 17 00:00:00 2001
> From: Mark Meyer <mark@ofosos.org>
> Date: Wed, 13 Dec 2017 23:49:09 +0100
> Subject: [PATCH] * gnu: krita: Add libjpeg-turbo to inputs.
>
> ---
> gnu/packages/kde.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> index b5a3df2ca..e8f38b920 100644
> --- a/gnu/packages/kde.scm
> +++ b/gnu/packages/kde.scm
> @@ -287,6 +287,7 @@ plugins, as well as code to create plugins, or complete applications.")
> ("exiv2" ,exiv2)
> ("lcms" ,lcms)
> ("libpng" ,libpng)
> + ("libjpeg-turbo" ,libjpeg-turbo)
> ("zlib" ,zlib)
> ("libx11" ,libx11)
> ("libxcb" ,libxcb)
> --
> 2.15.0
>


--
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAloyZrMACgkQ4i+bv+40
hYjdQg/+PWHKTHIcVbGYcF4OG5a9HlN7G0JZUdFcs5jc0BZRNKGtGslKjsqU2Rsw
p/2Wb+yvvq8D5kYSnBvt/kzKTcR3uAh5YH442mjDNI06gGPZ5gcSUGdS3QZZzD2g
daMIZ2Agle7SbrmdtWm+ftW3w6AhPz4JwtKocCAygmc/3J0TnoX4UcWIoABQ18Gr
btY4yKucsKWadzkYv5RFN4hjv4wed8z8xwqHN8DcH6WGy8+zU8UmqLX85HYGHrtZ
HZWABtIOLiGyy3VE8XPai5vc3YmEfir5fZ1OMs+SOORrUocYRVp85Gu1w/KsO1fG
l/xyR8U4Lv1G4Qhdv+VfDQYJ9QFhvKxp5KG/DO+1h4UTw9xUxD8ydEYrfoLVomaq
U9IHmAv7I3R89RzGgPer9hFjr7lZ0dy0pQPeLCadxFTMghFX8tFVKByyZ+VyftVI
ygoG58emAvpExvusbZM5xYMp9H6mHhFymr3qtLSC2ohsqZJG2eoSOP9ZwU95Rp8x
3V2sse1/lAlaXL7yyYd+0C3Sg37grVGAlxqEwNqYsEOgOAXY72V/WZ0nu5lveEpm
VOi19h5gpmR2cQZDfDxYgIEGR9tzcZmTZN04ZQbUkW6qdUh7ky71pWbCNjTbkFYw
i6iDUkkd287Su/RRJbmbR0jPOCp5WT9CZN0DLknMafWNVx1tUbM=
=89Uz
-----END PGP SIGNATURE-----


M
M
Mark Meyer wrote on 14 Dec 2017 15:02
(name . ng0)(address . ng0@n0.is)(address . 29703@debbugs.gnu.org)
1513260171.940424.1204970752.5399B230@webmail.messagingengine.com
Ok, see the following patch. This should also be aligned with the commit
message conventions.

On Thu, Dec 14, 2017, at 12:55, ng0 wrote:
Toggle quote (126 lines)
> Hi Mark,
>
> Mark Meyer transcribed 5.4K bytes:
> > Hi,
> > I'm currently testing several changes to Krita, I've broken stuff up
> > into three commits/patches which are attached.
> >
> > These
> > - add a dependency to vc (vectorize Krita)
> > - enable OpenEXR
> > - enable JPEG (via libjpeg-turbo)
>
> Thanks for the work on Krita.
> I haven't tested them, but it looks good.
> It would be okay to squash these commits into one, we've done this
> in the past in similar cases (see `git log gnu/packages/gnunet.scm`
> for libextractor for example).
>
> > Cheers, Mark
> >
> > --
> > Mark Meyer
> > mark@ofosos.org
>
> > From 8f631d21210af3c8ec35594f5a99e4259665a7c4 Mon Sep 17 00:00:00 2001
> > From: Mark Meyer <mark@ofosos.org>
> > Date: Thu, 14 Dec 2017 00:49:05 +0100
> > Subject: [PATCH] * gnu: krita: Add OpenEXR support.
> >
> > ---
> > gnu/packages/kde.scm | 9 +++++++--
> > 1 file changed, 7 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> > index d74325c5d..89ad30ecd 100644
> > --- a/gnu/packages/kde.scm
> > +++ b/gnu/packages/kde.scm
> > @@ -256,7 +256,10 @@ plugins, as well as code to create plugins, or complete applications.")
> > (string-append "-DWITH_LibRaw="
> > (assoc-ref %build-inputs "libraw"))
> > (string-append "-DWITH_TIFF="
> > - (assoc-ref %build-inputs "libtiff")))))
> > + (assoc-ref %build-inputs "libtiff"))
> > + (string-append "-DCMAKE_CXX_FLAGS=-I"
> > + (assoc-ref %build-inputs "ilmbase")
> > + "/include/OpenEXR"))))
> > (native-inputs
> > `(("curl" ,curl)
> > ("eigen" ,eigen)
> > @@ -298,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
> > ("poppler-qt5" ,poppler-qt5)
> > ("libraw" ,libraw)
> > ("libtiff" ,libtiff)
> > - ("perl" ,perl)))
> > + ("perl" ,perl)
> > + ("ilmbase" ,ilmbase)
> > + ("openexr" ,openexr)))
> > (home-page "https://krita.org")
> > (synopsis "Digital painting application")
> > (description
> > --
> > 2.15.0
> >
>
> > From adea158919123c732ea2a314133188a0c13929e5 Mon Sep 17 00:00:00 2001
> > From: Mark Meyer <mark@ofosos.org>
> > Date: Thu, 14 Dec 2017 00:36:26 +0100
> > Subject: [PATCH] * gnu: krita: Add vc to native-inputs.
> >
> > ---
> > gnu/packages/kde.scm | 3 ++-
> > 1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> > index e8f38b920..d74325c5d 100644
> > --- a/gnu/packages/kde.scm
> > +++ b/gnu/packages/kde.scm
> > @@ -263,7 +263,8 @@ plugins, as well as code to create plugins, or complete applications.")
> > ("extra-cmake-modules" ,extra-cmake-modules)
> > ("gettext-minimal" ,gettext-minimal)
> > ("kitemmodels" ,kitemmodels)
> > - ("qwt" ,qwt)))
> > + ("qwt" ,qwt)
> > + ("vc" ,vc)))
> > (inputs
> > `(("qtbase" ,qtbase)
> > ("qtdeclarative" ,qtdeclarative)
> > --
> > 2.15.0
> >
>
> > From 85e672fc58cad18177651f7e8c2af99e12475d88 Mon Sep 17 00:00:00 2001
> > From: Mark Meyer <mark@ofosos.org>
> > Date: Wed, 13 Dec 2017 23:49:09 +0100
> > Subject: [PATCH] * gnu: krita: Add libjpeg-turbo to inputs.
> >
> > ---
> > gnu/packages/kde.scm | 1 +
> > 1 file changed, 1 insertion(+)
> >
> > diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> > index b5a3df2ca..e8f38b920 100644
> > --- a/gnu/packages/kde.scm
> > +++ b/gnu/packages/kde.scm
> > @@ -287,6 +287,7 @@ plugins, as well as code to create plugins, or complete applications.")
> > ("exiv2" ,exiv2)
> > ("lcms" ,lcms)
> > ("libpng" ,libpng)
> > + ("libjpeg-turbo" ,libjpeg-turbo)
> > ("zlib" ,zlib)
> > ("libx11" ,libx11)
> > ("libxcb" ,libxcb)
> > --
> > 2.15.0
> >
>
>
> --
> GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
> GnuPG: https://c.n0.is/ng0_pubkeys/tree/keys
> WWW: https://n0.is
> Email had 1 attachment:
> + signature.asc
> 1k (application/pgp-signature)


--
Mark Meyer
mark@ofosos.org
From 158497a7bf1b5672018189101fa5448623cecb1b Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Wed, 13 Dec 2017 23:49:09 +0100
Subject: [PATCH] gnu: krita: Enhance krita

* gnu/packages/kde.scm (kirta)[inputs]: Add libjpeg-turbo to inputs.
* gnu/packages/kde.scm (krita)[inputs]: Add vc to native-inputs.
* gnu/packages/kde.scm (krita)[inputs]: Add OpenEXR support.
---
gnu/packages/kde.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b5a3df2ca..89ad30ecd 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -256,14 +256,18 @@ plugins, as well as code to create plugins, or complete applications.")
(string-append "-DWITH_LibRaw="
(assoc-ref %build-inputs "libraw"))
(string-append "-DWITH_TIFF="
- (assoc-ref %build-inputs "libtiff")))))
+ (assoc-ref %build-inputs "libtiff"))
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "ilmbase")
+ "/include/OpenEXR"))))
(native-inputs
`(("curl" ,curl)
("eigen" ,eigen)
("extra-cmake-modules" ,extra-cmake-modules)
("gettext-minimal" ,gettext-minimal)
("kitemmodels" ,kitemmodels)
- ("qwt" ,qwt)))
+ ("qwt" ,qwt)
+ ("vc" ,vc)))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
@@ -287,6 +291,7 @@ plugins, as well as code to create plugins, or complete applications.")
("exiv2" ,exiv2)
("lcms" ,lcms)
("libpng" ,libpng)
+ ("libjpeg-turbo" ,libjpeg-turbo)
("zlib" ,zlib)
("libx11" ,libx11)
("libxcb" ,libxcb)
@@ -296,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
("poppler-qt5" ,poppler-qt5)
("libraw" ,libraw)
("libtiff" ,libtiff)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("ilmbase" ,ilmbase)
+ ("openexr" ,openexr)))
(home-page "https://krita.org")
(synopsis "Digital painting application")
(description
--
2.15.0
N
(name . Mark Meyer)(address . mark@ofosos.org)
20171214143921.blzsslbcig76ysob@abyayala
Hi,

we're almost there. It's just a couple of fixes that need to be applied:

Mark Meyer transcribed 7.7K bytes:
Toggle quote (33 lines)
> Ok, see the following patch. This should also be aligned with the commit
> message conventions.
>
> On Thu, Dec 14, 2017, at 12:55, ng0 wrote:
> > Hi Mark,
> >
> > Mark Meyer transcribed 5.4K bytes:
> > > Hi,
> > > I'm currently testing several changes to Krita, I've broken stuff up
> > > into three commits/patches which are attached.
> > >
> > > These
> > > - add a dependency to vc (vectorize Krita)
> > > - enable OpenEXR
> > > - enable JPEG (via libjpeg-turbo)
> >
> > Thanks for the work on Krita.
> > I haven't tested them, but it looks good.
> > It would be okay to squash these commits into one, we've done this
> > in the past in similar cases (see `git log gnu/packages/gnunet.scm`
> > for libextractor for example).
> >
> > > Cheers, Mark

> From 158497a7bf1b5672018189101fa5448623cecb1b Mon Sep 17 00:00:00 2001
> From: Mark Meyer <mark@ofosos.org>
> Date: Wed, 13 Dec 2017 23:49:09 +0100
> Subject: [PATCH] gnu: krita: Enhance krita
>
> * gnu/packages/kde.scm (kirta)[inputs]: Add libjpeg-turbo to inputs.
> * gnu/packages/kde.scm (krita)[inputs]: Add vc to native-inputs.
> * gnu/packages/kde.scm (krita)[inputs]: Add OpenEXR support.

I would write:

gnu: krita: Enhance krita.

* gnu/packages/kde.scm (krita)[inputs]: Add 'libjpeg-turbo', 'ilmbase', 'openexr'.
(native-inputs): Add 'vc'.
(arguments)[configure-flags]: Add 'CMAKE_CXX_FLAGS' for ilmbase.



Or something like that. I'm not sure about the configure-flags wording.
I don't know Krita so I can't really review if your changes work. I'll
build it later tonight and see if it builds for me.

Toggle quote (53 lines)
> ---
> gnu/packages/kde.scm | 13 ++++++++++---
> 1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> index b5a3df2ca..89ad30ecd 100644
> --- a/gnu/packages/kde.scm
> +++ b/gnu/packages/kde.scm
> @@ -256,14 +256,18 @@ plugins, as well as code to create plugins, or complete applications.")
> (string-append "-DWITH_LibRaw="
> (assoc-ref %build-inputs "libraw"))
> (string-append "-DWITH_TIFF="
> - (assoc-ref %build-inputs "libtiff")))))
> + (assoc-ref %build-inputs "libtiff"))
> + (string-append "-DCMAKE_CXX_FLAGS=-I"
> + (assoc-ref %build-inputs "ilmbase")
> + "/include/OpenEXR"))))
> (native-inputs
> `(("curl" ,curl)
> ("eigen" ,eigen)
> ("extra-cmake-modules" ,extra-cmake-modules)
> ("gettext-minimal" ,gettext-minimal)
> ("kitemmodels" ,kitemmodels)
> - ("qwt" ,qwt)))
> + ("qwt" ,qwt)
> + ("vc" ,vc)))
> (inputs
> `(("qtbase" ,qtbase)
> ("qtdeclarative" ,qtdeclarative)
> @@ -287,6 +291,7 @@ plugins, as well as code to create plugins, or complete applications.")
> ("exiv2" ,exiv2)
> ("lcms" ,lcms)
> ("libpng" ,libpng)
> + ("libjpeg-turbo" ,libjpeg-turbo)
> ("zlib" ,zlib)
> ("libx11" ,libx11)
> ("libxcb" ,libxcb)
> @@ -296,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
> ("poppler-qt5" ,poppler-qt5)
> ("libraw" ,libraw)
> ("libtiff" ,libtiff)
> - ("perl" ,perl)))
> + ("perl" ,perl)
> + ("ilmbase" ,ilmbase)
> + ("openexr" ,openexr)))
> (home-page "https://krita.org")
> (synopsis "Digital painting application")
> (description
> --
> 2.15.0
>


--
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAloyjRkACgkQ4i+bv+40
hYhjdw//QpFJgY0JQ4IEJBlTGvYdUTerHBpg46sqO6gVxWaNQynd4v8kkQBP/JlZ
DD62iVMfY+9VsttojtncvSOVl8+H4fvAPiYpBTkA/aKgbb4WkILSyJtGaMgaXKSS
EHs70f/TxolzAq5/OPqMG/qQeOYcuEc6oy6xBKDazJCJTGfd9HtTZ5otzNZnfj8h
oLKBo3B/E5jKCyMn4WTulKejoOC+KzekLYIyDjMLTPIovt851j34kFpEGjZVHHne
bWldJjxKtjy/c1al/cjUfcUJd/FRIb6Nz9cvL6RhmjOIxARmc9cyspUlC18QG9Gs
tS73Qb6J/WZ84xFDscqaG9lPIf8zcgvXYkBfXx60aRvIzzAE4+BiB6/Q9naEMsIX
/7Yjxk6TNk/X2etTHBH/iqGrKW7curVaiSPbOszT3dMRNlT4AdJwbxrshs/RFOjG
9k3/ATKmB8x6FEAwL/069GirzMw+FmczntfVvGUEA4hSzO5YwaYCWUugUlsE9qNJ
NMYC6N91O9wIrZ8gVQPS2YntAlpigU8Jt79xmCgIsx3E7L+MwsX2hltQNaOF2nBP
UYtrHoXK3eetDc53Mbw35VAgCLCBsIQtE10D5efUkDPnSs1ENJ1NJvDH0BPHn0Zy
fV46/h6pFdLhrRj+JT7LAZ3OGH1FrTmmJ7EiNIQhJcQgw5n1HrI=
=28b8
-----END PGP SIGNATURE-----


M
M
Mark Meyer wrote on 14 Dec 2017 16:12
(name . ng0)(address . ng0@n0.is)(address . 29703@debbugs.gnu.org)
1513264340.1671908.1205049896.4F42762D@webmail.messagingengine.com
Thanks for your patience, from the log of gnunet.scm I think it should
be somthing like the appended one.

Cheers, Mark

On Thu, Dec 14, 2017, at 15:39, ng0 wrote:
Toggle quote (115 lines)
> Hi,
>
> we're almost there. It's just a couple of fixes that need to be applied:
>
> Mark Meyer transcribed 7.7K bytes:
> > Ok, see the following patch. This should also be aligned with the commit
> > message conventions.
> >
> > On Thu, Dec 14, 2017, at 12:55, ng0 wrote:
> > > Hi Mark,
> > >
> > > Mark Meyer transcribed 5.4K bytes:
> > > > Hi,
> > > > I'm currently testing several changes to Krita, I've broken stuff up
> > > > into three commits/patches which are attached.
> > > >
> > > > These
> > > > - add a dependency to vc (vectorize Krita)
> > > > - enable OpenEXR
> > > > - enable JPEG (via libjpeg-turbo)
> > >
> > > Thanks for the work on Krita.
> > > I haven't tested them, but it looks good.
> > > It would be okay to squash these commits into one, we've done this
> > > in the past in similar cases (see `git log gnu/packages/gnunet.scm`
> > > for libextractor for example).
> > >
> > > > Cheers, Mark
>
> > From 158497a7bf1b5672018189101fa5448623cecb1b Mon Sep 17 00:00:00 2001
> > From: Mark Meyer <mark@ofosos.org>
> > Date: Wed, 13 Dec 2017 23:49:09 +0100
> > Subject: [PATCH] gnu: krita: Enhance krita
> >
> > * gnu/packages/kde.scm (kirta)[inputs]: Add libjpeg-turbo to inputs.
> > * gnu/packages/kde.scm (krita)[inputs]: Add vc to native-inputs.
> > * gnu/packages/kde.scm (krita)[inputs]: Add OpenEXR support.
>
> I would write:
>
> gnu: krita: Enhance krita.
>
> * gnu/packages/kde.scm (krita)[inputs]: Add 'libjpeg-turbo', 'ilmbase',
> 'openexr'.
> (native-inputs): Add 'vc'.
> (arguments)[configure-flags]: Add 'CMAKE_CXX_FLAGS' for ilmbase.
>
>
>
> Or something like that. I'm not sure about the configure-flags wording.
> I don't know Krita so I can't really review if your changes work. I'll
> build it later tonight and see if it builds for me.
>
> > ---
> > gnu/packages/kde.scm | 13 ++++++++++---
> > 1 file changed, 10 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
> > index b5a3df2ca..89ad30ecd 100644
> > --- a/gnu/packages/kde.scm
> > +++ b/gnu/packages/kde.scm
> > @@ -256,14 +256,18 @@ plugins, as well as code to create plugins, or complete applications.")
> > (string-append "-DWITH_LibRaw="
> > (assoc-ref %build-inputs "libraw"))
> > (string-append "-DWITH_TIFF="
> > - (assoc-ref %build-inputs "libtiff")))))
> > + (assoc-ref %build-inputs "libtiff"))
> > + (string-append "-DCMAKE_CXX_FLAGS=-I"
> > + (assoc-ref %build-inputs "ilmbase")
> > + "/include/OpenEXR"))))
> > (native-inputs
> > `(("curl" ,curl)
> > ("eigen" ,eigen)
> > ("extra-cmake-modules" ,extra-cmake-modules)
> > ("gettext-minimal" ,gettext-minimal)
> > ("kitemmodels" ,kitemmodels)
> > - ("qwt" ,qwt)))
> > + ("qwt" ,qwt)
> > + ("vc" ,vc)))
> > (inputs
> > `(("qtbase" ,qtbase)
> > ("qtdeclarative" ,qtdeclarative)
> > @@ -287,6 +291,7 @@ plugins, as well as code to create plugins, or complete applications.")
> > ("exiv2" ,exiv2)
> > ("lcms" ,lcms)
> > ("libpng" ,libpng)
> > + ("libjpeg-turbo" ,libjpeg-turbo)
> > ("zlib" ,zlib)
> > ("libx11" ,libx11)
> > ("libxcb" ,libxcb)
> > @@ -296,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
> > ("poppler-qt5" ,poppler-qt5)
> > ("libraw" ,libraw)
> > ("libtiff" ,libtiff)
> > - ("perl" ,perl)))
> > + ("perl" ,perl)
> > + ("ilmbase" ,ilmbase)
> > + ("openexr" ,openexr)))
> > (home-page "https://krita.org")
> > (synopsis "Digital painting application")
> > (description
> > --
> > 2.15.0
> >
>
>
> --
> GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
> GnuPG: https://c.n0.is/ng0_pubkeys/tree/keys
> WWW: https://n0.is
> Email had 1 attachment:
> + signature.asc
> 1k (application/pgp-signature)


--
Mark Meyer
mark@ofosos.org
From 37e5519a2b326ff9d03c75440df38e2e5f116709 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Wed, 13 Dec 2017 23:49:09 +0100
Subject: [PATCH] gnu: krita: Enhance krita

* gnu/packages/kde.scm (kirta)[inputs]: Add 'libjpeg-turbo', 'ilmbase', 'openexr'.
[native-inputs]: Add vc.
[arguments]: Set path to headers for 'ilmbase'.
---
gnu/packages/kde.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b5a3df2ca..89ad30ecd 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -256,14 +256,18 @@ plugins, as well as code to create plugins, or complete applications.")
(string-append "-DWITH_LibRaw="
(assoc-ref %build-inputs "libraw"))
(string-append "-DWITH_TIFF="
- (assoc-ref %build-inputs "libtiff")))))
+ (assoc-ref %build-inputs "libtiff"))
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "ilmbase")
+ "/include/OpenEXR"))))
(native-inputs
`(("curl" ,curl)
("eigen" ,eigen)
("extra-cmake-modules" ,extra-cmake-modules)
("gettext-minimal" ,gettext-minimal)
("kitemmodels" ,kitemmodels)
- ("qwt" ,qwt)))
+ ("qwt" ,qwt)
+ ("vc" ,vc)))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
@@ -287,6 +291,7 @@ plugins, as well as code to create plugins, or complete applications.")
("exiv2" ,exiv2)
("lcms" ,lcms)
("libpng" ,libpng)
+ ("libjpeg-turbo" ,libjpeg-turbo)
("zlib" ,zlib)
("libx11" ,libx11)
("libxcb" ,libxcb)
@@ -296,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
("poppler-qt5" ,poppler-qt5)
("libraw" ,libraw)
("libtiff" ,libtiff)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("ilmbase" ,ilmbase)
+ ("openexr" ,openexr)))
(home-page "https://krita.org")
(synopsis "Digital painting application")
(description
--
2.15.0
K
K
Kei Kebreau wrote on 16 Dec 2017 22:53
(name . Mark Meyer)(address . mark@ofosos.org)
87wp1mz6ej.fsf@posteo.net
Mark Meyer <mark@ofosos.org> writes:

Toggle quote (120 lines)
> Thanks for your patience, from the log of gnunet.scm I think it should
> be somthing like the appended one.
>
> Cheers, Mark
>
> On Thu, Dec 14, 2017, at 15:39, ng0 wrote:
>> Hi,
>>
>> we're almost there. It's just a couple of fixes that need to be applied:
>>
>> Mark Meyer transcribed 7.7K bytes:
>> > Ok, see the following patch. This should also be aligned with the commit
>> > message conventions.
>> >
>> > On Thu, Dec 14, 2017, at 12:55, ng0 wrote:
>> > > Hi Mark,
>> > >
>> > > Mark Meyer transcribed 5.4K bytes:
>> > > > Hi,
>> > > > I'm currently testing several changes to Krita, I've broken stuff up
>> > > > into three commits/patches which are attached.
>> > > >
>> > > > These
>> > > > - add a dependency to vc (vectorize Krita)
>> > > > - enable OpenEXR
>> > > > - enable JPEG (via libjpeg-turbo)
>> > >
>> > > Thanks for the work on Krita.
>> > > I haven't tested them, but it looks good.
>> > > It would be okay to squash these commits into one, we've done this
>> > > in the past in similar cases (see `git log gnu/packages/gnunet.scm`
>> > > for libextractor for example).
>> > >
>> > > > Cheers, Mark
>>
>> > From 158497a7bf1b5672018189101fa5448623cecb1b Mon Sep 17 00:00:00 2001
>> > From: Mark Meyer <mark@ofosos.org>
>> > Date: Wed, 13 Dec 2017 23:49:09 +0100
>> > Subject: [PATCH] gnu: krita: Enhance krita
>> >
>> > * gnu/packages/kde.scm (kirta)[inputs]: Add libjpeg-turbo to inputs.
>> > * gnu/packages/kde.scm (krita)[inputs]: Add vc to native-inputs.
>> > * gnu/packages/kde.scm (krita)[inputs]: Add OpenEXR support.
>>
>> I would write:
>>
>> gnu: krita: Enhance krita.
>>
>> * gnu/packages/kde.scm (krita)[inputs]: Add 'libjpeg-turbo', 'ilmbase',
>> 'openexr'.
>> (native-inputs): Add 'vc'.
>> (arguments)[configure-flags]: Add 'CMAKE_CXX_FLAGS' for ilmbase.
>>
>>
>>
>> Or something like that. I'm not sure about the configure-flags wording.
>> I don't know Krita so I can't really review if your changes work. I'll
>> build it later tonight and see if it builds for me.
>>
>> > ---
>> > gnu/packages/kde.scm | 13 ++++++++++---
>> > 1 file changed, 10 insertions(+), 3 deletions(-)
>> >
>> > diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
>> > index b5a3df2ca..89ad30ecd 100644
>> > --- a/gnu/packages/kde.scm
>> > +++ b/gnu/packages/kde.scm
>> > @@ -256,14 +256,18 @@ plugins, as well as code to create plugins, or complete applications.")
>> > (string-append "-DWITH_LibRaw="
>> > (assoc-ref %build-inputs "libraw"))
>> > (string-append "-DWITH_TIFF="
>> > - (assoc-ref %build-inputs "libtiff")))))
>> > + (assoc-ref %build-inputs "libtiff"))
>> > + (string-append "-DCMAKE_CXX_FLAGS=-I"
>> > + (assoc-ref %build-inputs "ilmbase")
>> > + "/include/OpenEXR"))))
>> > (native-inputs
>> > `(("curl" ,curl)
>> > ("eigen" ,eigen)
>> > ("extra-cmake-modules" ,extra-cmake-modules)
>> > ("gettext-minimal" ,gettext-minimal)
>> > ("kitemmodels" ,kitemmodels)
>> > - ("qwt" ,qwt)))
>> > + ("qwt" ,qwt)
>> > + ("vc" ,vc)))
>> > (inputs
>> > `(("qtbase" ,qtbase)
>> > ("qtdeclarative" ,qtdeclarative)
>> > @@ -287,6 +291,7 @@ plugins, as well as code to create plugins, or complete applications.")
>> > ("exiv2" ,exiv2)
>> > ("lcms" ,lcms)
>> > ("libpng" ,libpng)
>> > + ("libjpeg-turbo" ,libjpeg-turbo)
>> > ("zlib" ,zlib)
>> > ("libx11" ,libx11)
>> > ("libxcb" ,libxcb)
>> > @@ -296,7 +301,9 @@ plugins, as well as code to create plugins, or complete applications.")
>> > ("poppler-qt5" ,poppler-qt5)
>> > ("libraw" ,libraw)
>> > ("libtiff" ,libtiff)
>> > - ("perl" ,perl)))
>> > + ("perl" ,perl)
>> > + ("ilmbase" ,ilmbase)
>> > + ("openexr" ,openexr)))
>> > (home-page "https://krita.org")
>> > (synopsis "Digital painting application")
>> > (description
>> > --
>> > 2.15.0
>> >
>>
>>
>> --
>> GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
>> GnuPG: https://c.n0.is/ng0_pubkeys/tree/keys
>> WWW: https://n0.is
>> Email had 1 attachment:
>> + signature.asc
>> 1k (application/pgp-signature)

I made tiny changes to the commit log and pushed this to master; you can
close this bug.

Thanks for contributing,
Kei
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlo1ldQACgkQ5qXuPBlG
eg3d1g/+N1K7TBnS1cvdrx1/m/xqIHNat3mzMrV78jP0GBGZOYXvYEhpkMmQxrOL
2v9YBXUznBD7R15YBEY1yyvkcLPARgxt7B+MlU7VICeag/dMiiyXFPjs3Sd/dO5n
pRaxZXHtH7osxhSf44fMtwcgX4PU5PxyboTBt8gd8wqCQwDm+leSw9uk/t2pWg2e
MLlsM+QuLCqBu4sQJKPoVFc2LlZgMvUU/E/gj+q0BHtD537Ieb3rcj7tBLu7Pyr0
uusG+JNmUEPKUhjddbCRut7n8hBkmqsG+fZAqm5HpJyIXYvHO3QnIGer03mQHIcO
OVURMRJimrRWXg1DuFijKIo4MGyyENC/ImKHNWSg4RmBE9vjLVzVWtu9GhsCEhVI
gWuA5pjOsKXWVfHFowlr5o7h1NQcdhZnNzPhyESJ8+4/7F3i5mIXSVfQJxnxOa+Q
jTLeKlTcTL4vs7yhoma2R5/BZkBslBrvdLk6EZmlrTCM/QAOxB63JakOV/sNv6SZ
F9BFRwfOXLVRCwKcRnmwE86/iQjXFJU/TT9n6qjr0qfzxvX/oPojO0K8qhxqMD7w
APTitmmNePzVakQZ16ZwEctSI+zTm0J59+OOdbwjwoQ7mZQenN7gfS2rf02mM6uc
0BqIw1qiIGOHYnhXIXzeh8ROP0BMmgx249ce1khkXgE/cI5mRBE=
=JLF0
-----END PGP SIGNATURE-----

M
M
Mark Meyer wrote on 17 Dec 2017 00:19
Fixed
(address . 29703-done@debbugs.gnu.org)
1513466384.3477815.1207421096.44699746@webmail.messagingengine.com
Fixed.

--
Mark Meyer
mark@ofosos.org
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29703@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29703
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch