Fwd: [PATCH] Add Krita to guix

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Mark Meyer
  • ng0
Owner
unassigned
Submitted by
Mark Meyer
Severity
normal
M
M
Mark Meyer wrote on 5 Dec 2017 02:35
(address . guix-patches@gnu.org)
1512437757.2664676.1194102760.4CC1A193@webmail.messagingengine.com
On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
Toggle quote (17 lines)
> Second try.
>
> I disabled all tests, since these required an X11 display to be present.
> It's running now. I created a new file and saved the output. Looks good.
>
> Please find the patch attached.
>
> Lints fine, but I didn't test if this is reproducible, since the build
> is taking a very long time (even with all tests disabled).
>
> Cheers, Mark
>
> --
> Mark Meyer
> mark@ofosos.org


--
Mark Meyer
mark@ofosos.org
From ed263ddc7b084c362165688bc1d1012e3978d9b8 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Tue, 5 Dec 2017 00:52:42 +0100
Subject: [PATCH] * gnu/packages/kde.scm (krita): Add new variable.

---
gnu/packages/kde.scm | 90 +++++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 89 insertions(+), 1 deletion(-)

Toggle diff (128 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 59271ebee..af182a033 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,18 +24,29 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphics)
+ #:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xorg))
(define-public kdevelop
(package
@@ -220,6 +232,82 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
plugins, as well as code to create plugins, or complete applications.")
(license license:gpl3+)))
+(define-public krita
+ (package
+ (name "krita")
+ (version "3.3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/krita/"
+ "3.3.2/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i3l27cfi1h486m74xf4ynk0pwx32xaqraa91a0g1bpj1jxf2mg5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
+ (string-append "-DWITH_FFTW3="
+ (assoc-ref %build-inputs "fftw"))
+ (string-append "-DWITH_GSL="
+ (assoc-ref %build-inputs "gsl"))
+ (string-append "-DWITH_LibRaw="
+ (assoc-ref %build-inputs "libraw"))
+ (string-append "-DWITH_JPEG="
+ (assoc-ref %build-inputs "openjpeg"))
+ (string-append "-DWITH_Poppler="
+ (assoc-ref %build-inputs "poppler"))
+ (string-append "-DWITH_TIFF="
+ (assoc-ref %build-inputs "libtiff")))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtx11extras" ,qtx11extras)
+ ("qtsvg" ,qtsvg)
+ ("qwt" ,qwt)
+ ("karchive" ,karchive)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kitemmodels" ,kitemmodels)
+ ("kitemviews" ,kitemviews)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("boost" ,boost)
+ ("exiv2" ,exiv2)
+ ("lcms" ,lcms)
+ ("libpng" ,libpng)
+ ("curl" ,curl)
+ ("zlib" ,zlib)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
+ ("libxi" ,libxi)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("openjpeg" ,openjpeg)
+ ("poppler" ,poppler)
+ ("libraw" ,libraw)
+ ("libtiff" ,libtiff)
+ ("eigen" ,eigen)
+ ("perl" ,perl)
+ ("gettext-minimal" ,gettext-minimal)))
+ (home-page "https://krita.org")
+ (synopsis "Digital painting application")
+ (description
+ "A digital image editor, primarily aimed at digital painting and animation.")
+ (license license:gpl2+)))
+
(define-public libkomparediff2
(package
(name "libkomparediff2")
--
2.15.0
K
K
Kei Kebreau wrote on 10 Dec 2017 20:32
(name . Mark Meyer)(address . mark@ofosos.org)(address . 29574@debbugs.gnu.org)
87609e1irt.fsf@posteo.net
Mark Meyer <mark@ofosos.org> writes:

Toggle quote (17 lines)
> On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
>> Second try.
>>
>> I disabled all tests, since these required an X11 display to be present.
>> It's running now. I created a new file and saved the output. Looks good.
>>
>> Please find the patch attached.
>>
>> Lints fine, but I didn't test if this is reproducible, since the build
>> is taking a very long time (even with all tests disabled).
>>
>> Cheers, Mark
>>
>> --
>> Mark Meyer
>> mark@ofosos.org

Hi Mark,

I built this package twice and it is reproducible! I've moved some
inputs to native-inputs in the attached patch because they didn't show
up as requisites for krita (i.e. I ran 'guix gc -R /gnu/store/...-krita-3.3.2.1'
to find this out).

Please tell me if this build works properly for you as it seems to for
me.

Thanks,
Kei
From 0f977a7444445753aaa48b65d8c84d6db16b8368 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Tue, 5 Dec 2017 00:52:42 +0100
Subject: [PATCH] gnu: Add krita.

* gnu/packages/kde.scm (krita): Add new variable.

Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
---
gnu/packages/kde.scm | 90 +++++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 89 insertions(+), 1 deletion(-)

Toggle diff (128 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 59271ebee..39a137397 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,18 +24,29 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphics)
+ #:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xorg))
(define-public kdevelop
(package
@@ -220,6 +232,82 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
plugins, as well as code to create plugins, or complete applications.")
(license license:gpl3+)))
+(define-public krita
+ (package
+ (name "krita")
+ (version "3.3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/krita/"
+ "3.3.2/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i3l27cfi1h486m74xf4ynk0pwx32xaqraa91a0g1bpj1jxf2mg5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
+ (string-append "-DWITH_FFTW3="
+ (assoc-ref %build-inputs "fftw"))
+ (string-append "-DWITH_GSL="
+ (assoc-ref %build-inputs "gsl"))
+ (string-append "-DWITH_LibRaw="
+ (assoc-ref %build-inputs "libraw"))
+ (string-append "-DWITH_JPEG="
+ (assoc-ref %build-inputs "openjpeg"))
+ (string-append "-DWITH_Poppler="
+ (assoc-ref %build-inputs "poppler"))
+ (string-append "-DWITH_TIFF="
+ (assoc-ref %build-inputs "libtiff")))))
+ (native-inputs
+ `(("curl" ,curl)
+ ("eigen" ,eigen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("gettext-minimal" ,gettext-minimal)
+ ("kitemmodels" ,kitemmodels)
+ ("qwt" ,qwt)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtx11extras" ,qtx11extras)
+ ("qtsvg" ,qtsvg)
+ ("karchive" ,karchive)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("boost" ,boost)
+ ("exiv2" ,exiv2)
+ ("lcms" ,lcms)
+ ("libpng" ,libpng)
+ ("zlib" ,zlib)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
+ ("libxi" ,libxi)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("openjpeg" ,openjpeg)
+ ("poppler" ,poppler)
+ ("libraw" ,libraw)
+ ("libtiff" ,libtiff)
+ ("perl" ,perl)))
+ (home-page "https://krita.org")
+ (synopsis "Digital painting application")
+ (description
+ "A digital image editor, primarily aimed at digital painting and animation.")
+ (license license:gpl2+)))
+
(define-public libkomparediff2
(package
(name "libkomparediff2")
--
2.15.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAloti7YACgkQ5qXuPBlG
eg0Kdg/9FVuEInAUdbtzUH1TDKvuXwF7/PgLCNK1WF8LS61kGsoHC2CqrKyd3xfU
bbGTBAIzNdTB3Nm4sMNwSp0nt50HpbBP6U7M2OPdVSnpQVCvUiq70pO943E1CALx
bXIaeWDoeugpAH5y0/fpU0wGoBFAhaOSFgtp0KHD790vwSRozIQuTOp8OUkd9U1b
KZvaGu7Xy35Leb9z3bgpk3fkDUqYyVPXS5E7Uq6Ds07+z3jV82R1Z5fWKjw6uFT9
z+iFObFbsgRLfUpI96t1kYRF4iwXs/QiGjw5z/wUaKzAZ3AD0DJj1e19aZgrkDuo
Sap2V3pTog8SrAxs4qpEi0tunpS5DdrWEEFDJstG8zpBQPURIn6PautiL08fx1H0
qET6yRWoomhNOFVxytu5KI0g7m4HVQ9/2dhpXpeolJuHzDv5hs2k63KfN7gL4WRe
HtKki5jI/AATtfSGxKOzksOnGfqCT5I324O0XJaUVLWAsS8IaDx/Jdu9hqyNVz04
QsB8y6VviV9xk3/vZHgZunO1AjokN0fNr3BL0Avf5IXj/P9Ch1cmPTQgg0pxP2Vc
rQjDVTj8jtmDC3vFqjtRi3CDqtLQStprbcW01hvdPni0AeaUXYlECxgOfwmf90Ly
iGXkC3xoMjrF8Q1OiTo1dn+tMHOt2uPY42dMxzHGMR8G4kGKzpA=
=F5W3
-----END PGP SIGNATURE-----

M
M
Mark Meyer wrote on 10 Dec 2017 22:27
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29574@debbugs.gnu.org)
1512941249.3712080.1200398728.2D061D86@webmail.messagingengine.com
Hi Kei,
I want to double check the output tomorrow morning. I think my copy
lacks JPG support, but I'm not sure. I'll check tomorrow.

Cheers, Mark

On Sun, Dec 10, 2017, at 20:32, Kei Kebreau wrote:
Toggle quote (40 lines)
> Mark Meyer <mark@ofosos.org> writes:
>
> > On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
> >> Second try.
> >>
> >> I disabled all tests, since these required an X11 display to be present.
> >> It's running now. I created a new file and saved the output. Looks good.
> >>
> >> Please find the patch attached.
> >>
> >> Lints fine, but I didn't test if this is reproducible, since the build
> >> is taking a very long time (even with all tests disabled).
> >>
> >> Cheers, Mark
> >>
> >> --
> >> Mark Meyer
> >> mark@ofosos.org
>
> Hi Mark,
>
> I built this package twice and it is reproducible! I've moved some
> inputs to native-inputs in the attached patch because they didn't show
> up as requisites for krita (i.e. I ran 'guix gc -R
> /gnu/store/...-krita-3.3.2.1'
> to find this out).
>
> Please tell me if this build works properly for you as it seems to for
> me.
>
> Thanks,
> Kei
>
> Email had 2 attachments:
> + 0001-gnu-Add-krita.patch
> 5k (text/plain)
> + signature.asc
> 1k (application/pgp-signature)


--
Mark Meyer
mark@ofosos.org
M
M
Mark Meyer wrote on 11 Dec 2017 01:07
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29574@debbugs.gnu.org)
1512950869.101909.1200498696.0575B966@webmail.messagingengine.com
Hey Kei,
JPEG does not work and PDF also doesn't seem to work, we might as well
remove both dependencies, I think they're nice but not essential.

When I do `guix environment krita` and start a manual build I get:

-- The following OPTIONAL packages have not been found:

* XCB , X protocol C-language Binding , http://xcb.freedesktop.org
* OpenEXR , High dynamic-range (HDR) image file format ,
Required by the Krita OpenEXR filter
* JPEG , Free library for JPEG image compression. Note: libjpeg8 is NOT
Required by the Krita JPEG filter
* OCIO , The OpenColorIO Library , http://www.opencolorio.org
Required by the Krita LUT docker
* Vc (required version >= 1.1.0) , Portable, zero-overhead SIMD library
Required by the Krita for vectorization
* Poppler , A PDF rendering library , http://poppler.freedesktop.org
Required by the Krita PDF filter.

I intend to enable OpenEXR JPEG and Poppler in a later patch.

So: looks good to me.

Cheers, Mark

On Sun, Dec 10, 2017, at 20:32, Kei Kebreau wrote:
Toggle quote (40 lines)
> Mark Meyer <mark@ofosos.org> writes:
>
> > On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
> >> Second try.
> >>
> >> I disabled all tests, since these required an X11 display to be present.
> >> It's running now. I created a new file and saved the output. Looks good.
> >>
> >> Please find the patch attached.
> >>
> >> Lints fine, but I didn't test if this is reproducible, since the build
> >> is taking a very long time (even with all tests disabled).
> >>
> >> Cheers, Mark
> >>
> >> --
> >> Mark Meyer
> >> mark@ofosos.org
>
> Hi Mark,
>
> I built this package twice and it is reproducible! I've moved some
> inputs to native-inputs in the attached patch because they didn't show
> up as requisites for krita (i.e. I ran 'guix gc -R
> /gnu/store/...-krita-3.3.2.1'
> to find this out).
>
> Please tell me if this build works properly for you as it seems to for
> me.
>
> Thanks,
> Kei
>
> Email had 2 attachments:
> + 0001-gnu-Add-krita.patch
> 5k (text/plain)
> + signature.asc
> 1k (application/pgp-signature)


--
Mark Meyer
mark@ofosos.org
M
M
Mark Meyer wrote on 11 Dec 2017 01:29
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29574@debbugs.gnu.org)
1512952158.106542.1200513048.7646AEF0@webmail.messagingengine.com
Hi Kei,
Poppler was an easy target, it just pointed to the wrong package. JPEG
requires some more packaging and EXR some thought. Meanwhile the
attached patch should be ok.

Cheers, Mark

On Sun, Dec 10, 2017, at 20:32, Kei Kebreau wrote:
Toggle quote (40 lines)
> Mark Meyer <mark@ofosos.org> writes:
>
> > On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
> >> Second try.
> >>
> >> I disabled all tests, since these required an X11 display to be present.
> >> It's running now. I created a new file and saved the output. Looks good.
> >>
> >> Please find the patch attached.
> >>
> >> Lints fine, but I didn't test if this is reproducible, since the build
> >> is taking a very long time (even with all tests disabled).
> >>
> >> Cheers, Mark
> >>
> >> --
> >> Mark Meyer
> >> mark@ofosos.org
>
> Hi Mark,
>
> I built this package twice and it is reproducible! I've moved some
> inputs to native-inputs in the attached patch because they didn't show
> up as requisites for krita (i.e. I ran 'guix gc -R
> /gnu/store/...-krita-3.3.2.1'
> to find this out).
>
> Please tell me if this build works properly for you as it seems to for
> me.
>
> Thanks,
> Kei
>
> Email had 2 attachments:
> + 0001-gnu-Add-krita.patch
> 5k (text/plain)
> + signature.asc
> 1k (application/pgp-signature)


--
Mark Meyer
mark@ofosos.org
From 341c2de5b922e6062e9a65ea88cdfcc6062819e6 Mon Sep 17 00:00:00 2001
From: Mark Meyer <mark@ofosos.org>
Date: Tue, 5 Dec 2017 00:52:42 +0100
Subject: [PATCH] * gnu/packages/kde.scm (krita): Add new variable.

---
gnu/packages/kde.scm | 85 +++++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 84 insertions(+), 1 deletion(-)

Toggle diff (123 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 59271ebee..a384626c0 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,18 +24,29 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphics)
+ #:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
- #:use-module (gnu packages version-control))
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages xorg))
(define-public kdevelop
(package
@@ -220,6 +232,77 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
plugins, as well as code to create plugins, or complete applications.")
(license license:gpl3+)))
+(define-public krita
+ (package
+ (name "krita")
+ (version "3.3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/krita/"
+ "3.3.2/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i3l27cfi1h486m74xf4ynk0pwx32xaqraa91a0g1bpj1jxf2mg5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
+ (string-append "-DWITH_FFTW3="
+ (assoc-ref %build-inputs "fftw"))
+ (string-append "-DWITH_GSL="
+ (assoc-ref %build-inputs "gsl"))
+ (string-append "-DWITH_LibRaw="
+ (assoc-ref %build-inputs "libraw"))
+ (string-append "-DWITH_TIFF="
+ (assoc-ref %build-inputs "libtiff")))))
+ (native-inputs
+ `(("curl" ,curl)
+ ("eigen" ,eigen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("gettext-minimal" ,gettext-minimal)
+ ("kitemmodels" ,kitemmodels)
+ ("qwt" ,qwt)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtx11extras" ,qtx11extras)
+ ("qtsvg" ,qtsvg)
+ ("karchive" ,karchive)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("boost" ,boost)
+ ("exiv2" ,exiv2)
+ ("lcms" ,lcms)
+ ("libpng" ,libpng)
+ ("zlib" ,zlib)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
+ ("libxi" ,libxi)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("poppler-qt5" ,poppler-qt5)
+ ("libraw" ,libraw)
+ ("libtiff" ,libtiff)
+ ("perl" ,perl)))
+ (home-page "https://krita.org")
+ (synopsis "Digital painting application")
+ (description
+ "A digital image editor, primarily aimed at digital painting and animation.")
+ (license license:gpl2+)))
+
(define-public libkomparediff2
(package
(name "libkomparediff2")
--
2.15.0
K
K
Kei Kebreau wrote on 13 Dec 2017 03:51
(name . Mark Meyer)(address . mark@ofosos.org)(address . 29574@debbugs.gnu.org)
87374f1gtn.fsf@posteo.net
Mark Meyer <mark@ofosos.org> writes:

Toggle quote (47 lines)
> Hi Kei,
> Poppler was an easy target, it just pointed to the wrong package. JPEG
> requires some more packaging and EXR some thought. Meanwhile the
> attached patch should be ok.
>
> Cheers, Mark
>
> On Sun, Dec 10, 2017, at 20:32, Kei Kebreau wrote:
>> Mark Meyer <mark@ofosos.org> writes:
>>
>> > On Tue, Dec 5, 2017, at 02:26, Mark Meyer wrote:
>> >> Second try.
>> >>
>> >> I disabled all tests, since these required an X11 display to be present.
>> >> It's running now. I created a new file and saved the output. Looks good.
>> >>
>> >> Please find the patch attached.
>> >>
>> >> Lints fine, but I didn't test if this is reproducible, since the build
>> >> is taking a very long time (even with all tests disabled).
>> >>
>> >> Cheers, Mark
>> >>
>> >> --
>> >> Mark Meyer
>> >> mark@ofosos.org
>>
>> Hi Mark,
>>
>> I built this package twice and it is reproducible! I've moved some
>> inputs to native-inputs in the attached patch because they didn't show
>> up as requisites for krita (i.e. I ran 'guix gc -R
>> /gnu/store/...-krita-3.3.2.1'
>> to find this out).
>>
>> Please tell me if this build works properly for you as it seems to for
>> me.
>>
>> Thanks,
>> Kei
>>
>> Email had 2 attachments:
>> + 0001-gnu-Add-krita.patch
>> 5k (text/plain)
>> + signature.asc
>> 1k (application/pgp-signature)

Great, LGTM. I added some detail to the description and pushed it to master, so you can close this bug.

Also, please be sure to follow our change log conventions, which are
something like these[0]. When in doubt, copy from a recent change log
for a change similar to yours from our repo. Most of the time this works
without a problem.

Thanks,
Kei

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlowlZQACgkQ5qXuPBlG
eg0ZnxAAuwxjp6hTkjhlIeedjVj52lDQTWnR9xrL0M77MqP3wUwhdKIgvdjsl4TE
JYInw5fqwc1v31ILmGpp+gxbBVl/m3pJejkE8QSY9SL7qHSQUjR81Tdnji4YqtBK
sVc6lg2+M6/IVIlanGUky7CBgXcvZlKurm0LM1hNGU2Hoy921jP2pcPOGP24hwfd
1N1OY4IA0qRppjBgYh9owAaXu7AvBpDqM+YGp3Ie/7zCi2OiA+UkEM6ZFyhZ9yPA
qU8FzVog4dGheEPlcB4fLRLa7n/EF+ETM92sPMoWE8w6iNBd0CyJe8bkV2l2XqOR
qo909za0QaILqw04BlZ26oTIecPUNDaqIaG4kSDtDSUqR0mSjiQN8ZzWrKs+OiCZ
MpP3RfgnBlkiYPA24IK3O9UNK/iySeGkv0BOkiQs3exrZt8mgNtjh85KaGO4ou2/
DocuBXYKsj/ArI0NCyfP5gRy4nhiXF/Fe8ooW5Br7i1kgN3Q0qHyAqpSN0MTNo7P
6YrseLbOZldKdEAeSc4ABJrzmKrbs4r7VX+iD6reNY4qYiS1Btd0B85cOd6yPvfK
aU8CTYFAKQQRGtjt7TFfSaJ9plWoMX4YsMgbZLnzYbWWfKr8V66zj3Mbzg21DZr4
2SLc/zO84scA97cdU86ITEYb4jhVSKbg1Jow3wnmM2iTNju9GC8=
=XTk0
-----END PGP SIGNATURE-----

M
M
Mark Meyer wrote on 14 Dec 2017 01:14
Fixed
(address . 29574-close@debbugs.gnu.org)
1513210459.1192027.1204379840.178686AC@webmail.messagingengine.com
Fixed.

--
Mark Meyer
mark@ofosos.org
N
20171214085914.g7w4xgbksytbpscm@abyayala
Mark Meyer transcribed 0.1K bytes:
Toggle quote (6 lines)
> Fixed.
>
> --
> Mark Meyer
> mark@ofosos.org

If XXXX-close@debbugs.gnu.org does something, I think it could be similar to
"disregard, closing as not working on it, dropping this".
XXXX-done@debbugs.gnu.org is what we use for tickets that have been resolved.
There are notes in HACKING and in the chapter 'contributing' about this I
think
Please use this next time

Thanks
--
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAloyPWEACgkQ4i+bv+40
hYjHyQ/+P39lKa5s3nZR9TUrUO+wjA0mGyzeM3U0bQVGerrSoskp9DayU2WmQWnd
l52nTlMlgpbXcvpfLZ0MJQKS/AwEiaON5YD4nKyugPSy9SZsDjdiFmlfX6lYM97F
mSEfiylBnxNt1XtyoGcqW9OW8gUSNCu1PP4LUUnGUtBOrlibDSKPspN2DBQHfPfs
XqHd9he9J/lJ8S5LE9PNemAek/6J9k2Ui4xee6+uXgwJyBbiJPyTYXWPb9G3AeN4
Krj/cstUSTFIhiwu8hLN9Tm4zOB6eCe7Nybjf4BFTDNX+0cR81jaU/dl8TerdU9I
CIzmWdsRjK3rBzoviA3gyVyx+IcALzDHRktzUg0oajeGw198SPSjLf0+ydd+BabM
UQPHo33ieLrtyC3qlv3LupDADNA87eMel1lW4Czyep3w6rQDcCulCbxOJZAkpEWF
YG4NHjFtBxvvJU0H9kNWnzuFJtw3bsES/G1EUqv5cl1MlGTurJ4mPuuUoFJbmD2Z
ghZOrV6sfXPNuEdKN9IpMNvvQPo8tzlsfT3Da4kq//mhdv0etzXa/8UPsxo73Vbq
fdu2rGCypjL5aPOm0Cov8Lwc5OtA0FSA4mPCljCEEn5oaQqZrfY84KGwAJ74ng4a
Cd4ZfttfJTTfwX7RFL1LXtS4HoQjtW79OG1wq+PSTVbv7JAiXxU=
=vIwo
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29574@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29574
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch