[PATCH 1/2] gnu: Add python-olefile.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20171205003422.18643-1-kkebreau@posteo.net
* gnu/packages/python.scm (python-olefile): New variable.
---
gnu/packages/python.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 01b4e2cd2..4304cd7f5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3643,6 +3643,29 @@ Python's distutils.")
services for your Python modules and applications.")
(license license:lgpl3+)))
+(define-public python-olefile
+ (package
+ (name "python-olefile")
+ (version "0.44")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/decalage2/olefile/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wmxbrhyqjry2000zx0zdhqdqxhgi06nz7sbzjlh222q2zjv1gpj"))))
+ (build-system python-build-system)
+ (home-page
+ "https://www.decalage.info/python/olefileio")
+ (synopsis "Read and write Microsoft OLE2 files.")
+ (description
+ "@code{olefile} can parse, read and write Microsoft OLE2 files (Structured
+Storage or Compound Document, Microsoft Office). It is an improved version of
+the OleFileIO module from PIL, the Python Image Library.")
+ (license license:bsd-3)))
+
(define-public python-pillow
(package
(name "python-pillow")
--
2.15.0
Ludovic Courtès wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29571@debbugs.gnu.org)
87608zb0gv.fsf@gnu.org
Hello!

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/python.scm (python-olefile): New variable.

[...]

Toggle quote (5 lines)
> +(define-public python-olefile
> + (package
> + (name "python-olefile")
> + (version "0.44")

Did you purposefully omit the “python2-” variant? If so, please add a
tiny comment explaining this and push.

Thanks,
Ludo’.
Kei Kebreau wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29571-done@debbugs.gnu.org)
87a7yayacr.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (16 lines)
> Hello!
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/python.scm (python-olefile): New variable.
>
> [...]
>
>> +(define-public python-olefile
>> + (package
>> + (name "python-olefile")
>> + (version "0.44")
>
> Did you purposefully omit the “python2-” variant? If so, please add a
> tiny comment explaining this and push.

No, I did not! Added and pushed.

Toggle quote (3 lines)
>
> Thanks,
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlo9OBQACgkQ5qXuPBlG
eg3vIg//SLU5VMfkSkm38aAXdSUEn3RGH8oclK+xdMIhrcrdhn4Fsv0HQalITbI+
m8JxSYEOhSelRV6STfRdYd5wZiJw9uXePguSSyU19dOrQ+tsP+CtcqypRRNZO82z
/j9zEOEqBzm5GYS9sL70PY8rK9++rUyy2bk7xukI5BvsDlQUkK6UtobOAmueLhp5
FJH5mWR49xSByyekXPEhmHo8x+euzDgKlalNPfZCB1CqclryqAKXJrVSqoRZfGxX
EiuogzyKmaaNSCsa5ibUpb+mojfFb6v/ZMQlsu0fiBpvXW9nkUGHb+AdSL2b0rwX
guyCh4Hk5hcU0EsYltWDQal5W32WsWphWiS7yEdVSaqMPRo20+okHum0RtYme65a
XU73n60v+bRYkvfbmVjh4hcEbvUetwj8FwRgQku9FshMMeD4o7jO4d0v06vr49dD
ci8fyaNh100ne/e07s0MVkOq8WY4iYI8tmk3Dw+UmW/Ptcs+xVVJ8cNuB3xMLepD
qLQ6r9PBmbwliY7Laiy/o/wOFTxdYEyACAeSBZ3BR4puF/YlwE8uj+VxqEXdQipo
u0o5uNFDKuVTqDTZBlaeJqrEImoir7iSDGVSN8x7aMmEVuXcym4L6dhHOa1F4PEk
/cV2IVRwa9SP1vgJRIqW2ymbWX1gJjsHmrO3l4+g6kCtimC6Ftg=
=QZcn
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29571@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29571
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help