[PATCH] gnu: diffoscope: Fix error messages related to comparison tools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20171124210958.10089-1-kkebreau@posteo.net
* gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
substitution and add stat and getfacl substitutions.
[inputs]: Add acl.
---
gnu/packages/package-management.scm | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c7a368116..15c310d6e 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -63,6 +63,7 @@
#:use-module (gnu packages ssh)
#:use-module (gnu packages vim)
#:use-module (gnu packages serialization)
+ #:use-module (gnu packages acl)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
@@ -520,7 +521,6 @@ transactions from C or Python.")
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before 'unpack 'n (lambda _ #t))
;; setup.py mistakenly requires python-magic from PyPi, even
;; though the Python bindings of `file` are sufficient.
;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
@@ -535,8 +535,15 @@ transactions from C or Python.")
(string-append "['" (which "xxd") "',")))
(substitute* "diffoscope/comparators/elf.py"
(("@tool_required\\('readelf'\\)") "")
- (("\\['readelf',")
- (string-append "['" (which "readelf") "',")))
+ (("get_tool_name\\('readelf'\\)")
+ (string-append "'" (which "readelf") "'")))
+ (substitute* "diffoscope/comparators/directory.py"
+ (("@tool_required\\('stat'\\)") "")
+ (("@tool_required\\('getfacl'\\)") "")
+ (("\\['stat',")
+ (string-append "['" (which "stat") "',"))
+ (("\\['getfacl',")
+ (string-append "['" (which "getfacl") "',")))
#t))
(add-before 'check 'delete-failing-test
(lambda _
@@ -547,6 +554,7 @@ transactions from C or Python.")
("python-debian" ,python-debian)
("python-libarchive-c" ,python-libarchive-c)
("python-tlsh" ,python-tlsh)
+ ("acl" ,acl) ;for getfacl
("colordiff" ,colordiff)
("xxd" ,xxd)
--
2.15.0
Leo Famulari wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29432@debbugs.gnu.org)
20171125001716.GC17061@jasmine.lan
On Fri, Nov 24, 2017 at 04:09:58PM -0500, Kei Kebreau wrote:
Toggle quote (4 lines)
> * gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
> substitution and add stat and getfacl substitutions.
> [inputs]: Add acl.

Can you add an example of the error messages in the commit message?
Otherwise LGTM.

Toggle quote (9 lines)
> @@ -520,7 +521,6 @@ transactions from C or Python.")
> (build-system python-build-system)
> (arguments
> `(#:phases (modify-phases %standard-phases
> - (add-before 'unpack 'n (lambda _ #t))
> ;; setup.py mistakenly requires python-magic from PyPi, even
> ;; though the Python bindings of `file` are sufficient.
> ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844

Some leftover debugging? :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAloYtowACgkQJkb6MLrK
fwiGchAA072iRug7ZPUs6OdM5R7C+EkoBhSlOLX7Tqj6WH9qM/NPZwSeDqQ8ZT9Y
L05YYapu41AROOIPlI3znBn7HJJOpDAzhG21j/M/zLhJ/8+8X5SSKmR33F4FQFOx
YxbM+pbNCRpoeRE80U51joQjaehppy5BCrciBuM0klGS96RewLyy7tsIrSsQfB1f
rhRvQRq8BBQGDi2sFKTF7xMgr4I8QHdTVlX+5vntrNGrrt54boBHvDXLN9Y5vaOz
OpX9uj5bI4a9UBV0dZ1xs3Fp3CVFpXmoYKuAVchE7CJyLiWGLPLzgj51G8+wCeS8
f2ZiacMcnMWmcEUe8/3e4vWPlSaF9XJ1omfrPlQkPXN4HJvVkb8iR3guXKpfUDYZ
3FDV77X+vV4K3E0ug23PKPWLZqnj5VtmDSoV9Lve92av2kwF84f+a+7zszooMu3J
ujQPY/sDYoGy+4hUI3WQ33b4Yfght5ftvQJnGL3AS6ol9dbuwncz9S64qetTaTM4
Sc7Y7LMdmgwaNt/DVQQR53dZu2Kh/uBEGLWx2YfZDTsLpoOJFvHeEnru9QCQZb0H
TtIjs/kQFKLIH544OJYWUwUcwmtD85PTH9isCmnkoSNp80hIAUMCu4U4un0IrVve
ODfzZNx1GG3Z3/QxdkGo6ZnawmrOVjjH9ASNUu5lis1wHegK6U0=
=mgTB
-----END PGP SIGNATURE-----


Kei Kebreau wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29432@debbugs.gnu.org)
873752jlfr.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (9 lines)
> On Fri, Nov 24, 2017 at 04:09:58PM -0500, Kei Kebreau wrote:
>> * gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
>> substitution and add stat and getfacl substitutions.
>> [inputs]: Add acl.
>
> Can you add an example of the error messages in the commit message?
> Otherwise LGTM.
>

Like this?

Errors fixed include the following:
"FileNotFoundError: [Errno 2] No such file or directory: 'readelf'"
"diffoscope.comparators.directory: Unable to find 'getfacl', some
directory metadata differences might not be noticed."
"diffoscope.comparators.directory: Unable to find 'stat'"
Toggle quote (11 lines)
>> @@ -520,7 +521,6 @@ transactions from C or Python.")
>> (build-system python-build-system)
>> (arguments
>> `(#:phases (modify-phases %standard-phases
>> - (add-before 'unpack 'n (lambda _ #t))
>> ;; setup.py mistakenly requires python-magic from PyPi, even
>> ;; though the Python bindings of `file` are sufficient.
>> ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
>
> Some leftover debugging? :)

You know it! ;)
I figured out that this is unnecessary if one uses --keep-failed when
building with multiple rounds.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAloZrbgACgkQ5qXuPBlG
eg2GwhAAo3rU69Zbrzltemw89CXZWp80HhTsG2NwVGT1knybrPV2OjpMsZK8iZeG
vfIEoTF8m9x8Qj514vMvwd5+AODTuA21K35p8Jl02EKNEN3MPzuc/AlBhJwNm5dE
oc7HDz6n5csgi7o07DYPBeeX87oPiJdvo3eI/kF3WZWGgm7HBqVXy6tVkNUE6GxC
MRl7qhb8In0V1XK5xXJ/geLDn2vgt8zOr0aAIm/qqs3Hlymk4jNXWIMlO1mCz8Oc
ExokFWLhUyz9cJKVvO1GL3jDbsDrg6DzcLS5o2c7zRwvNHbiR7QlFaIrSrfLytQj
kYAMPuCjzpb4GSautFrePvnPT+2fw3fIPf2JNFak0aCxfENZiV0lWGZfvBkVPxUX
SgMQNMZHu4oOc2KL+UMiGkT7V4WmjjDwBsRbyfEouJBNbKGflPwE81T//16K2EyG
cOeVSyJl7hBcVra/xH2OINp0QAaXdUPBQB2K+MhheUlnW0kpwGyPW2HI14rECQNB
k90CaeoYMV1hln+rs1U1xpk3Wh5phIdPyqEjNgTVLgt6qmpTJWrciPvBo+EjJb6G
21wxK352PxxvEPcv5o9vdFyB5ISZyWsQ2HPFgKmTKMDa7KhFS5O0A08IiTg47CUD
ICC1iOO4pJO+G7/7aC6cMv3zFrKdR+O5b6UaPNrHIxFiUr9qV8Y=
=Pd7L
-----END PGP SIGNATURE-----

Leo Famulari wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29432@debbugs.gnu.org)
20171125175710.GA23396@jasmine.lan
On Sat, Nov 25, 2017 at 12:51:52PM -0500, Kei Kebreau wrote:
Toggle quote (19 lines)
> Leo Famulari <leo@famulari.name> writes:
>
> > On Fri, Nov 24, 2017 at 04:09:58PM -0500, Kei Kebreau wrote:
> >> * gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
> >> substitution and add stat and getfacl substitutions.
> >> [inputs]: Add acl.
> >
> > Can you add an example of the error messages in the commit message?
> > Otherwise LGTM.
> >
>
> Like this?
>
> Errors fixed include the following:
> "FileNotFoundError: [Errno 2] No such file or directory: 'readelf'"
> "diffoscope.comparators.directory: Unable to find 'getfacl', some
> directory metadata differences might not be noticed."
> "diffoscope.comparators.directory: Unable to find 'stat'"

Sure!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAloZrvIACgkQJkb6MLrK
fwhCXw//fJbG3rTqtzT9HVppwDv9n5/ocKnFHMbvPlGXvGUcIYPpkgorVhbgDXxB
UEKA+NwPlErk90mTdIfDxt2X9XyQSXUbugZPZQbymiXGrWhVVVBv89HZYbMHDSPV
fUuMiXHzvuDvXcQish+WogWyCejhHYzKCpPvtqH9SiFKM1UbXl1tNV1pJkFptIor
YB8GKREhMS9E/mM1RDOgXU+BZBLxaL18viHajulWjaEALchj6NMTvubV2p50G6ny
BMb67zvz74VaZeL/NDhFN5ivjolmnqdBbh7t1fl6sPt0z7uXjhF8pF4LE9zev0l4
8iODasKTX0B4nWVmMSruxV35YDNpuLSTkGFOAvDfGmM/jj8bit+G39AdauD7WTCg
u2y2bS9V78Yf0+0w2CqRlWut/PCOo97b3D0d1j4iMinSqvbfx48XlgMT8L1CVjSZ
WZM5ptRh7GV+PF0qOUdJZJlxfewxdhB6HFXX14ALPOm0++m1o8/BaAs9IDdyVvho
/o3DmGs4HLHpx1/FOJH0nxUMan6g/GbSImqBEGMY/dAG7lwljEjtxa6OAFXzM5lW
6JwN7sRKzFypVGdXT95urvr1kodeLO7jXLclKX6940R2qb7PhfLr71+2UPvuWfIq
ao6joOrjA8pgsCPFIql2AsJ9E2aIdhnVKJmjN367smBjsJOakGQ=
=bDfK
-----END PGP SIGNATURE-----


Kei Kebreau wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29432-done@debbugs.gnu.org)
87y3muhx8a.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (22 lines)
> On Sat, Nov 25, 2017 at 12:51:52PM -0500, Kei Kebreau wrote:
>> Leo Famulari <leo@famulari.name> writes:
>>
>> > On Fri, Nov 24, 2017 at 04:09:58PM -0500, Kei Kebreau wrote:
>> >> * gnu/packages/package-management.scm (diffoscope)[arguments]: Replace readelf
>> >> substitution and add stat and getfacl substitutions.
>> >> [inputs]: Add acl.
>> >
>> > Can you add an example of the error messages in the commit message?
>> > Otherwise LGTM.
>> >
>>
>> Like this?
>>
>> Errors fixed include the following:
>> "FileNotFoundError: [Errno 2] No such file or directory: 'readelf'"
>> "diffoscope.comparators.directory: Unable to find 'getfacl', some
>> directory metadata differences might not be noticed."
>> "diffoscope.comparators.directory: Unable to find 'stat'"
>
> Sure!

Pushed to master as 2af6be91d59ad5aefe01e90aa9045e26d8667098. Thank you
for the review!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAloZ3oYACgkQ5qXuPBlG
eg1N2hAAgTzbCBUlarDkXxKxUpijBZPWWK6wUWmg4tZ0kv7H8PWXL3c62fQQrrCC
CUwHTcC9/iY6f3PMFuNCz+gi1eBN8nfzzCIb4XBzxN9l71LFLTGCwa7tPK4B4CYL
+T1/eoiMPo5B4TA5v7grK16M17x0uid/G36YcQ/DoMSqAgyDW8+1IfUBg7wTSRq0
8pbsHHzdTMTgS6jakb82QO2ifyPx9hAqgXX5TL2S7/JAtp1SjsI4F+KHGLWhiWSP
Zc4A4hCVIAs7eBbJybbni1G4xva8g95gEYhF/PQ7E00OBe/9zPBeOwYNzhRZS4Vj
1mpE5Znxq2FbyrEDJPWzuxWYtKHpe46mP7d7hpV7TGYHc8kh6v1seeTkkEdXPdVl
70nHWGyV27oqa3/AQCMnGeZa3pWcJ6zDQxDPDgryetQ5HYLJO/c/TQ+Ceu5aiy3a
8GAAeHdG0raUfI63Rq87aogzk6juFpt2Z58OgIMuFY253pW1juw3cg8R2oemowRj
D9AosWIrHGSCYX5xPexxVZXwI7ZhkjIpNDlNRufpWbEOuuJ0Ix8eSXYzcPAosXb4
nDm9HbcdurBCPw59oU6elxEh7XM81dHG9RskthCSTdeKcO+4ezflHCccNSgTOeuZ
w+IwHMMuWzu85OBh4M+yXBUD6XZfrF+x1WAvHOp8/ulAAb57ShE=
=kgdr
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29432@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29432
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help