[PATCH] gnu: Patch path to locale in gnome-desktop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171120210446.14503-1-mail@cbaines.net
* gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-path phase to
get libgnome-desktop to use the full path to the locale binary.
---
gnu/packages/gnome.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 25e0e8fe3..86ec22d33 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -454,6 +454,16 @@ commonly used macros.")
(base32
"0pkq5l1llw8gkjhfq6y58iyj6wac8dh1mc3rzjzn6nd7lrkdx8cg"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc")))
+ (substitute* "libgnome-desktop/gnome-languages.c"
+ (("\"locale\"")
+ (string-append "\"" libc "/bin/locale\"")))
+ #t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("itstool" ,itstool)
--
2.14.1
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 29369@debbugs.gnu.org)
873758zimv.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-path phase to
> get libgnome-desktop to use the full path to the locale binary.

Makes sense. LGTM, thank you!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29369-done@debbugs.gnu.org)
8760a4j9sj.fsf@cbaines.net
Ludovic Courtès writes:

Toggle quote (7 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-path phase to
>> get libgnome-desktop to use the full path to the locale binary.
>
> Makes sense. LGTM, thank you!

Great, I've pushed this as a0fe7c06452ad89d15e38ba2b698228f4fe3a76d.

Thanks for reviewing :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29369@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29369
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help