Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (gnome-desktop)[arguments]: Add 'patch-path phase to
get libgnome-desktop to use the full path to the locale binary.
---
gnu/packages/gnome.scm | 10 ++++++++++
1 file changed, 10 insertions(+)
Toggle diff (23 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 25e0e8fe3..86ec22d33 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -454,6 +454,16 @@ commonly used macros.")
(base32
"0pkq5l1llw8gkjhfq6y58iyj6wac8dh1mc3rzjzn6nd7lrkdx8cg"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (assoc-ref inputs "libc")))
+ (substitute* "libgnome-desktop/gnome-languages.c"
+ (("\"locale\"")
+ (string-append "\"" libc "/bin/locale\"")))
+ #t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("itstool" ,itstool)
--
2.14.1