Adding to what Chris Marusich described:
'substitute* works somewhat in the following way:
Toggle snippet (5 lines)
(substitute FILE-string-or-FILE-list-of-strings
((EREGEX-string SYMBOLS-to-put-both-entire-match-and-captures-or-NOTHING)
REPLACEMENT-string))
Toggle snippet (27 lines)
(substitute "file1.txt"
(("a")
"b")
;; ... would replace every "a" with "b".
(("1([[:digit:]]*)([^[:digit:]])" full capture1 capture2)
(string-append full
" 2"
capture1
capture2)))
;; ... would replace "1234A" and "1A" with "1234A 2234A" and "1A 2A",
;; respectively.
(substitute '("file2.txt"
"file3.txt"
"file4.txt")
(("a\\*\n") ; matches literal asterisk (*) followed by a new
; line/line feed.
"b")
;; ... from "a*[newline]" to "b".
(("(1)[^[:digit:]]*" _ interesting-one) ; use "_" capture to not save
; the whole match.
(string-append interesting-one
" 1")))
;; ... from "1A" or from "1ABC" to "1 1" ("A" and "ABC" parts are
;; discarded).
Notice that the regular expression that GNU Guile uses is the extended
one (Extended Regular Expression). See the info page for Guile for more
details (type `info guile' in the terminal, and go to the section
"Regular Expressions", inside that section notice that there is one
talking about backslash escapes, this one is also important for reasons
that you'll see in the next paragrah).
Notice that in Guile backslashes in strings also have special meaning,
so one has to take into account string+regex special meaning when doing
backslash escapes. In the examples given, the replacement for
"file2.txt" onwards shows us how to deal with this.
I hope this helps! ;)
2017-11-22T01:35:59-0800 Chris Marusich wrote:
Toggle quote (21 lines)
>
> Based on your assessment, it looks like the problem is that the
> application hard-codes the "/usr" directory path.
>
> One solution for this problem is to replace that line of code in the
> source with the correct path. You can do this in the package definition
> by using the substitute* macro provided by the (guix build utils)
> module. In fact, it looks like the current package definition for
> openmolar already attempts to do this. Run "guix edit openmolar" to
> view the current package definition.
>
> Perhaps you could modify the package definition to also replace the path
> in localsettings.py? You might also want to look around in the source
> for other paths that need to be fixed (a command such as "grep -r /usr"
> might be helpful).
>
> For information on how to use substitute*, please refer to
> guix/build/utils.scm in the Guix source tree. For general information
> on hacking on Guix, check the section titled "Contributing" in the
> manual (e.g., run info '(guix) Contributing' in a terminal).
--
- Palestrante e consultor sobre /software/ livre (não confundir com
gratis).
- "WhatsApp"? Ele não é livre. Por favor, veja formas de se comunicar
instantaneamente comigo no endereço abaixo.
- Arquivos comuns aceitos (apenas sem DRM): Corel Draw, Microsoft
Office, MP3, MP4, WMA, WMV.
- Arquivos comuns aceitos e enviados: CSV, GNU Dia, GNU Emacs Org, GNU
GIMP, Inkscape SVG, JPG, LibreOffice (padrão ODF), OGG, OPUS, PDF
(apenas sem DRM), PNG, TXT, WEBM.