[PATCH] gnu: Add python-pyodbc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20171119074744.11774-1-dannym@scratchpost.org
* gnu/packages/databases.scm (python-pyodbc, python2-pyodbc): New variables.
---
gnu/packages/databases.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b1cb9ed2b..4c678dd32 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1704,6 +1704,33 @@ for ODBC.")
(define-public python2-pyodbc-c
(package-with-python2 python-pyodbc-c))
+(define-public python-pyodbc
+ (package
+ (name "python-pyodbc")
+ (version "4.0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyodbc" version))
+ (sha256
+ (base32
+ "0a83zwz3h1agshnsc6r7al6q83222w8601gpzzzjvjz5m56ghmcn"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("unixodbc" ,unixodbc)))
+ (arguments
+ `(;; No unit tests exist.
+ #:tests? #f))
+ (home-page "https://github.com/mkleehammer/pyodbc")
+ (synopsis "Python ODBC Library")
+ (description "@code{python-pyodbc} provides a Python DB-API driver
+for ODBC.")
+ (license (license:x11-style "file:///LICENSE.TXT"))))
+
+(define-public python2-pyodbc
+ (package-with-python2 python-pyodbc))
+
(define-public mdbtools
(package
(name "mdbtools")
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 29355@debbugs.gnu.org)
87fu995m4n.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/databases.scm (python-pyodbc, python2-pyodbc): New variables.

LGTM, thanks!

Ludo'.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20171120204717.527257ea@scratchpost.org
close 29355
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29355@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29355
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help