[PATCH] gnu: Add kodi-cli.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Marius Bakke
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 1 Nov 2017 07:48
(address . guix-patches@gnu.org)
8760au8pfk.fsf@gmail.com
From 741284b1619490859910fb402802ab10b31f0fd2 Mon Sep 17 00:00:00 2001
From: Oleg Pykhalov <go.wigust@gmail.com>
Date: Wed, 1 Nov 2017 09:39:05 +0300
Subject: [PATCH] gnu: Add kodi-cli.

* gnu/packages/kodi.scm (kodi-cli): New variable.
---
gnu/packages/kodi.scm | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index c8a65af79..65621e152 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -25,11 +25,13 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -426,3 +428,49 @@ plug-in system.")
license:public-domain ;cpluff/examples
license:bsd-3 ;misc, gtest
license:bsd-2))))) ;xbmc/freebsd
+
+(define-public kodi-cli
+ (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
+ (revision "1")) ; `$HOME/.kodirc'.
+ (package
+ (name "kodi-cli")
+ (version (string-append "1.1-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/nawar/kodi-cli")
+ (commit commit)))
+ (sha256
+ (base32
+ "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system trivial-build-system)
+ (inputs `(("bash" ,bash)))
+ (propagated-inputs `(("curl" ,curl)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ (substitute* "kodi-cli"
+ (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
+ "/bin/bash")))
+ (install-file "kodi-cli" (string-append %output "/bin")))))
+ (home-page "https://github.com/nawar/kodi-cli")
+ (synopsis "Bash script to send commands to Kodi using JSON RPC")
+ (description "@code{kodi-cli} provides the Bash script to send commands to
+Kodi using JSON RPC.
+
+Feautures:
+
+@itemize
+@item Play, pause, stop the current played video.
+@item Skip forward or backward in the current played video.
+@item Play or queue to the current list YouTube video.
+@item Interactive and noninteractive volume control.
+@item Interactive navigation.
+@item Send text.
+@item Toggle fullscreen.
+@item Update or clean Kodi libraries.
+@end itemize\n")
+ (license license:gpl2+))))
--
2.14.3
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAln5bj8ACgkQckbhHGm3
lWl1UQ/9Fn2x3pQrwY2NhmQ7Fh7la3L+rxhAYcjfy5dhbzwMvT0LcI3fll+De6XG
dV+/9dWCXqcy4qbRoWE3jjugVvupO9KKSsasaqxDVPEhSHyht/W7Pl5nPZFAb3VH
AiPp3VXxdLKaQc8K96vezuNKQCjFPSkOHCjbrbYroyklrv0Eidzo1xH1ndoduUtf
U+LDq6Ns/N7wJZs6IbPrMlKhnoGg+IYggSwS5j+k1FknznUTF3lZ7rtnJQ7VEBtL
hTYvJZY7U0VAnrOg4CmXwYXPZK9oa/HKjFgFSw6wXtkY3S192w57kZYIOxeGGiCJ
V/OgVxfVD21fqh6S7aUQjuUnhUKuP00i7R0NXogoimpF3Qath0/78u+X8MYc6ZBJ
vxbUxeAXQGvXTH/KQs5HrxcRGOo5JvMqV5yENi+BNf5kSqd47PXToz6JFupqQDGv
yyUnhO+gqi8C/TSrlxXw0BXLWeL3/olJl0F8wQ0QWi4NuCzkQSTmyvD6Xw5WVFwE
QZS2VT8NmUMouO77538sdnMSOJOObgrzpkT6tuHmdIk/fyva1md4d2KqGrGgCpm1
Y3l75iekXN+vMeFvq3T8aMoCKapmDK0R+Ju6xmWAx9m1mdgQF9GJYmiRpoWv8m6U
1cAZncH+yHWKUvwovxnB8hRumJ5CWrx6rMt2fitwPqNntJ/IcrA=
=HwGC
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 1 Nov 2017 22:32
87a8054rd9.fsf@fastmail.com
Hello Oleg!

Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (7 lines)
> From 741284b1619490859910fb402802ab10b31f0fd2 Mon Sep 17 00:00:00 2001
> From: Oleg Pykhalov <go.wigust@gmail.com>
> Date: Wed, 1 Nov 2017 09:39:05 +0300
> Subject: [PATCH] gnu: Add kodi-cli.
>
> * gnu/packages/kodi.scm (kodi-cli): New variable.

Cool!

[...]

Toggle quote (18 lines)
> +(define-public kodi-cli
> + (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
> + (revision "1")) ; `$HOME/.kodirc'.
> + (package
> + (name "kodi-cli")
> + (version (string-append "1.1-" revision "." (string-take commit 7)))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference (url "https://github.com/nawar/kodi-cli")
> + (commit commit)))
> + (sha256
> + (base32
> + "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
> + (file-name (string-append name "-" version "-checkout"))))
> + (build-system trivial-build-system)
> + (inputs `(("bash" ,bash)))
> + (propagated-inputs `(("curl" ,curl)))

There is only one reference to `curl` in the script, can you try to
substitute it with the absolute path and make it a regular input? It's
good to avoid propagation when we can.

Toggle quote (11 lines)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder
> + (begin
> + (use-modules (guix build utils))
> + (copy-recursively (assoc-ref %build-inputs "source") ".")
> + (substitute* "kodi-cli"
> + (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
> + "/bin/bash")))
> + (install-file "kodi-cli" (string-append %output "/bin")))))

(install-file ...) has an unspecified return value, so please return #t here.

Toggle quote (3 lines)
> + (synopsis "Bash script to send commands to Kodi using JSON RPC")

Maybe just "Control Kodi from the command line".

Toggle quote (3 lines)
> + (description "@code{kodi-cli} provides the Bash script to send commands to
> +Kodi using JSON RPC.

Similarly, this sentence can be reduced to something like
"@code{kodi-cli} is a tool for sending commands to a Kodi server using
JSON-RPC.". Bash is an boring implementation detail IMO. :-)

Toggle quote (2 lines)
> +
> +Feautures:
^ Stray 'u' character.

Toggle quote (4 lines)
> +
> +@itemize
> +@item Play, pause, stop the current played video.

"currently playing"

Toggle quote (2 lines)
> +@item Skip forward or backward in the current played video.

Same here. Maybe it should be "currently playing item", since I assume
this works for music as well.

Toggle quote (2 lines)
> +@item Play or queue to the current list YouTube video.

"List of YouTube videos"?

Toggle quote (4 lines)
> +@item Interactive and noninteractive volume control.
> +@item Interactive navigation.
> +@item Send text.

What does this mean? Arbitrary commands, or text notifications?

Toggle quote (5 lines)
> +@item Toggle fullscreen.
> +@item Update or clean Kodi libraries.
> +@end itemize\n")
> + (license license:gpl2+))))

LGTM with some cosmetic improvements. And welcome!

By the way, if you use Kodi from Guix, feel free to update the 18
snapshot if you can. My media PC died a while back, and I didn't get a
replacement yet, so I have not been able to maintain the Kodi package.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAln6PXIACgkQoqBt8qM6
VPqEGggAuTMBXdXJFLxDxp8MZjux4GAnbW4YaiFM5WoobSMSozTGUZqfteh/EP/6
tpzXIL3IRjgPXGH+rj4HLxynnZaLZIYOKr1I2ct3hwojKr07n3QjQcXNDk6wHQBW
JqXvliNbBOkbTh6O6ZRVKsrGGY6gv2M+9Lf5DwX12A/50e29MmknrG1monAKJTW2
woXBrKYyNFh5+Hl2yXYM9VcFBW3qZhkUAJD+lg73WHIJEcAXLE3uHNWMAegwi7SF
RqtjBvM+JfOXNFnWdHy6Iw38/d3k+PrRo4XerMjw/pDEVotV7bJv80QmfUnWaSMo
D0Q0sp5hGaZAyzTMakr4OB4o10KsYQ==
=IuuB
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 2 Nov 2017 10:14
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 29099@debbugs.gnu.org)
87mv45vy7l.fsf@gmail.com
Hello Marius,

Thank you for review!

Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (22 lines)
>> +(define-public kodi-cli
>> + (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
>> + (revision "1")) ; `$HOME/.kodirc'.
>> + (package
>> + (name "kodi-cli")
>> + (version (string-append "1.1-" revision "." (string-take commit 7)))
>> + (source (origin
>> + (method git-fetch)
>> + (uri (git-reference (url "https://github.com/nawar/kodi-cli")
>> + (commit commit)))
>> + (sha256
>> + (base32
>> + "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
>> + (file-name (string-append name "-" version "-checkout"))))
>> + (build-system trivial-build-system)
>> + (inputs `(("bash" ,bash)))
>> + (propagated-inputs `(("curl" ,curl)))
>
> There is only one reference to `curl` in the script, can you try to
> substitute it with the absolute path and make it a regular input? It's
> good to avoid propagation when we can.

Done. I also added input mps-youtube and did the same.

Toggle quote (13 lines)
>> + (arguments
>> + `(#:modules ((guix build utils))
>> + #:builder
>> + (begin
>> + (use-modules (guix build utils))
>> + (copy-recursively (assoc-ref %build-inputs "source") ".")
>> + (substitute* "kodi-cli"
>> + (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
>> + "/bin/bash")))
>> + (install-file "kodi-cli" (string-append %output "/bin")))))
>
> (install-file ...) has an unspecified return value, so please return #t here.

Done.

Toggle quote (5 lines)
>> + (synopsis "Bash script to send commands to Kodi using JSON RPC")
>
> Maybe just "Control Kodi from the command line".

Done.

Toggle quote (7 lines)
>> + (description "@code{kodi-cli} provides the Bash script to send commands to
>> +Kodi using JSON RPC.
>
> Similarly, this sentence can be reduced to something like
> "@code{kodi-cli} is a tool for sending commands to a Kodi server using
> JSON-RPC.". Bash is an boring implementation detail IMO. :-)

Done.

Toggle quote (4 lines)
>> +
>> +Feautures:
> ^ Stray 'u' character.

Done.

Toggle quote (6 lines)
>> +
>> +@itemize
>> +@item Play, pause, stop the current played video.
>
> "currently playing"

Done.

Toggle quote (5 lines)
>> +@item Skip forward or backward in the current played video.
>
> Same here. Maybe it should be "currently playing item", since I assume
> this works for music as well.

Done.

Toggle quote (4 lines)
>> +@item Play or queue to the current list YouTube video.
>
> "List of YouTube videos"?

Done.

Toggle quote (6 lines)
>> +@item Interactive and noninteractive volume control.
>> +@item Interactive navigation.
>> +@item Send text.
>
> What does this mean? Arbitrary commands, or text notifications?

From my experience this allows you do the following:

1. Open Videos.
2. Add videos…
3. Select <none>.
4. Enter path by sending a command via 'kodi-cli -t PATH'.

Maybe call this item of the feature list as
“Send text to the Kodi keyboard”?


New patch is attached.
From 82691aa8ec24ebad702867e006014f34eaceeb93 Mon Sep 17 00:00:00 2001
From: Oleg Pykhalov <go.wigust@gmail.com>
Date: Wed, 1 Nov 2017 09:39:05 +0300
Subject: [PATCH] gnu: Add kodi-cli.

* gnu/packages/kodi.scm (kodi-cli): New variable.
---
gnu/packages/kodi.scm | 59 +++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index c8a65af79..8c49f720a 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -25,11 +25,13 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -426,3 +428,60 @@ plug-in system.")
license:public-domain ;cpluff/examples
license:bsd-3 ;misc, gtest
license:bsd-2))))) ;xbmc/freebsd
+
+(define-public kodi-cli
+ (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
+ (revision "1")) ; `$HOME/.kodirc'.
+ (package
+ (name "kodi-cli")
+ (version (string-append "1.1-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/nawar/kodi-cli")
+ (commit commit)))
+ (sha256
+ (base32
+ "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system trivial-build-system)
+ (inputs
+ `(("bash" ,bash)
+ ("curl" ,curl)
+ ("mps-youtube" ,mps-youtube)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (copy-recursively (assoc-ref %build-inputs "source") ".")
+ (substitute* "kodi-cli"
+ (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
+ "/bin/bash"))
+ (("output=\\$\\((curl)" all curl)
+ (string-append "output=$("
+ (assoc-ref %build-inputs "curl")
+ "/bin/" curl))
+ (("play_youtube `(mpsyt)" all mpsyt)
+ (string-append "play_youtube `"
+ (assoc-ref %build-inputs "mps-youtube")
+ "/bin/" mpsyt)))
+ (install-file "kodi-cli" (string-append %output "/bin"))
+ #t)))
+ (home-page "https://github.com/nawar/kodi-cli")
+ (synopsis "Control Kodi from the command line")
+ (description "@code{kodi-cli} is a tool for sending commands to a Kodi
+server using JSON RPC.
+
+Features:
+
+@itemize
+@item Play, pause, stop the current playing item.
+@item Skip forward or backward in the current playing item.
+@item Play or queue to the current list YouTube videos.
+@item Interactive and noninteractive volume control.
+@item Interactive navigation.
+@item Send text.
+@item Toggle fullscreen.
+@item Update or clean Kodi libraries.
+@end itemize\n")
+ (license license:gpl2+))))
--
2.14.3
Toggle quote (11 lines)
>> +@item Toggle fullscreen.
>> +@item Update or clean Kodi libraries.
>> +@end itemize\n")
>> + (license license:gpl2+))))
>
> LGTM with some cosmetic improvements. And welcome!
>
> By the way, if you use Kodi from Guix, feel free to update the 18
> snapshot if you can. My media PC died a while back, and I didn't get a
> replacement yet, so I have not been able to maintain the Kodi package.

OK. I do, but not much. Primarily use it on a “media tablet”. :-)

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAln64g4ACgkQckbhHGm3
lWmIsQ//ZH+Wv9+iApNTUZjYV7cGdnkWHfrTMt/xNj24yKQGi0qlR5x118J8aRFQ
WA7b8oep9hy1WBOIXgK3yTsxuXtfq/f2suzPl7ckXrxhtEqUBcqZZtTnGoiGNBdI
2t/DqkKOWlZXOw/DTZaOnY2SlZ9Lqp72bSq663YRmnFuZhgBfpjydc+aJPwNl5np
BBViS2CZZc/ii4EK1IqPzkpEtHBUsuXhqX/4CLPmduBUPKD8J1DrA0oTSGqxv4c8
wVYk1jHAvobjtjJvrfimcaf0PAC1+d135Rk1y3n2loWvyhJgyxJfp6pw5Y0eGNaM
fP+vY3eVfNoszjJcWakgHRgUdjgabKMMwCm/S+lPYFwximMlDkCUjV5Z4SgMSwGh
VsTePZfd0WYYwKwOfxNKhpen1N64Y4v8t8w+LHbgFuBtDZRrIotQVl/Gta4Scwo5
+k7RMxqfE/8uIKYeJ5UwcVWAoCr1mrtngiKyVdRQtswZUEubC2nN3WOEz3LAy/x4
u0vfXbLrnQ7JVHMGaEG4sO2/rhENIQeeC9j+7QLinrYgrtavs2VBCAlPRIyywwFd
n3FxzOCG+H1asfFbZGyhyP1b8w1ZSwjsXh8q8uim7Ai9lH3SvkSLwOXUxVnJXIU5
hM5O8/XH3MkaaFo03/TqGx4WZ4TnxXB6ZwZ0IxamTLHsjMnGYkM=
=11Ev
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 2 Nov 2017 21:00
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 29099@debbugs.gnu.org)
87zi8430z5.fsf@fastmail.com
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (30 lines)
> Hello Marius,
>
> Thank you for review!
>
> Marius Bakke <mbakke@fastmail.com> writes:
>
>>> +(define-public kodi-cli
>>> + (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
>>> + (revision "1")) ; `$HOME/.kodirc'.
>>> + (package
>>> + (name "kodi-cli")
>>> + (version (string-append "1.1-" revision "." (string-take commit 7)))
>>> + (source (origin
>>> + (method git-fetch)
>>> + (uri (git-reference (url "https://github.com/nawar/kodi-cli")
>>> + (commit commit)))
>>> + (sha256
>>> + (base32
>>> + "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
>>> + (file-name (string-append name "-" version "-checkout"))))
>>> + (build-system trivial-build-system)
>>> + (inputs `(("bash" ,bash)))
>>> + (propagated-inputs `(("curl" ,curl)))
>>
>> There is only one reference to `curl` in the script, can you try to
>> substitute it with the absolute path and make it a regular input? It's
>> good to avoid propagation when we can.
>
> Done. I also added input mps-youtube and did the same.

Excellent.

Toggle quote (16 lines)
>>> +@item Interactive and noninteractive volume control.
>>> +@item Interactive navigation.
>>> +@item Send text.
>>
>> What does this mean? Arbitrary commands, or text notifications?
>
> From my experience this allows you do the following:
>
> 1. Open Videos.
> 2. Add videos…
> 3. Select <none>.
> 4. Enter path by sending a command via 'kodi-cli -t PATH'.
>
> Maybe call this item of the feature list as
> “Send text to the Kodi keyboard”?

"Send text to the Kodi keyboard" is much better, thanks!

Toggle quote (2 lines)
> New patch is attached.

[...]

Toggle quote (18 lines)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder
> + (begin
> + (use-modules (guix build utils))
> + (copy-recursively (assoc-ref %build-inputs "source") ".")
> + (substitute* "kodi-cli"
> + (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
> + "/bin/bash"))
> + (("output=\\$\\((curl)" all curl)
> + (string-append "output=$("
> + (assoc-ref %build-inputs "curl")
> + "/bin/" curl))
> + (("play_youtube `(mpsyt)" all mpsyt)
> + (string-append "play_youtube `"
> + (assoc-ref %build-inputs "mps-youtube")
> + "/bin/" mpsyt)))

FYI, you could also use (which "curl") etc from (guix build utils) here,
but I usually prefer this form.

[...]

Toggle quote (4 lines)
> +@itemize
> +@item Play, pause, stop the current playing item.
> +@item Skip forward or backward in the current playing item.

These should be "currently playing".

Toggle quote (2 lines)
> +@item Play or queue to the current list YouTube videos.

"... current list of YouTube videos."

(note the "of")

LGTM otherwise. Don't forget to add a copyright line for yourself.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAln7eU8ACgkQoqBt8qM6
VPquawf+KndR6f5zs5LHkM3FzM8W+ero3tgPwAiWZeza+c3os9YZs9NrStOatchE
XT6OViWp+rRKQt7viU+qqdBnV5lmREXbFXg+h8Wxzh9MCwpn++Gn80HqukYQSAJk
k7Ay5PheaNulh3q2/Ydq+v/I4UpdbIwyJxNXN5KDmo1dMoMOZyJHChHHQ27/Cd26
32ttZxafN6StjJLZDd8S9useW4U3H+E8nzed+4vx0wv/CV2HIXv/qj9ErKfClmj3
30w08qk1iKKrQpOJJhJHqsljgL37sJg1xeB18gCY0V+FgYP/LrQar5dKV3fLp5lH
HB4SgJ2ZewTEywCOnM7I/KjSNknuIA==
=RL18
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 3 Nov 2017 04:57
(name . Marius Bakke)(address . mbakke@fastmail.com)
87fu9wggku.fsf@gmail.com
Marius Bakke <mbakke@fastmail.com> writes:

[...]

Toggle quote (26 lines)
>> Maybe call this item of the feature list as
>> “Send text to the Kodi keyboard”?
>
> "Send text to the Kodi keyboard" is much better, thanks!
>
>> + (arguments
>> + `(#:modules ((guix build utils))
>> + #:builder
>> + (begin
>> + (use-modules (guix build utils))
>> + (copy-recursively (assoc-ref %build-inputs "source") ".")
>> + (substitute* "kodi-cli"
>> + (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
>> + "/bin/bash"))
>> + (("output=\\$\\((curl)" all curl)
>> + (string-append "output=$("
>> + (assoc-ref %build-inputs "curl")
>> + "/bin/" curl))
>> + (("play_youtube `(mpsyt)" all mpsyt)
>> + (string-append "play_youtube `"
>> + (assoc-ref %build-inputs "mps-youtube")
>> + "/bin/" mpsyt)))
>
> FYI, you could also use (which "curl") etc from (guix build utils) here,
> but I usually prefer this form.

Thanks for notice. I prefer a form used in attached patch, too.

Toggle quote (6 lines)
>> +@itemize
>> +@item Play, pause, stop the current playing item.
>> +@item Skip forward or backward in the current playing item.
>
> These should be "currently playing".

Done.

Toggle quote (6 lines)
>> +@item Play or queue to the current list YouTube videos.
>
> "... current list of YouTube videos."
>
> (note the "of")

Done.

Toggle quote (2 lines)
> LGTM otherwise. Don't forget to add a copyright line for yourself.

OK. I think it's fine to merge it now.


Pushed as 72df48dbad95c3bc70a2962f496420ce3363d0de

Oleg,
Thanks.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEc+OyAXw1EaDPCmAPckbhHGm3lWkFAln76REACgkQckbhHGm3
lWnJnQ//dxqWnZQgjqyKchtZYabT1an0oGWvHSliWbFJBXU+ApwB5m/9LOsErDAe
Ainf8Tj/+A4z0nnXtsTxIrpcvCmWljXd9zFNlNg0XqGoM150JhUPtppltWO/2dJ0
uWs3o6FnhcupLIfeSVGVA6tu+56hQ4SPZ/NO5jXz0C6/VbB5ABxEFq7clZhIkYiS
IrlZNiE9wpGnkNxL1oVJDtTZFhR5cYE3R/lprZgDhtP4g5E87DnzbEJtgqyeWuI5
iZhSqvEGLgMxHRToIR7Qmu9eDb7c9AFaoE9b71NvP9B8w/5ApLVXynebr4rwaM5W
q3qlromKKt+p7+s2Aon1vQquDsAIxNW6qFThOt9ChaknaJpL5aMf8PKHE2NWqN3T
sfWK4ITrFZ06ge0YgzRcl/9WUKTDMAtR0qVJKoxwag51kjpuGzCPaDAeNCS/1Anp
xToV0+S7YtAOq4ciPR+d9y0wArP1Rr4Lr0+emXIhc1KDAiBdYRcV86axwNdDl8tm
VY1U/GxGnUoMvmE1+D+wMbyE9kbELINFn3YhN6hAaXknJXF1Lmpz8Bp4NagiQq4c
biX11ACwQGzHZdaa/kxlEIf5Gpr8a4I8VwqrG2sMoM1MxXCicmYMZWuvpiIUWt8u
jH47FOZIHXtACUPpI36uuPQV6Hx0PzHlp3+XWGR4CEIC/yQK+eg=
=bknp
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 29099@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29099
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch