[PATCH] gnu: Add r-directlabels.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171031180928.26880-1-kyle@kyleam.com
* gnu/packages/statistics.scm (r-directlabels): New variable.
---
gnu/packages/statistics.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3367c7aa4..062a4ea38 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5527,3 +5527,27 @@ tools.")
"The goal of tgconfig is to provide infrastructure for managing package
parameters.")
(license license:gpl3))))
+
+(define-public r-directlabels
+ (package
+ (name "r-directlabels")
+ (version "2017.03.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "directlabels" version))
+ (sha256
+ (base32
+ "01ahw0c56mnzwl611s8hnghicww4c4dgf5v2wv6bl1s1pramw9pr"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quadprog" ,r-quadprog)))
+ (home-page "http://directlabels.r-forge.r-project.org/")
+ (synopsis "Direct labels for multicolor plots")
+ (description
+ "This package provides an extensible framework for automatically placing
+direct labels onto multicolor plots. Label positions are described using
+positioning methods that can be re-used across several different plots. There
+are heuristics for examining @code{trellis} and @code{ggplot} objects and
+inferring an appropriate positioning method.")
+ (license license:gpl3)))
--
2.14.3
Ludovic Courtès wrote 7 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 29090-done@debbugs.gnu.org)
871sl7hxln.fsf@gnu.org
Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/statistics.scm (r-directlabels): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29090@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29090
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help