Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/dictionaries.scm (hunspell-en-US): New variable.
---
gnu/packages/dictionaries.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 062c29b66..0cc7df394 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -252,3 +253,39 @@ translator powered by Google Translate (default), Bing Translator,
Yandex.Translate and Apertium. It gives you easy access to one of these
translation engines from your terminal.")
(license public-domain)))
+
+(define-public hunspell-en-US
+ (package
+ (name "hunspell-en-US")
+ (version "2017.01.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/hunspell-en_US/trunk/"
+ version "/+download/hunspell-en_US-" version
+ ".zip"))
+ (sha256
+ (base32
+ "0svc3m09vz7q37481a0lrf6j2raw65zqg6lazic06s7f1vc6h92i"))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:builder (begin
+ (use-modules (guix build utils))
+
+ (let* ((dict (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out"))
+ (share (string-append out "/share/hunspell"))
+ (unzip (string-append
+ (assoc-ref %build-inputs "unzip")
+ "/bin/unzip")))
+ (mkdir-p share)
+ (zero? (system* unzip dict "-d" share))))
+ #:modules ((guix build utils))))
+ (native-inputs
+ `(("source" ,source)
+ ("unzip" ,unzip)))
+ (home-page "http://wordlist.aspell.net/")
+ (synopsis "American English dictionary for use with hunspell")
+ (description
+ "This is an American English dictionary for use with the hunspell spell
+checker.")
+ (license (non-copyleft "file://README_en_US.txt"))))
--
2.14.3