[PATCH] gnu: Add sakura.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20171030220650.18578-1-kkebreau@posteo.net
* gnu/packages/terminals.scm (sakura): New variable.
---
gnu/packages/terminals.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 2fa5f7e4c..d6ebdb6a7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -27,6 +27,7 @@
(define-module (gnu packages terminals)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
@@ -51,6 +52,7 @@
#:use-module (gnu packages wm)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
#:use-module (srfi srfi-26))
(define-public tilda
@@ -537,3 +539,33 @@ eye-candy, customizable, and reasonably lightweight.")
license:silofl1.1
license:x11
license:bsd-3)))))
+
+(define-public sakura
+ (package
+ (name "sakura")
+ (version "3.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/" name "/trunk/"
+ version "/+download/" name "-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0fhcn3540iw22l5zg3njh5z8cj0g2n9p6fvagjqa5zc323jfsc7b"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; no check phase
+ '(#:tests? #f))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("perl" ,perl) ; for pod2man
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxft" ,libxft)
+ ("vte" ,vte)))
+ (home-page "https://launchpad.net/sakura")
+ (synopsis "A simple but powerful libvte-based terminal emulator")
+ (description "@code{Sakura} is a terminal emulator based on GTK+ and VTE.
+It's a terminal emulator with few dependencies, so you don't need a full GNOME
+desktop installed to have a decent terminal emulator.")
+ (license license:gpl2)))
--
2.14.3
Leo Famulari wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 29075@debbugs.gnu.org)
20171031022551.GA11166@jasmine.lan
On Mon, Oct 30, 2017 at 06:06:50PM -0400, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/terminals.scm (sakura): New variable.

Thanks, LGTM! Please remember to add yourself to the list of copyright
headers in 'gnu/packages/terminals.scm'.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAln33y4ACgkQJkb6MLrK
fwjtbhAAg3/2eJiWuWuBZefGzsCHlWHJR01eZ0K8uYRnDP6MFrEPln0AJRK1qxPy
NtZoZRzo/G5mQMeTJJ9DCRB+Gby7020UQS7azw2Hn9KxybMa8mjJkMjCwS3Af/2j
yE8yj1nXSqUbMtZgXJOZ7D7l1QTZk8B/V64QkgRiRZ7mTxd8mLRZNIVcsWN8sxRU
dX+f4Bzci/wkZrX9YZQJH1FYUc441QlZmtA2k3ENvlWJq4hUezDYWVF66nEw4JbW
Pee1yUoXg0LcMsU85Gwxi/hysINIdIUWdIWv/2foZH60/SO+Kz8JGorGLMgxF2N/
6sLM5qSXH7dA3Wo7lVyt86cGNbXZNJFf2KB52ZmnKfdrI+ttjT66pAiWhXXJOqeg
iGPikLILJsPKQesuJvsOceQfqBInZw9OwmQXMAfUblsP9/qC1GvR4IlDtpK+AdNC
HjSBGetm3ShvMXr+4FJs0jdic6ZscPhwCObAKDqlipjG10a4FYItSKdlDAMk1jKb
P+pfjUcuV02o+v3PmK86rnLlMKr3aLxmtW5uQ+BA2KEt5+wkYQDpu+rG69zFFpiK
+HdPq7DPsiIlgp/de2kfd28p96rTV+ot/2Bws8/H35/vkTCUOzup3P/ZTxzGT2KU
187Eg9lbSEJivqqFacSF5LPf4kABSLe2nLTeKWPLZ97LunWpp8k=
=XCTL
-----END PGP SIGNATURE-----


Kei Kebreau wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 29075-done@debbugs.gnu.org)
87375z8mbi.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (6 lines)
> On Mon, Oct 30, 2017 at 06:06:50PM -0400, Kei Kebreau wrote:
>> * gnu/packages/terminals.scm (sakura): New variable.
>
> Thanks, LGTM! Please remember to add yourself to the list of copyright
> headers in 'gnu/packages/terminals.scm'.

Thank you for reviewing. I've pushed this to master as
90bf26088eed513bb93222daa533da2b43fa4b20.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAln4fgEACgkQ5qXuPBlG
eg357Q//SKnwUIww/K/HuuUzF7e3XClS+6wdFTRhPhL+MuBr11ndlJmD/DATGR8G
//3LWx9UFUaCsm22gYk1npVYkeU9105ARIEu9oR6poO+T9gYf133f6GJfwlb+E0Z
2mobjz6dt3sDi6KymFzjorbcdOfZqpX6wOvV3TT0xSYeWIuXTgteAqW+ABPXd2K5
txuiYSqqfeSKgqGfNyT6HZyHcH3bt9w7jZ87SoPR50r13lxkb54PWh/OHx2trxdf
9Q+U8xxM+aCC/XkKxM5jne/QtCprgWEPSGacolViP4mbiiEgWGnBrzFv1BByCxr9
8YnYzojwhUu8p9aXIVJGQRCRNY691luuB3fw96pVsyIGJ5PPeQItKVopU+wOWBdZ
D+n7V+zw9MCADeNa8B/ezy6TKlnlQVRS2T6fKjmJG6o9n76gkH14rxFNePkLJBgH
eIreW9ET018uaJyBp7OPmgfsMVTrOhPbaohK+HItY0bz/+7C40JEhEPcuU+kDffo
SbRg2G9kV0z3r8JIbfHaSc4fRL2fxE6BP074VT1htkdEP73iNGSSFIcZsRi+Ouur
3lVN41TdCVU8uvdBh58+4Ce8i6tpqIXyO7hBpDtkR90dW8h1VxlFjEUjfobhr8bO
iwy/SR1ZDa7e49B7mX6skhFFqIgNyWJD+iDqC5rtohKwfTeiAgw=
=4dqa
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29075@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29075
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help