[PATCH 0/3] Update snakemake (and python-configargparse)

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Marius Bakke
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171026205948.25159-1-kyle@kyleam.com
gnu: python-configargparse: Update to 0.12.0.
gnu: Add python-ratelimiter.
gnu: snakemake: Update to 4.2.0.

gnu/packages/python.scm | 58 ++++++++++++++++++++++++++++++++++++++++---------
1 file changed, 48 insertions(+), 10 deletions(-)

--
2.14.3
Kyle Meyer wrote 7 years ago
[PATCH 1/3] gnu: python-configargparse: Update to 0.12.0.
(address . 29018@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171026210230.25307-1-kyle@kyleam.com
* gnu/packages/python.scm (python-configargparse, python2-configargparse):
Update to 0.12.0.
[arguments]: Enable tests.
[native-inputs]: Add python-pyyaml, which is an optional dependency but
required to run the tests.
---
gnu/packages/python.scm | 24 +++++++++++++++++-------
1 file changed, 17 insertions(+), 7 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f003cb2ef..3f92da44d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2015, 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
@@ -9279,20 +9279,30 @@ config files.")
(define-public python-configargparse
(package
(name "python-configargparse")
- (version "0.10.0")
+ (version "0.12.0")
(source (origin
(method url-fetch)
(uri (string-append
- "https://pypi.python.org/packages/source/C/ConfigArgParse/"
+ "https://pypi.io/packages/source/C/ConfigArgParse/"
"ConfigArgParse-" version ".tar.gz"))
(sha256
(base32
- "19wh919gbdbzxzpagg52q3lm62yicm95ddlcx77dyjc1slyshl1v"))))
+ "0fgkiqh6r3rbkdq3k8c48m85g52k96686rw3a6jg4lcncrkpvk98"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-pyyaml" ,python-pyyaml)))
(arguments
- ;; FIXME: Bug in test suite filed upstream:
- ;; https://github.com/bw2/ConfigArgParse/issues/32
- '(#:tests? #f))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Bypass setuptools-shim because one test relies on "setup.py"
+ ;; being the first argument passed to the python call.
+ ;;
+ ;; NOTE: Many tests do not run because they rely on Python's
+ ;; built-in test.test_argparse, but we remove the unit tests from
+ ;; our Python installation.
+ (zero? (system* "python" "setup.py" "test")))))))
(synopsis "Replacement for argparse")
(description "A drop-in replacement for argparse that allows options to also
be set via config files and/or environment variables.")
--
2.14.3
Kyle Meyer wrote 7 years ago
[PATCH 2/3] gnu: Add python-ratelimiter.
(address . 29018@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171026210230.25307-2-kyle@kyleam.com
* gnu/packages/python.scm (python-ratelimiter, python2-ratelimiter): New
variables.
---
gnu/packages/python.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3f92da44d..fed7394d7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16843,3 +16843,27 @@ interpreter when it prints a stack trace.")
(define-public python2-traceback2
(package-with-python2 python-traceback2))
+
+(define-public python-ratelimiter
+ (package
+ (name "python-ratelimiter")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ratelimiter" version))
+ (sha256
+ (base32
+ "1dhz85mj5bqd2mij84ncs6pz32hgidr79hay4aqfmzaa4rbb497p"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; There are no tests in the pypi archive.
+ (home-page "https://github.com/RazerM/ratelimiter")
+ (synopsis "Simple rate limiting object")
+ (description
+ "The @code{ratelimiter} module ensures that an operation will not be
+executed more than a given number of times during a given period.")
+ (license license:asl2.0)))
+
+(define-public python2-ratelimiter
+ (package-with-python2 python-ratelimiter))
--
2.14.3
Kyle Meyer wrote 7 years ago
[PATCH 3/3] gnu: snakemake: Update to 4.2.0.
(address . 29018@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171026210230.25307-3-kyle@kyleam.com
* gnu/packages/python.scm (snakemake): Update to 4.2.0.
[propagated-inputs]: Add python-appdirs, python-configargparse, python-pyyaml,
and python-ratelimiter, which are dependencies as of Snakemake 4.1.0.
---
gnu/packages/python.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fed7394d7..e8a733919 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6626,13 +6626,13 @@ of the structure, dynamics, and functions of complex networks.")
(define-public snakemake
(package
(name "snakemake")
- (version "3.13.3")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "snakemake" version))
(sha256
- (base32 "1nixb944r4hlskwkzc4wjs34b40xpxpw9gmhhm5p09gvmm22ap5d"))))
+ (base32 "0mgl44q152ws40zj2vicqark5szyd73vqy9pf26g6hk6dk0y0c79"))))
(build-system python-build-system)
(arguments
;; TODO: Package missing test dependencies.
@@ -6651,7 +6651,11 @@ of the structure, dynamics, and functions of complex networks.")
#t)))))
(propagated-inputs
`(("python-wrapt" ,python-wrapt)
- ("python-requests" ,python-requests)))
+ ("python-requests" ,python-requests)
+ ("python-appdirs" ,python-appdirs)
+ ("python-configargparse" ,python-configargparse)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-ratelimiter" ,python-ratelimiter)))
(home-page "https://bitbucket.org/snakemake/snakemake/wiki/Home")
(synopsis "Python-based execution environment for make-like workflows")
(description
--
2.14.3
Marius Bakke wrote 7 years ago
Re: [bug#29018] [PATCH 0/3] Update snakemake (and python-configargparse)
87vaj1y1gp.fsf@fastmail.com
Kyle Meyer <kyle@kyleam.com> writes:

Toggle quote (4 lines)
> gnu: python-configargparse: Update to 0.12.0.
> gnu: Add python-ratelimiter.
> gnu: snakemake: Update to 4.2.0.

Pushed as all three, bringing 'master' to 3414ce9876.

Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlnyZRcACgkQoqBt8qM6
VPrA/gf/aVFxkgzhFe901zuxGn+5B03R7Z8sfPiPEM/0bKN76FjUGJ75A2oL6z0Y
Ehrin1x2tukCBG2OMigUNQSZRcLmu9q/xlpuFz3LoFEtxLVCpu2PYDhkFLgH7WvB
I89BRhkehFd/3kYucbBR/5csQH5KUOFp1AbTP3F0JPsjJ/HsHNlGmfZu7SGLcscG
gT9NVHCDpWbh3pTLQGyi/KFgimrwiSc9cS/+oReGEF9NDa4ZIfRp5iG5L7rXD86h
jZ8ap7AnDA8JRwr1FMZZs8tkG9nOTazeTzVU9S2GWp6mKp2rL22ZgYu8Hjf6hrwx
5OYy1hiQbs7pXoehJtB7Wp9VGkFl6g==
=B639
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 29018@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 29018
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help