[PATCH] gnu: Add r-forcats.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 7 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20171024222116.10715-1-kyle@kyleam.com
* gnu/packages/statistics.scm (r-forcats): New variable.
---
gnu/packages/statistics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b3ebd5abb..2fcef8369 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
+;;; Copyright © 2017 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5442,3 +5443,27 @@ the least concave majorant (LCM), for the half-normal and correlation
distributions, and for computing empirical higher criticism (HC) scores and
the corresponding decision threshold.")
(license license:gpl3+)))
+
+(define-public r-forcats
+ (package
+ (name "r-forcats")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "forcats" version))
+ (sha256
+ (base32
+ "1mvwkynvvgz2vi8dyz11x7xrp53kadjawjcja34hwk1d89qf7g5m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-magrittr" ,r-magrittr)
+ ("r-tibble" ,r-tibble)))
+ (home-page "http://forcats.tidyverse.org")
+ (synopsis "Tools for working with factors")
+ (description
+ "Helpers for reordering factor levels (including moving specified levels
+to front, ordering by first appearance, reversing, and randomly shuffling),
+and tools for modifying factor levels (including collapsing rare levels into
+other, \"anonymising\", and manually \"recoding\").")
+ (license license:gpl3)))
--
2.14.2
Ricardo Wurmus wrote 7 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 28980-done@debbugs.gnu.org)
871slrcnke.fsf@elephly.net
Hi Kyle,

Toggle quote (2 lines)
> * gnu/packages/statistics.scm (r-forcats): New variable.

Thanks. I pushed this to master with commit 4c77abc4d.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28980@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28980
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help