[PATCH] gnu: Add python2-libmpsse.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 7 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20171021190303.30463-1-dannym@scratchpost.org
* gnu/packages/embedded.scm: Add imports.
(python2-libmpsse): New variable.
---
gnu/packages/embedded.scm | 64 +++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index e89f5570b..e74db51ed 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -42,6 +42,8 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages texinfo)
#:use-module (srfi srfi-1))
@@ -867,3 +869,65 @@ the Raspberry Pi chip.")
(synopsis "GCC for VC4")
(description "This package provides @code{gcc} for VideoCore IV,
the Raspberry Pi chip."))))
+
+(define-public python2-libmpsse
+ (package
+ (name "python2-libmpsse")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://storage.googleapis.com/"
+ "google-code-archive-downloads/v2/"
+ "code.google.com/libmpsse/"
+ "libmpsse-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jq7nhqq3na8675jnpfcar3pd3dp3adhhc4lw900swkla01a1wh8"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libftdi" ,libftdi)
+ ("python" ,python-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("swig" ,swig)
+ ("which" ,base:which)))
+ (arguments
+ `(#:tests? #f ; No tests exist.
+ #:make-flags
+ (list (string-append "CFLAGS=-Wall -fPIC -fno-strict-aliasing -g -O2 "
+ "$(shell pkg-config --cflags libftdi1)"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-environment-up
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (chdir "src")
+ (setenv "PYDEV" (string-append (assoc-ref inputs "python")
+ "/include/python2.7"))
+ #t))
+ (add-after 'unpack 'patch-global-variable
+ (lambda _
+ ;; fast_rw_buf was defined in a header file which was making
+ ;; the build not reproducible.
+ (substitute* "src/fast.c"
+ (("^int fast_build_block_buffer") "
+
+unsigned char fast_rw_buf[SPI_RW_SIZE + CMD_SIZE];
+int fast_build_block_buffer"))
+ (substitute* "src/mpsse.h"
+ (("unsigned char fast_rw_buf.*") "
+"))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs make-flags #:allow-other-keys #:rest args)
+ (let* ((out (assoc-ref outputs "out"))
+ (out-python (string-append out
+ "/lib/python2.7/site-packages"))
+ (install (assoc-ref %standard-phases 'install)))
+ (install #:make-flags (cons (string-append "PYLIB=" out-python)
+ make-flags))))))))
+ (home-page "https://code.google.com/archive/p/libmpsse/")
+ (synopsis "Python library for MPSSE SPI I2C JTAG adapter by FTDI")
+ (description "This package provides a library in order to support the
+MPSSE adapter by FTDI that can do SPI, I2C, JTAG.")
+ (license license:gpl2+)))
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28928@debbugs.gnu.org)
87d15eyfc6.fsf@gnu.org
Hello Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/embedded.scm: Add imports.
> (python2-libmpsse): New variable.

[...]

Toggle quote (5 lines)
> + (synopsis "Python library for MPSSE SPI I2C JTAG adapter by FTDI")
> + (description "This package provides a library in order to support the
> +MPSSE adapter by FTDI that can do SPI, I2C, JTAG.")

Could you, at least in the description, expand at “MPSSE” and/or give a
bit of context?

Otherwise LGTM, thank you!

Ludo’.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20171023191239.5d3435d3@scratchpost.org
close 28928
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28928@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28928
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help