[PATCH] gnu: Patch ikiwiki to set PERL5LIB in the CGI wrapper.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171017210741.4450-1-mail@cbaines.net
This helps with CGI support.

* gnu/packages/web.scm (ikiwik)[arguments]: Add 'include-PERL5LIB-in-wrapper
phase.
---
gnu/packages/web.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 41e52756e..5c633d6bf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4195,6 +4195,15 @@ NetSurf project.")
#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'include-PERL5LIB-in-wrapper
+ (lambda _
+ (substitute* "IkiWiki/Wrapper.pm"
+ (("^@wrapper\\_hooks")
+ (string-append
+ "@wrapper_hooks\n"
+ " addenv(\"PERL5LIB\", \""
+ (getenv "PERL5LIB")
+ "\");")))))
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.14.2
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28880@debbugs.gnu.org)
87zi8nmvy1.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> This helps with CGI support.
>
> * gnu/packages/web.scm (ikiwik)[arguments]: Add 'include-PERL5LIB-in-wrapper
> phase.

LGTM, thanks!

Ludo'.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28880-done@debbugs.gnu.org)
20171119091907.117fdbca@cbaines.net
On Thu, 19 Oct 2017 09:35:34 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > This helps with CGI support.
> >
> > * gnu/packages/web.scm (ikiwik)[arguments]: Add
> > 'include-PERL5LIB-in-wrapper phase.
>
> LGTM, thanks!

Thanks for reviewing, I've finally got around to pushing this :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAloRTItfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XearRAAgqptkxkydNvpBqBTNHVU/graR7w9u4zQ19LlgzE+yJ0UhaccXnm5Wq+/
suuAZnorciwaRTTCJ6K9cNqdDknbVMuI7Exc91cAwd/cb0k5VsvVevlEp8xCyO0z
xS4QEroCHbE2XPBiXNmFbn1Lg+Ph59QSZbfvKsi9oRBF50KCA6sLcBmr42Dx+QRG
ZtdkiKS0JSPTf1I64HrCbIDjXdB+/Fq6ZG6UIRiKMBYRZJ86O6IUF4POgYv4zhvc
g7dDyPOUq98Zz7N7Fx2f229eU472QASv9z7QpulphuKsVHROZjuBtyg1owOZ/2m9
jW1lyk5fMR4MfThWKlZeYJVu5EIBdGQSZaa1JUe+0Hh2aA7X6fpEggFkp4iMw40C
wzJvn/FAMmBNnPIxYC9XK0Bz3fTsVPiDrNKtYNnyDUr0A37M6Y/Rr4U85zoPbNh6
2W0I4MFjHZX0yUIinpHNwi87nyaU5HkdG8DlKq/hSjL8khncOZ2ArpbmYbTr9AR3
Sh+y82uplhpI4+1MnfTkSLkajcPWYaMZqdp9P8ZMXZiplAWTd/wiO4bt5rNrZ9dy
Jgo7tttNYUIdn79BscRlmGt7TjQrb/O2DX+xTyGlNTcXIwTTVEg4U9/JYfLDMdlX
NQDQlasXmCVn0qULEAt/XewlrZ7YBLaDhXlB7pymNBvKZESJ7p8=
=bOhn
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help