Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
This helps with CGI support.
* gnu/packages/web.scm (ikiwik)[arguments]: Add 'include-PERL5LIB-in-wrapper
phase.
---
gnu/packages/web.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 41e52756e..5c633d6bf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4195,6 +4195,15 @@ NetSurf project.")
#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'include-PERL5LIB-in-wrapper
+ (lambda _
+ (substitute* "IkiWiki/Wrapper.pm"
+ (("^@wrapper\\_hooks")
+ (string-append
+ "@wrapper_hooks\n"
+ " addenv(\"PERL5LIB\", \""
+ (getenv "PERL5LIB")
+ "\");")))))
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.14.2