Some virt-manager improvements

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Patterson
  • 宋文武
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Patterson
Severity
normal

Debbugs page

Andy Patterson wrote 7 years ago
(address . guix-patches@gnu.org)
20171015151545.024a589f@uwaterloo.ca
While trying out virt-manager on GuixSD I ran into some minor issues
creating a VM with the default settings; I'll be sending some fixes for
them to this thread.

--
Andy
Andy Patterson wrote 7 years ago
[PATCH 1/8] gnu: virt-manager: Enable gtk schemas and glib modules support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-1-ajpatter@uwaterloo.ca
Fixes a crash when opening the file chooser dialog.

* gnu/packages/virtualization.scm (virt-manager)[arguments]
<#:imported-modules>: Add (guix build glib-or-gtk-build-system).
<#:modules>: Import (guix build glib-or-gtk-build-system) as glib-or-gtk:.
<#:arguments>: Add 'glib-or-gtk-compile-schemas and 'glib-or-gtk-wrap.
---
gnu/packages/virtualization.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4e384e79a..5cdf6d09b 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -499,9 +499,12 @@ virtualization library.")
;; Some of the tests seem to require network access to install virtual
;; machines.
#:tests? #f
+ #:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%python-build-system-modules)
#:modules ((ice-9 match)
(srfi srfi-26)
(guix build python-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build utils))
#:phases
(modify-phases %standard-phases
@@ -528,7 +531,11 @@ virtualization library.")
`("GI_TYPELIB_PATH" ":" prefix
,(filter identity paths))))
bin-files))
- #t)))))
+ #t))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(inputs
`(("gtk+" ,gtk+)
("gtk-vnc" ,gtk-vnc)
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 2/8] gnu: qemu: Enable spice usb redirection support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-2-ajpatter@uwaterloo.ca
* gnu/packages/virtualization.scm (qemu)[arguments]<#:configure-flags>: New
argument.
[inputs]: Add usbredir.
(qemu-minimal)[arguments]<#:configure-flags>: Restrict them even when they are
set by qemu.
[inputs]: Remove usbredir.
---
gnu/packages/virtualization.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 5cdf6d09b..24ffc2f28 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -85,7 +86,7 @@
'(;; Running tests in parallel can occasionally lead to failures, like:
;; boot_sector_test: assertion failed (signature == SIGNATURE): (0x00000000 == 0x0000dead)
#:parallel-tests? #f
-
+ #:configure-flags '("--enable-usb-redir")
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -152,6 +153,7 @@
("pixman" ,pixman)
("sdl" ,sdl)
("spice" ,spice)
+ ("usbredir" ,usbredir)
("util-linux" ,util-linux)
;; ("vde2" ,vde2)
("virglrenderer" ,virglrenderer)
@@ -188,14 +190,17 @@ server and embedded PowerPC, and S390 guests.")
(name "qemu-minimal")
(synopsis "Machine emulator and virtualizer (without GUI)")
(arguments
- `(#:configure-flags
- ;; Restrict to the targets supported by Guix.
- '("--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu,arm-softmmu,aarch64-softmmu")
- ,@(package-arguments qemu)))
+ (substitute-keyword-arguments (package-arguments qemu)
+ ((#:configure-flags _ '(list))
+ `(list
+ ,(string-append
+ "--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu"
+ ",arm-softmmu,aarch64-softmmu")))))
;; Remove dependencies on optional libraries, notably GUI libraries.
(inputs (fold alist-delete (package-inputs qemu)
- '("libusb" "mesa" "sdl" "spice" "virglrenderer")))))
+ '("libusb" "mesa" "sdl" "spice" "virglrenderer"
+ "usbredir")))))
(define-public libosinfo
(package
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 3/8] gnu: spice-gtk: Enable GObject introspection support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-3-ajpatter@uwaterloo.ca
Allows virt-manager to use the spice-gtk widget.

* gnu/packages/spice.scm (spice-gtk)[inputs]: Add gobject-introspection.
[arguments]<#:configure-flags>: Add --enable-introspection.
---
gnu/packages/spice.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 8e3c5e2b7..7d49f90be 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -162,6 +162,7 @@ which allows users to view a desktop computing environment.")
("spice-protocol" ,spice-protocol)))
(inputs
`(("glib-networking" ,glib-networking)
+ ("gobject-introspection" ,gobject-introspection)
("gtk+" ,gtk+)
("libepoxy" ,libepoxy)
("libjpeg" ,libjpeg)
@@ -182,7 +183,8 @@ which allows users to view a desktop computing environment.")
`(#:configure-flags
'("--enable-gstaudio"
"--enable-gstvideo"
- "--enable-pulse")
+ "--enable-pulse"
+ "--enable-introspection")
#:phases
(modify-phases %standard-phases
(add-after
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 4/8] gnu: virt-manager: Enable spice-gtk support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-4-ajpatter@uwaterloo.ca
* gnu/packages/virtualization.scm (virt-manager)[inputs]: Add spice-gtk.
---
gnu/packages/virtualization.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 24ffc2f28..1c69c4a97 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -553,7 +553,8 @@ virtualization library.")
("python2-requests" ,python2-requests)
("python2-ipaddr" ,python2-ipaddr)
("python2-pygobject" ,python2-pygobject)
- ("python2-libxml2" ,python2-libxml2)))
+ ("python2-libxml2" ,python2-libxml2)
+ ("spice-gtk" ,spice-gtk)))
;; virt-manager searches for qemu-img or kvm-img in the PATH.
(propagated-inputs
`(("qemu" ,qemu)))
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 5/8] gnu: qemu: Add OpenGL support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-5-ajpatter@uwaterloo.ca
Enables virgl support with spice 0.13+.

* gnu/packages/virtualization.scm (qemu)[arguments]<#:configure-flags>: Add
--enable-opengl.
[inputs]: Add libdrm and libepoxy.
(qemu-minimal)[inputs]: Remove libdrm and libepoxy.
---
gnu/packages/virtualization.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 1c69c4a97..62ba7811e 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -86,7 +86,7 @@
'(;; Running tests in parallel can occasionally lead to failures, like:
;; boot_sector_test: assertion failed (signature == SIGNATURE): (0x00000000 == 0x0000dead)
#:parallel-tests? #f
- #:configure-flags '("--enable-usb-redir")
+ #:configure-flags '("--enable-usb-redir" "--enable-opengl")
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -144,6 +144,8 @@
("libaio" ,libaio)
("libattr" ,attr)
("libcap" ,libcap) ; virtfs support requires libcap & libattr
+ ("libdrm" ,libdrm)
+ ("libepoxy" ,libepoxy)
("libjpeg" ,libjpeg-8)
("libpng" ,libpng)
("libusb" ,libusb) ;USB pass-through support
@@ -200,7 +202,7 @@ server and embedded PowerPC, and S390 guests.")
;; Remove dependencies on optional libraries, notably GUI libraries.
(inputs (fold alist-delete (package-inputs qemu)
'("libusb" "mesa" "sdl" "spice" "virglrenderer"
- "usbredir")))))
+ "usbredir" "libdrm" "libepoxy")))))
(define-public libosinfo
(package
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 6/8] gnu: virt-manager: Enable statistics graphing support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-6-ajpatter@uwaterloo.ca
* gnu/packages/virtualization.scm (virt-manager)[inputs]: Add
python2-pycairo.
---
gnu/packages/virtualization.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 62ba7811e..f2494f74f 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -554,6 +554,7 @@ virtualization library.")
("python2-libvirt" ,python2-libvirt)
("python2-requests" ,python2-requests)
("python2-ipaddr" ,python2-ipaddr)
+ ("python2-pycairo" ,python2-pycairo)
("python2-pygobject" ,python2-pygobject)
("python2-libxml2" ,python2-libxml2)
("spice-gtk" ,spice-gtk)))
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 7/8] gnu: virt-manager: Fix default URI check.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-7-ajpatter@uwaterloo.ca
Allows virt-manager to connect to qemu://system by default.

* gnu/packages/virtualization.scm (virt-manager)[arguments]<#:phases>: Add
'fix-default-uri.
---
gnu/packages/virtualization.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index f2494f74f..bdf9c8274 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -520,6 +520,13 @@ virtualization library.")
(substitute* "virtcli/cliconfig.py"
(("/usr") (assoc-ref outputs "out")))
#t))
+ (add-after 'unpack 'fix-default-uri
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; xen is not available for now - so only patch qemu
+ (substitute* "virtManager/connect.py"
+ (("/usr(/bin/qemu-system)" _ suffix)
+ (string-append (assoc-ref inputs "qemu") suffix)))
+ #t))
(add-before 'wrap 'wrap-with-GI_TYPELIB_PATH
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin"))
--
2.14.2
Andy Patterson wrote 7 years ago
[PATCH 8/8] gnu: virt-manager: Enable persistent configuration support.
(address . 28853@debbugs.gnu.org)(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)
20171015200328.4830-8-ajpatter@uwaterloo.ca
* gnu/packages/virtualization.scm (virt-manager)[inputs]: Add dconf.
---
gnu/packages/virtualization.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index bdf9c8274..be8681d4e 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -551,7 +551,8 @@ virtualization library.")
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(inputs
- `(("gtk+" ,gtk+)
+ `(("dconf" ,dconf)
+ ("gtk+" ,gtk+)
("gtk-vnc" ,gtk-vnc)
("libvirt" ,libvirt)
("libvirt-glib" ,libvirt-glib)
--
2.14.2
宋文武 wrote 7 years ago
Re: [bug#28853] [PATCH 2/8] gnu: qemu: Enable spice usb redirection support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87r2u3kzd0.fsf@member.fsf.org
Andy Patterson <ajpatter@uwaterloo.ca> writes:

Toggle quote (7 lines)
> * gnu/packages/virtualization.scm (qemu)[arguments]<#:configure-flags>: New
> argument.
> [inputs]: Add usbredir.
> (qemu-minimal)[arguments]<#:configure-flags>: Restrict them even when they are
> set by qemu.
> [inputs]: Remove usbredir.

Doesn't the 'configure' script auto-detect usb redirection support when
usbredir is available?

Toggle quote (23 lines)
> ---
> gnu/packages/virtualization.scm | 17 +++++++++++------
> 1 file changed, 11 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 5cdf6d09b..24ffc2f28 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -4,6 +4,7 @@
> ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
> ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
> +;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -85,7 +86,7 @@
> '(;; Running tests in parallel can occasionally lead to failures, like:
> ;; boot_sector_test: assertion failed (signature == SIGNATURE): (0x00000000 == 0x0000dead)
> #:parallel-tests? #f
> -
> + #:configure-flags '("--enable-usb-redir")

In that case, this and ...

Toggle quote (26 lines)
> #:phases
> (modify-phases %standard-phases
> (replace 'configure
> @@ -152,6 +153,7 @@
> ("pixman" ,pixman)
> ("sdl" ,sdl)
> ("spice" ,spice)
> + ("usbredir" ,usbredir)
> ("util-linux" ,util-linux)
> ;; ("vde2" ,vde2)
> ("virglrenderer" ,virglrenderer)
> @@ -188,14 +190,17 @@ server and embedded PowerPC, and S390 guests.")
> (name "qemu-minimal")
> (synopsis "Machine emulator and virtualizer (without GUI)")
> (arguments
> - `(#:configure-flags
> - ;; Restrict to the targets supported by Guix.
> - '("--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu,arm-softmmu,aarch64-softmmu")
> - ,@(package-arguments qemu)))
> + (substitute-keyword-arguments (package-arguments qemu)
> + ((#:configure-flags _ '(list))
> + `(list
> + ,(string-append
> + "--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu"
> + ",arm-softmmu,aarch64-softmmu")))))
>
... can be removed.
宋文武 wrote 7 years ago
Re: [bug#28853] [PATCH 1/8] gnu: virt-manager: Enable gtk schemas and glib modules support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87mv4rkywx.fsf@member.fsf.org
Andy Patterson <ajpatter@uwaterloo.ca> writes:

Toggle quote (2 lines)
> virt-manager: Enable gtk schemas and glib modules support.

How about: Wrap with GSettings schema and GIO modules search paths.

Otherwise, this patch series look good to me, thanks!
Andy Patterson wrote 7 years ago
Re: [bug#28853] [PATCH 2/8] gnu: qemu: Enable spice usb redirection support.
(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28853@debbugs.gnu.org)
20171018221442.6e140c5b@uwaterloo.ca
Hey 宋文武,

Thanks for the review!

On Mon, 16 Oct 2017 21:15:39 +0800
iyzsong@member.fsf.org (宋文武) wrote:

Toggle quote (12 lines)
> Andy Patterson <ajpatter@uwaterloo.ca> writes:
>
> > * gnu/packages/virtualization.scm
> > (qemu)[arguments]<#:configure-flags>: New argument.
> > [inputs]: Add usbredir.
> > (qemu-minimal)[arguments]<#:configure-flags>: Restrict them even
> > when they are set by qemu.
> > [inputs]: Remove usbredir.
>
> Doesn't the 'configure' script auto-detect usb redirection support
> when usbredir is available?

To me, the advantage of specifying the enabled features is that the
build will require the dependencies to be available for that feature
even if they change. So, if more dependencies are required for the
feature in future versions, the build will immediately inform us, rather
than somewhat silently dropping support. Thoughts?

[...]

Thanks,

--
Andy
Andy Patterson wrote 7 years ago
Re: [bug#28853] [PATCH 1/8] gnu: virt-manager: Enable gtk schemas and glib modules support.
(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28853@debbugs.gnu.org)
20171018221906.7f76610a@uwaterloo.ca
Hi,

On Mon, 16 Oct 2017 21:25:18 +0800
iyzsong@member.fsf.org (宋文武) wrote:

Toggle quote (8 lines)
> Andy Patterson <ajpatter@uwaterloo.ca> writes:
>
> > virt-manager: Enable gtk schemas and glib modules support.
>
> How about: Wrap with GSettings schema and GIO modules search paths.
>
> Otherwise, this patch series look good to me, thanks!

Sounds good, updated patch appened:

--
Andy

From f504ccc9e961e7657261a478e278c142b9006e6b Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Sun, 15 Oct 2017 11:47:16 -0400
Subject: [PATCH] gnu: virt-manager: Wrap with GSettings schema and GIO modules
search paths.

Fixes a crash when opening the file chooser dialog.

* gnu/packages/virtualization.scm (virt-manager)[arguments]
<#:imported-modules>: Add (guix build glib-or-gtk-build-system).
<#:modules>: Import (guix build glib-or-gtk-build-system) as glib-or-gtk:.
<#:arguments>: Add 'glib-or-gtk-compile-schemas and 'glib-or-gtk-wrap.
---
gnu/packages/virtualization.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4e384e79a..5cdf6d09b 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -499,9 +499,12 @@ virtualization library.")
;; Some of the tests seem to require network access to install virtual
;; machines.
#:tests? #f
+ #:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%python-build-system-modules)
#:modules ((ice-9 match)
(srfi srfi-26)
(guix build python-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build utils))
#:phases
(modify-phases %standard-phases
@@ -528,7 +531,11 @@ virtualization library.")
`("GI_TYPELIB_PATH" ":" prefix
,(filter identity paths))))
bin-files))
- #t)))))
+ #t))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(inputs
`(("gtk+" ,gtk+)
("gtk-vnc" ,gtk-vnc)
--
2.14.2
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 2/8] gnu: qemu: Enable spice usb redirection support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28853@debbugs.gnu.org)
87shefmpml.fsf@gnu.org
Hello,

Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (21 lines)
> On Mon, 16 Oct 2017 21:15:39 +0800
> iyzsong@member.fsf.org (宋文武) wrote:
>
>> Andy Patterson <ajpatter@uwaterloo.ca> writes:
>>
>> > * gnu/packages/virtualization.scm
>> > (qemu)[arguments]<#:configure-flags>: New argument.
>> > [inputs]: Add usbredir.
>> > (qemu-minimal)[arguments]<#:configure-flags>: Restrict them even
>> > when they are set by qemu.
>> > [inputs]: Remove usbredir.
>>
>> Doesn't the 'configure' script auto-detect usb redirection support
>> when usbredir is available?
>
> To me, the advantage of specifying the enabled features is that the
> build will require the dependencies to be available for that feature
> even if they change. So, if more dependencies are required for the
> feature in future versions, the build will immediately inform us, rather
> than somewhat silently dropping support. Thoughts?

That makes sense to me.

I took the liberty to make the change below, to avoid a rebuild of
‘qemu-minimal’, and applied it.

Thanks,
Ludo’.
Toggle diff (17 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4a711ee7f..49dee07f5 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -192,10 +192,8 @@ server and embedded PowerPC, and S390 guests.")
(arguments
(substitute-keyword-arguments (package-arguments qemu)
((#:configure-flags _ '(list))
- `(list
- ,(string-append
- "--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu"
- ",arm-softmmu,aarch64-softmmu")))))
+ ;; Restrict to the targets supported by Guix.
+ ''("--target-list=i386-softmmu,x86_64-softmmu,mips64el-softmmu,arm-softmmu,aarch64-softmmu"))))
;; Remove dependencies on optional libraries, notably GUI libraries.
(inputs (fold alist-delete (package-inputs qemu)
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 3/8] gnu: spice-gtk: Enable GObject introspection support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87o9p3mpeh.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (5 lines)
> Allows virt-manager to use the spice-gtk widget.
>
> * gnu/packages/spice.scm (spice-gtk)[inputs]: Add gobject-introspection.
> [arguments]<#:configure-flags>: Add --enable-introspection.

Applied.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 4/8] gnu: virt-manager: Enable spice-gtk support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87k1zrmpe4.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (2 lines)
> * gnu/packages/virtualization.scm (virt-manager)[inputs]: Add spice-gtk.

Applied.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 5/8] gnu: qemu: Add OpenGL support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87fuafmp9y.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (7 lines)
> Enables virgl support with spice 0.13+.
>
> * gnu/packages/virtualization.scm (qemu)[arguments]<#:configure-flags>: Add
> --enable-opengl.
> [inputs]: Add libdrm and libepoxy.
> (qemu-minimal)[inputs]: Remove libdrm and libepoxy.

Applied.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 6/8] gnu: virt-manager: Enable statistics graphing support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853@debbugs.gnu.org)
87bml3mp9r.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (3 lines)
> * gnu/packages/virtualization.scm (virt-manager)[inputs]: Add
> python2-pycairo.

Applied.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 7/8] gnu: virt-manager: Fix default URI check.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28853@debbugs.gnu.org)
877evrmp6q.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (5 lines)
> Allows virt-manager to connect to qemu://system by default.
>
> * gnu/packages/virtualization.scm (virt-manager)[arguments]<#:phases>: Add
> 'fix-default-uri.

Applied.

There are only two patches left. 宋文武, I’ll let you conclude with
these two patches since you already started reviewing #1 (which #8
depends on); let me know if you’d prefer to let me take care of these.

Thanks Andy for all these improvements!

Ludo’.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 1/8] gnu: virt-manager: Enable gtk schemas and glib modules support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28853@debbugs.gnu.org)
87o9ouij1y.fsf@gnu.org
Hello,

Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (29 lines)
> On Mon, 16 Oct 2017 21:25:18 +0800
> iyzsong@member.fsf.org (宋文武) wrote:
>
>> Andy Patterson <ajpatter@uwaterloo.ca> writes:
>>
>> > virt-manager: Enable gtk schemas and glib modules support.
>>
>> How about: Wrap with GSettings schema and GIO modules search paths.
>>
>> Otherwise, this patch series look good to me, thanks!
>
> Sounds good, updated patch appened:
>
> --
> Andy
>
> From f504ccc9e961e7657261a478e278c142b9006e6b Mon Sep 17 00:00:00 2001
> From: Andy Patterson <ajpatter@uwaterloo.ca>
> Date: Sun, 15 Oct 2017 11:47:16 -0400
> Subject: [PATCH] gnu: virt-manager: Wrap with GSettings schema and GIO modules
> search paths.
>
> Fixes a crash when opening the file chooser dialog.
>
> * gnu/packages/virtualization.scm (virt-manager)[arguments]
> <#:imported-modules>: Add (guix build glib-or-gtk-build-system).
> <#:modules>: Import (guix build glib-or-gtk-build-system) as glib-or-gtk:.
> <#:arguments>: Add 'glib-or-gtk-compile-schemas and 'glib-or-gtk-wrap.

Since we haven’t heard from 宋文武, I went ahead and committed it.

Thanks!

Ludo’.
Ludovic Courtès wrote 7 years ago
Re: [bug#28853] [PATCH 8/8] gnu: virt-manager: Enable persistent configuration support.
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 28853-done@debbugs.gnu.org)
87efpqiiuj.fsf@gnu.org
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

Toggle quote (2 lines)
> * gnu/packages/virtualization.scm (virt-manager)[inputs]: Add dconf.

Applied. We’re done, thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28853@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28853
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help