[PATCH] gnu: Add emacs-org-plus-contrib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
Blocked by

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171013054542.2032-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-org-plus-contrib): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b29436154..de2b89370 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4005,6 +4005,30 @@ also is an authoring system with unique support for literate programming and
reproducible research.")
(license license:gpl3+)))
+(define-public emacs-org-plus-contrib
+ (package
+ (name "emacs-org-plus-contrib")
+ (version "20170917")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://orgmode.org/elpa/org-plus-contrib-"
+ version ".tar"))
+ (sha256
+ (base32
+ "1ya4kah8kg13ka3gpsw8hn6y8358843g986p1bgw5w77n9bgbwsl"))))
+ (build-system emacs-build-system)
+ (home-page "http://orgmode.org/")
+ (synopsis "Outline-based notes management and organizer (with contrib files)")
+ (description "Org is an Emacs mode for keeping notes, maintaining TODO
+lists, and project planning with a fast and effective plain-text system. It
+also is an authoring system with unique support for literate programming and
+reproducible research.
+
+This package includes all the functionality of the @code{emacs-org} package,
+plus all files that you would find in @file{contrib/} from the git
+repository.")
+ (license license:gpl3+)))
+
(define-public emacs-flx
(package
(name "emacs-flx")
--
2.14.2
Christopher Baines wrote 7 years ago
control message for bug #28805
(address . control@debbugs.gnu.org)
8760bjd2gx.fsf@cbaines.net
block 28805 by 28787
Ludovic Courtès wrote 7 years ago
Re: [bug#28805] [PATCH] gnu: Add emacs-org-plus-contrib.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28805@debbugs.gnu.org)
87shemybat.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-org-plus-contrib): New variable.

[...]

Toggle quote (4 lines)
> +This package includes all the functionality of the @code{emacs-org} package,
> +plus all files that you would find in @file{contrib/} from the git
> +repository.")

I’m sorry to ask ;-), but would it be an option to have a separate
‘emacs-contrib’ package instead? That way people could install
emacs-org, and optionally emacs-contrib on top of it.

If not, this package if perfectly fine.

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28805@debbugs.gnu.org)
20171015200517.253789a0@cbaines.net
On Fri, 13 Oct 2017 23:42:34 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (14 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/emacs.scm (emacs-org-plus-contrib): New variable.
>
> [...]
>
> > +This package includes all the functionality of the @code{emacs-org} package,
> > +plus all files that you would find in @file{contrib/} from the git
> > +repository.")
>
> I’m sorry to ask ;-), but would it be an option to have a separate
> ‘emacs-contrib’ package instead? That way people could install
> emacs-org, and optionally emacs-contrib on top of it.

No problem, I had a similar thought when I was first figuring out what
this contrib thing was.

I've attached my attempt at making an emacs-org-contrib package. Which
binds it to the emacs-org package, propagates emacs-org, as well as
deleting all the files included within the emacs-org package.

Thanks for taking a look,

Chris
From 2c5b66bf198ae77047e7c3d4e5631b10e90981eb Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Wed, 11 Oct 2017 14:46:47 +0100
Subject: [PATCH] gnu: Add emacs-org-contrib.

* gnu/packages/emacs.scm (emacs-org-contrib): New variable.
---
gnu/packages/emacs.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7661855a8..7a97a5471 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4099,6 +4099,49 @@ also is an authoring system with unique support for literate programming and
reproducible research.")
(license license:gpl3+)))
+(define-public emacs-org-contrib
+ (package
+ (inherit emacs-org)
+ (name "emacs-org-contrib")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://orgmode.org/elpa/org-plus-contrib-"
+ (package-version emacs-org) ".tar"))
+ (sha256
+ (base32
+ "1ya4kah8kg13ka3gpsw8hn6y8358843g986p1bgw5w77n9bgbwsl"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'delete-org-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (use-modules (ice-9 ftw))
+ (let ((out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (file)
+ (if (and (not (string-prefix? "." file))
+ (file-exists? file))
+ (delete-file
+ (string-append
+ out
+ "/share/emacs/site-lisp/guix.d/org-contrib-"
+ ,(package-version emacs-org)
+ "/"
+ file))))
+ (scandir
+ (string-append
+ (assoc-ref inputs "emacs-org")
+ "/share/emacs/site-lisp/guix.d/org-"
+ ,(package-version emacs-org))))))))))
+ (propagated-inputs
+ `(("emacs-org" ,emacs-org)))
+ (synopsis "Contributed packages to Org-mode")
+ (description "Org is an Emacs mode for keeping notes, maintaining TODO
+lists, and project planning with a fast and effective plain-text system.
+
+This package includes additional files that you would find in @file{contrib/}
+from the git repository.")))
+
(define-public emacs-flx
(package
(name "emacs-flx")
--
2.14.2
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnjsW1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd3HBAAlJGPD/pqy3TSiC6eNw4izbzfcspP78QrY6I3AFUHU1pTuX+qyePq5yVr
JJlTa/0FecgdWV+gYzEwEz0VS2GvjUNTIUQrSTv/bFGsnhKd87r7SVfsGZ1jkRnf
eB0yU5LaSuSPI5tMhVEoBLzeFBtDwsC6P2JbZz9vAARkx1S5KpTMQ1QIxQeBBd4K
Iw56d2BnB2idgPUZ8pONHFuowHcUT79Q7dNpJTSGY2ssfklPYwqz32axlfddcYxG
bAI4gOotL/W7sgIyPhNokgAu86e+PiWS2Eo0BI9CamZ3CNk1E3BalPiJ1b+nV544
vxM17ZVoLHMyegfMZnSvrekgTCnJhgYIaiutKqvdPpNuvXCvscoWyBiMmxb8JIGr
B22x43sMrvqkyFudQJORe1ObHuYPc8MCbcURwEpPjM5PQvQksC6VzjYo5F3/vhwD
0KBq2Uj0wab1BMf4AjRXFYObCmP9ACGIGKfT3g3n8FC/7lPdXLt22AQFKZ0Ih7wF
lqTRNEQrst3AtynusPVP8TimXEHwosnTBcHBiCEcplymFz5eaMiljhkF7BSyu8V5
FayZa3D4suQN0K5no/43Go7bRp/YWn+0euL+ihdjzDE/L9tRTNn4tCs3DMgrwOgp
V0UPg6Kayf+pJv60EIQPkvlbFdHYopOmjoxtEWgYlZ5k3fWHJZ4=
=oaLM
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28805@debbugs.gnu.org)
877evwurfm.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> On Fri, 13 Oct 2017 23:42:34 +0200
> ludo@gnu.org (Ludovic Courtès) wrote:

[...]

Toggle quote (11 lines)
>> I’m sorry to ask ;-), but would it be an option to have a separate
>> ‘emacs-contrib’ package instead? That way people could install
>> emacs-org, and optionally emacs-contrib on top of it.
>
> No problem, I had a similar thought when I was first figuring out what
> this contrib thing was.
>
> I've attached my attempt at making an emacs-org-contrib package. Which
> binds it to the emacs-org package, propagates emacs-org, as well as
> deleting all the files included within the emacs-org package.

[...]

Toggle quote (36 lines)
> From 2c5b66bf198ae77047e7c3d4e5631b10e90981eb Mon Sep 17 00:00:00 2001
> From: Christopher Baines <mail@cbaines.net>
> Date: Wed, 11 Oct 2017 14:46:47 +0100
> Subject: [PATCH] gnu: Add emacs-org-contrib.
>
> * gnu/packages/emacs.scm (emacs-org-contrib): New variable.
> ---
> gnu/packages/emacs.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7661855a8..7a97a5471 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -4099,6 +4099,49 @@ also is an authoring system with unique support for literate programming and
> reproducible research.")
> (license license:gpl3+)))
>
> +(define-public emacs-org-contrib
> + (package
> + (inherit emacs-org)
> + (name "emacs-org-contrib")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "http://orgmode.org/elpa/org-plus-contrib-"
> + (package-version emacs-org) ".tar"))
> + (sha256
> + (base32
> + "1ya4kah8kg13ka3gpsw8hn6y8358843g986p1bgw5w77n9bgbwsl"))))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'install 'delete-org-files
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (use-modules (ice-9 ftw))

Please use #:modules instead of this inner ‘use-modules’ form (it has
wacky semantic and could be deprecated in the future.)

Toggle quote (18 lines)
> + (let ((out (assoc-ref outputs "out")))
> + (for-each
> + (lambda (file)
> + (if (and (not (string-prefix? "." file))
> + (file-exists? file))
> + (delete-file
> + (string-append
> + out
> + "/share/emacs/site-lisp/guix.d/org-contrib-"
> + ,(package-version emacs-org)
> + "/"
> + file))))
> + (scandir
> + (string-append
> + (assoc-ref inputs "emacs-org")
> + "/share/emacs/site-lisp/guix.d/org-"
> + ,(package-version emacs-org))))))))))

For clarity, what about first buildign up the list of files to delete,
and then actually deleting them?

(let* (…
(org+contrib (map basename (find-files out)))
(org (map basename (find-files org)))
(duplicates (lset-intersection string=? org+contrib org)))
(with-directory-excursion (string-append out …)
(for-each delete-file duplicates))
#t)

WDYT?

Thanks,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28805@debbugs.gnu.org)
20171015211123.08bbae84@cbaines.net
On Sun, 15 Oct 2017 21:44:29 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (52 lines)
> > +(define-public emacs-org-contrib
> > + (package
> > + (inherit emacs-org)
> > + (name "emacs-org-contrib")
> > + (source (origin
> > + (method url-fetch)
> > + (uri (string-append "http://orgmode.org/elpa/org-plus-contrib-"
> > + (package-version emacs-org) ".tar"))
> > + (sha256
> > + (base32
> > + "1ya4kah8kg13ka3gpsw8hn6y8358843g986p1bgw5w77n9bgbwsl"))))
> > + (arguments
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (add-after 'install 'delete-org-files
> > + (lambda* (#:key inputs outputs #:allow-other-keys)
> > + (use-modules (ice-9 ftw))
>
> Please use #:modules instead of this inner ‘use-modules’ form (it has
> wacky semantic and could be deprecated in the future.)
>
> > + (let ((out (assoc-ref outputs "out")))
> > + (for-each
> > + (lambda (file)
> > + (if (and (not (string-prefix? "." file))
> > + (file-exists? file))
> > + (delete-file
> > + (string-append
> > + out
> > + "/share/emacs/site-lisp/guix.d/org-contrib-"
> > + ,(package-version emacs-org)
> > + "/"
> > + file))))
> > + (scandir
> > + (string-append
> > + (assoc-ref inputs "emacs-org")
> > + "/share/emacs/site-lisp/guix.d/org-"
> > + ,(package-version emacs-org))))))))))
>
> For clarity, what about first buildign up the list of files to delete,
> and then actually deleting them?
>
> (let* (…
> (org+contrib (map basename (find-files out)))
> (org (map basename (find-files org)))
> (duplicates (lset-intersection string=? org+contrib org)))
> (with-directory-excursion (string-append out …)
> (for-each delete-file duplicates))
> #t)
>
> WDYT?

That is nice :) I've attached an updated patch.
From 43ad9a4e6db6f4f94d2b2f63cbd9b729f5d4e607 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Wed, 11 Oct 2017 14:46:47 +0100
Subject: [PATCH] gnu: Add emacs-org-contrib.

* gnu/packages/emacs.scm (emacs-org-contrib): New variable.
---
gnu/packages/emacs.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7661855a8..6e9c2a19d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4099,6 +4099,49 @@ also is an authoring system with unique support for literate programming and
reproducible research.")
(license license:gpl3+)))
+(define-public emacs-org-contrib
+ (package
+ (inherit emacs-org)
+ (name "emacs-org-contrib")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://orgmode.org/elpa/org-plus-contrib-"
+ (package-version emacs-org) ".tar"))
+ (sha256
+ (base32
+ "1ya4kah8kg13ka3gpsw8hn6y8358843g986p1bgw5w77n9bgbwsl"))))
+ (arguments
+ `(#:modules ((guix build emacs-build-system)
+ (guix build utils)
+ (guix build emacs-utils)
+ (ice-9 ftw)
+ (srfi srfi-1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'delete-org-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (org (assoc-ref inputs "emacs-org"))
+ (contrib-files
+ (map basename (find-files out)))
+ (org+contrib-files
+ (map basename (find-files org)))
+ (duplicates (lset-intersection
+ string=? contrib-files org+contrib-files)))
+ (with-directory-excursion
+ (string-append
+ out "/share/emacs/site-lisp/guix.d/org-contrib-"
+ ,(package-version emacs-org))
+ (for-each delete-file duplicates))))))))
+ (propagated-inputs
+ `(("emacs-org" ,emacs-org)))
+ (synopsis "Contributed packages to Org-mode")
+ (description "Org is an Emacs mode for keeping notes, maintaining TODO
+lists, and project planning with a fast and effective plain-text system.
+
+This package is equivilent to org-plus-contrib, but only includes additional
+files that you would find in @file{contrib/} from the git repository.")))
+
(define-public emacs-flx
(package
(name "emacs-flx")
--
2.14.2
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnjwOtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xcp5w//Vyp3Lp+HwCDrGm+0QC3aQI5/0ye1NLM1V3rcF1O56WhxPqG8ubV6zceU
ZD/Qw13pt/nPRktlqS5ktksRVJ6oPe09hkR12x+1dZ4RRKhAEH5RgXFM8Bypl/q+
cU05MdZz7QGgfPEeNzF0hDs2GYtSUBcqh1B1aZU7YtJL7TB9OQNGpXDySk54kIc8
Fv4MZ2v0mX8KquQJfxc/UlIsq22Mg65vXXz8LAmgX9MgABT6HQfGs3KhfwGuUYbP
HgCd3aRwe8+dlBVC/zukkLe5rwzVeKs57kEnqEDvBil/Fk67baB7fcCQpbtyInA2
Qj8wklFOBnYfh2MP9KIksqB3e1qF+ALkrg0QhRLxaxmm/HGW75xP5z9QEqcprMCd
zlXNb02z8kBlR7YkadoBbFq3qMdnsNdNZah2w2E9L6Dw1a/aHFq2mTYvF1W4XKUO
KCxFTbnYdq1sel52PMi68RlPbOPV/q2ZHppoJrhhwJHdmFRx29pfvxc/Rv9mkTKj
UNRHNcVi0P0QoNBV+LASM4ULaIOtlB7G2ApFMfQCSbHxFNnCl0EjdBes4UwALGPe
6Xry+hAM8PyQWp15sUKHUga0TiPRSqQW/v/03cWMgi/G57iESXOFpncDKU2KK1ZG
E77FQj3lxQpJ4T1MfzS3MU00ketRBaTHJazb3PSixf+5D26LSHc=
=enMZ
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28805@debbugs.gnu.org)
87inffimbm.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> From 43ad9a4e6db6f4f94d2b2f63cbd9b729f5d4e607 Mon Sep 17 00:00:00 2001
> From: Christopher Baines <mail@cbaines.net>
> Date: Wed, 11 Oct 2017 14:46:47 +0100
> Subject: [PATCH] gnu: Add emacs-org-contrib.
>
> * gnu/packages/emacs.scm (emacs-org-contrib): New variable.

[...]

Toggle quote (17 lines)
> + (modify-phases %standard-phases
> + (add-after 'install 'delete-org-files
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (org (assoc-ref inputs "emacs-org"))
> + (contrib-files
> + (map basename (find-files out)))
> + (org+contrib-files
> + (map basename (find-files org)))
> + (duplicates (lset-intersection
> + string=? contrib-files org+contrib-files)))
> + (with-directory-excursion
> + (string-append
> + out "/share/emacs/site-lisp/guix.d/org-contrib-"
> + ,(package-version emacs-org))
> + (for-each delete-file duplicates))))))))

Awesome. Just return #t and we’re done. :-)

Thank you!

Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28805-done@debbugs.gnu.org)
20171016084055.02cb9ebc@cbaines.net
On Mon, 16 Oct 2017 09:27:57 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (34 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
> > From 43ad9a4e6db6f4f94d2b2f63cbd9b729f5d4e607 Mon Sep 17 00:00:00 2001
> > From: Christopher Baines <mail@cbaines.net>
> > Date: Wed, 11 Oct 2017 14:46:47 +0100
> > Subject: [PATCH] gnu: Add emacs-org-contrib.
> >
> > * gnu/packages/emacs.scm (emacs-org-contrib): New variable.
>
> [...]
>
> > + (modify-phases %standard-phases
> > + (add-after 'install 'delete-org-files
> > + (lambda* (#:key inputs outputs #:allow-other-keys)
> > + (let* ((out (assoc-ref outputs "out"))
> > + (org (assoc-ref inputs "emacs-org"))
> > + (contrib-files
> > + (map basename (find-files out)))
> > + (org+contrib-files
> > + (map basename (find-files org)))
> > + (duplicates (lset-intersection
> > + string=? contrib-files org+contrib-files)))
> > + (with-directory-excursion
> > + (string-append
> > + out "/share/emacs/site-lisp/guix.d/org-contrib-"
> > + ,(package-version emacs-org))
> > + (for-each delete-file duplicates))))))))
>
> Awesome. Just return #t and we’re done. :-)
>
> Thank you!

Great, I've now added #t, and pushed this. Thanks for reviewing :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnkYodfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeT9g/+M2BI2CvtC8/M22LPBarkQEU6gOv5ZYhefK8GlAq8cuMfJS0MQ/GKR4zS
q9sOHowsmYdtAin55Q4FfJCi4E9YGvK6NSrJSNSq2EE5TFOY7lnkQxBixecsHhKm
w0F34jV+9iUWmY9NIXq+vF0G91tVCV1CEteWn1DF4iiofO1Gi9CS5Rd/TTE43twE
QD6LXzMe1sm04bNEbjuIXi+unAanx8gYoO9hRCNmJn3HllxQhbU7ZZfUmkSPdsDL
Po7BNuapA6tOESatta6YsknzGXouD4EbLnxo0n5ofT+LeH8KQ3bebeQFj41UjLt7
atGpqauvjua7LJ45u4xL9dBu+8nkZ5QjCPPDLVPK5q7x48Yo7w+CM0LVVTqba9EQ
0+iHusmzK7AinXlUmpyxuzWUP2W/OWYJf7d0/wplHmKHA07+D6SwxzeX2z1W307i
IwQ/B9NzrDPv21odWZF/sFG6zMrFYi3DvzrR3gy/HQtDLf1WexYwQK4Un3Mzgp6v
TGFuCzGw90blWMEiKQxFg0OPdH5To7uMsNHU2pXdN2yp0/w1DmI/QD4hwzCwUYqj
ru3nJe9Fo3SfJEcxwHybnA7dkNbtCIGJ5rP/oyVSlirgQgKFrEez1t5YPXzv9f7g
4QtkjExF+H/PSB1JqyiMvdG3SsEZdWkqAbTesuK+/Gwp4dBSsT0=
=cwcM
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28805@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28805
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help