[PATCH] gnu: Add emacs-graphviz-dot-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 years ago
(address . guix-patches@gnu.org)
20171013053342.31024-1-mail@cbaines.net
* gnu/packages/emacs.scm (graphviz-dot-mode): New variable.
---
gnu/packages/emacs.scm | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b29436154..d3f87fdc4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1245,6 +1245,55 @@ written in the Go programming language.")
Maps directly inside Emacs.")
(license license:gpl3+)))
+(define-public emacs-graphviz-dot-mode
+ (let ((commit "fdaabbcc95d9156e3dadc84f81a4750c5b692580")
+ (revision "1"))
+ (package
+ (name "emacs-graphviz-dot-mode")
+ (version (string-append "0.3.10-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ppareit/graphviz-dot-mode.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1s1qh5r0xp6hs0rl5yz5mkmjhpg04bh449c7vgjbb1pjsl1dl714"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "texinfo"
+ (substitute* "Makefile"
+ (("\\/usr\\/bin\\/gzip")
+ (string-append (assoc-ref inputs "gzip") "/bin/gzip")))
+ (zero?
+ (system* "make"
+ "clean"
+ "info"
+ (string-append "TEXINFODIR="
+ (assoc-ref inputs "texinfo")
+ "/bin"))))))
+ (add-after 'install 'install-info
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (info (string-append out "/share/info")))
+ (install-file "texinfo/graphviz-dot-mode.info.gz" info)
+ #t))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)
+ ("gzip" ,gzip)))
+ (home-page "http://ppareit.github.com/graphviz-dot-mode")
+ (synopsis "Major mode for editing Graphviz Dot files")
+ (description
+ "This Emacs packages helps you to create .dot or .gv files using the
+dot syntax, and use Graphviz to convert these files to diagrams.")
+ (license license:gpl3+))))
+
(define-public emacs-mmm-mode
(package
(name "emacs-mmm-mode")
--
2.14.2
Christopher Baines wrote 7 years ago
(address . 28804@debbugs.gnu.org)
20171013060120.3249-1-mail@cbaines.net
* gnu/packages/emacs.scm (graphviz-dot-mode): New variable.
---
gnu/packages/emacs.scm | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b29436154..71a7c09c9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1245,6 +1245,55 @@ written in the Go programming language.")
Maps directly inside Emacs.")
(license license:gpl3+)))
+(define-public emacs-graphviz-dot-mode
+ (let ((commit "fdaabbcc95d9156e3dadc84f81a4750c5b692580")
+ (revision "1"))
+ (package
+ (name "emacs-graphviz-dot-mode")
+ (version (string-append "0.3.10-" revision "."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ppareit/graphviz-dot-mode.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1s1qh5r0xp6hs0rl5yz5mkmjhpg04bh449c7vgjbb1pjsl1dl714"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "texinfo"
+ (substitute* "Makefile"
+ (("\\/usr\\/bin\\/gzip")
+ (string-append (assoc-ref inputs "gzip") "/bin/gzip")))
+ (zero?
+ (system* "make"
+ "clean"
+ "info"
+ (string-append "TEXINFODIR="
+ (assoc-ref inputs "texinfo")
+ "/bin"))))))
+ (add-after 'install 'install-info
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (info (string-append out "/share/info")))
+ (install-file "texinfo/graphviz-dot-mode.info.gz" info)
+ #t))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)
+ ("gzip" ,gzip)))
+ (home-page "http://ppareit.github.com/graphviz-dot-mode")
+ (synopsis "Major mode for editing Graphviz Dot files")
+ (description
+ "This Emacs packages helps you to create .dot or .gv files using the
+dot syntax, and use Graphviz to convert these files to diagrams.")
+ (license license:gpl2+))))
+
(define-public emacs-mmm-mode
(package
(name "emacs-mmm-mode")
--
2.14.2
Ludovic Courtès wrote 7 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28804@debbugs.gnu.org)
874lr3qvka.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (graphviz-dot-mode): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "Major mode for editing Graphviz Dot files")
> + (description
> + "This Emacs packages helps you to create .dot or .gv files using the
^ ^
I’d use @file here but otherwise LGTM.

Thank you,
Ludo’.
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28804-done@debbugs.gnu.org)
20171013204242.7d5423b1@cbaines.net
On Fri, 13 Oct 2017 10:52:05 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (13 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/emacs.scm (graphviz-dot-mode): New variable.
>
> [...]
>
> > + (synopsis "Major mode for editing Graphviz Dot files")
> > + (description
> > + "This Emacs packages helps you to create .dot or .gv files
> > using the
> ^ ^
> I’d use @file here but otherwise LGTM.

Awesome, I've updated and pushed. Thanks for the prompt review Ludo :D
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnhFzJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcK+g//b6K84NCq9yW8hE0XtBlLzm11z+UApTc4PTri5E8UkIaFl1RaLzQtzWZF
ocNbMobkliagQSqm/FBs4cnhEMZJA1mbITSMvGatrTxHD2PRHgErp8y/yhxvzf1F
w4k2UKQewM9Xjatif4q3sC9ra7aBJu9M6PrsoMPHcWvjjGHmdIVTjQW20Xy9FR/H
GnftFZ7VJbHnJlnxajzs82Om5XrSmcenBnvISBezGTglDwXTz062M6VrRArrUcqL
r909/fbI6ULa+1gtW81jp505Ne9aaVovUjNTMphT2nnMSt+uVtQ89At4jfk08QRD
x1pqEOIOzhgrhZ7G0F33mQ0Zh59xD5c5wpxgQVhpENC8tJw2PrtoYWewUFBVKXlV
/09WAVBdBlNmoBYYjDwIcqf0Yq82ThyDRsHJnQ7ER/viy/cN4jgMjPfh3CAFIKDK
SG/Xp33MlHfgCjwqTAfBEyZRTpCdHKXLWAg1EHZ4cas+QskkZc9UbDKTZs+B60xM
7Xx+Dm7SYH1NrX9QKoYSIHvArmcBJLjM7euzO37PTR9IrSA5BAUzfpS/NhxkJ+Iy
D5WMVQ2sEnT4hqrDYBWLn4Sti0L25TuP+pc01uBHcP6qtwBb48khJvKDuhVtgtWR
s19iP2z2ftxRWYZFG4HmkJhNEO/l4mSaRE73IfK2cwMS0vr5ZCc=
=m++W
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28804@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28804
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help